- New upstream release v3.3
Includes the DASD virtio-blk fix. - Dropping pre-3.2 changelog entries
This commit is contained in:
parent
5f329fbe24
commit
9afea59440
2
.gitignore
vendored
2
.gitignore
vendored
@ -13,3 +13,5 @@ clog
|
||||
/parted-3.2.tar.xz.sig
|
||||
/parted-3.2.153.tar.xz
|
||||
/parted-3.2.153.tar.xz.sig
|
||||
/parted-3.3.tar.xz
|
||||
/parted-3.3.tar.xz.sig
|
||||
|
@ -1,56 +0,0 @@
|
||||
From a943ad27eb3fa36b2d3161fd8cca9bfaa3a84911 Mon Sep 17 00:00:00 2001
|
||||
From: Viktor Mihajlovski <mihajlov@linux.ibm.com>
|
||||
Date: Fri, 27 Sep 2019 18:34:46 +0300
|
||||
Subject: [PATCH] libparted/s390: Re-enabled virtio-attached DASD heuristics
|
||||
|
||||
DASDs attached to KVM guest as virtio-blk devices are only handled
|
||||
properly, if the unique DASD geometry is detected. Commit id
|
||||
61dd3d4c5eb782eb43caa95342e63727db3f8281 has prevented proper geometry
|
||||
detection. Fixed by making sure that HDIO_GETGEO takes precedence
|
||||
on s390[x].
|
||||
|
||||
Signed-off-by: Viktor Mihajlovski <mihajlov@linux.ibm.com>
|
||||
Signed-off-by: Brian C. Lane <bcl@redhat.com>
|
||||
(cherry picked from commit 52360db2f5397b7842d2ed90bf946c5e8fa91750)
|
||||
---
|
||||
libparted/arch/linux.c | 13 ++++++++++---
|
||||
1 file changed, 10 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/libparted/arch/linux.c b/libparted/arch/linux.c
|
||||
index bb4d5ea..09ec781 100644
|
||||
--- a/libparted/arch/linux.c
|
||||
+++ b/libparted/arch/linux.c
|
||||
@@ -867,6 +867,7 @@ _device_probe_geometry (PedDevice* dev)
|
||||
LinuxSpecific* arch_specific = LINUX_SPECIFIC (dev);
|
||||
struct stat dev_stat;
|
||||
struct hd_geometry geometry;
|
||||
+ int geometry_is_valid = 0;
|
||||
int sector_size = 0;
|
||||
|
||||
if (!_device_stat (dev, &dev_stat))
|
||||
@@ -884,13 +885,19 @@ _device_probe_geometry (PedDevice* dev)
|
||||
dev->bios_geom.heads = 0;
|
||||
dev->bios_geom.cylinders = 0;
|
||||
|
||||
+ geometry_is_valid = !ioctl (arch_specific->fd, HDIO_GETGEO, &geometry)
|
||||
+ && geometry.sectors && geometry.heads;
|
||||
+
|
||||
+#if defined __s390__ || defined __s390x__
|
||||
+ if (geometry_is_valid) {
|
||||
+#else
|
||||
if (!ioctl (arch_specific->fd, BLKSSZGET, §or_size)) {
|
||||
/* get the sector count first */
|
||||
dev->bios_geom.sectors = 1 + (sector_size / PED_SECTOR_SIZE_DEFAULT);
|
||||
dev->bios_geom.heads = 255;
|
||||
- } else if (!ioctl (arch_specific->fd, HDIO_GETGEO, &geometry)
|
||||
- && geometry.sectors && geometry.heads) {
|
||||
- /* if BLKSSZGET failed, try the deprecated HDIO_GETGEO */
|
||||
+ } else if (geometry_is_valid) {
|
||||
+ /* if BLKSSZGET failed, use deprecated HDIO_GETGEO result */
|
||||
+#endif
|
||||
dev->bios_geom.sectors = geometry.sectors;
|
||||
dev->bios_geom.heads = geometry.heads;
|
||||
} else {
|
||||
--
|
||||
2.21.0
|
||||
|
1056
parted.spec
1056
parted.spec
File diff suppressed because it is too large
Load Diff
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (parted-3.2.153.tar.xz) = 149772c95f12430f6eb64ae1dc83a905059263bf8ec9a84bb2d2ff573d3a1b76d5dd67dfb511973f9fb63a9843e098b126e5f5c2c93cec7c926b6a1abe646a43
|
||||
SHA512 (parted-3.2.153.tar.xz.sig) = 6c84f7434fd36da94472f2a8c59ce3b0a5aa22f474ea5f90def27f1db391c86bd700a851ebc82519fa7dc44a9f23c4efc2c3374b9e6f04b845d2e34399d06702
|
||||
SHA512 (parted-3.3.tar.xz) = d1384694a491aa53bab6206fdeccd1d192de2ed379fe25aa865dd6aa06ed945a728e85b2ccc2fb23f5aa9dfee4a8bd8f0f2be1dd386cb8e8861b73382c6a07e4
|
||||
SHA512 (parted-3.3.tar.xz.sig) = b96f048b92e4056ca327635b3b6c00c86e9213be1af4d42ddc1dace91fe44bf40f2d99052ef04509ef8097fea69eca758bcb0de37ef7afc6a1c0d982c2aac5bd
|
||||
|
Loading…
Reference in New Issue
Block a user