New snapshot version.
This commit is contained in:
parent
1027857575
commit
2e25e6e435
@ -1,27 +0,0 @@
|
||||
From 4d7e16d3a36ce3875b9f34a04f4078cc5b935417 Mon Sep 17 00:00:00 2001
|
||||
From: Joel Granados Moreno <jgranado@redhat.com>
|
||||
Date: Tue, 30 Jun 2009 17:07:06 +0200
|
||||
Subject: [PATCH] Identify the device by path.
|
||||
|
||||
* libparted/labels/dasd.c (dasd_probe): The element name is not defined
|
||||
in the dev structure.
|
||||
---
|
||||
libparted/labels/dasd.c | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/libparted/labels/dasd.c b/libparted/labels/dasd.c
|
||||
index e3e5d1b..40c0546 100644
|
||||
--- a/libparted/labels/dasd.c
|
||||
+++ b/libparted/labels/dasd.c
|
||||
@@ -166,7 +166,7 @@ dasd_probe (const PedDevice *dev)
|
||||
error_cleanup:
|
||||
fdasd_cleanup(&anchor);
|
||||
ped_exception_throw(PED_EXCEPTION_ERROR,PED_EXCEPTION_IGNORE_CANCEL,
|
||||
- "Error while probing device %s.", dev->name);
|
||||
+ "Error while probing device %s.", dev->path);
|
||||
|
||||
return 0;
|
||||
}
|
||||
--
|
||||
1.6.0.6
|
||||
|
@ -1,26 +0,0 @@
|
||||
From c3bd7f40c18197d8092b80f0975d1e0486b686c7 Mon Sep 17 00:00:00 2001
|
||||
From: Joel Granados Moreno <jgranado@redhat.com>
|
||||
Date: Wed, 10 Jun 2009 17:33:42 +0200
|
||||
Subject: [PATCH] Remove unnecessary variable.
|
||||
|
||||
* libparted/labels/fdasd.c (fdasd_get_geometry): The variable "s" is not
|
||||
used in the function.
|
||||
---
|
||||
libparted/labels/fdasd.c | 1 -
|
||||
1 files changed, 0 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/libparted/labels/fdasd.c b/libparted/labels/fdasd.c
|
||||
index 40ba8c9..4cf4eb0 100644
|
||||
--- a/libparted/labels/fdasd.c
|
||||
+++ b/libparted/labels/fdasd.c
|
||||
@@ -773,7 +773,6 @@ fdasd_get_geometry (fdasd_anchor_t *anc, int f)
|
||||
PDEBUG
|
||||
int blksize = 0;
|
||||
dasd_information_t dasd_info;
|
||||
- char s[LINE_LENGTH];
|
||||
|
||||
if (ioctl(f, HDIO_GETGEO, &anc->geo) != 0)
|
||||
fdasd_error(anc, unable_to_ioctl,
|
||||
--
|
||||
1.6.0.6
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 72866a8b24da93e982142304c614d08bae5589c7 Mon Sep 17 00:00:00 2001
|
||||
From 7c7d7b3efc1eb39f884083c852875e1451efc29f Mon Sep 17 00:00:00 2001
|
||||
From: Joel Granados Moreno <jgranado@redhat.com>
|
||||
Date: Thu, 11 Jun 2009 17:05:39 +0200
|
||||
Subject: [PATCH] return errro on push or pop update mode.
|
||||
@ -8,7 +8,7 @@ Subject: [PATCH] return errro on push or pop update mode.
|
||||
1 files changed, 56 insertions(+), 29 deletions(-)
|
||||
|
||||
diff --git a/libparted/disk.c b/libparted/disk.c
|
||||
index 5fb8060..8bab741 100644
|
||||
index 3269b9d..39f3a74 100644
|
||||
--- a/libparted/disk.c
|
||||
+++ b/libparted/disk.c
|
||||
@@ -54,8 +54,8 @@
|
||||
@ -276,5 +276,5 @@ index 5fb8060..8bab741 100644
|
||||
}
|
||||
|
||||
--
|
||||
1.6.3.3
|
||||
1.6.0.6
|
||||
|
||||
|
@ -1,107 +0,0 @@
|
||||
From 2f0d94d200fb8822a9f8699e93b65c2d5476b087 Mon Sep 17 00:00:00 2001
|
||||
From: Joel Granados Moreno <jgranado@redhat.com>
|
||||
Date: Tue, 30 Jun 2009 16:21:02 +0200
|
||||
Subject: [PATCH] The file include/parted/linux.h is needed by dasd.c
|
||||
|
||||
* include/parted/linux.h (PED_LINUX_H_INCLUDED, LINUX_SPECIFIC)
|
||||
(LinuxSpecific, _LinuxSpecific, fd, dmtype, real_sector_size, anchor):
|
||||
New file.
|
||||
* libparted/arch/linux.c (PROC_DEVICES_BUFSIZ, LINUX_SPECIFIC)
|
||||
(LinuxSpecific, RW_MODE, _LinuxSpecific, anchor, dmtype, fd)
|
||||
(real_sector_size): User new header file.
|
||||
---
|
||||
include/parted/linux.h | 44 ++++++++++++++++++++++++++++++++++++++++++++
|
||||
libparted/arch/linux.c | 19 +------------------
|
||||
2 files changed, 45 insertions(+), 18 deletions(-)
|
||||
create mode 100644 include/parted/linux.h
|
||||
|
||||
diff --git a/include/parted/linux.h b/include/parted/linux.h
|
||||
new file mode 100644
|
||||
index 0000000..1a4171d
|
||||
--- /dev/null
|
||||
+++ b/include/parted/linux.h
|
||||
@@ -0,0 +1,44 @@
|
||||
+/*
|
||||
+ libparted - a library for manipulating disk partitions
|
||||
+ Copyright (C) 2001, 2007 Free Software Foundation, Inc.
|
||||
+
|
||||
+ This program is free software; you can redistribute it and/or modify
|
||||
+ it under the terms of the GNU General Public License as published by
|
||||
+ the Free Software Foundation; either version 3 of the License, or
|
||||
+ (at your option) any later version.
|
||||
+
|
||||
+ This program is distributed in the hope that it will be useful,
|
||||
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
+ GNU General Public License for more details.
|
||||
+
|
||||
+ You should have received a copy of the GNU General Public License
|
||||
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
|
||||
+*/
|
||||
+
|
||||
+#ifndef PED_LINUX_H_INCLUDED
|
||||
+#define PED_LINUX_H_INCLUDED
|
||||
+
|
||||
+#include <parted/parted.h>
|
||||
+#include <parted/device.h>
|
||||
+
|
||||
+#if defined(__s390__) || defined(__s390x__)
|
||||
+# include <parted/fdasd.h>
|
||||
+#endif
|
||||
+
|
||||
+#define LINUX_SPECIFIC(dev) ((LinuxSpecific*) (dev)->arch_specific)
|
||||
+
|
||||
+typedef struct _LinuxSpecific LinuxSpecific;
|
||||
+
|
||||
+struct _LinuxSpecific {
|
||||
+ int fd;
|
||||
+ char* dmtype; /**< device map target type */
|
||||
+#if defined(__s390__) || defined(__s390x__)
|
||||
+ unsigned int real_sector_size;
|
||||
+ /* IBM internal dasd structure (i guess ;), required. */
|
||||
+ struct fdasd_anchor *anchor;
|
||||
+#endif
|
||||
+};
|
||||
+
|
||||
+#endif /* PED_LINUX_H_INCLUDED */
|
||||
+
|
||||
diff --git a/libparted/arch/linux.c b/libparted/arch/linux.c
|
||||
index 66fdd37..92c8f31 100644
|
||||
--- a/libparted/arch/linux.c
|
||||
+++ b/libparted/arch/linux.c
|
||||
@@ -21,6 +21,7 @@
|
||||
|
||||
#include <parted/parted.h>
|
||||
#include <parted/debug.h>
|
||||
+#include <parted/linux.h>
|
||||
|
||||
#include <ctype.h>
|
||||
#include <errno.h>
|
||||
@@ -75,24 +76,6 @@
|
||||
#define RW_MODE (O_RDWR)
|
||||
#endif
|
||||
|
||||
-#if defined(__s390__) || defined(__s390x__)
|
||||
-# include <parted/fdasd.h>
|
||||
-#endif
|
||||
-
|
||||
-#define LINUX_SPECIFIC(dev) ((LinuxSpecific*) (dev)->arch_specific)
|
||||
-
|
||||
-typedef struct _LinuxSpecific LinuxSpecific;
|
||||
-
|
||||
-struct _LinuxSpecific {
|
||||
- int fd;
|
||||
- char* dmtype; /**< device map target type */
|
||||
-#if defined(__s390__) || defined(__s390x__)
|
||||
- unsigned int real_sector_size;
|
||||
- /* IBM internal dasd structure (i guess ;), required. */
|
||||
- struct fdasd_anchor *anchor;
|
||||
-#endif
|
||||
-};
|
||||
-
|
||||
struct hd_geometry {
|
||||
unsigned char heads;
|
||||
unsigned char sectors;
|
||||
--
|
||||
1.6.0.6
|
||||
|
Binary file not shown.
49
parted.spec
49
parted.spec
@ -4,23 +4,30 @@
|
||||
Summary: The GNU disk partition manipulation program
|
||||
Name: parted
|
||||
Version: 1.9.0
|
||||
Release: 3.20090610git32dc%{?dist}
|
||||
Release: 4.20090721git980c%{?dist}
|
||||
License: GPLv3+
|
||||
Group: Applications/System
|
||||
URL: http://www.gnu.org/software/parted
|
||||
|
||||
# Reproduce the snapshot tar.gz run this script:
|
||||
# run http://jgranado.fedorapeople.org/packages/parted/upstream/parted-release
|
||||
#
|
||||
# the line that was used is:
|
||||
# parted-release --version 1.9.0 --key-id PUB_KEY
|
||||
#
|
||||
# Note that this script will give different results if master changes in upstream.
|
||||
#
|
||||
Source: %{name}/%{name}-%{version}.tar.gz
|
||||
Patch1: %{name}-1.9.0-appletv-support.patch
|
||||
Patch2: %{name}-1.9.0-extended-mbr.patch
|
||||
Patch3: %{name}-1.9.0-extra-var.patch
|
||||
Patch4: %{name}-1.9.0-noheaders.patch
|
||||
Patch5: %{name}-1.9.0-pop-push-error.patch
|
||||
Patch6: %{name}-1.9.0-no-cylinder-align.patch
|
||||
Patch7: %{name}-1.9.0-swap-flag.patch
|
||||
Patch8: %{name}-1.9.0-remove-struct-elem.patch
|
||||
Patch9: %{name}-1.9.0-move-function-declarations.patch
|
||||
Patch10: %{name}-1.9.0-use-linuxh.patch
|
||||
Patch11: %{name}-1.9.0-device-path.patch
|
||||
Patch3: %{name}-1.9.0-noheaders.patch
|
||||
Patch4: %{name}-1.9.0-pop-push-error.patch
|
||||
Patch5: %{name}-1.9.0-no-cylinder-align.patch
|
||||
Patch6: %{name}-1.9.0-swap-flag.patch
|
||||
Patch7: %{name}-1.9.0-remove-struct-elem.patch
|
||||
Patch8: %{name}-1.9.0-move-function-declarations.patch
|
||||
Patch9: %{name}-1.9.0-dasd-duplicate.patch
|
||||
Patch10: %{name}-1.9.0-new-duplicate.patch
|
||||
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: e2fsprogs-devel
|
||||
@ -62,15 +69,15 @@ Parted library, you need to install this package.
|
||||
%setup -q -n %{name}-%{version}
|
||||
%patch1 -p1 -b .appletv
|
||||
%patch2 -p1 -b .extended-mbr
|
||||
%patch3 -p1 -b .extra-var
|
||||
%patch4 -p1 -b .noheaders
|
||||
%patch5 -p1 -b .pop-push-error
|
||||
%patch6 -p1 -b .no-cylinder-align
|
||||
%patch7 -p1 -b .swap-flag
|
||||
%patch8 -p1 -b .remove-struct-elem
|
||||
%patch9 -p1 -b .move-function-declarations
|
||||
%patch10 -p1 -b .use-linuxh
|
||||
%patch11 -p1 -b .device-path
|
||||
%patch3 -p1 -b .noheaders
|
||||
%patch4 -p1 -b .pop-push-error
|
||||
%patch5 -p1 -b .no-cylinder-align
|
||||
%patch6 -p1 -b .swap-flag
|
||||
%patch7 -p1 -b .remove-struct-elem
|
||||
%patch8 -p1 -b .move-function-declarations
|
||||
%patch9 -p1 -b .dasd-duplicate
|
||||
%patch10 -p1 -b .new-duplicate
|
||||
|
||||
|
||||
%build
|
||||
%configure --enable-selinux --disable-static
|
||||
@ -128,6 +135,10 @@ fi
|
||||
%{_exec_prefix}/%{_lib}/pkgconfig/libparted.pc
|
||||
|
||||
%changelog
|
||||
* Tue Jul 21 2009 Joel Granados <jgranado@redhat.com> - 1.9.0-20090721git980c
|
||||
- New snapshot.
|
||||
- Add patches to make dasd duplicate disk work.
|
||||
|
||||
* Sat Jul 18 2009 Lubomir Rintel <lkundrak@v3.sk> - 1.9.0-3.20090610git32dc
|
||||
- Fix a typo in the errno patch
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user