paps/paps-0.6.8-shared.patch
Akira TAGOH 1a8b5cd74a - New upstream release.
- Remove patches merged and unnecessary anymore:
- paps-makefile.patch
- paps-formfeed.patch
- paps-0.6.6-encoding.patch
- paps-typo-font-scale.patch
- paps-0.6.6-segfault.patch
- paps-0.6.6-font-option.patch
- paps-0.6.6-lcctype.patch
- paps-0.6.8-shared.patch: Enable building shared library.
- paps-0.6.8-wordwrap.patch: Update a bit to get it working without an
    wordwrap mode.
- Add paps-libs and paps-devel package.
- paps-cups.patch: Update.
- paps-cpilpi.patch: Update.
- Fix the wrong rendering with CPI option. (#237202)
- Fix the unnecessary rotation with the landscape option when paps is
    running as CUPS filter. (#222137)
2007-11-30 11:29:46 +00:00

36 lines
1.1 KiB
Diff

diff -ruN paps-0.6.8.orig/src/Makefile.am paps-0.6.8/src/Makefile.am
--- paps-0.6.8.orig/src/Makefile.am 2006-04-17 16:42:08.000000000 +0900
+++ paps-0.6.8/src/Makefile.am 2007-11-16 11:50:07.000000000 +0900
@@ -1,15 +1,15 @@
man_MANS = paps.1
-lib_LIBRARIES = libpaps.a
-libpaps_a_SOURCES = libpaps.c
-libpaps_a_inc_HEADERS = libpaps.h
-libpaps_a_incdir = $(includedir)
+lib_LTLIBRARIES = libpaps.la
+libpaps_la_SOURCES = libpaps.c
+libpapsinc_HEADERS = libpaps.h
+libpapsincdir = $(includedir)
bin_PROGRAMS = paps
paps_CFLAGS = -Wall
paps_SOURCES = paps.c
-paps_LDADD = $(lib_LIBRARIES) $(all_libraries)
+paps_LDADD = $(lib_LTLIBRARIES) $(all_libraries)
paps_LDFLAGS = `pkg-config --libs pangoft2`
-paps_DEPENDENCIES = $(lib_LIBRARIES)
+paps_DEPENDENCIES = $(lib_LTLIBRARIES)
EXTRA_DIST = test_libpaps.c paps.1
@@ -21,7 +21,7 @@
test_libpaps_SOURCES = test_libpaps.c
-test_libpaps_LDADD = $(lib_LIBRARIES) $(all_libraries)
+test_libpaps_LDADD = $(lib_LTLIBRARIES) $(all_libraries)
test_libpaps_LDFLAGS = `pkg-config --libs pangoft2`
-test_libpaps_DEPENDENCIES = $(lib_LIBRARIES)
+test_libpaps_DEPENDENCIES = $(lib_LTLIBRARIES)