paps/paps-makefile.patch

48 lines
1.6 KiB
Diff

diff -ruN paps-0.6.5.orig/doc/Makefile.am paps-0.6.5/doc/Makefile.am
--- paps-0.6.5.orig/doc/Makefile.am 2005-12-21 04:35:35.000000000 +0900
+++ paps-0.6.5/doc/Makefile.am 2006-04-17 17:28:52.000000000 +0900
@@ -10,7 +10,7 @@
EXTRA_DIST = Doxyfile example-output.png mainpage.h
-htmldir = share/doc/libpaps/html
-install-data-hook:
- mkdir -p $(prefix)/$(htmldir)
- cp -dpR doxygen-html/* $(prefix)/$(htmldir)
+htmldir = $(datadir)/doc/paps-$(VERSION)/html
+#install-data-hook:
+# mkdir -p $(prefix)/$(htmldir)
+# cp -dpR doxygen-html/* $(prefix)/$(htmldir)
diff -ruN paps-0.6.5.orig/src/Makefile.am paps-0.6.5/src/Makefile.am
--- paps-0.6.5.orig/src/Makefile.am 2006-04-17 15:04:13.000000000 +0900
+++ paps-0.6.5/src/Makefile.am 2006-04-17 17:30:01.000000000 +0900
@@ -1,5 +1,5 @@
man_MANS = paps.1
-lib_LIBRARIES = libpaps.a
+noinst_LIBRARIES = libpaps.a
libpaps_a_SOURCES = libpaps.c
libpaps_a_inc_HEADERS = libpaps.h
libpaps_a_incdir = $(includedir)
@@ -7,9 +7,9 @@
bin_PROGRAMS = paps
paps_CFLAGS = -Wall
paps_SOURCES = paps.c
-paps_LDADD = $(lib_LIBRARIES) $(all_libraries)
+paps_LDADD = $(noinst_LIBRARIES) $(all_libraries)
paps_LDFLAGS = `pkg-config --libs pangoft2`
-paps_DEPENDENCIES = $(lib_LIBRARIES)
+paps_DEPENDENCIES = $(noinst_LIBRARIES)
EXTRA_DIST = test_libpaps.c paps.1
@@ -21,7 +21,7 @@
test_libpaps_SOURCES = test_libpaps.c
-test_libpaps_LDADD = $(lib_LIBRARIES) $(all_libraries)
+test_libpaps_LDADD = $(noinst_LIBRARIES) $(all_libraries)
test_libpaps_LDFLAGS = `pkg-config --libs pangoft2`
-test_libpaps_DEPENDENCIES = $(lib_LIBRARIES)
+test_libpaps_DEPENDENCIES = $(noinst_LIBRARIES)