the spec file cleanup
- Fix the undefined symbol issue in libpaps.so.0 - Correct FSF address in the COPYING.LIB
This commit is contained in:
parent
8f2354d8c1
commit
f446746739
77
paps-correct-fsf-address.patch
Normal file
77
paps-correct-fsf-address.patch
Normal file
@ -0,0 +1,77 @@
|
||||
diff -pruN paps-0.6.8.orig/COPYING.LIB paps-0.6.8/COPYING.LIB
|
||||
--- paps-0.6.8.orig/COPYING.LIB 2005-12-21 04:35:27.000000000 +0900
|
||||
+++ paps-0.6.8/COPYING.LIB 2012-11-23 14:30:46.297512335 +0900
|
||||
@@ -1,16 +1,15 @@
|
||||
- GNU LIBRARY GENERAL PUBLIC LICENSE
|
||||
- Version 2, June 1991
|
||||
+ GNU LIBRARY GENERAL PUBLIC LICENSE
|
||||
+ Version 2, June 1991
|
||||
|
||||
Copyright (C) 1991 Free Software Foundation, Inc.
|
||||
- 59 Temple Place - Suite 330
|
||||
- Boston, MA 02111-1307, USA.
|
||||
+ 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
|
||||
Everyone is permitted to copy and distribute verbatim copies
|
||||
of this license document, but changing it is not allowed.
|
||||
|
||||
[This is the first released version of the library GPL. It is
|
||||
numbered 2 because it goes with version 2 of the ordinary GPL.]
|
||||
|
||||
- Preamble
|
||||
+ Preamble
|
||||
|
||||
The licenses for most software are designed to take away your
|
||||
freedom to share and change it. By contrast, the GNU General Public
|
||||
@@ -100,7 +99,7 @@ works together with the library.
|
||||
Note that it is possible for a library to be covered by the ordinary
|
||||
General Public License rather than by this special one.
|
||||
|
||||
- GNU LIBRARY GENERAL PUBLIC LICENSE
|
||||
+ GNU LIBRARY GENERAL PUBLIC LICENSE
|
||||
TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION
|
||||
|
||||
0. This License Agreement applies to any software library which
|
||||
@@ -412,7 +411,7 @@ decision will be guided by the two goals
|
||||
of all derivatives of our free software and of promoting the sharing
|
||||
and reuse of software generally.
|
||||
|
||||
- NO WARRANTY
|
||||
+ NO WARRANTY
|
||||
|
||||
15. BECAUSE THE LIBRARY IS LICENSED FREE OF CHARGE, THERE IS NO
|
||||
WARRANTY FOR THE LIBRARY, TO THE EXTENT PERMITTED BY APPLICABLE LAW.
|
||||
@@ -435,8 +434,9 @@ FAILURE OF THE LIBRARY TO OPERATE WITH A
|
||||
SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH
|
||||
DAMAGES.
|
||||
|
||||
- END OF TERMS AND CONDITIONS
|
||||
- How to Apply These Terms to Your New Libraries
|
||||
+ END OF TERMS AND CONDITIONS
|
||||
+
|
||||
+ How to Apply These Terms to Your New Libraries
|
||||
|
||||
If you develop a new library, and you want it to be of the greatest
|
||||
possible use to the public, we recommend making it free software that
|
||||
@@ -453,18 +453,18 @@ convey the exclusion of warranty; and ea
|
||||
Copyright (C) <year> <name of author>
|
||||
|
||||
This library is free software; you can redistribute it and/or
|
||||
- modify it under the terms of the GNU Lesser General Public
|
||||
+ modify it under the terms of the GNU Library General Public
|
||||
License as published by the Free Software Foundation; either
|
||||
version 2 of the License, or (at your option) any later version.
|
||||
|
||||
This library is distributed in the hope that it will be useful,
|
||||
but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
||||
- Lesser General Public License for more details.
|
||||
+ Library General Public License for more details.
|
||||
|
||||
- You should have received a copy of the GNU Lesser General Public
|
||||
+ You should have received a copy of the GNU Library General Public
|
||||
License along with this library; if not, write to the Free Software
|
||||
- Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
|
||||
+ Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
|
||||
|
||||
Also add information on how to contact you by electronic and paper mail.
|
||||
|
26
paps-fix-non-weak-symbol.patch
Normal file
26
paps-fix-non-weak-symbol.patch
Normal file
@ -0,0 +1,26 @@
|
||||
diff -pruN paps-0.6.8.orig/src/Makefile.am paps-0.6.8/src/Makefile.am
|
||||
--- paps-0.6.8.orig/src/Makefile.am 2012-11-23 14:22:51.506176037 +0900
|
||||
+++ paps-0.6.8/src/Makefile.am 2012-11-23 14:25:41.828410416 +0900
|
||||
@@ -8,13 +8,14 @@ bin_PROGRAMS = paps
|
||||
paps_CFLAGS = -Wall $(CUPS_CFLAGS)
|
||||
paps_SOURCES = paps.c
|
||||
paps_LDADD = $(lib_LTLIBRARIES) $(all_libraries)
|
||||
-paps_LDFLAGS = `pkg-config --libs pangoft2` $(CUPS_LIBS)
|
||||
+paps_LDFLAGS = $(CUPS_LIBS)
|
||||
paps_DEPENDENCIES = $(lib_LTLIBRARIES)
|
||||
|
||||
EXTRA_DIST = test_libpaps.c paps.1
|
||||
|
||||
# set the include path found by configure
|
||||
INCLUDES= $(all_includes) `pkg-config --cflags pangoft2`
|
||||
+LIBS = `pkg-config --libs pangoft2`
|
||||
|
||||
# Test program
|
||||
noinst_PROGRAMS = test_libpaps
|
||||
@@ -22,6 +23,5 @@ noinst_PROGRAMS = test_libpaps
|
||||
|
||||
test_libpaps_SOURCES = test_libpaps.c
|
||||
test_libpaps_LDADD = $(lib_LTLIBRARIES) $(all_libraries)
|
||||
-test_libpaps_LDFLAGS = `pkg-config --libs pangoft2`
|
||||
test_libpaps_DEPENDENCIES = $(lib_LTLIBRARIES)
|
||||
|
36
paps.spec
36
paps.spec
@ -1,12 +1,11 @@
|
||||
Name: paps
|
||||
Version: 0.6.8
|
||||
Release: 22%{?dist}
|
||||
Release: 23%{?dist}
|
||||
|
||||
License: LGPLv2+
|
||||
URL: http://paps.sourceforge.net/
|
||||
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
||||
Source1: paps.convs
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: pango-devel automake autoconf libtool doxygen cups-devel
|
||||
## https://sourceforge.net/tracker/index.php?func=detail&aid=1832897&group_id=153049&atid=786241
|
||||
Patch0: paps-0.6.8-shared.patch
|
||||
@ -18,18 +17,26 @@ Patch2: paps-langinfo.patch
|
||||
Patch3: paps-0.6.6-lcnumeric.patch
|
||||
## https://sourceforge.net/tracker/index.php?func=detail&aid=1832935&group_id=153049&atid=786241
|
||||
Patch4: paps-exitcode.patch
|
||||
## rhbz#854897
|
||||
Patch5: paps-854897-manpage.patch
|
||||
## Fedora specific patch to integrate with CUPS
|
||||
Patch50: paps-cups.patch
|
||||
Patch51: paps-cpilpi.patch
|
||||
## rhbz#424951
|
||||
Patch52: paps-dsc-compliant.patch
|
||||
Patch53: paps-autoconf262.patch
|
||||
## rhbz#524883
|
||||
Patch54: paps-fix-cpi.patch
|
||||
Patch55: paps-fix-loop-in-split.patch
|
||||
Patch56: paps-fix-tab-width.patch
|
||||
## rhbz#618483
|
||||
Patch55: paps-fix-loop-in-split.patch
|
||||
## rhbz#857592
|
||||
Patch56: paps-fix-tab-width.patch
|
||||
Patch57: paps-fix-non-weak-symbol.patch
|
||||
Patch58: paps-correct-fsf-address.patch
|
||||
|
||||
Summary: Plain Text to PostScript converter
|
||||
Group: Applications/Publishing
|
||||
Requires: %{name}-libs = %{version}-%{release}
|
||||
Requires: %{name}-libs = %{version}-%{release}
|
||||
%description
|
||||
paps is a PostScript converter from plain text file using Pango.
|
||||
|
||||
@ -66,6 +73,8 @@ applications using paps API.
|
||||
%patch54 -p1 -b .fixcpi
|
||||
%patch55 -p1 -b .loop
|
||||
%patch56 -p1 -b .tab
|
||||
%patch57 -p1 -b .weak-symbol
|
||||
%patch58 -p1 -b .fsf
|
||||
libtoolize -f -c
|
||||
autoreconf
|
||||
|
||||
@ -76,27 +85,23 @@ make %{?_smp_mflags}
|
||||
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
make install DESTDIR=$RPM_BUILD_ROOT
|
||||
make install DESTDIR=$RPM_BUILD_ROOT INSTALL="/usr/bin/install -p"
|
||||
|
||||
# remove unnecessary files
|
||||
rm $RPM_BUILD_ROOT%{_libdir}/libpaps.la
|
||||
|
||||
# make a symlink for CUPS filter
|
||||
%{__mkdir_p} $RPM_BUILD_ROOT%{_cups_serverbin}/filter # Not libdir
|
||||
install -d $RPM_BUILD_ROOT%{_cups_serverbin}/filter # Not libdir
|
||||
ln -s %{_bindir}/paps $RPM_BUILD_ROOT%{_cups_serverbin}/filter/texttopaps
|
||||
|
||||
install -d $RPM_BUILD_ROOT%{_sysconfdir}/cups
|
||||
install -p -m0644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/cups
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%post libs -p /sbin/ldconfig
|
||||
%postun libs -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-, root, root, -)
|
||||
%doc AUTHORS COPYING.LIB README TODO
|
||||
%{_bindir}/paps
|
||||
%{_mandir}/man1/paps.1*
|
||||
@ -105,17 +110,20 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_sysconfdir}/cups/paps.convs
|
||||
|
||||
%files libs
|
||||
%defattr(-, root, root, -)
|
||||
%doc COPYING.LIB
|
||||
%{_libdir}/libpaps.so.*
|
||||
|
||||
%files devel
|
||||
%defattr(-, root, root, -)
|
||||
%doc COPYING.LIB
|
||||
%{_includedir}/libpaps.h
|
||||
%{_libdir}/libpaps.so
|
||||
|
||||
%changelog
|
||||
* Fri Nov 23 2012 Akira TAGOH <tagoh@redhat.com> - 0.6.8-23
|
||||
- the spec file cleanup
|
||||
- Fix the undefined symbol issue in libpaps.so.0
|
||||
- Correct FSF address in the COPYING.LIB
|
||||
|
||||
* Mon Sep 24 2012 Akira TAGOH <tagoh@redhat.com> - 0.6.8-22
|
||||
- Ensure the latest version of paps-libs are installed.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user