- paps-langinfo.patch: Updated.
- paps-exitcode.patch: Updated.
This commit is contained in:
parent
57239163e2
commit
dc38bd42f1
@ -1,7 +1,7 @@
|
|||||||
diff -ruN paps-0.6.6.orig/src/paps.c paps-0.6.6/src/paps.c
|
diff -pruN paps-0.6.8.orig/src/paps.c paps-0.6.8/src/paps.c
|
||||||
--- paps-0.6.6.orig/src/paps.c 2006-09-30 02:51:39.000000000 +0900
|
--- paps-0.6.8.orig/src/paps.c 2008-09-01 15:54:11.000000000 +0900
|
||||||
+++ paps-0.6.6/src/paps.c 2006-09-30 03:00:26.000000000 +0900
|
+++ paps-0.6.8/src/paps.c 2008-09-01 15:54:47.000000000 +0900
|
||||||
@@ -346,7 +346,7 @@
|
@@ -365,7 +365,7 @@ int main(int argc, char *argv[])
|
||||||
if (!IN)
|
if (!IN)
|
||||||
{
|
{
|
||||||
fprintf(stderr, "Failed to open %s!\n", filename_in);
|
fprintf(stderr, "Failed to open %s!\n", filename_in);
|
||||||
@ -10,7 +10,7 @@ diff -ruN paps-0.6.6.orig/src/paps.c paps-0.6.6/src/paps.c
|
|||||||
}
|
}
|
||||||
}
|
}
|
||||||
else
|
else
|
||||||
@@ -457,7 +457,7 @@
|
@@ -499,7 +499,7 @@ int main(int argc, char *argv[])
|
||||||
if (cvh == NULL)
|
if (cvh == NULL)
|
||||||
{
|
{
|
||||||
fprintf(stderr, "%s: Invalid encoding: %s\n", g_get_prgname (), encoding);
|
fprintf(stderr, "%s: Invalid encoding: %s\n", g_get_prgname (), encoding);
|
||||||
@ -19,7 +19,7 @@ diff -ruN paps-0.6.6.orig/src/paps.c paps-0.6.6/src/paps.c
|
|||||||
}
|
}
|
||||||
}
|
}
|
||||||
|
|
||||||
@@ -517,7 +517,7 @@
|
@@ -559,7 +559,7 @@ read_file (FILE *file,
|
||||||
{
|
{
|
||||||
fprintf(stderr, "%s: Error reading file.\n", g_get_prgname ());
|
fprintf(stderr, "%s: Error reading file.\n", g_get_prgname ());
|
||||||
g_string_free (inbuf, TRUE);
|
g_string_free (inbuf, TRUE);
|
||||||
@ -28,7 +28,7 @@ diff -ruN paps-0.6.6.orig/src/paps.c paps-0.6.6/src/paps.c
|
|||||||
}
|
}
|
||||||
else if (bp == NULL)
|
else if (bp == NULL)
|
||||||
break;
|
break;
|
||||||
@@ -531,7 +531,7 @@
|
@@ -573,7 +573,7 @@ read_file (FILE *file,
|
||||||
if (g_iconv (handle, &ib, &iblen, &ob, &oblen) == -1)
|
if (g_iconv (handle, &ib, &iblen, &ob, &oblen) == -1)
|
||||||
{
|
{
|
||||||
fprintf (stderr, "%s: Error while converting strings.\n", g_get_prgname ());
|
fprintf (stderr, "%s: Error while converting strings.\n", g_get_prgname ());
|
||||||
@ -37,7 +37,7 @@ diff -ruN paps-0.6.6.orig/src/paps.c paps-0.6.6/src/paps.c
|
|||||||
}
|
}
|
||||||
obuffer[BUFSIZE * 6 - 1 - oblen] = 0;
|
obuffer[BUFSIZE * 6 - 1 - oblen] = 0;
|
||||||
}
|
}
|
||||||
@@ -591,7 +591,7 @@
|
@@ -637,7 +637,7 @@ split_text_into_paragraphs (PangoContext
|
||||||
if (wtext == NULL)
|
if (wtext == NULL)
|
||||||
{
|
{
|
||||||
fprintf (stderr, "Failed to convert UTF-8 to UCS-4.\n");
|
fprintf (stderr, "Failed to convert UTF-8 to UCS-4.\n");
|
||||||
@ -45,8 +45,8 @@ diff -ruN paps-0.6.6.orig/src/paps.c paps-0.6.6/src/paps.c
|
|||||||
+ exit(1);
|
+ exit(1);
|
||||||
}
|
}
|
||||||
|
|
||||||
len = wcswidth (wtext);
|
len = g_utf8_strlen (para->text, para->length);
|
||||||
@@ -604,7 +604,7 @@
|
@@ -650,7 +650,7 @@ split_text_into_paragraphs (PangoContext
|
||||||
{
|
{
|
||||||
fprintf (stderr, "Failed to allocate a memory.\n");
|
fprintf (stderr, "Failed to allocate a memory.\n");
|
||||||
g_free (wtext);
|
g_free (wtext);
|
||||||
@ -55,7 +55,7 @@ diff -ruN paps-0.6.6.orig/src/paps.c paps-0.6.6/src/paps.c
|
|||||||
}
|
}
|
||||||
for (i = 0; i < len; i++)
|
for (i = 0; i < len; i++)
|
||||||
{
|
{
|
||||||
@@ -619,7 +619,7 @@
|
@@ -665,7 +665,7 @@ split_text_into_paragraphs (PangoContext
|
||||||
if (newtext == NULL)
|
if (newtext == NULL)
|
||||||
{
|
{
|
||||||
fprintf (stderr, "Failed to convert UCS-4 to UTF-8.\n");
|
fprintf (stderr, "Failed to convert UCS-4 to UTF-8.\n");
|
@ -1,6 +1,6 @@
|
|||||||
diff -pruN paps-0.6.6.orig/src/paps.c paps-0.6.6/src/paps.c
|
diff -pruN paps-0.6.8.orig/src/paps.c paps-0.6.8/src/paps.c
|
||||||
--- paps-0.6.6.orig/src/paps.c 2007-01-23 18:56:04.000000000 +0900
|
--- paps-0.6.8.orig/src/paps.c 2008-09-01 15:07:03.000000000 +0900
|
||||||
+++ paps-0.6.6/src/paps.c 2007-01-23 18:59:15.000000000 +0900
|
+++ paps-0.6.8/src/paps.c 2008-09-01 15:49:10.000000000 +0900
|
||||||
@@ -25,6 +25,7 @@
|
@@ -25,6 +25,7 @@
|
||||||
#include <pango/pangoft2.h>
|
#include <pango/pangoft2.h>
|
||||||
#include "libpaps.h"
|
#include "libpaps.h"
|
||||||
@ -9,9 +9,9 @@ diff -pruN paps-0.6.6.orig/src/paps.c paps-0.6.6/src/paps.c
|
|||||||
#include <stdlib.h>
|
#include <stdlib.h>
|
||||||
#include <stdio.h>
|
#include <stdio.h>
|
||||||
#include <string.h>
|
#include <string.h>
|
||||||
@@ -324,6 +325,9 @@ int main(int argc, char *argv[])
|
@@ -331,6 +332,9 @@ int main(int argc, char *argv[])
|
||||||
int max_width = 0, w;
|
|
||||||
GIConv cvh = NULL;
|
GIConv cvh = NULL;
|
||||||
|
GOptionGroup *options;
|
||||||
|
|
||||||
+ /* Set locale from environment. */
|
+ /* Set locale from environment. */
|
||||||
+ setlocale(LC_ALL, "");
|
+ setlocale(LC_ALL, "");
|
||||||
@ -19,9 +19,9 @@ diff -pruN paps-0.6.6.orig/src/paps.c paps-0.6.6/src/paps.c
|
|||||||
/* Prerequisite when using glib. */
|
/* Prerequisite when using glib. */
|
||||||
g_type_init();
|
g_type_init();
|
||||||
|
|
||||||
@@ -451,6 +455,15 @@ int main(int argc, char *argv[])
|
@@ -480,6 +484,15 @@ int main(int argc, char *argv[])
|
||||||
g_object_unref (G_OBJECT (fontmap));
|
page_layout.scale_x = page_layout.scale_y = 1.0;
|
||||||
}
|
|
||||||
|
|
||||||
+ if (encoding == NULL)
|
+ if (encoding == NULL)
|
||||||
+ {
|
+ {
|
10
paps.spec
10
paps.spec
@ -1,6 +1,6 @@
|
|||||||
Name: paps
|
Name: paps
|
||||||
Version: 0.6.8
|
Version: 0.6.8
|
||||||
Release: 6%{?dist}
|
Release: 7%{?dist}
|
||||||
|
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
URL: http://paps.sourceforge.net/
|
URL: http://paps.sourceforge.net/
|
||||||
@ -12,11 +12,11 @@ Patch0: paps-0.6.8-shared.patch
|
|||||||
## https://sourceforge.net/tracker/index.php?func=detail&aid=1832924&group_id=153049&atid=786241
|
## https://sourceforge.net/tracker/index.php?func=detail&aid=1832924&group_id=153049&atid=786241
|
||||||
Patch1: paps-0.6.8-wordwrap.patch
|
Patch1: paps-0.6.8-wordwrap.patch
|
||||||
## https://sourceforge.net/tracker/index.php?func=detail&aid=1832926&group_id=153049&atid=786241
|
## https://sourceforge.net/tracker/index.php?func=detail&aid=1832926&group_id=153049&atid=786241
|
||||||
Patch2: paps-0.6.6-langinfo.patch
|
Patch2: paps-langinfo.patch
|
||||||
## https://sourceforge.net/tracker/index.php?func=detail&aid=1832929&group_id=153049&atid=786241
|
## https://sourceforge.net/tracker/index.php?func=detail&aid=1832929&group_id=153049&atid=786241
|
||||||
Patch3: paps-0.6.6-lcnumeric.patch
|
Patch3: paps-0.6.6-lcnumeric.patch
|
||||||
## https://sourceforge.net/tracker/index.php?func=detail&aid=1832935&group_id=153049&atid=786241
|
## https://sourceforge.net/tracker/index.php?func=detail&aid=1832935&group_id=153049&atid=786241
|
||||||
Patch4: paps-0.6.6-exitcode.patch
|
Patch4: paps-exitcode.patch
|
||||||
Patch50: paps-cups.patch
|
Patch50: paps-cups.patch
|
||||||
Patch51: paps-cpilpi.patch
|
Patch51: paps-cpilpi.patch
|
||||||
Patch52: paps-dsc-compliant.patch
|
Patch52: paps-dsc-compliant.patch
|
||||||
@ -98,6 +98,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_libdir}/libpaps.so
|
%{_libdir}/libpaps.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Sep 1 2008 Akira TAGOH <tagoh@redhat.com> - 0.6.8-7
|
||||||
|
- paps-langinfo.patch: Updated.
|
||||||
|
- paps-exitcode.patch: Updated.
|
||||||
|
|
||||||
* Fri May 16 2008 Akira TAGOH <tagoh@redhat.com> - 0.6.8-6
|
* Fri May 16 2008 Akira TAGOH <tagoh@redhat.com> - 0.6.8-6
|
||||||
- paps-cups.patch: Fix printing with -o landscape in CUPS. (#222137)
|
- paps-cups.patch: Fix printing with -o landscape in CUPS. (#222137)
|
||||||
- paps-autoconf262.patch: Fix an error on autoreconf.
|
- paps-autoconf262.patch: Fix an error on autoreconf.
|
||||||
|
Loading…
Reference in New Issue
Block a user