- Courier font to be a default font for texttopaps. (#469325)

This commit is contained in:
Akira TAGOH 2008-11-17 08:44:04 +00:00
parent dc38bd42f1
commit 3dfbf626fb
3 changed files with 29 additions and 24 deletions

View File

@ -1,6 +1,6 @@
diff -pruN -x .libs -x '*o' -x '*ps' ../paps-0.6.8.orig/src/paps.c ../paps-0.6.8/src/paps.c
--- paps-0.6.8.orig/src/paps.c 2007-11-28 16:20:56.000000000 +0900
+++ paps-0.6.8/src/paps.c 2007-11-30 17:53:06.000000000 +0900
diff -pruN paps-0.6.8.orig/src/paps.c paps-0.6.8/src/paps.c
--- paps-0.6.8.orig/src/paps.c 2008-11-07 08:27:54.000000000 +0900
+++ paps-0.6.8/src/paps.c 2008-11-07 08:29:08.000000000 +0900
@@ -92,8 +92,8 @@ typedef struct {
gchar *filename;
gchar *header_font_desc;
@ -12,15 +12,15 @@ diff -pruN -x .libs -x '*o' -x '*ps' ../paps-0.6.8.orig/src/paps.c ../paps-0.6.8
} page_layout_t;
typedef struct {
@@ -376,6 +376,7 @@ int main(int argc, char *argv[])
bottom_margin = 36;
page_width = 612;
@@ -378,6 +378,7 @@ int main(int argc, char *argv[])
page_height = 792;
font = g_strdup(MAKE_FONT_NAME ("Courier", DEFAULT_FONT_SIZE));
header_font_desc = g_strdup(MAKE_FONT_NAME ("Courier", HEADER_FONT_SCALE));
+ do_stretch_chars = TRUE;
if (argc < 6 || argc > 7) {
fprintf(stderr, "ERROR: %s job-id user title copies options [file]\n", prgname);
@@ -596,7 +597,8 @@ int main(int argc, char *argv[])
@@ -595,7 +596,8 @@ int main(int argc, char *argv[])
/* calculate x-coordinate scale */
if (page_layout.cpi > 0.0L)
{
@ -30,7 +30,7 @@ diff -pruN -x .libs -x '*o' -x '*ps' ../paps-0.6.8.orig/src/paps.c ../paps-0.6.8
fontmap = pango_ft2_font_map_new ();
fontset = pango_font_map_load_fontset (fontmap, pango_context, font_description, get_language ());
metrics = pango_fontset_get_metrics (fontset);
@@ -608,13 +610,10 @@ int main(int argc, char *argv[])
@@ -607,13 +609,10 @@ int main(int argc, char *argv[])
pango_font_metrics_unref (metrics);
g_object_unref (G_OBJECT (fontmap));
@ -46,7 +46,7 @@ diff -pruN -x .libs -x '*o' -x '*ps' ../paps-0.6.8.orig/src/paps.c ../paps-0.6.8
}
page_layout.scale_x = page_layout.scale_y = 1.0;
@@ -1002,6 +1001,7 @@ output_pages(FILE *OUT,
@@ -1001,6 +1000,7 @@ output_pages(FILE *OUT,
int column_y_pos = 0;
int page_idx = 1;
int pango_column_height = page_layout->column_height * page_layout->pt_to_pixel * PANGO_SCALE;
@ -54,7 +54,7 @@ diff -pruN -x .libs -x '*o' -x '*ps' ../paps-0.6.8.orig/src/paps.c ../paps-0.6.8
LineLink *prev_line_link = NULL;
start_page(OUT, page_idx);
@@ -1039,17 +1039,17 @@ output_pages(FILE *OUT,
@@ -1038,17 +1038,17 @@ output_pages(FILE *OUT,
);
}
}

View File

@ -1,6 +1,6 @@
diff -pruN paps-0.6.8.orig/configure.in paps-0.6.8/configure.in
--- paps-0.6.8.orig/configure.in 2007-01-19 20:06:10.000000000 +0900
+++ paps-0.6.8/configure.in 2008-05-15 22:46:49.000000000 +0900
+++ paps-0.6.8/configure.in 2008-11-07 08:21:19.000000000 +0900
@@ -7,6 +7,19 @@ AC_LANG_C
AC_PROG_CC
AM_PROG_LIBTOOL
@ -22,8 +22,8 @@ diff -pruN paps-0.6.8.orig/configure.in paps-0.6.8/configure.in
DX_CHM_FEATURE(OFF)
DX_CHI_FEATURE(OFF)
diff -pruN paps-0.6.8.orig/src/Makefile.am paps-0.6.8/src/Makefile.am
--- paps-0.6.8.orig/src/Makefile.am 2008-05-15 22:46:34.000000000 +0900
+++ paps-0.6.8/src/Makefile.am 2008-05-15 22:46:49.000000000 +0900
--- paps-0.6.8.orig/src/Makefile.am 2008-11-07 08:21:05.000000000 +0900
+++ paps-0.6.8/src/Makefile.am 2008-11-07 08:21:19.000000000 +0900
@@ -5,10 +5,10 @@ libpapsinc_HEADERS = libpaps.h
libpapsincdir = $(includedir)
@ -38,8 +38,8 @@ diff -pruN paps-0.6.8.orig/src/Makefile.am paps-0.6.8/src/Makefile.am
EXTRA_DIST = test_libpaps.c paps.1
diff -pruN paps-0.6.8.orig/src/paps.c paps-0.6.8/src/paps.c
--- paps-0.6.8.orig/src/paps.c 2008-05-15 22:46:34.000000000 +0900
+++ paps-0.6.8/src/paps.c 2008-05-15 22:48:42.000000000 +0900
--- paps-0.6.8.orig/src/paps.c 2008-11-07 08:21:05.000000000 +0900
+++ paps-0.6.8/src/paps.c 2008-11-07 08:26:28.000000000 +0900
@@ -31,6 +31,7 @@
#include <string.h>
#include <time.h>
@ -80,7 +80,7 @@ diff -pruN paps-0.6.8.orig/src/paps.c paps-0.6.8/src/paps.c
/* Set locale from environment. */
setlocale(LC_ALL, "");
@@ -348,6 +353,128 @@ int main(int argc, char *argv[])
@@ -348,6 +353,130 @@ int main(int argc, char *argv[])
g_option_context_add_main_entries(ctxt, entries, NULL);
#endif
@ -107,6 +107,8 @@ diff -pruN paps-0.6.8.orig/src/paps.c paps-0.6.8/src/paps.c
+ bottom_margin = 36;
+ page_width = 612;
+ page_height = 792;
+ font = g_strdup(MAKE_FONT_NAME ("Courier", DEFAULT_FONT_SIZE));
+ header_font_desc = g_strdup(MAKE_FONT_NAME ("Courier", HEADER_FONT_SCALE));
+
+ if (argc < 6 || argc > 7) {
+ fprintf(stderr, "ERROR: %s job-id user title copies options [file]\n", prgname);
@ -209,7 +211,7 @@ diff -pruN paps-0.6.8.orig/src/paps.c paps-0.6.8/src/paps.c
/* Parse command line */
if (!g_option_context_parse(ctxt, &argc, &argv, &error))
{
@@ -374,6 +501,8 @@ int main(int argc, char *argv[])
@@ -374,6 +503,8 @@ int main(int argc, char *argv[])
IN = stdin;
}
title = filename_in;
@ -218,7 +220,7 @@ diff -pruN paps-0.6.8.orig/src/paps.c paps-0.6.8/src/paps.c
paps = paps_new();
pango_context = paps_get_pango_context (paps);
@@ -392,8 +521,10 @@ int main(int argc, char *argv[])
@@ -392,8 +523,10 @@ int main(int argc, char *argv[])
pango_context_set_font_description (pango_context, font_description);
/* Page layout */
@ -231,7 +233,7 @@ diff -pruN paps-0.6.8.orig/src/paps.c paps-0.6.8/src/paps.c
if (num_columns == 1)
total_gutter_width = 0;
@@ -456,6 +587,8 @@ int main(int argc, char *argv[])
@@ -456,6 +589,8 @@ int main(int argc, char *argv[])
page_layout.pango_dir = pango_dir;
page_layout.filename = filename_in;
page_layout.header_font_desc = header_font_desc;
@ -240,7 +242,7 @@ diff -pruN paps-0.6.8.orig/src/paps.c paps-0.6.8/src/paps.c
/* calculate x-coordinate scale */
if (page_layout.cpi > 0.0L)
@@ -756,6 +889,12 @@ split_text_into_paragraphs (PangoContext
@@ -756,6 +891,12 @@ split_text_into_paragraphs (PangoContext
if (wc == (gunichar)-1)
{
fprintf (stderr, "%s: Invalid character in input\n", g_get_prgname ());
@ -253,7 +255,7 @@ diff -pruN paps-0.6.8.orig/src/paps.c paps-0.6.8/src/paps.c
wc = 0;
}
if (!*p || !wc || wc == '\n' || wc == '\f')
@@ -925,21 +1064,32 @@ void print_postscript_header(FILE *OUT,
@@ -925,21 +1066,32 @@ void print_postscript_header(FILE *OUT,
int orientation = page_layout->page_width > page_layout->page_height;
int bb_page_width = page_layout->page_width;
int bb_page_height = page_layout->page_height;
@ -288,7 +290,7 @@ diff -pruN paps-0.6.8.orig/src/paps.c paps-0.6.8/src/paps.c
"%%%%BeginProlog\n"
"%%%%Orientation: %s\n"
"/papsdict 1 dict def\n"
@@ -961,7 +1111,7 @@ void print_postscript_header(FILE *OUT,
@@ -961,7 +1113,7 @@ void print_postscript_header(FILE *OUT,
" pagewidth\n"
" /pagewidth pageheight def\n"
" /pageheight exch def\n"
@ -297,7 +299,7 @@ diff -pruN paps-0.6.8.orig/src/paps.c paps-0.6.8/src/paps.c
" } if\n"
" 2 dict\n"
" dup /PageSize [pagewidth pageheight] put\n"
@@ -986,11 +1136,21 @@ void print_postscript_header(FILE *OUT,
@@ -986,11 +1138,21 @@ void print_postscript_header(FILE *OUT,
" 90 rotate\n"
" 0 pageheight neg translate\n"
"} def\n",

View File

@ -1,6 +1,6 @@
Name: paps
Version: 0.6.8
Release: 7%{?dist}
Release: 8%{?dist}
License: LGPLv2+
URL: http://paps.sourceforge.net/
@ -98,6 +98,9 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/libpaps.so
%changelog
* Mon Nov 17 2008 Akira TAGOH <tagoh@redhat.com> - 0.6.8-8
- Courier font to be a default font for texttopaps. (#469325)
* Mon Sep 1 2008 Akira TAGOH <tagoh@redhat.com> - 0.6.8-7
- paps-langinfo.patch: Updated.
- paps-exitcode.patch: Updated.