Update to papi-3.7.1.
This commit is contained in:
parent
8ef6ac26ef
commit
e210718c99
@ -1,12 +0,0 @@
|
|||||||
diff -ur papi-3.7.0.orig/src/papi_internal.c papi-3.7.0.patches/src/papi_internal.c
|
|
||||||
--- papi-3.7.0.orig/src/papi_internal.c 2009-08-26 20:01:25.000000000 +0100
|
|
||||||
+++ papi-3.7.0.patches/src/papi_internal.c 2009-10-09 10:14:39.665680864 +0100
|
|
||||||
@@ -107,7 +107,7 @@
|
|
||||||
PAPIERROR(str);
|
|
||||||
|
|
||||||
if (_papi_hwi_error_level == PAPI_VERB_ESTOP)
|
|
||||||
- exit(-errorCode);
|
|
||||||
+ abort ();
|
|
||||||
else
|
|
||||||
return errorCode;
|
|
||||||
break;
|
|
@ -1,15 +0,0 @@
|
|||||||
diff -up src/multiplex.c.mult src/multiplex.c
|
|
||||||
--- src/multiplex.c.mult 2009-09-25 12:11:49.451283900 -0400
|
|
||||||
+++ src/multiplex.c 2009-09-25 12:12:53.144294969 -0400
|
|
||||||
@@ -313,9 +313,10 @@ static MasterEvent *get_my_threads_maste
|
|
||||||
return (tlist->head);
|
|
||||||
|
|
||||||
tid = _papi_hwi_thread_id_fn();
|
|
||||||
+ unsigned long pid = getpid();
|
|
||||||
|
|
||||||
while (t) {
|
|
||||||
- if (t->tid == tid)
|
|
||||||
+ if (t->tid == tid || ((tid==0) && (t->tid==pid)))
|
|
||||||
return (t->head);
|
|
||||||
t = t->next;
|
|
||||||
}
|
|
@ -1,60 +0,0 @@
|
|||||||
diff -ur papi-3.7.0.orig/src/Rules.perfctr papi-3.7.0.patches/src/Rules.perfctr
|
|
||||||
--- papi-3.7.0.orig/src/Rules.perfctr 2009-08-24 21:21:29.000000000 +0100
|
|
||||||
+++ papi-3.7.0.patches/src/Rules.perfctr 2009-10-09 10:11:53.137683917 +0100
|
|
||||||
@@ -69,7 +69,7 @@
|
|
||||||
endif
|
|
||||||
|
|
||||||
CC_R := $(CC) -pthread
|
|
||||||
-CC_SHR := $(CC) -fPIC -DPIC -shared -Wl,-soname -Wl,libpapi.so -Xlinker "-rpath" -Xlinker "$(LIBDIR)"
|
|
||||||
+CC_SHR := $(CC) -fPIC -DPIC -shared -Wl,-soname -Wl,libpapi.so.3 -Xlinker "-rpath" -Xlinker "$(LIBDIR)"
|
|
||||||
|
|
||||||
ifeq (pgf77,$(F77))
|
|
||||||
FFLAGS += -Wall -Mextend $(BITFLAGS)
|
|
||||||
diff -ur papi-3.7.0.orig/src/Rules.perfctr-pfm papi-3.7.0.patches/src/Rules.perfctr-pfm
|
|
||||||
--- papi-3.7.0.orig/src/Rules.perfctr-pfm 2009-08-24 21:21:29.000000000 +0100
|
|
||||||
+++ papi-3.7.0.patches/src/Rules.perfctr-pfm 2009-10-09 10:12:13.249680559 +0100
|
|
||||||
@@ -78,7 +78,7 @@
|
|
||||||
endif
|
|
||||||
|
|
||||||
CC_R := $(CC) -pthread
|
|
||||||
-CC_SHR := $(CC) -fPIC -DPIC -shared -Wl,-soname -Wl,libpapi.so -Xlinker "-rpath" -Xlinker "$(LIBDIR)"
|
|
||||||
+CC_SHR := $(CC) -fPIC -DPIC -shared -Wl,-soname -Wl,libpapi.so.3 -Xlinker "-rpath" -Xlinker "$(LIBDIR)"
|
|
||||||
|
|
||||||
ifeq (pgf77,$(F77))
|
|
||||||
FFLAGS += -Wall -Mextend $(BITFLAGS)
|
|
||||||
diff -ur papi-3.7.0.orig/src/Rules.pfm2 papi-3.7.0.patches/src/Rules.pfm2
|
|
||||||
--- papi-3.7.0.orig/src/Rules.pfm2 2009-08-24 21:21:29.000000000 +0100
|
|
||||||
+++ papi-3.7.0.patches/src/Rules.pfm2 2009-10-09 10:12:38.552430433 +0100
|
|
||||||
@@ -17,7 +17,7 @@
|
|
||||||
endif
|
|
||||||
|
|
||||||
CC_R := $(CC) -pthread
|
|
||||||
-CC_SHR := $(CC) -fPIC -DPIC -shared -Wl,-soname -Wl,libpapi.so -Xlinker "-rpath" -Xlinker "$(LIBDIR)"
|
|
||||||
+CC_SHR := $(CC) -fPIC -DPIC -shared -Wl,-soname -Wl,libpapi.so.3 -Xlinker "-rpath" -Xlinker "$(LIBDIR)"
|
|
||||||
|
|
||||||
ifeq (pgf77,$(F77))
|
|
||||||
FFLAGS += -Mextend
|
|
||||||
diff -ur papi-3.7.0.orig/src/Rules.pfm_pcl papi-3.7.0.patches/src/Rules.pfm_pcl
|
|
||||||
--- papi-3.7.0.orig/src/Rules.pfm_pcl 2009-10-09 10:06:54.326680322 +0100
|
|
||||||
+++ papi-3.7.0.patches/src/Rules.pfm_pcl 2009-10-09 10:12:45.255680805 +0100
|
|
||||||
@@ -16,7 +16,7 @@
|
|
||||||
endif
|
|
||||||
|
|
||||||
CC_R := $(CC) -pthread
|
|
||||||
-CC_SHR := $(CC) -fPIC -DPIC -shared -Wl,-soname -Wl,libpapi.so -Xlinker "-rpath" -Xlinker "$(LIBDIR)"
|
|
||||||
+CC_SHR := $(CC) -fPIC -DPIC -shared -Wl,-soname -Wl,libpapi.so.3 -Xlinker "-rpath" -Xlinker "$(LIBDIR)"
|
|
||||||
|
|
||||||
ifeq (pgf77,$(F77))
|
|
||||||
FFLAGS += -Mextend
|
|
||||||
diff -ur papi-3.7.0.orig/src/Rules.pfm_pcl.x86 papi-3.7.0.patches/src/Rules.pfm_pcl.x86
|
|
||||||
--- papi-3.7.0.orig/src/Rules.pfm_pcl.x86 2009-08-24 21:21:29.000000000 +0100
|
|
||||||
+++ papi-3.7.0.patches/src/Rules.pfm_pcl.x86 2009-10-09 10:12:52.808555272 +0100
|
|
||||||
@@ -16,7 +16,7 @@
|
|
||||||
endif
|
|
||||||
|
|
||||||
CC_R := $(CC) -pthread
|
|
||||||
-CC_SHR := $(CC) -fPIC -DPIC -shared -Wl,-soname -Wl,libpapi.so -Xlinker "-rpath" -Xlinker "$(LIBDIR)"
|
|
||||||
+CC_SHR := $(CC) -fPIC -DPIC -shared -Wl,-soname -Wl,libpapi.so.3 -Xlinker "-rpath" -Xlinker "$(LIBDIR)"
|
|
||||||
|
|
||||||
ifeq (pgf77,$(F77))
|
|
||||||
FFLAGS += -Mextend
|
|
@ -1,18 +0,0 @@
|
|||||||
diff -up src/Rules.pfm_pcl.x86 src/Rules.pfm_pcl
|
|
||||||
--- src/Rules.pfm_pcl.x86 2009-08-24 16:21:29.000000000 -0400
|
|
||||||
+++ src/Rules.pfm_pcl 2009-09-29 11:11:14.000000000 -0400
|
|
||||||
@@ -74,12 +74,9 @@ ifeq (pcl, $(SUBSTR))
|
|
||||||
MISCSRCS += sys_perf_counter_open.c
|
|
||||||
endif
|
|
||||||
|
|
||||||
-ifneq (CRAYX2, $(COMPILER))
|
|
||||||
- ifneq (ia64, $(ARCH))
|
|
||||||
- ifneq (ppc64, $(ARCH))
|
|
||||||
+# Additional ARCH settings for x86
|
|
||||||
+ifeq (86, $(findstring 86,$(ARCH)))
|
|
||||||
MISCSRCS += x86_cache_info.c
|
|
||||||
- endif
|
|
||||||
- endif
|
|
||||||
endif
|
|
||||||
|
|
||||||
# This is necessary to avoid text relocations. You cannot do -Lxx -lx because
|
|
16
papi.spec
16
papi.spec
@ -1,16 +1,12 @@
|
|||||||
Summary: Performance Application Programming Interface
|
Summary: Performance Application Programming Interface
|
||||||
Name: papi
|
Name: papi
|
||||||
Version: 3.7.0
|
Version: 3.7.1
|
||||||
Release: 11%{?dist}
|
Release: 1%{?dist}
|
||||||
License: BSD
|
License: BSD
|
||||||
Group: Development/System
|
Group: Development/System
|
||||||
URL: http://icl.cs.utk.edu/papi/
|
URL: http://icl.cs.utk.edu/papi/
|
||||||
Source0: http://icl.cs.utk.edu/projects/papi/downloads/%{name}-%{version}.tar.gz
|
Source0: http://icl.cs.utk.edu/projects/papi/downloads/%{name}-%{version}.tar.gz
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||||
Patch1: papi-3.7.0-multiplex.patch
|
|
||||||
Patch2: papi-3.7.0-x86-rule.patch
|
|
||||||
Patch3: papi-3.7.0-soname.patch
|
|
||||||
Patch4: papi-3.7.0-exit.patch
|
|
||||||
BuildRequires: ncurses-devel
|
BuildRequires: ncurses-devel
|
||||||
BuildRequires: gcc-gfortran
|
BuildRequires: gcc-gfortran
|
||||||
BuildRequires: kernel-devel >= 2.6.31
|
BuildRequires: kernel-devel >= 2.6.31
|
||||||
@ -31,11 +27,6 @@ that uses PAPI.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p0 -b .multiplex
|
|
||||||
%patch2 -p0 -b .x86
|
|
||||||
%patch3 -p1 -b .soname
|
|
||||||
%patch4 -p1 -b .exit
|
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
cd src
|
cd src
|
||||||
@ -79,6 +70,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%doc %{_mandir}/man3/*
|
%doc %{_mandir}/man3/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Nov 16 2009 William Cohen <wcohen@redhat.com> - 3.7.1-1
|
||||||
|
- Import papi-3.7.1.
|
||||||
|
|
||||||
* Mon Oct 26 2009 William Cohen <wcohen@redhat.com> - 3.7.0-11
|
* Mon Oct 26 2009 William Cohen <wcohen@redhat.com> - 3.7.0-11
|
||||||
- Add distro to release.
|
- Add distro to release.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user