Update source to papi-5.1.0.2.
This commit is contained in:
parent
fa16f85669
commit
d70b965d13
1
.gitignore
vendored
1
.gitignore
vendored
@ -7,3 +7,4 @@ papi-4.1.0.tar.gz
|
||||
/papi-4.4.0.tar.gz
|
||||
/papi-5.0.0.tar.gz
|
||||
/papi-5.0.1.tar.gz
|
||||
/papi-5.1.0.2.tar.gz
|
||||
|
@ -1,77 +0,0 @@
|
||||
commit f65c9d9efce2df3658f66c99c92a7de8a510b004
|
||||
Author: William Cohen <wcohen@redhat.com>
|
||||
Date: Mon Jan 7 14:00:20 2013 -0500
|
||||
|
||||
Add preset events for ARM Cortex A15
|
||||
|
||||
diff --git a/src/papi_events.csv b/src/papi_events.csv
|
||||
index 44e4b65..286ee27 100644
|
||||
--- a/src/papi_events.csv
|
||||
+++ b/src/papi_events.csv
|
||||
@@ -1349,6 +1349,24 @@ PRESET,PAPI_L1_DCA,NOT_DERIVED,DCACHE_ACCESS
|
||||
PRESET,PAPI_L1_DCM,NOT_DERIVED,DCACHE_REFILL
|
||||
PRESET,PAPI_L1_ICM,NOT_DERIVED,IFETCH_MISS
|
||||
#
|
||||
+CPU,arm_ac15
|
||||
+#
|
||||
+PRESET,PAPI_TOT_INS,NOT_DERIVED,INST_RETIRED
|
||||
+PRESET,PAPI_TOT_IIS,NOT_DERIVED,INST_SPEC_EXEC
|
||||
+PRESET,PAPI_TOT_CYC,NOT_DERIVED,CPU_CYCLES
|
||||
+#PRESET,PAPI_HW_INT,NOT_DERIVED,EXT_INTERRUPTS
|
||||
+PRESET,PAPI_FP_INS,NOT_DERIVED,INST_SPEC_EXEC_VFP
|
||||
+PRESET,PAPI_VEC_INS,NOT_DERIVED,INST_SPEC_EXEC_SIMD
|
||||
+PRESET,PAPI_BR_INS,NOT_DERIVED,INST_SPEC_EXEC_SOFT_PC
|
||||
+PRESET,PAPI_BR_MSP,NOT_DERIVED,BRANCH_MISPRED
|
||||
+PRESET,PAPI_LD_INS,NOT_DERIVED,DATA_MEM_READ_ACCESS
|
||||
+PRESET,PAPI_SR_INS,NOT_DERIVED,DATA_MEM_WRITE_ACCESS
|
||||
+#PRESET,PAPI_TLB_IM,NOT_DERIVED,ITLB_MISS
|
||||
+#PRESET,PAPI_TLB_DM,NOT_DERIVED,DTLB_REFILL
|
||||
+PRESET,PAPI_L1_DCA,DERIVED_ADD,L1D_READ_ACCESS,L1D_WRITE_ACCESS
|
||||
+PRESET,PAPI_L1_DCM,DERIVED_ADD,L1D_READ_REFILL,L1D_WRITE_REFILL
|
||||
+PRESET,PAPI_L1_ICM,NOT_DERIVED,L1I_CACHE_REFILL
|
||||
+#
|
||||
CPU,mips_74k
|
||||
#
|
||||
PRESET,PAPI_TOT_CYC,NOT_DERIVED,CYCLES
|
||||
commit 57c520df4ca957a0b2550e1177d87f8b167c06a5
|
||||
Author: William Cohen <wcohen@redhat.com>
|
||||
Date: Fri Jan 11 16:34:56 2013 -0500
|
||||
|
||||
Clean up armv7 cortex a15 presets
|
||||
|
||||
Clean up armv7 cortex a15 presets and add presets for L1 and L2 cache
|
||||
|
||||
Signed-off-by: William Cohen <wcohen@redhat.com>
|
||||
|
||||
diff --git a/src/papi_events.csv b/src/papi_events.csv
|
||||
index 286ee27..13260bc 100644
|
||||
--- a/src/papi_events.csv
|
||||
+++ b/src/papi_events.csv
|
||||
@@ -1354,18 +1354,24 @@ CPU,arm_ac15
|
||||
PRESET,PAPI_TOT_INS,NOT_DERIVED,INST_RETIRED
|
||||
PRESET,PAPI_TOT_IIS,NOT_DERIVED,INST_SPEC_EXEC
|
||||
PRESET,PAPI_TOT_CYC,NOT_DERIVED,CPU_CYCLES
|
||||
-#PRESET,PAPI_HW_INT,NOT_DERIVED,EXT_INTERRUPTS
|
||||
PRESET,PAPI_FP_INS,NOT_DERIVED,INST_SPEC_EXEC_VFP
|
||||
PRESET,PAPI_VEC_INS,NOT_DERIVED,INST_SPEC_EXEC_SIMD
|
||||
PRESET,PAPI_BR_INS,NOT_DERIVED,INST_SPEC_EXEC_SOFT_PC
|
||||
PRESET,PAPI_BR_MSP,NOT_DERIVED,BRANCH_MISPRED
|
||||
PRESET,PAPI_LD_INS,NOT_DERIVED,DATA_MEM_READ_ACCESS
|
||||
PRESET,PAPI_SR_INS,NOT_DERIVED,DATA_MEM_WRITE_ACCESS
|
||||
-#PRESET,PAPI_TLB_IM,NOT_DERIVED,ITLB_MISS
|
||||
-#PRESET,PAPI_TLB_DM,NOT_DERIVED,DTLB_REFILL
|
||||
PRESET,PAPI_L1_DCA,DERIVED_ADD,L1D_READ_ACCESS,L1D_WRITE_ACCESS
|
||||
PRESET,PAPI_L1_DCM,DERIVED_ADD,L1D_READ_REFILL,L1D_WRITE_REFILL
|
||||
+PRESET,PAPI_L1_DCR,NOT_DERIVED,L1D_READ_ACCESS
|
||||
+PRESET,PAPI_L1_DCW,NOT_DERIVED,L1D_WRITE_ACCESS
|
||||
+PRESET,PAPI_L1_ICA,NOT_DERIVED,L1I_CACHE_ACCESS
|
||||
PRESET,PAPI_L1_ICM,NOT_DERIVED,L1I_CACHE_REFILL
|
||||
+PRESET,PAPI_L2_DCH,NOT_DERIVED,L2D_CACHE_ACCESS
|
||||
+PRESET,PAPI_L2_DCM,NOT_DERIVED,L2D_CACHE_REFILL
|
||||
+PRESET,PAPI_L2_DCR,NOT_DERIVED,L2D_READ_ACCESS
|
||||
+PRESET,PAPI_L2_DCW,NOT_DERIVED,L2D_WRITE_ACCESS
|
||||
+PRESET,PAPI_L2_LDM,NOT_DERIVED,L2D_READ_REFILL
|
||||
+PRESET,PAPI_L2_STM,NOT_DERIVED,L2D_WRITE_REFILL
|
||||
#
|
||||
CPU,mips_74k
|
||||
#
|
@ -1,46 +0,0 @@
|
||||
commit d239c350a17b0e329223f62e7efc1f786e3e7ac7
|
||||
Author: William Cohen <wcohen@redhat.com>
|
||||
Date: Wed Nov 7 13:31:50 2012 -0500
|
||||
|
||||
Factor out duplicate install code from Rules.pfm4_pe
|
||||
|
||||
The Makefile.inc has a rule to installed shared libraries. However,
|
||||
Rules.pfm4_pe also has a slightly different set of rules to install
|
||||
code for shared libraries. This leads to the same shared library
|
||||
being installed under two different names. The duplicate code has
|
||||
been removed from Rules.pfm4_pe and a symbolic link has been added to
|
||||
ensure that any code that might have linked with
|
||||
libpapi.so.$(PAPIVER).$(PAPIREV).$(PAPIAGE) still runs.
|
||||
|
||||
Signed-off-by: William Cohen <wcohen@redhat.com>
|
||||
|
||||
diff --git a/src/Makefile.inc b/src/Makefile.inc
|
||||
index 1cdb270..e733ed9 100644
|
||||
--- a/src/Makefile.inc
|
||||
+++ b/src/Makefile.inc
|
||||
@@ -308,6 +308,7 @@ install-lib: native_install
|
||||
@if test -r $(SHLIB) ; then \
|
||||
cp -p $(SHLIB) $(DESTDIR)$(LIBDIR)/libpapi.so.$(PAPIVER).$(PAPIREV).$(PAPIAGE).$(PAPIINC); \
|
||||
chmod go+r $(DESTDIR)$(LIBDIR)/libpapi.so.$(PAPIVER).$(PAPIREV).$(PAPIAGE).$(PAPIINC) ; \
|
||||
+ cd $(DESTDIR)$(LIBDIR); ln -sf libpapi.so.$(PAPIVER).$(PAPIREV).$(PAPIAGE).$(PAPIINC) libpapi.so.$(PAPIVER).$(PAPIREV).$(PAPIAGE); \
|
||||
cd $(DESTDIR)$(LIBDIR); ln -sf libpapi.so.$(PAPIVER).$(PAPIREV).$(PAPIAGE).$(PAPIINC) libpapi.so.$(PAPIVER); \
|
||||
cd $(DESTDIR)$(LIBDIR); ln -sf libpapi.so.$(PAPIVER).$(PAPIREV).$(PAPIAGE).$(PAPIINC) libpapi.so; \
|
||||
fi
|
||||
diff --git a/src/Rules.pfm4_pe b/src/Rules.pfm4_pe
|
||||
index 56a2f07..0f83ec4 100644
|
||||
--- a/src/Rules.pfm4_pe
|
||||
+++ b/src/Rules.pfm4_pe
|
||||
@@ -66,11 +66,8 @@ ifneq (,${PFM_ROOT})
|
||||
-$(MAKE) -C $(PFM_ROOT) ARCH="$(ARCH)" DESTDIR=$(DESTDIR) PREFIX=$(PREFIX) install_prefix=$(PREFIX) LIBDIR=$(LIBDIR) INCDIR=$(INCDIR) MANDIR=$(MANDIR) install
|
||||
endif
|
||||
-install -d $(DESTDIR)$(LIBDIR)
|
||||
-ifneq (,$(findstring shared,$(LIBS)))
|
||||
- cp -p $(SHLIB) $(DESTDIR)$(LIBDIR)/libpapi.so.$(PAPIVER).$(PAPIREV).$(PAPIAGE)
|
||||
- cd $(DESTDIR)$(LIBDIR); ln -sf libpapi.so.$(PAPIVER).$(PAPIREV).$(PAPIAGE) libpapi.so.$(PAPIVER)
|
||||
- cd $(DESTDIR)$(LIBDIR); ln -sf libpapi.so.$(PAPIVER).$(PAPIREV).$(PAPIAGE) libpapi.so
|
||||
-endif
|
||||
+# Makefile.inc already has installation of shared libraries so
|
||||
+# there is no need to do it here
|
||||
-install -d $(DESTDIR)$(DATADIR)
|
||||
cp -f ./papi_events.csv $(DESTDIR)$(DATADIR)
|
||||
|
14
papi.spec
14
papi.spec
@ -1,14 +1,12 @@
|
||||
%bcond_with bundled_libpfm
|
||||
Summary: Performance Application Programming Interface
|
||||
Name: papi
|
||||
Version: 5.0.1
|
||||
Release: 6%{?dist}
|
||||
Version: 5.1.0.2
|
||||
Release: 1%{?dist}
|
||||
License: BSD
|
||||
Group: Development/System
|
||||
URL: http://icl.cs.utk.edu/papi/
|
||||
Source0: http://icl.cs.utk.edu/projects/papi/downloads/%{name}-%{version}.tar.gz
|
||||
Patch200: papi-libversion.patch
|
||||
Patch201: papi-armv7a15.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||
BuildRequires: ncurses-devel
|
||||
BuildRequires: gcc-gfortran
|
||||
@ -48,10 +46,7 @@ PAPI-static includes the static versions of the library files for
|
||||
the PAPI user-space libraries and interfaces.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%patch200 -p1 -b .visible
|
||||
%patch201 -p1 -b .armv7a15
|
||||
%setup -q -n papi-5.1.0
|
||||
|
||||
%build
|
||||
%if %{without bundled_libpfm}
|
||||
@ -114,6 +109,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_libdir}/*.a
|
||||
|
||||
%changelog
|
||||
* Tue Apr 9 2013 William Cohen <wcohen@redhat.com> - 5.1.0.2-1
|
||||
- Rebase to 5.1.0.2
|
||||
|
||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.0.1-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user