import papi-5.6.0-8.el8
This commit is contained in:
commit
d2a774589e
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
SOURCES/papi-5.6.0.tar.gz
|
1
.papi.metadata
Normal file
1
.papi.metadata
Normal file
@ -0,0 +1 @@
|
|||||||
|
377656f6b75cd821de9a9e663cfeb405a70906aa SOURCES/papi-5.6.0.tar.gz
|
43
SOURCES/papi-divzero.patch
Normal file
43
SOURCES/papi-divzero.patch
Normal file
@ -0,0 +1,43 @@
|
|||||||
|
commit 7a6ae407b62615d3ffa9b0d2ac17771b7fc63056
|
||||||
|
Author: Vince Weaver <vince@deater.net>
|
||||||
|
Date: Thu Sep 27 23:47:58 2018 -0400
|
||||||
|
|
||||||
|
perf_event: avoid floating point exception if running is 0
|
||||||
|
|
||||||
|
The perf_event interface isn't supposed to return 0 for running, but
|
||||||
|
it happens occasionally. So be sure not to divide by zero if this
|
||||||
|
happens. This makes the rdpmc code match the generic perf code in this
|
||||||
|
case.
|
||||||
|
|
||||||
|
This is in response to bitbucket issue #52
|
||||||
|
|
||||||
|
diff --git a/src/components/perf_event/perf_event.c b/src/components/perf_event/perf_event.c
|
||||||
|
index 7fd753ed..82b7d398 100644
|
||||||
|
--- a/src/components/perf_event/perf_event.c
|
||||||
|
+++ b/src/components/perf_event/perf_event.c
|
||||||
|
@@ -1099,14 +1099,23 @@ _pe_rdpmc_read( hwd_context_t *ctx, hwd_control_state_t *ctl,
|
||||||
|
count = mmap_read_self(pe_ctl->events[i].mmap_buf,
|
||||||
|
&enabled,&running);
|
||||||
|
|
||||||
|
- /* TODO: error checking? */
|
||||||
|
+ /* TODO: more error checking? */
|
||||||
|
|
||||||
|
/* Handle multiplexing case */
|
||||||
|
- if (enabled!=running) {
|
||||||
|
+ if (enabled == running) {
|
||||||
|
+ /* no adjustment needed */
|
||||||
|
+ }
|
||||||
|
+ else if (enabled && running) {
|
||||||
|
adjusted = (enabled * 128LL) / running;
|
||||||
|
adjusted = adjusted * count;
|
||||||
|
adjusted = adjusted / 128LL;
|
||||||
|
count = adjusted;
|
||||||
|
+ } else {
|
||||||
|
+ /* This should not happen, but we have had it reported */
|
||||||
|
+ SUBDBG("perf_event kernel bug(?) count, enabled, "
|
||||||
|
+ "running: %lld, %lld, %lld\n",
|
||||||
|
+ papi_pe_buffer[0],enabled,running);
|
||||||
|
+
|
||||||
|
}
|
||||||
|
|
||||||
|
pe_ctl->counts[i] = count;
|
115
SOURCES/papi-ldflags.patch
Normal file
115
SOURCES/papi-ldflags.patch
Normal file
@ -0,0 +1,115 @@
|
|||||||
|
commit bde3da26f1f2755689e16fc9f5ab404367d1fdc8
|
||||||
|
Author: Vince Weaver <vincent.weaver@maine.edu>
|
||||||
|
Date: Wed Jan 24 14:13:28 2018 -0500
|
||||||
|
|
||||||
|
build: fix various LDFLAGS/CFLAGS issues
|
||||||
|
|
||||||
|
issues were reported by Andreas Beckmann <anbe@debian.org>
|
||||||
|
|
||||||
|
diff --git a/src/components/Makefile_comp_tests.target.in b/src/components/Makefile_comp_tests.target.in
|
||||||
|
index 9a369adb..a4412bea 100644
|
||||||
|
--- a/src/components/Makefile_comp_tests.target.in
|
||||||
|
+++ b/src/components/Makefile_comp_tests.target.in
|
||||||
|
@@ -9,7 +9,7 @@ INCLUDE = -I. -I@includedir@ -I$(datadir) -I$(testlibdir) -I$(validationlibdir)
|
||||||
|
LIBDIR = @libdir@
|
||||||
|
PAPILIB = $(datadir)/@LIBRARY@
|
||||||
|
TESTLIB = $(testlibdir)/libtestlib.a
|
||||||
|
-LDFLAGS = @LDL@
|
||||||
|
+LDFLAGS = @LDFLAGS@ @LDL@
|
||||||
|
CC = @CC@
|
||||||
|
F77 = @F77@
|
||||||
|
CC_R = @CC_R@
|
||||||
|
diff --git a/src/components/perf_event_uncore/tests/Makefile b/src/components/perf_event_uncore/tests/Makefile
|
||||||
|
index 3ee8fc2a..d70debe6 100644
|
||||||
|
--- a/src/components/perf_event_uncore/tests/Makefile
|
||||||
|
+++ b/src/components/perf_event_uncore/tests/Makefile
|
||||||
|
@@ -17,19 +17,19 @@ perf_event_uncore_lib.o: perf_event_uncore_lib.c perf_event_uncore_lib.h
|
||||||
|
|
||||||
|
|
||||||
|
perf_event_amd_northbridge: perf_event_amd_northbridge.o $(DOLOOPS) $(UTILOBJS) $(PAPILIB) $(DOLOOPS)
|
||||||
|
- $(CC) $(LFLAGS) -o perf_event_amd_northbridge perf_event_amd_northbridge.o $(UTILOBJS) $(DOLOOPS) $(PAPILIB) $(LDFLAGS)
|
||||||
|
+ $(CC) $(CFLAGS) -o perf_event_amd_northbridge perf_event_amd_northbridge.o $(UTILOBJS) $(DOLOOPS) $(PAPILIB) $(LDFLAGS)
|
||||||
|
|
||||||
|
perf_event_uncore: perf_event_uncore.o $(UTILOBJS) $(DOLOOPS) $(PAPILIB) perf_event_uncore_lib.o
|
||||||
|
- $(CC) $(LFLAGS) -o perf_event_uncore perf_event_uncore.o perf_event_uncore_lib.o $(UTILOBJS) $(DOLOOPS) $(PAPILIB) $(LDFLAGS)
|
||||||
|
+ $(CC) $(CFLAGS) -o perf_event_uncore perf_event_uncore.o perf_event_uncore_lib.o $(UTILOBJS) $(DOLOOPS) $(PAPILIB) $(LDFLAGS)
|
||||||
|
|
||||||
|
perf_event_uncore_attach: perf_event_uncore_attach.o $(UTILOBJS) $(DOLOOPS) $(PAPILIB) perf_event_uncore_lib.o
|
||||||
|
- $(CC) $(LFLAGS) -o perf_event_uncore_attach perf_event_uncore_attach.o perf_event_uncore_lib.o $(UTILOBJS) $(DOLOOPS) $(PAPILIB) $(LDFLAGS)
|
||||||
|
+ $(CC) $(CFLAGS) -o perf_event_uncore_attach perf_event_uncore_attach.o perf_event_uncore_lib.o $(UTILOBJS) $(DOLOOPS) $(PAPILIB) $(LDFLAGS)
|
||||||
|
|
||||||
|
perf_event_uncore_multiple: perf_event_uncore_multiple.o perf_event_uncore_lib.o $(UTILOBJS) $(DOLOOPS) $(PAPILIB)
|
||||||
|
- $(CC) $(LFLAGS) $(INCLUDE) -o perf_event_uncore_multiple perf_event_uncore_multiple.o perf_event_uncore_lib.o $(UTILOBJS) $(DOLOOPS) $(PAPILIB) $(LDFLAGS)
|
||||||
|
+ $(CC) $(CFLAGS) $(INCLUDE) -o perf_event_uncore_multiple perf_event_uncore_multiple.o perf_event_uncore_lib.o $(UTILOBJS) $(DOLOOPS) $(PAPILIB) $(LDFLAGS)
|
||||||
|
|
||||||
|
perf_event_uncore_cbox: perf_event_uncore_cbox.o perf_event_uncore_lib.o $(UTILOBJS) $(DOLOOPS) $(PAPILIB)
|
||||||
|
- $(CC) $(LFLAGS) $(INCLUDE) -o perf_event_uncore_cbox perf_event_uncore_cbox.o perf_event_uncore_lib.o $(UTILOBJS) $(DOLOOPS) $(PAPILIB) $(LDFLAGS)
|
||||||
|
+ $(CC) $(CFLAGS) $(INCLUDE) -o perf_event_uncore_cbox perf_event_uncore_cbox.o perf_event_uncore_lib.o $(UTILOBJS) $(DOLOOPS) $(PAPILIB) $(LDFLAGS)
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
|
diff --git a/src/ctests/Makefile.recipies b/src/ctests/Makefile.recipies
|
||||||
|
index 63c107c0..201f3c85 100644
|
||||||
|
--- a/src/ctests/Makefile.recipies
|
||||||
|
+++ b/src/ctests/Makefile.recipies
|
||||||
|
@@ -350,7 +350,7 @@ code2name: code2name.c $(TESTLIB) $(PAPILIB)
|
||||||
|
$(CC) $(INCLUDE) $(CFLAGS) $(TOPTFLAGS) code2name.c $(TESTLIB) $(PAPILIB) $(LDFLAGS) -o code2name
|
||||||
|
|
||||||
|
attach_target: attach_target.c $(DOLOOPS)
|
||||||
|
- -$(CC) $(INCLUDE) $(CFLAGS) $(TOPTFLAGS) attach_target.c -o attach_target $(DOLOOPS) $(TESTLIB)
|
||||||
|
+ -$(CC) $(INCLUDE) $(CFLAGS) $(TOPTFLAGS) attach_target.c -o attach_target $(DOLOOPS) $(TESTLIB) $(LDFLAGS)
|
||||||
|
|
||||||
|
zero_attach: zero_attach.c $(TESTLIB) $(DOLOOPS) $(PAPILIB)
|
||||||
|
-$(CC) $(INCLUDE) $(CFLAGS) $(TOPTFLAGS) zero_attach.c $(TESTLIB) $(DOLOOPS) $(PAPILIB) $(LDFLAGS) -o zero_attach
|
||||||
|
diff --git a/src/ctests/Makefile.target.in b/src/ctests/Makefile.target.in
|
||||||
|
index bb51c350..fcc3373b 100644
|
||||||
|
--- a/src/ctests/Makefile.target.in
|
||||||
|
+++ b/src/ctests/Makefile.target.in
|
||||||
|
@@ -12,7 +12,7 @@ LIBRARY=@LIBRARY@
|
||||||
|
SHLIB=@SHLIB@
|
||||||
|
PAPILIB = ../@LINKLIB@
|
||||||
|
TESTLIB = $(testlibdir)/libtestlib.a
|
||||||
|
-LDFLAGS = @LDL@ @STATIC@
|
||||||
|
+LDFLAGS = @LDFLAGS@ @LDL@ @STATIC@
|
||||||
|
CC = @CC@
|
||||||
|
MPICC = @MPICC@
|
||||||
|
F77 = @F77@
|
||||||
|
diff --git a/src/ftests/Makefile.target.in b/src/ftests/Makefile.target.in
|
||||||
|
index 718586e5..8006dd8d 100644
|
||||||
|
--- a/src/ftests/Makefile.target.in
|
||||||
|
+++ b/src/ftests/Makefile.target.in
|
||||||
|
@@ -11,7 +11,7 @@ LIBRARY = @LIBRARY@
|
||||||
|
SHLIB=@SHLIB@
|
||||||
|
PAPILIB = ../@LINKLIB@
|
||||||
|
TESTLIB = $(testlibdir)/libtestlib.a
|
||||||
|
-LDFLAGS = @LDL@
|
||||||
|
+LDFLAGS = @LDFLAGS@ @LDL@
|
||||||
|
CC = @CC@
|
||||||
|
F77 = @F77@
|
||||||
|
CC_R = @CC_R@
|
||||||
|
diff --git a/src/utils/Makefile.target.in b/src/utils/Makefile.target.in
|
||||||
|
index a5eab438..58d438a1 100644
|
||||||
|
--- a/src/utils/Makefile.target.in
|
||||||
|
+++ b/src/utils/Makefile.target.in
|
||||||
|
@@ -11,7 +11,7 @@ LIBRARY=@LIBRARY@
|
||||||
|
SHLIB=@SHLIB@
|
||||||
|
PAPILIB = ../@LINKLIB@
|
||||||
|
TESTLIB = $(testlibdir)/libtestlib.a
|
||||||
|
-LDFLAGS = @LDL@ @STATIC@
|
||||||
|
+LDFLAGS = @LDFLAGS@ @LDL@ @STATIC@
|
||||||
|
CC = @CC@
|
||||||
|
MPICC = @MPICC@
|
||||||
|
F77 = @F77@
|
||||||
|
diff --git a/src/validation_tests/Makefile.target.in b/src/validation_tests/Makefile.target.in
|
||||||
|
index a5eab438..58d438a1 100644
|
||||||
|
--- a/src/validation_tests/Makefile.target.in
|
||||||
|
+++ b/src/validation_tests/Makefile.target.in
|
||||||
|
@@ -11,7 +11,7 @@ LIBRARY=@LIBRARY@
|
||||||
|
SHLIB=@SHLIB@
|
||||||
|
PAPILIB = ../@LINKLIB@
|
||||||
|
TESTLIB = $(testlibdir)/libtestlib.a
|
||||||
|
-LDFLAGS = @LDL@ @STATIC@
|
||||||
|
+LDFLAGS = @LDFLAGS@ @LDL@ @STATIC@
|
||||||
|
CC = @CC@
|
||||||
|
MPICC = @MPICC@
|
||||||
|
F77 = @F77@
|
393
SPECS/papi.spec
Normal file
393
SPECS/papi.spec
Normal file
@ -0,0 +1,393 @@
|
|||||||
|
%bcond_with bundled_libpfm
|
||||||
|
# rdma is not available
|
||||||
|
%ifarch %{arm}
|
||||||
|
%{!?with_rdma: %global with_rdma 0}
|
||||||
|
%else
|
||||||
|
%{!?with_rdma: %global with_rdma 1}
|
||||||
|
%endif
|
||||||
|
Summary: Performance Application Programming Interface
|
||||||
|
Name: papi
|
||||||
|
Version: 5.6.0
|
||||||
|
Release: 8%{?dist}
|
||||||
|
License: BSD
|
||||||
|
Group: Development/System
|
||||||
|
Requires: papi-libs = %{version}-%{release}
|
||||||
|
URL: http://icl.cs.utk.edu/papi/
|
||||||
|
Source0: http://icl.cs.utk.edu/projects/papi/downloads/%{name}-%{version}.tar.gz
|
||||||
|
Patch1: papi-ldflags.patch
|
||||||
|
Patch2: papi-divzero.patch
|
||||||
|
BuildRequires: autoconf
|
||||||
|
BuildRequires: doxygen
|
||||||
|
BuildRequires: ncurses-devel
|
||||||
|
BuildRequires: gcc-gfortran
|
||||||
|
BuildRequires: kernel-headers >= 2.6.32
|
||||||
|
BuildRequires: chrpath
|
||||||
|
BuildRequires: lm_sensors-devel
|
||||||
|
%if %{without bundled_libpfm}
|
||||||
|
BuildRequires: libpfm-devel >= 4.6.0-1
|
||||||
|
BuildRequires: libpfm-static >= 4.6.0-1
|
||||||
|
%endif
|
||||||
|
# Following required for net component
|
||||||
|
BuildRequires: net-tools
|
||||||
|
%if %{with_rdma}
|
||||||
|
# Following required for inifiband component
|
||||||
|
BuildRequires: rdma-core-devel
|
||||||
|
BuildRequires: infiniband-diags-devel
|
||||||
|
%endif
|
||||||
|
BuildRequires: perl-generators
|
||||||
|
#Right now libpfm does not know anything about s390 and will fail
|
||||||
|
ExcludeArch: s390 s390x
|
||||||
|
|
||||||
|
%description
|
||||||
|
PAPI provides a programmer interface to monitor the performance of
|
||||||
|
running programs.
|
||||||
|
|
||||||
|
%package libs
|
||||||
|
Summary: Libraries for PAPI clients
|
||||||
|
Group: Development/System
|
||||||
|
%description libs
|
||||||
|
This package contains the run-time libraries for any application that wishes
|
||||||
|
to use PAPI.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Header files for the compiling programs with PAPI
|
||||||
|
Group: Development/System
|
||||||
|
Requires: papi = %{version}-%{release}
|
||||||
|
Requires: pkgconfig
|
||||||
|
%description devel
|
||||||
|
PAPI-devel includes the C header files that specify the PAPI user-space
|
||||||
|
libraries and interfaces. This is required for rebuilding any program
|
||||||
|
that uses PAPI.
|
||||||
|
|
||||||
|
%package testsuite
|
||||||
|
Summary: Set of tests for checking PAPI functionality
|
||||||
|
Group: Development/System
|
||||||
|
Requires: papi = %{version}-%{release}
|
||||||
|
%description testsuite
|
||||||
|
PAPI-testuiste includes compiled versions of papi tests to ensure
|
||||||
|
that PAPI functions on particular hardware.
|
||||||
|
|
||||||
|
%package static
|
||||||
|
Summary: Static libraries for the compiling programs with PAPI
|
||||||
|
Group: Development/System
|
||||||
|
Requires: papi = %{version}-%{release}
|
||||||
|
%description static
|
||||||
|
PAPI-static includes the static versions of the library files for
|
||||||
|
the PAPI user-space libraries and interfaces.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch1 -p1 -b .ldflags
|
||||||
|
%patch2 -p1 -b .divzero
|
||||||
|
|
||||||
|
%build
|
||||||
|
%if %{without bundled_libpfm}
|
||||||
|
# Build our own copy of libpfm.
|
||||||
|
%global libpfm_config --with-pfm-incdir=%{_includedir} --with-pfm-libdir=%{_libdir}
|
||||||
|
%endif
|
||||||
|
|
||||||
|
cd src
|
||||||
|
autoconf
|
||||||
|
%configure --with-perf-events \
|
||||||
|
%{?libpfm_config} \
|
||||||
|
--with-static-lib=yes --with-shared-lib=yes --with-shlib --with-shlib-tools \
|
||||||
|
--with-components="appio coretemp example infiniband lmsensors lustre micpower mx net rapl stealtime"
|
||||||
|
# implicit enabled components: perf_event perf_event_uncore
|
||||||
|
#components currently left out because of build configure/build issues
|
||||||
|
# --with-components="bgpm coretemp_freebsd cuda host_micpower nvml vmware"
|
||||||
|
|
||||||
|
pushd components
|
||||||
|
#pushd cuda; ./configure; popd
|
||||||
|
#pushd host_micpower; ./configure; popd
|
||||||
|
%if %{with_rdma}
|
||||||
|
pushd infiniband_umad; %configure; popd
|
||||||
|
%endif
|
||||||
|
pushd lmsensors; \
|
||||||
|
%configure --with-sensors_incdir=/usr/include/sensors \
|
||||||
|
--with-sensors_libdir=%{_libdir}; \
|
||||||
|
popd
|
||||||
|
#pushd vmware; ./configure; popd
|
||||||
|
popd
|
||||||
|
|
||||||
|
#DBG workaround to make sure libpfm just uses the normal CFLAGS
|
||||||
|
DBG="" make %{?_smp_mflags}
|
||||||
|
|
||||||
|
#generate updated versions of the documentation
|
||||||
|
#DBG workaround to make sure libpfm just uses the normal CFLAGS
|
||||||
|
pushd ../doc
|
||||||
|
DBG="" make
|
||||||
|
DBG="" make install
|
||||||
|
popd
|
||||||
|
|
||||||
|
%install
|
||||||
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
cd src
|
||||||
|
make DESTDIR=$RPM_BUILD_ROOT LDCONFIG=/bin/true install-all
|
||||||
|
|
||||||
|
chrpath --delete $RPM_BUILD_ROOT%{_libdir}/*.so*
|
||||||
|
|
||||||
|
%files
|
||||||
|
%{_bindir}/*
|
||||||
|
%dir /usr/share/papi
|
||||||
|
/usr/share/papi/papi_events.csv
|
||||||
|
%doc INSTALL.txt README LICENSE.txt RELEASENOTES.txt
|
||||||
|
%doc %{_mandir}/man1/*
|
||||||
|
|
||||||
|
%post libs -p /sbin/ldconfig
|
||||||
|
%postun libs -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%files libs
|
||||||
|
%{_libdir}/*.so.*
|
||||||
|
%doc INSTALL.txt README LICENSE.txt RELEASENOTES.txt
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%{_includedir}/*.h
|
||||||
|
%if %{with bundled_libpfm}
|
||||||
|
%{_includedir}/perfmon/*.h
|
||||||
|
%endif
|
||||||
|
%{_libdir}/*.so
|
||||||
|
%{_libdir}/pkgconfig/papi*.pc
|
||||||
|
%doc %{_mandir}/man3/*
|
||||||
|
|
||||||
|
%files testsuite
|
||||||
|
/usr/share/papi/run_tests*
|
||||||
|
/usr/share/papi/ctests
|
||||||
|
/usr/share/papi/ftests
|
||||||
|
/usr/share/papi/validation_tests
|
||||||
|
/usr/share/papi/components
|
||||||
|
/usr/share/papi/testlib
|
||||||
|
|
||||||
|
%files static
|
||||||
|
%{_libdir}/*.a
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Nov 2 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.0-8
|
||||||
|
- Pull in patch to avoid division-by-0.
|
||||||
|
|
||||||
|
* Thu May 17 2018 William Cohen <wcohen@redhat.com> - 5.6.0-6
|
||||||
|
- Dynamically link utilities and tests to papi libraries.
|
||||||
|
|
||||||
|
* Mon Apr 30 2018 William Cohen <wcohen@redhat.com> - 5.6.0-5
|
||||||
|
- Include various LDFLAGS/CFLAGS.
|
||||||
|
|
||||||
|
* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.0-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jan 31 2018 William Cohen <wcohen@redhat.com> - 5.6.0-3
|
||||||
|
- Bump and rebuild.
|
||||||
|
|
||||||
|
* Thu Dec 21 2017 William Cohen <wcohen@redhat.com> - 5.6.0-2
|
||||||
|
- Correct infiniband buildrequires.
|
||||||
|
|
||||||
|
* Thu Dec 21 2017 William Cohen <wcohen@redhat.com> - 5.6.0-1
|
||||||
|
- Rebase to papi-5.6.0.
|
||||||
|
|
||||||
|
* Mon Aug 28 2017 Honggang LI <honli@redhat.com> - 5.5.1-6
|
||||||
|
- Disable RDMA support on ARM32
|
||||||
|
|
||||||
|
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.5.1-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.5.1-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.5.1-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Feb 2 2017 William Cohen <wcohen@redhat.com> - 5.5.1-2
|
||||||
|
- Bump version and rebuild due to new libgfortan.so version.
|
||||||
|
|
||||||
|
* Fri Nov 18 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.5.1-1
|
||||||
|
- Rebase to papi-5.5.1.
|
||||||
|
|
||||||
|
* Wed Sep 14 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.5.0-1
|
||||||
|
- Rebase to papi-5.5.0.
|
||||||
|
|
||||||
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.4.3-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jan 26 2016 William Cohen <wcohen@redhat.com> - 5.4.3-1
|
||||||
|
- Rebase to papi-5.4.3.
|
||||||
|
|
||||||
|
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.4.1-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Mar 6 2015 William Cohen <wcohen@redhat.com> - 5.4.1-2
|
||||||
|
- Make sure using libpfm-4.6.0.
|
||||||
|
|
||||||
|
* Tue Mar 3 2015 William Cohen <wcohen@redhat.com> - 5.4.1-1
|
||||||
|
- Rebase to papi-5.4.1.
|
||||||
|
|
||||||
|
* Wed Feb 11 2015 William Cohen <wcohen@redhat.com> - 5.4.0-3
|
||||||
|
- Bump version and rebuild.
|
||||||
|
|
||||||
|
* Thu Dec 18 2014 William Cohen <wcohen@redhat.com> - 5.4.0-2
|
||||||
|
- Split out papi-libs as separate subpackage. (#1172875)
|
||||||
|
|
||||||
|
* Mon Nov 17 2014 William Cohen <wcohen@redhat.com> - 5.4.0-1
|
||||||
|
- Rebase to papi-5.4.0.
|
||||||
|
|
||||||
|
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.2-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Aug 4 2014 William Cohen <wcohen@redhat.com> - 5.3.2-1
|
||||||
|
- Rebase to 5.3.2.
|
||||||
|
|
||||||
|
* Fri Jun 06 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.0-2.16.ga7f6159
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jan 17 2014 Lukas Berk <lberk@redhat.com> - 5.3.0-1.16.ga7f6159
|
||||||
|
- Automated weekly rawhide release
|
||||||
|
|
||||||
|
* Thu Jan 16 2014 William Cohen <wcohen@redhat.com> - 5.3.0-1
|
||||||
|
- Rebase to 5.3.0.
|
||||||
|
|
||||||
|
* Tue Jan 14 2014 William Cohen <wcohen@redhat.com> - 5.2.0-5
|
||||||
|
- Add presets for Intel Silvermont.
|
||||||
|
|
||||||
|
* Mon Jan 13 2014 William Cohen <wcohen@redhat.com> - 5.2.0-4
|
||||||
|
- Add presets for Haswell and Ivy Bridge.
|
||||||
|
|
||||||
|
* Wed Aug 14 2013 William Cohen <wcohen@redhat.com> - 5.2.0-2
|
||||||
|
- Enable infiniband and stealtime components.
|
||||||
|
|
||||||
|
* Wed Aug 07 2013 William Cohen <wcohen@redhat.com> - 5.2.0-1
|
||||||
|
- Rebase to 5.2.0
|
||||||
|
|
||||||
|
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.1-8
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 24 2013 William Cohen <wcohen@redhat.com> - 5.1.1-7
|
||||||
|
- rhbz830275 - Add support for POWER8 processor to PAPI
|
||||||
|
|
||||||
|
* Mon Jul 22 2013 William Cohen <wcohen@redhat.com> - 5.1.1-6
|
||||||
|
- Add autoconf buildrequires.
|
||||||
|
|
||||||
|
* Mon Jul 22 2013 William Cohen <wcohen@redhat.com> - 5.1.1-5
|
||||||
|
- rhbz986673 - /usr/lib64/libpapi.so is unowned
|
||||||
|
- Package files in /usr/share/papi only once.
|
||||||
|
- Avoid dependency problem with parallel make of man pages.
|
||||||
|
|
||||||
|
* Fri Jul 19 2013 William Cohen <wcohen@redhat.com> - 5.1.1-4
|
||||||
|
- Correct changelog.
|
||||||
|
|
||||||
|
* Fri Jul 5 2013 William Cohen <wcohen@redhat.com> - 5.1.1-3
|
||||||
|
- Add man page corrections/updates.
|
||||||
|
|
||||||
|
* Fri Jun 28 2013 William Cohen <wcohen@redhat.com> - 5.1.1-2
|
||||||
|
- Add testsuite subpackage.
|
||||||
|
|
||||||
|
* Thu May 30 2013 William Cohen <wcohen@redhat.com> - 5.1.1-1
|
||||||
|
- Rebase to 5.1.1
|
||||||
|
|
||||||
|
* Mon Apr 15 2013 William Cohen <wcohen@redhat.com> - 5.1.0.2-2
|
||||||
|
- Fix arm FTBS rhbz 951806.
|
||||||
|
|
||||||
|
* Tue Apr 9 2013 William Cohen <wcohen@redhat.com> - 5.1.0.2-1
|
||||||
|
- Rebase to 5.1.0.2
|
||||||
|
|
||||||
|
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.0.1-6
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Jan 14 2013 William Cohen <wcohen@redhat.com> - 5.0.1-5
|
||||||
|
- Add armv7 cortex a15 presets.
|
||||||
|
|
||||||
|
* Tue Dec 04 2012 William Cohen <wcohen@redhat.com> - 5.0.1-4
|
||||||
|
- Disable ldconfig on install.
|
||||||
|
|
||||||
|
* Thu Nov 08 2012 William Cohen <wcohen@redhat.com> - 5.0.1-3
|
||||||
|
- Avoid duplicated shared library.
|
||||||
|
|
||||||
|
* Wed Oct 03 2012 William Cohen <wcohen@redhat.com> - 5.0.1-2
|
||||||
|
- Make sure using compatible version of libpfm.
|
||||||
|
|
||||||
|
* Thu Sep 20 2012 William Cohen <wcohen@redhat.com> - 5.0.1-1
|
||||||
|
- Rebase to 5.0.1.
|
||||||
|
|
||||||
|
* Mon Sep 10 2012 William Cohen <wcohen@redhat.com> - 5.0.0-6
|
||||||
|
- Back port fixes for Intel Ivy Bridge event presets.
|
||||||
|
|
||||||
|
* Thu Aug 30 2012 William Cohen <wcohen@redhat.com> - 5.0.0-5
|
||||||
|
- Fixes to make papi with unbundled libpfm.
|
||||||
|
|
||||||
|
* Mon Aug 27 2012 William Cohen <wcohen@redhat.com> - 5.0.0-2
|
||||||
|
- Keep libpfm unbundled.
|
||||||
|
|
||||||
|
* Fri Aug 24 2012 William Cohen <wcohen@redhat.com> - 5.0.0-1
|
||||||
|
- Rebase to 5.0.0.
|
||||||
|
|
||||||
|
* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.4.0-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Jun 11 2012 William Cohen <wcohen@redhat.com> - 4.4.0-4
|
||||||
|
- Use siginfo_t rather than struct siginfo.
|
||||||
|
|
||||||
|
* Mon Jun 11 2012 William Cohen <wcohen@redhat.com> - 4.4.0-3
|
||||||
|
- Correct build requires.
|
||||||
|
|
||||||
|
* Mon Jun 11 2012 William Cohen <wcohen@redhat.com> - 4.4.0-2
|
||||||
|
- Unbundle libpfm4 from papi.
|
||||||
|
- Correct description spellings.
|
||||||
|
- Remove unused test section.
|
||||||
|
|
||||||
|
* Fri Apr 20 2012 William Cohen <wcohen@redhat.com> - 4.4.0-1
|
||||||
|
- Rebase to 4.4.0.
|
||||||
|
|
||||||
|
* Fri Mar 9 2012 William Cohen <wcohen@redhat.com> - 4.2.1-2
|
||||||
|
- Fix overrun in lmsensor component. (rhbz797692)
|
||||||
|
|
||||||
|
* Tue Feb 14 2012 William Cohen <wcohen@redhat.com> - 4.2.1-1
|
||||||
|
- Rebase to 4.2.1.
|
||||||
|
|
||||||
|
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.0-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Nov 02 2011 William Cohen <wcohen@redhat.com> - 4.2.0-3
|
||||||
|
- Remove unwanted man1/*.c.1 files. (rhbz749725)
|
||||||
|
|
||||||
|
* Mon Oct 31 2011 William Cohen <wcohen@redhat.com> - 4.2.0-2
|
||||||
|
- Include appropirate man pages with papi rpm. (rhbz749725)
|
||||||
|
- Rebase to papi-4.2.0, fixup for coretemp component. (rhbz746851)
|
||||||
|
|
||||||
|
* Thu Oct 27 2011 William Cohen <wcohen@redhat.com> - 4.2.0-1
|
||||||
|
- Rebase to papi-4.2.0.
|
||||||
|
|
||||||
|
* Fri Aug 12 2011 William Cohen <wcohen@redhat.com> - 4.1.3-3
|
||||||
|
- Provide papi-static.
|
||||||
|
|
||||||
|
* Thu May 12 2011 William Cohen <wcohen@redhat.com> - 4.1.3-2
|
||||||
|
- Use corrected papi-4.1.3.
|
||||||
|
|
||||||
|
* Thu May 12 2011 William Cohen <wcohen@redhat.com> - 4.1.3-1
|
||||||
|
- Rebase to papi-4.1.3
|
||||||
|
|
||||||
|
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.1.2.1-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Jan 24 2011 William Cohen <wcohen@redhat.com> - 4.1.2.1-1
|
||||||
|
- Rebase to papi-4.1.2.1
|
||||||
|
|
||||||
|
* Fri Oct 1 2010 William Cohen <wcohen@redhat.com> - 4.1.1-1
|
||||||
|
- Rebase to papi-4.1.1
|
||||||
|
|
||||||
|
* Tue Jun 22 2010 William Cohen <wcohen@redhat.com> - 4.1.0-1
|
||||||
|
- Rebase to papi-4.1.0
|
||||||
|
|
||||||
|
* Mon May 17 2010 William Cohen <wcohen@redhat.com> - 4.0.0-5
|
||||||
|
- Test run with upstream cvs version.
|
||||||
|
|
||||||
|
* Wed Feb 10 2010 William Cohen <wcohen@redhat.com> - 4.0.0-4
|
||||||
|
- Resolves: rhbz562935 Rebase to papi-4.0.0 (correct ExcludeArch).
|
||||||
|
|
||||||
|
* Wed Feb 10 2010 William Cohen <wcohen@redhat.com> - 4.0.0-3
|
||||||
|
- Resolves: rhbz562935 Rebase to papi-4.0.0 (bump nvr).
|
||||||
|
|
||||||
|
* Wed Feb 10 2010 William Cohen <wcohen@redhat.com> - 4.0.0-2
|
||||||
|
- correct the ctests/shlib test
|
||||||
|
- have PAPI_set_multiplex() return proper value
|
||||||
|
- properly handle event unit masks
|
||||||
|
- correct PAPI_name_to_code() to match events
|
||||||
|
- Resolves: rhbz562935 Rebase to papi-4.0.0
|
||||||
|
|
||||||
|
* Wed Jan 13 2010 William Cohen <wcohen@redhat.com> - 4.0.0-1
|
||||||
|
- Generate papi.spec file for papi-4.0.0.
|
Loading…
Reference in New Issue
Block a user