Resolves: RHEL-33515

This commit is contained in:
William Cohen 2024-04-26 14:35:13 -04:00
parent 7b57259877
commit 5c6e4fd8df
2 changed files with 39 additions and 1 deletions

33
papi-libsde.patch Normal file
View File

@ -0,0 +1,33 @@
commit 2f37f74ea25f850835b22fa617938264bd158134
Author: William Cohen <wcohen@redhat.com>
Date: Thu Apr 25 10:55:36 2024 -0400
SDE_LIB: Build libsde.so.1.0 with the CFLAGS and LDFLAGS passed in
A recent annocheck of the papi RPMS showed that libsde.so.1.0 was not
built with the expected flags passed into the RPM build. Minor
changes were made to src/sde_lib/Makefile to use the CFLAGS and
LDFLAGS passed in.
diff --git a/src/sde_lib/Makefile b/src/sde_lib/Makefile
index 67ef5987..8518f92e 100644
--- a/src/sde_lib/Makefile
+++ b/src/sde_lib/Makefile
@@ -1,7 +1,7 @@
CC ?= gcc
SDE_INC = -I. -I..
SDE_LD = -ldl -pthread
-CFLAGS = -Wextra -Wall -O2
+CFLAGS += -Wextra -Wall -O2
%_d.o: %.c
$(CC) -c -Bdynamic -fPIC -shared -fvisibility=hidden $(CFLAGS) $(SDE_INC) $< -o $@
@@ -14,7 +14,7 @@ SOBJS=$(patsubst %.c,%_s.o,$(wildcard *.c))
all: dynamic static
dynamic: $(DOBJS)
- $(CC) -Bdynamic -fPIC -shared -Wl,-soname -Wl,libsde.so -fvisibility=hidden $(CFLAGS) $(DOBJS) -lrt -ldl -pthread -o libsde.so.1.0
+ $(CC) $(LDFLAGS) -Bdynamic -fPIC -shared -Wl,-soname -Wl,libsde.so -fvisibility=hidden $(CFLAGS) $(DOBJS) -lrt -ldl -pthread -o libsde.so.1.0
rm -f *_d.o
static: $(SOBJS)

View File

@ -15,13 +15,14 @@
Summary: Performance Application Programming Interface
Name: papi
Version: 7.1.0
Release: 3%{?dist}
Release: 4%{?dist}
License: BSD-3-Clause
Requires: papi-libs = %{version}-%{release}
URL: http://icl.cs.utk.edu/papi/
Source0: http://icl.cs.utk.edu/projects/papi/downloads/%{name}-%{version}.tar.gz
Patch1: papi-python3.patch
Patch5: papi-nostatic.patch
Patch6: papi-libsde.patch
BuildRequires: make
BuildRequires: autoconf
BuildRequires: doxygen
@ -95,6 +96,7 @@ the PAPI user-space libraries and interfaces.
%setup -q
%patch 1 -p1 -b .python3
%patch 5 -p1
%patch 6 -p1 -b .flags
%build
@ -189,6 +191,9 @@ find %{buildroot} -type f -executable ! -iname "*.py" ! -iname "*.sh" | xargs ch
%endif
%changelog
* Fri Apr 26 2024 William Cohen <wcohen@redhat.com> - 7.1.0-4
- Ensure sde library built with proper flags. (RHEL-33515)
* Thu Jan 25 2024 Fedora Release Engineering <releng@fedoraproject.org> - 7.1.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild