436eae4e1e
... for release candidate: Pacemaker-2.0.0-rc2, for full details, see included ChangeLog file or https://github.com/ClusterLabs/pacemaker/releases/tag/Pacemaker-2.0.0-rc2 Adapt spec file more akin to upstream version including: . out-of-tree change from 1.1.18-2 build got subsumed (508ad52e7) . %%{_sysconfdir}/pacemaker path got properly owned (-cli package; f6e3ab98d) . -libs package started to properly declare Requires(pre): shadow-utils (293fcc1e8 + b3d49d210) . some build conditionals and dependencies dropped for no longer (snmp, esmtp; f24bdc6f2 and 1f7374884, respectively) or never being relevant (~bison, byacc, flex; 61aef8af4) . some dependencies were constrained with new or higher lower bounds: corosync needs to be of version 2+ unconditionally (ccd58fe29), ditto some others components (~GLib, 1ac2e7cbb), plus both 2 and 3 versions of Python are now (comprehensively for the auxiliary functionality where used) supported upstream with the latter being a better fit (453355f8f) . package descriptions got to reflect the drop of legacy low-level cluster infrastructures (55ab749bf) Adapt spec file akin to current packaging guidelines including: . drop some redundant/futile expressions (defattr, "-n %%{name}-libs" instead of plain "libs", "timezone hack"), add some notes for future . make -cts and -doc packages noarch (former enabled with 088a5e7d4) . simplify "systemd_requires" macro invocation, and relax it to "systemd_ordering" for -remote package where possible so as not to drag systemd into a lightweight system setup (e.g. container) needlessly . adjust, in a compatible way, common ldconfig invocation with post{,un} scriptlets (https://fedoraproject.org/wiki/Changes/Removing_ldconfig_scriptlets) . drop some more unuseful conditionals (upstart_job) Apply some regression fixes on top as patches (PR #1457, #1459) Signed-off-by: Jan Pokorný <jpokorny@redhat.com>
172 lines
6.6 KiB
Diff
172 lines
6.6 KiB
Diff
From 560281f7479d3526fd974a0c21c09ae930151df1 Mon Sep 17 00:00:00 2001
|
|
From: Ken Gaillot <kgaillot@redhat.com>
|
|
Date: Tue, 10 Apr 2018 10:43:35 -0500
|
|
Subject: [PATCH 11/17] Build: tools: only link against necessary libraries
|
|
|
|
COMMONLIBS was not
|
|
---
|
|
tools/Makefile.am | 103 ++++++++++++++++++++++------------------------
|
|
1 file changed, 50 insertions(+), 53 deletions(-)
|
|
|
|
diff --git a/tools/Makefile.am b/tools/Makefile.am
|
|
index f1cc92ed2..24b1d8bdd 100644
|
|
--- a/tools/Makefile.am
|
|
+++ b/tools/Makefile.am
|
|
@@ -1,19 +1,8 @@
|
|
#
|
|
-# Copyright (C) 2004-2009 Andrew Beekhof
|
|
+# Copyright 2004-2018 Andrew Beekhof <andrew@beekhof.net>
|
|
#
|
|
-# This program is free software; you can redistribute it and/or
|
|
-# modify it under the terms of the GNU General Public License
|
|
-# as published by the Free Software Foundation; either version 2
|
|
-# of the License, or (at your option) any later version.
|
|
-#
|
|
-# This program is distributed in the hope that it will be useful,
|
|
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
|
-# GNU General Public License for more details.
|
|
-#
|
|
-# You should have received a copy of the GNU General Public License
|
|
-# along with this program; if not, write to the Free Software
|
|
-# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
|
|
+# This source code is licensed under the GNU General Public License version 2
|
|
+# or later (GPLv2+) WITHOUT ANY WARRANTY.
|
|
#
|
|
include $(top_srcdir)/Makefile.common
|
|
|
|
@@ -21,11 +10,6 @@ if BUILD_SYSTEMD
|
|
systemdunit_DATA = crm_mon.service
|
|
endif
|
|
|
|
-COMMONLIBS = \
|
|
- $(top_builddir)/lib/common/libcrmcommon.la \
|
|
- $(top_builddir)/lib/cib/libcib.la \
|
|
- $(CURSESLIBS) $(CLUSTERLIBS)
|
|
-
|
|
noinst_HEADERS = crm_resource.h fake_transition.h
|
|
|
|
pcmkdir = $(datadir)/$(PACKAGE)
|
|
@@ -52,71 +36,84 @@ endif
|
|
MAN8DEPS = crm_attribute crm_node
|
|
|
|
crmadmin_SOURCES = crmadmin.c
|
|
-crmadmin_LDADD = $(top_builddir)/lib/pengine/libpe_status.la \
|
|
- $(COMMONLIBS) $(CLUSTERLIBS)
|
|
+crmadmin_LDADD = $(top_builddir)/lib/pengine/libpe_status.la \
|
|
+ $(top_builddir)/lib/cib/libcib.la \
|
|
+ $(top_builddir)/lib/common/libcrmcommon.la \
|
|
+ $(CLUSTERLIBS)
|
|
|
|
crm_error_SOURCES = crm_error.c
|
|
-crm_error_LDADD = $(COMMONLIBS)
|
|
+crm_error_LDADD = $(top_builddir)/lib/common/libcrmcommon.la
|
|
|
|
cibadmin_SOURCES = cibadmin.c
|
|
-cibadmin_LDADD = $(COMMONLIBS)
|
|
+cibadmin_LDADD = $(top_builddir)/lib/cib/libcib.la \
|
|
+ $(top_builddir)/lib/common/libcrmcommon.la
|
|
|
|
crm_shadow_SOURCES = cib_shadow.c
|
|
-crm_shadow_LDADD = $(COMMONLIBS)
|
|
+crm_shadow_LDADD = $(top_builddir)/lib/cib/libcib.la \
|
|
+ $(top_builddir)/lib/common/libcrmcommon.la
|
|
|
|
crm_node_SOURCES = crm_node.c
|
|
-crm_node_LDADD = $(top_builddir)/lib/cluster/libcrmcluster.la \
|
|
- $(COMMONLIBS) $(CLUSTERLIBS)
|
|
+crm_node_LDADD = $(top_builddir)/lib/cluster/libcrmcluster.la \
|
|
+ $(top_builddir)/lib/cib/libcib.la \
|
|
+ $(top_builddir)/lib/common/libcrmcommon.la \
|
|
+ $(CLUSTERLIBS)
|
|
|
|
crm_simulate_SOURCES = crm_simulate.c fake_transition.c
|
|
crm_simulate_CFLAGS = -I$(top_srcdir)/pengine
|
|
|
|
-crm_simulate_LDADD = $(top_builddir)/lib/pengine/libpe_status.la \
|
|
- $(top_builddir)/pengine/libpengine.la \
|
|
- $(top_builddir)/lib/cib/libcib.la \
|
|
- $(top_builddir)/lib/lrmd/liblrmd.la \
|
|
- $(top_builddir)/lib/transition/libtransitioner.la \
|
|
- $(COMMONLIBS)
|
|
+crm_simulate_LDADD = $(top_builddir)/lib/pengine/libpe_status.la \
|
|
+ $(top_builddir)/pengine/libpengine.la \
|
|
+ $(top_builddir)/lib/cib/libcib.la \
|
|
+ $(top_builddir)/lib/lrmd/liblrmd.la \
|
|
+ $(top_builddir)/lib/transition/libtransitioner.la \
|
|
+ $(top_builddir)/lib/common/libcrmcommon.la
|
|
|
|
crm_diff_SOURCES = crm_diff.c
|
|
-crm_diff_LDADD = $(COMMONLIBS)
|
|
+crm_diff_LDADD = $(top_builddir)/lib/common/libcrmcommon.la
|
|
|
|
crm_mon_SOURCES = crm_mon.c
|
|
-crm_mon_LDADD = $(top_builddir)/lib/pengine/libpe_status.la \
|
|
- $(top_builddir)/lib/fencing/libstonithd.la \
|
|
- $(top_builddir)/pengine/libpengine.la \
|
|
- $(COMMONLIBS)
|
|
+crm_mon_LDADD = $(top_builddir)/lib/pengine/libpe_status.la \
|
|
+ $(top_builddir)/lib/fencing/libstonithd.la \
|
|
+ $(top_builddir)/pengine/libpengine.la \
|
|
+ $(top_builddir)/lib/cib/libcib.la \
|
|
+ $(top_builddir)/lib/common/libcrmcommon.la \
|
|
+ $(CURSESLIBS)
|
|
|
|
# Arguments could be made that this should live in crm/pengine
|
|
crm_verify_SOURCES = crm_verify.c
|
|
crm_verify_LDADD = $(top_builddir)/lib/pengine/libpe_status.la \
|
|
- $(top_builddir)/pengine/libpengine.la \
|
|
- $(COMMONLIBS)
|
|
+ $(top_builddir)/pengine/libpengine.la \
|
|
+ $(top_builddir)/lib/cib/libcib.la \
|
|
+ $(top_builddir)/lib/common/libcrmcommon.la
|
|
|
|
crm_attribute_SOURCES = crm_attribute.c
|
|
-crm_attribute_LDADD = $(top_builddir)/lib/cluster/libcrmcluster.la $(COMMONLIBS)
|
|
+crm_attribute_LDADD = $(top_builddir)/lib/cluster/libcrmcluster.la \
|
|
+ $(top_builddir)/lib/cib/libcib.la \
|
|
+ $(top_builddir)/lib/common/libcrmcommon.la
|
|
|
|
crm_resource_SOURCES = crm_resource.c crm_resource_ban.c crm_resource_runtime.c crm_resource_print.c fake_transition.c
|
|
crm_resource_CFLAGS = -I$(top_srcdir)/pengine
|
|
-crm_resource_LDADD = $(top_builddir)/lib/pengine/libpe_rules.la \
|
|
- $(top_builddir)/lib/lrmd/liblrmd.la \
|
|
- $(top_builddir)/lib/services/libcrmservice.la \
|
|
- $(top_builddir)/lib/pengine/libpe_status.la \
|
|
- $(top_builddir)/pengine/libpengine.la \
|
|
- $(top_builddir)/lib/transition/libtransitioner.la \
|
|
- $(COMMONLIBS)
|
|
+crm_resource_LDADD = $(top_builddir)/lib/pengine/libpe_rules.la \
|
|
+ $(top_builddir)/lib/lrmd/liblrmd.la \
|
|
+ $(top_builddir)/lib/services/libcrmservice.la \
|
|
+ $(top_builddir)/lib/pengine/libpe_status.la \
|
|
+ $(top_builddir)/pengine/libpengine.la \
|
|
+ $(top_builddir)/lib/transition/libtransitioner.la \
|
|
+ $(top_builddir)/lib/cib/libcib.la \
|
|
+ $(top_builddir)/lib/common/libcrmcommon.la
|
|
|
|
iso8601_SOURCES = test.iso8601.c
|
|
-iso8601_LDADD = $(COMMONLIBS)
|
|
+iso8601_LDADD = $(top_builddir)/lib/common/libcrmcommon.la
|
|
|
|
attrd_updater_SOURCES = attrd_updater.c
|
|
-attrd_updater_LDADD = $(COMMONLIBS)
|
|
+attrd_updater_LDADD = $(top_builddir)/lib/common/libcrmcommon.la
|
|
|
|
crm_ticket_SOURCES = crm_ticket.c
|
|
-crm_ticket_LDADD = $(top_builddir)/lib/pengine/libpe_rules.la \
|
|
- $(top_builddir)/lib/pengine/libpe_status.la \
|
|
- $(top_builddir)/pengine/libpengine.la \
|
|
- $(COMMONLIBS)
|
|
+crm_ticket_LDADD = $(top_builddir)/lib/pengine/libpe_rules.la \
|
|
+ $(top_builddir)/lib/pengine/libpe_status.la \
|
|
+ $(top_builddir)/pengine/libpengine.la \
|
|
+ $(top_builddir)/lib/cib/libcib.la \
|
|
+ $(top_builddir)/lib/common/libcrmcommon.la
|
|
|
|
if BUILD_SERVICELOG
|
|
notifyServicelogEvent_SOURCES = notifyServicelogEvent.c
|
|
--
|
|
2.17.0
|
|
|