pacemaker/bz1297985-fix-configure-curses-test.patch
2016-01-18 18:52:50 +01:00

24 lines
894 B
Diff

--- a/configure.ac 2016-01-18 17:40:43.096090475 +0100
+++ b/configure.ac 2016-01-18 17:54:09.426193896 +0100
@@ -941,12 +941,18 @@
dnl Check for printw() prototype compatibility
if test X"$CURSESLIBS" != X"" && cc_supports_flag -Wcast-qual && cc_supports_flag -Werror; then
- AC_MSG_CHECKING(whether printw() requires argument of "const char *")
ac_save_LIBS=$LIBS
- LIBS="$CURSESLIBS $LIBS"
+ LIBS="$CURSESLIBS"
ac_save_CFLAGS=$CFLAGS
CFLAGS="-Wcast-qual -Werror"
+ # avoid broken test because of hardened build environment in Fedora 23+
+ # - https://fedoraproject.org/wiki/Changes/Harden_All_Packages
+ # - https://bugzilla.redhat.com/1297985
+ if cc_supports_flag -fPIC; then
+ CFLAGS="$CFLAGS -fPIC"
+ fi
+ AC_MSG_CHECKING(whether printw() requires argument of "const char *")
AC_LINK_IFELSE(
[AC_LANG_PROGRAM(
[