import pacemaker-2.0.4-3.el8
This commit is contained in:
parent
ed303ba18c
commit
e0f6d5b090
2
.gitignore
vendored
2
.gitignore
vendored
@ -1,2 +1,2 @@
|
|||||||
SOURCES/nagios-agents-metadata-105ab8a.tar.gz
|
SOURCES/nagios-agents-metadata-105ab8a.tar.gz
|
||||||
SOURCES/pacemaker-4b1f869.tar.gz
|
SOURCES/pacemaker-2deceaa.tar.gz
|
||||||
|
@ -1,2 +1,2 @@
|
|||||||
ea6c0a27fd0ae8ce02f84a11f08a0d79377041c3 SOURCES/nagios-agents-metadata-105ab8a.tar.gz
|
ea6c0a27fd0ae8ce02f84a11f08a0d79377041c3 SOURCES/nagios-agents-metadata-105ab8a.tar.gz
|
||||||
dfd19e7ec7aa96520f4948fc37d48ea69835bbdb SOURCES/pacemaker-4b1f869.tar.gz
|
78c94fdcf59cfb064d4433e1b8f71fd856eeec5f SOURCES/pacemaker-2deceaa.tar.gz
|
||||||
|
4947
SOURCES/001-rules.patch
Normal file
4947
SOURCES/001-rules.patch
Normal file
File diff suppressed because it is too large
Load Diff
8664
SOURCES/002-demote.patch
Normal file
8664
SOURCES/002-demote.patch
Normal file
File diff suppressed because it is too large
Load Diff
30
SOURCES/003-trace.patch
Normal file
30
SOURCES/003-trace.patch
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
From 47c3e06b098c7e148c54675588d03b4d2bea40b5 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Chris Lumens <clumens@redhat.com>
|
||||||
|
Date: Mon, 22 Jun 2020 16:20:01 -0400
|
||||||
|
Subject: [PATCH] Fix: libpacemaker: Don't allow a potential NULL in a format
|
||||||
|
string.
|
||||||
|
|
||||||
|
This is only tripping up F32 s390x builds, but I don't suppose there's
|
||||||
|
any reason it couldn't come up elsewhere later.
|
||||||
|
---
|
||||||
|
lib/pacemaker/pcmk_sched_constraints.c | 4 ++--
|
||||||
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/lib/pacemaker/pcmk_sched_constraints.c b/lib/pacemaker/pcmk_sched_constraints.c
|
||||||
|
index 9c3a88d..d8c3e69 100644
|
||||||
|
--- a/lib/pacemaker/pcmk_sched_constraints.c
|
||||||
|
+++ b/lib/pacemaker/pcmk_sched_constraints.c
|
||||||
|
@@ -1595,8 +1595,8 @@ custom_action_order(pe_resource_t * lh_rsc, char *lh_action_task, pe_action_t *
|
||||||
|
order = calloc(1, sizeof(pe__ordering_t));
|
||||||
|
|
||||||
|
crm_trace("Creating[%d] %s %s %s - %s %s %s", data_set->order_id,
|
||||||
|
- lh_rsc?lh_rsc->id:"NA", lh_action_task, lh_action?lh_action->uuid:"NA",
|
||||||
|
- rh_rsc?rh_rsc->id:"NA", rh_action_task, rh_action?rh_action->uuid:"NA");
|
||||||
|
+ lh_rsc?lh_rsc->id:"NA", lh_action_task?lh_action_task:"NA", lh_action?lh_action->uuid:"NA",
|
||||||
|
+ rh_rsc?rh_rsc->id:"NA", rh_action_task?rh_action_task:"NA", rh_action?rh_action->uuid:"NA");
|
||||||
|
|
||||||
|
/* CRM_ASSERT(data_set->order_id != 291); */
|
||||||
|
|
||||||
|
--
|
||||||
|
1.8.3.1
|
||||||
|
|
27
SOURCES/004-test.patch
Normal file
27
SOURCES/004-test.patch
Normal file
@ -0,0 +1,27 @@
|
|||||||
|
From 7ed7675615ada7d0be5654e0dcb26de60cf5b5e9 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Ken Gaillot <kgaillot@redhat.com>
|
||||||
|
Date: Mon, 22 Jun 2020 20:03:56 -0500
|
||||||
|
Subject: [PATCH] Test: scheduler: explicitly disable concurrent-fencing in
|
||||||
|
on_fail_demote4
|
||||||
|
|
||||||
|
... so the expected output is the same regardless of what default the build was
|
||||||
|
compiled with
|
||||||
|
---
|
||||||
|
cts/scheduler/on_fail_demote4.xml | 1 +
|
||||||
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
|
diff --git a/cts/scheduler/on_fail_demote4.xml b/cts/scheduler/on_fail_demote4.xml
|
||||||
|
index eb4c4cc..1082266 100644
|
||||||
|
--- a/cts/scheduler/on_fail_demote4.xml
|
||||||
|
+++ b/cts/scheduler/on_fail_demote4.xml
|
||||||
|
@@ -8,6 +8,7 @@
|
||||||
|
<nvpair id="cts-shutdown-escalation" name="shutdown-escalation" value="5min"/>
|
||||||
|
<nvpair id="cts-batch-limit" name="batch-limit" value="10"/>
|
||||||
|
<nvpair id="cts-dc-deadtime" name="dc-deadtime" value="5s"/>
|
||||||
|
+ <nvpair id="cts-concurrent-fencing" name="concurrent-fencing" value="false"/>
|
||||||
|
<nvpair id="cib-bootstrap-options-have-watchdog" name="have-watchdog" value="false"/>
|
||||||
|
<nvpair id="cib-bootstrap-options-dc-version" name="dc-version" value="2.0.4-578.6e1b582.git.el7_8-6e1b582"/>
|
||||||
|
<nvpair id="cib-bootstrap-options-cluster-infrastructure" name="cluster-infrastructure" value="corosync"/>
|
||||||
|
--
|
||||||
|
1.8.3.1
|
||||||
|
|
32
SOURCES/005-sysconfig.patch
Normal file
32
SOURCES/005-sysconfig.patch
Normal file
@ -0,0 +1,32 @@
|
|||||||
|
From 85040eb19b9405464b01a7e67eb6769d2a03c611 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Ken Gaillot <kgaillot@redhat.com>
|
||||||
|
Date: Fri, 19 Jun 2020 17:49:22 -0500
|
||||||
|
Subject: [PATCH] Doc: sysconfig: remove outdated reference to wildcards in
|
||||||
|
PCMK_trace_files
|
||||||
|
|
||||||
|
Wildcards stopped working when the log filtering implementation changed in
|
||||||
|
1.1.8 to support PCMK_trace_tags. It's not worth the effort to fix at this
|
||||||
|
point, so just update the comment in the sysconfig file.
|
||||||
|
---
|
||||||
|
daemons/pacemakerd/pacemaker.sysconfig | 5 ++---
|
||||||
|
1 file changed, 2 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/daemons/pacemakerd/pacemaker.sysconfig b/daemons/pacemakerd/pacemaker.sysconfig
|
||||||
|
index c7745d8..e4a5c4d 100644
|
||||||
|
--- a/daemons/pacemakerd/pacemaker.sysconfig
|
||||||
|
+++ b/daemons/pacemakerd/pacemaker.sysconfig
|
||||||
|
@@ -34,9 +34,8 @@
|
||||||
|
# Log all messages from a comma-separated list of functions.
|
||||||
|
# PCMK_trace_functions=function1,function2,function3
|
||||||
|
|
||||||
|
-# Log all messages from a comma-separated list of files (no path).
|
||||||
|
-# Wildcards are supported, e.g. PCMK_trace_files=prefix*.c
|
||||||
|
-# PCMK_trace_files=file.c,other.h
|
||||||
|
+# Log all messages from a comma-separated list of file names (without path).
|
||||||
|
+# PCMK_trace_files=file1.c,file2.c
|
||||||
|
|
||||||
|
# Log all messages matching comma-separated list of formats.
|
||||||
|
# PCMK_trace_formats="Sent delete %d"
|
||||||
|
--
|
||||||
|
1.8.3.1
|
||||||
|
|
@ -1,4 +1,5 @@
|
|||||||
# Globals and defines to control package behavior (configure these as desired)
|
# User-configurable globals and defines to control package behavior
|
||||||
|
# (these should not test {with X} values, which are declared later)
|
||||||
|
|
||||||
## User and group to use for nonprivileged services
|
## User and group to use for nonprivileged services
|
||||||
%global uname hacluster
|
%global uname hacluster
|
||||||
@ -21,12 +22,11 @@
|
|||||||
## Upstream pacemaker version, and its package version (specversion
|
## Upstream pacemaker version, and its package version (specversion
|
||||||
## can be incremented to build packages reliably considered "newer"
|
## can be incremented to build packages reliably considered "newer"
|
||||||
## than previously built packages with the same pcmkversion)
|
## than previously built packages with the same pcmkversion)
|
||||||
%global pcmkversion 2.0.3
|
%global pcmkversion 2.0.4
|
||||||
%global specversion 3
|
%global specversion 3
|
||||||
|
|
||||||
## Upstream commit (or git tag, such as "Pacemaker-" plus the
|
## Upstream commit (full commit ID, abbreviated commit ID, or tag) to build
|
||||||
## {pcmkversion} macro for an official release) to use for this package
|
%global commit 2deceaa3ae1fbadd844f5c5b47fd33129fa2c227
|
||||||
%global commit 4b1f869f0f64ef0d248b6aa4781d38ecccf83318
|
|
||||||
## Since git v2.11, the extent of abbreviation is autoscaled by default
|
## Since git v2.11, the extent of abbreviation is autoscaled by default
|
||||||
## (used to be constant of 7), so we need to convey it for non-tags, too.
|
## (used to be constant of 7), so we need to convey it for non-tags, too.
|
||||||
%global commit_abbrev 7
|
%global commit_abbrev 7
|
||||||
@ -39,24 +39,58 @@
|
|||||||
%global nagios_hash 105ab8a
|
%global nagios_hash 105ab8a
|
||||||
|
|
||||||
|
|
||||||
|
# Define conditionals so that "rpmbuild --with <feature>" and
|
||||||
|
# "rpmbuild --without <feature>" can enable and disable specific features
|
||||||
|
|
||||||
|
## Add option to enable support for stonith/external fencing agents
|
||||||
|
%bcond_with stonithd
|
||||||
|
|
||||||
|
## Add option to disable support for storing sensitive information outside CIB
|
||||||
|
%bcond_without cibsecrets
|
||||||
|
|
||||||
|
## Add option to create binaries suitable for use with profiling tools
|
||||||
|
%bcond_with profiling
|
||||||
|
|
||||||
|
## Add option to create binaries with coverage analysis
|
||||||
|
%bcond_with coverage
|
||||||
|
|
||||||
|
## Add option to generate documentation (requires Publican, Asciidoc and Inkscape)
|
||||||
|
%bcond_with doc
|
||||||
|
|
||||||
|
## Add option to prefix package version with "0."
|
||||||
|
## (so later "official" packages will be considered updates)
|
||||||
|
%bcond_with pre_release
|
||||||
|
|
||||||
|
## Add option to ship Upstart job files
|
||||||
|
%bcond_with upstart_job
|
||||||
|
|
||||||
|
## Add option to turn off hardening of libraries and daemon executables
|
||||||
|
%bcond_without hardening
|
||||||
|
|
||||||
|
## Add option to disable links for legacy daemon names
|
||||||
|
%bcond_without legacy_links
|
||||||
|
|
||||||
|
|
||||||
# Define globals for convenient use later
|
# Define globals for convenient use later
|
||||||
|
|
||||||
## Workaround to use parentheses in other globals
|
## Workaround to use parentheses in other globals
|
||||||
%global lparen (
|
%global lparen (
|
||||||
%global rparen )
|
%global rparen )
|
||||||
|
|
||||||
## Short version of git commit
|
## Whether this is a tagged release (final or release candidate)
|
||||||
%define shortcommit %(c=%{commit}; case ${c} in
|
%define tag_release %(c=%{commit}; case ${c} in Pacemaker-*%{rparen} echo 1 ;;
|
||||||
Pacemaker-*%{rparen} echo ${c:10};;
|
*%{rparen} echo 0 ;; esac)
|
||||||
*%{rparen} echo ${c:0:%{commit_abbrev}};; esac)
|
|
||||||
|
|
||||||
## Whether this is a tagged release
|
## Portion of export/dist tarball name after "pacemaker-", and release version
|
||||||
%define tag_release %([ %{commit} != Pacemaker-%{shortcommit} ]; echo $?)
|
%if 0%{tag_release}
|
||||||
|
%define archive_version %(c=%{commit}; echo ${c:10})
|
||||||
## Whether this is a release candidate (in case of a tagged release)
|
%define archive_github_url %{commit}#/%{name}-%{archive_version}.tar.gz
|
||||||
%define pre_release %([ "%{tag_release}" -eq 0 ] || {
|
%else
|
||||||
case "%{shortcommit}" in *-rc[[:digit:]]*%{rparen} false;;
|
%define archive_version %(c=%{commit}; echo ${c:0:%{commit_abbrev}})
|
||||||
esac; }; echo $?)
|
%define archive_github_url %{archive_version}#/%{name}-%{archive_version}.tar.gz
|
||||||
|
%endif
|
||||||
|
# RHEL always uses a simple release number
|
||||||
|
%define pcmk_release %{specversion}
|
||||||
|
|
||||||
## Heuristic used to infer bleeding-edge deployments that are
|
## Heuristic used to infer bleeding-edge deployments that are
|
||||||
## less likely to have working versions of the documentation tools
|
## less likely to have working versions of the documentation tools
|
||||||
@ -181,35 +215,6 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
|
||||||
# Define conditionals so that "rpmbuild --with <feature>" and
|
|
||||||
# "rpmbuild --without <feature>" can enable and disable specific features
|
|
||||||
|
|
||||||
## Add option to enable support for stonith/external fencing agents
|
|
||||||
%bcond_with stonithd
|
|
||||||
|
|
||||||
## Add option to create binaries suitable for use with profiling tools
|
|
||||||
%bcond_with profiling
|
|
||||||
|
|
||||||
## Add option to create binaries with coverage analysis
|
|
||||||
%bcond_with coverage
|
|
||||||
|
|
||||||
## Add option to generate documentation (requires Publican, Asciidoc and Inkscape)
|
|
||||||
%bcond_with doc
|
|
||||||
|
|
||||||
## Add option to prefix package version with "0."
|
|
||||||
## (so later "official" packages will be considered updates)
|
|
||||||
%bcond_with pre_release
|
|
||||||
|
|
||||||
## Add option to ship Upstart job files
|
|
||||||
%bcond_with upstart_job
|
|
||||||
|
|
||||||
## Add option to turn off hardening of libraries and daemon executables
|
|
||||||
%bcond_without hardening
|
|
||||||
|
|
||||||
## Add option to disable links for legacy daemon names
|
|
||||||
%bcond_without legacy_links
|
|
||||||
|
|
||||||
|
|
||||||
# Keep sane profiling data if requested
|
# Keep sane profiling data if requested
|
||||||
%if %{with profiling}
|
%if %{with profiling}
|
||||||
|
|
||||||
@ -219,24 +224,6 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
|
||||||
# Define the release version
|
|
||||||
# (do not look at externally enforced pre-release flag for tagged releases
|
|
||||||
# as only -rc tags, captured with the second condition, implies that then)
|
|
||||||
%if (!%{tag_release} && %{with pre_release}) || 0%{pre_release}
|
|
||||||
%if 0%{pre_release}
|
|
||||||
%define pcmk_release 0.%{specversion}.%(s=%{shortcommit}; echo ${s: -3})
|
|
||||||
%else
|
|
||||||
%define pcmk_release 0.%{specversion}.%{shortcommit}.git
|
|
||||||
%endif
|
|
||||||
%else
|
|
||||||
%if 0%{tag_release}
|
|
||||||
%define pcmk_release %{specversion}
|
|
||||||
%else
|
|
||||||
# Never use the short commit in a RHEL release number
|
|
||||||
%define pcmk_release %{specversion}
|
|
||||||
%endif
|
|
||||||
%endif
|
|
||||||
|
|
||||||
Name: pacemaker
|
Name: pacemaker
|
||||||
Summary: Scalable High-Availability cluster resource manager
|
Summary: Scalable High-Availability cluster resource manager
|
||||||
Version: %{pcmkversion}
|
Version: %{pcmkversion}
|
||||||
@ -250,13 +237,23 @@ License: GPLv2+ and LGPLv2+ and BSD
|
|||||||
Url: http://www.clusterlabs.org
|
Url: http://www.clusterlabs.org
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
|
|
||||||
# Hint: use "spectool -s 0 pacemaker.spec" (rpmdevtools) to check the final URL:
|
# Example: https://codeload.github.com/ClusterLabs/pacemaker/tar.gz/e91769e
|
||||||
# https://github.com/ClusterLabs/pacemaker/archive/e91769e5a39f5cb2f7b097d3c612368f0530535e/pacemaker-e91769e.tar.gz
|
# will download pacemaker-e91769e.tar.gz
|
||||||
Source0: https://github.com/%{github_owner}/%{name}/archive/%{commit}/%{name}-%{shortcommit}.tar.gz
|
#
|
||||||
|
# The ending part starting with '#' is ignored by github but necessary for
|
||||||
|
# rpmbuild to know what the tar archive name is. (The downloaded file will be
|
||||||
|
# named correctly only for commit IDs, not tagged releases.)
|
||||||
|
#
|
||||||
|
# You can use "spectool -s 0 pacemaker.spec" (rpmdevtools) to show final URL.
|
||||||
|
Source0: https://codeload.github.com/%{github_owner}/%{name}/tar.gz/%{archive_github_url}
|
||||||
Source1: nagios-agents-metadata-%{nagios_hash}.tar.gz
|
Source1: nagios-agents-metadata-%{nagios_hash}.tar.gz
|
||||||
|
|
||||||
# upstream commits
|
# upstream commits
|
||||||
#Patch1: 001-xxx.patch
|
Patch1: 001-rules.patch
|
||||||
|
Patch2: 002-demote.patch
|
||||||
|
Patch3: 003-trace.patch
|
||||||
|
Patch4: 004-test.patch
|
||||||
|
Patch5: 005-sysconfig.patch
|
||||||
|
|
||||||
# downstream-only commits
|
# downstream-only commits
|
||||||
#Patch100: xxx.patch
|
#Patch100: xxx.patch
|
||||||
@ -271,7 +268,11 @@ Requires: psmisc
|
|||||||
%endif
|
%endif
|
||||||
%{?systemd_requires}
|
%{?systemd_requires}
|
||||||
|
|
||||||
|
%if %{defined centos}
|
||||||
|
ExclusiveArch: aarch64 i686 ppc64le s390x x86_64 %{arm}
|
||||||
|
%else
|
||||||
ExclusiveArch: aarch64 i686 ppc64le s390x x86_64
|
ExclusiveArch: aarch64 i686 ppc64le s390x x86_64
|
||||||
|
%endif
|
||||||
|
|
||||||
Requires: %{python_path}
|
Requires: %{python_path}
|
||||||
BuildRequires: %{python_name}-devel
|
BuildRequires: %{python_name}-devel
|
||||||
@ -335,7 +336,8 @@ when related resources fail and can be configured to periodically check
|
|||||||
resource health.
|
resource health.
|
||||||
|
|
||||||
Available rpmbuild rebuild options:
|
Available rpmbuild rebuild options:
|
||||||
--with(out) : coverage doc stonithd hardening pre_release profiling
|
--with(out) : cibsecrets coverage doc stonithd hardening pre_release
|
||||||
|
profiling
|
||||||
|
|
||||||
%package cli
|
%package cli
|
||||||
License: GPLv2+ and LGPLv2+
|
License: GPLv2+ and LGPLv2+
|
||||||
@ -509,7 +511,7 @@ The metadata files required for Pacemaker to execute the nagios plugin
|
|||||||
monitor resources.
|
monitor resources.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%autosetup -a 1 -n %{name}-%{commit} -S git_am -p 1
|
%autosetup -a 1 -n %{name}-%{archive_version} -S git_am -p 1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
|
||||||
@ -541,6 +543,7 @@ export LDFLAGS_HARDENED_LIB="%{?_hardening_ldflags}"
|
|||||||
%{!?with_legacy_links: --disable-legacy-links} \
|
%{!?with_legacy_links: --disable-legacy-links} \
|
||||||
%{?with_profiling: --with-profiling} \
|
%{?with_profiling: --with-profiling} \
|
||||||
%{?with_coverage: --with-coverage} \
|
%{?with_coverage: --with-coverage} \
|
||||||
|
%{?with_cibsecrets: --with-cibsecrets} \
|
||||||
%{!?with_doc: --with-brand=} \
|
%{!?with_doc: --with-brand=} \
|
||||||
%{?gnutls_priorities: --with-gnutls-priorities="%{gnutls_priorities}"} \
|
%{?gnutls_priorities: --with-gnutls-priorities="%{gnutls_priorities}"} \
|
||||||
--with-initdir=%{_initrddir} \
|
--with-initdir=%{_initrddir} \
|
||||||
@ -561,6 +564,7 @@ sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
|||||||
make %{_smp_mflags} V=1
|
make %{_smp_mflags} V=1
|
||||||
|
|
||||||
%check
|
%check
|
||||||
|
make %{_smp_mflags} check
|
||||||
{ cts/cts-scheduler --run load-stopped-loop \
|
{ cts/cts-scheduler --run load-stopped-loop \
|
||||||
&& cts/cts-cli \
|
&& cts/cts-cli \
|
||||||
&& touch .CHECKED
|
&& touch .CHECKED
|
||||||
@ -740,7 +744,7 @@ getent passwd %{uname} >/dev/null || useradd -r -g %{gname} -u %{hacluster_id} -
|
|||||||
exit 0
|
exit 0
|
||||||
|
|
||||||
%if %{defined ldconfig_scriptlets}
|
%if %{defined ldconfig_scriptlets}
|
||||||
%ldconfig_scriptlets libs
|
%ldconfig_scriptlets -n %{pkgname_pcmk_libs}
|
||||||
%ldconfig_scriptlets cluster-libs
|
%ldconfig_scriptlets cluster-libs
|
||||||
%else
|
%else
|
||||||
%post -n %{pkgname_pcmk_libs} -p /sbin/ldconfig
|
%post -n %{pkgname_pcmk_libs} -p /sbin/ldconfig
|
||||||
@ -813,6 +817,9 @@ exit 0
|
|||||||
|
|
||||||
%{_sbindir}/attrd_updater
|
%{_sbindir}/attrd_updater
|
||||||
%{_sbindir}/cibadmin
|
%{_sbindir}/cibadmin
|
||||||
|
%if %{with cibsecrets}
|
||||||
|
%{_sbindir}/cibsecret
|
||||||
|
%endif
|
||||||
%{_sbindir}/crm_diff
|
%{_sbindir}/crm_diff
|
||||||
%{_sbindir}/crm_error
|
%{_sbindir}/crm_error
|
||||||
%{_sbindir}/crm_failcount
|
%{_sbindir}/crm_failcount
|
||||||
@ -944,6 +951,51 @@ exit 0
|
|||||||
%license %{nagios_name}-%{nagios_hash}/COPYING
|
%license %{nagios_name}-%{nagios_hash}/COPYING
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jun 25 2020 Ken Gaillot <kgaillot@redhat.com> - 2.0.4-3
|
||||||
|
- Allow resource and operation defaults per resource or operation type
|
||||||
|
- Rebase on upstream 2.0.4 final release
|
||||||
|
- Support on-fail="demote" and no-quorum-policy="demote" options
|
||||||
|
- Remove incorrect comment from sysconfig file
|
||||||
|
- Resolves: rhbz1628701
|
||||||
|
- Resolves: rhbz1828488
|
||||||
|
- Resolves: rhbz1837747
|
||||||
|
- Resolves: rhbz1848789
|
||||||
|
|
||||||
|
* Wed Jun 10 2020 Ken Gaillot <kgaillot@redhat.com> - 2.0.4-2
|
||||||
|
- Improve cibsecret help and clean up code per static analysis
|
||||||
|
- Resolves: rhbz1793860
|
||||||
|
|
||||||
|
* Mon Jun 8 2020 Ken Gaillot <kgaillot@redhat.com> - 2.0.4-1
|
||||||
|
- Clear leaving node's attributes if there is no DC
|
||||||
|
- Add crm_mon --node option to limit display to particular node or tagged nodes
|
||||||
|
- Add crm_mon --include/--exclude options to select what sections are shown
|
||||||
|
- priority-fencing-delay option bases delay on where resources are active
|
||||||
|
- Pending DC fencing gets 'stuck' in status display
|
||||||
|
- crm_rule can now check rule expiration when "years" is specified
|
||||||
|
- crm_mon now formats error messages better
|
||||||
|
- Support for CIB secrets is enabled
|
||||||
|
- Rebase on latest upstream Pacemaker release
|
||||||
|
- Fix regression introduced in 8.2 so crm_node -n works on remote nodes
|
||||||
|
- Avoid infinite loop when topology is removed while unfencing is in progress
|
||||||
|
- Resolves: rhbz1300604
|
||||||
|
- Resolves: rhbz1363907
|
||||||
|
- Resolves: rhbz1784601
|
||||||
|
- Resolves: rhbz1787751
|
||||||
|
- Resolves: rhbz1790591
|
||||||
|
- Resolves: rhbz1793653
|
||||||
|
- Resolves: rhbz1793860
|
||||||
|
- Resolves: rhbz1828488
|
||||||
|
- Resolves: rhbz1830535
|
||||||
|
- Resolves: rhbz1831775
|
||||||
|
|
||||||
|
* Mon Jan 27 2020 Ken Gaillot <kgaillot@redhat.com> - 2.0.3-5
|
||||||
|
- Clear leaving node's attributes if there is no DC
|
||||||
|
- Resolves: rhbz1791841
|
||||||
|
|
||||||
|
* Thu Jan 16 2020 Ken Gaillot <kgaillot@redhat.com> - 2.0.3-4
|
||||||
|
- Implement shutdown-lock feature
|
||||||
|
- Resolves: rhbz1712584
|
||||||
|
|
||||||
* Wed Nov 27 2019 Ken Gaillot <kgaillot@redhat.com> - 2.0.3-3
|
* Wed Nov 27 2019 Ken Gaillot <kgaillot@redhat.com> - 2.0.3-3
|
||||||
- Rebase on Pacemaker-2.0.3 final release
|
- Rebase on Pacemaker-2.0.3 final release
|
||||||
- Resolves: rhbz1752538
|
- Resolves: rhbz1752538
|
||||||
|
Loading…
Reference in New Issue
Block a user