2.0.3-1 (rev. 1) - Fix unability to build with Inkscape 1.0 beta
...(and possibly beyond) Signed-off-by: Jan Pokorný <jpokorny@redhat.com>
This commit is contained in:
parent
eecb2bf2ac
commit
bf2e068dcf
38
Build-fix-unability-to-build-with-Inkscape-1.0-beta-.patch
Normal file
38
Build-fix-unability-to-build-with-Inkscape-1.0-beta-.patch
Normal file
@ -0,0 +1,38 @@
|
|||||||
|
From a85d411e04eaffb2eb9f0a1bdba025b2fb168a54 Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Jan=20Pokorn=C3=BD?= <jpokorny@redhat.com>
|
||||||
|
Date: Tue, 26 Nov 2019 20:07:36 +0100
|
||||||
|
Subject: [PATCH] Build: fix unability to build with Inkscape 1.0 beta
|
||||||
|
version(s)
|
||||||
|
|
||||||
|
...and possibly beyond.
|
||||||
|
|
||||||
|
References:
|
||||||
|
https://gitlab.com/inkscape/inbox/issues/1244
|
||||||
|
---
|
||||||
|
doc/Makefile.am | 6 +++---
|
||||||
|
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/doc/Makefile.am b/doc/Makefile.am
|
||||||
|
index 257f5cdf5..90670a605 100644
|
||||||
|
--- a/doc/Makefile.am
|
||||||
|
+++ b/doc/Makefile.am
|
||||||
|
@@ -85,13 +85,13 @@ PNGS = $(PNGS_ORIGINAL) $(PNGS_GENERATED)
|
||||||
|
graphics: $(PNGS)
|
||||||
|
|
||||||
|
%.png: %.svg
|
||||||
|
- $(AM_V_GEN)$(INKSCAPE) --file=$< --export-dpi=90 -C --export-png=$@ $(PCMK_quiet)
|
||||||
|
+ $(AM_V_GEN)$(INKSCAPE) --export-dpi=90 -C --export-png=$@ $< $(PCMK_quiet)
|
||||||
|
|
||||||
|
%-small.png: %.svg
|
||||||
|
- $(AM_V_GEN)$(INKSCAPE) --file=$< --export-dpi=45 -C --export-png=$@ $(PCMK_quiet)
|
||||||
|
+ $(AM_V_GEN)$(INKSCAPE) --export-dpi=45 -C --export-png=$@ $< $(PCMK_quiet)
|
||||||
|
|
||||||
|
%-large.png: %.svg
|
||||||
|
- $(AM_V_GEN)$(INKSCAPE) --file=$< --export-dpi=180 -C --export-png=$@ $(PCMK_quiet)
|
||||||
|
+ $(AM_V_GEN)$(INKSCAPE) --export-dpi=180 -C --export-png=$@ $< $(PCMK_quiet)
|
||||||
|
|
||||||
|
if IS_ASCIIDOC
|
||||||
|
ASCIIDOC_HTML_ARGS = --unsafe --backend=xhtml11
|
||||||
|
--
|
||||||
|
2.24.0
|
||||||
|
|
@ -143,7 +143,7 @@ Url: http://www.clusterlabs.org
|
|||||||
Source0: https://github.com/%{github_owner}/%{name}/archive/%{commit}/%{name}-%{shortcommit}.tar.gz
|
Source0: https://github.com/%{github_owner}/%{name}/archive/%{commit}/%{name}-%{shortcommit}.tar.gz
|
||||||
Source1: https://github.com/%{github_owner}/%{nagios_name}/archive/%{nagios_hash}/%{nagios_name}-%{nagios_hash}.tar.gz
|
Source1: https://github.com/%{github_owner}/%{nagios_name}/archive/%{nagios_hash}/%{nagios_name}-%{nagios_hash}.tar.gz
|
||||||
# ---
|
# ---
|
||||||
# patches go here
|
Patch0: Build-fix-unability-to-build-with-Inkscape-1.0-beta-.patch
|
||||||
|
|
||||||
Requires: resource-agents
|
Requires: resource-agents
|
||||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||||
@ -188,7 +188,7 @@ BuildRequires: asciidoc inkscape publican
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
# git-style patch application
|
# git-style patch application
|
||||||
#BuildRequires: git
|
BuildRequires: git
|
||||||
|
|
||||||
Provides: pcmk-cluster-manager = %{version}-%{release}
|
Provides: pcmk-cluster-manager = %{version}-%{release}
|
||||||
Provides: pcmk-cluster-manager%{?_isa} = %{version}-%{release}
|
Provides: pcmk-cluster-manager%{?_isa} = %{version}-%{release}
|
||||||
@ -348,9 +348,9 @@ monitor resources.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -a 1 -n %{name}-%{commit}
|
%setup -q -a 1 -n %{name}-%{commit}
|
||||||
#global __scm git_am
|
%global __scm git_am
|
||||||
#__scm_setup_git
|
%__scm_setup_git
|
||||||
#autopatch -p1
|
%autopatch -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
|
||||||
@ -719,6 +719,7 @@ exit 0
|
|||||||
https://github.com/ClusterLabs/pacemaker/releases/tag/Pacemaker-2.0.3
|
https://github.com/ClusterLabs/pacemaker/releases/tag/Pacemaker-2.0.3
|
||||||
(functionally identical to 2.0.3-rc3, new build mostly to fix a memory
|
(functionally identical to 2.0.3-rc3, new build mostly to fix a memory
|
||||||
leak & allow for easy glibc ~2.31+ friendly switch away from ftime(3))
|
leak & allow for easy glibc ~2.31+ friendly switch away from ftime(3))
|
||||||
|
- Fix unability to build with Inkscape 1.0 beta (and possibly beyond)
|
||||||
|
|
||||||
* Thu Nov 14 2019 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 2.0.3-0.1.rc3
|
* Thu Nov 14 2019 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 2.0.3-0.1.rc3
|
||||||
- Update for new upstream tarball for release candidate: Pacemaker-2.0.3-rc3,
|
- Update for new upstream tarball for release candidate: Pacemaker-2.0.3-rc3,
|
||||||
|
Loading…
Reference in New Issue
Block a user