* Mon Sep 13 2021 Klaus Wenninger <kwenning@redhat.com> - 2.1.1-6
- Update for new upstream release tarball: Pacemaker-2.1.1 for full details, see included ChangeLog file or https://github.com/ClusterLabs/pacemaker/releases/tag/Pacemaker-2.1.1 - Add fencing regression-test to gating
This commit is contained in:
parent
a74f8cfffa
commit
6470742ce3
@ -1,82 +0,0 @@
|
|||||||
From b34570ecaeb4fb0106dd0aa5a8776a5417a07f90 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Klaus Wenninger <klaus.wenninger@aon.at>
|
|
||||||
Date: Mon, 16 Aug 2021 16:41:18 +0200
|
|
||||||
Subject: [PATCH] Fix: tools: make exit-code stdout/stderr consistent with
|
|
||||||
--version
|
|
||||||
|
|
||||||
---
|
|
||||||
tools/crm_attribute.c | 2 +-
|
|
||||||
tools/crm_diff.c | 2 +-
|
|
||||||
tools/crm_error.c | 2 +-
|
|
||||||
tools/crm_node.c | 2 +-
|
|
||||||
tools/crm_rule.c | 2 +-
|
|
||||||
5 files changed, 5 insertions(+), 5 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/tools/crm_attribute.c b/tools/crm_attribute.c
|
|
||||||
index 6bd4e2a..faf4aae 100644
|
|
||||||
--- a/tools/crm_attribute.c
|
|
||||||
+++ b/tools/crm_attribute.c
|
|
||||||
@@ -326,7 +326,7 @@ main(int argc, char **argv)
|
|
||||||
g_strfreev(processed_args);
|
|
||||||
pcmk__free_arg_context(context);
|
|
||||||
/* FIXME: When crm_attribute is converted to use formatted output, this can go. */
|
|
||||||
- pcmk__cli_help('v', CRM_EX_USAGE);
|
|
||||||
+ pcmk__cli_help('v', CRM_EX_OK);
|
|
||||||
}
|
|
||||||
|
|
||||||
if (options.promotion_score && options.attr_name == NULL) {
|
|
||||||
diff --git a/tools/crm_diff.c b/tools/crm_diff.c
|
|
||||||
index 9890c10..18f5d48 100644
|
|
||||||
--- a/tools/crm_diff.c
|
|
||||||
+++ b/tools/crm_diff.c
|
|
||||||
@@ -322,7 +322,7 @@ main(int argc, char **argv)
|
|
||||||
g_strfreev(processed_args);
|
|
||||||
pcmk__free_arg_context(context);
|
|
||||||
/* FIXME: When crm_diff is converted to use formatted output, this can go. */
|
|
||||||
- pcmk__cli_help('v', CRM_EX_USAGE);
|
|
||||||
+ pcmk__cli_help('v', CRM_EX_OK);
|
|
||||||
}
|
|
||||||
|
|
||||||
if (options.apply && options.no_version) {
|
|
||||||
diff --git a/tools/crm_error.c b/tools/crm_error.c
|
|
||||||
index 923f393..f26efe7 100644
|
|
||||||
--- a/tools/crm_error.c
|
|
||||||
+++ b/tools/crm_error.c
|
|
||||||
@@ -93,7 +93,7 @@ main(int argc, char **argv)
|
|
||||||
g_strfreev(processed_args);
|
|
||||||
pcmk__free_arg_context(context);
|
|
||||||
/* FIXME: When crm_error is converted to use formatted output, this can go. */
|
|
||||||
- pcmk__cli_help('v', CRM_EX_USAGE);
|
|
||||||
+ pcmk__cli_help('v', CRM_EX_OK);
|
|
||||||
}
|
|
||||||
|
|
||||||
if (options.do_list) {
|
|
||||||
diff --git a/tools/crm_node.c b/tools/crm_node.c
|
|
||||||
index 25da978..489a39a 100644
|
|
||||||
--- a/tools/crm_node.c
|
|
||||||
+++ b/tools/crm_node.c
|
|
||||||
@@ -549,7 +549,7 @@ main(int argc, char **argv)
|
|
||||||
g_strfreev(processed_args);
|
|
||||||
pcmk__free_arg_context(context);
|
|
||||||
/* FIXME: When crm_node is converted to use formatted output, this can go. */
|
|
||||||
- pcmk__cli_help('v', CRM_EX_USAGE);
|
|
||||||
+ pcmk__cli_help('v', CRM_EX_OK);
|
|
||||||
}
|
|
||||||
|
|
||||||
if (options.command == 0) {
|
|
||||||
diff --git a/tools/crm_rule.c b/tools/crm_rule.c
|
|
||||||
index 30c5155..0880415 100644
|
|
||||||
--- a/tools/crm_rule.c
|
|
||||||
+++ b/tools/crm_rule.c
|
|
||||||
@@ -252,7 +252,7 @@ main(int argc, char **argv)
|
|
||||||
g_strfreev(processed_args);
|
|
||||||
pcmk__free_arg_context(context);
|
|
||||||
/* FIXME: When crm_rule is converted to use formatted output, this can go. */
|
|
||||||
- pcmk__cli_help('v', CRM_EX_USAGE);
|
|
||||||
+ pcmk__cli_help('v', CRM_EX_OK);
|
|
||||||
}
|
|
||||||
|
|
||||||
/* Check command line arguments before opening a connection to
|
|
||||||
--
|
|
||||||
1.8.3.1
|
|
||||||
|
|
@ -1,29 +0,0 @@
|
|||||||
From 2e0ac6390327e387e9b94e50080d13fd95f545d6 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Klaus Wenninger <klaus.wenninger@aon.at>
|
|
||||||
Date: Mon, 16 Aug 2021 16:42:51 +0200
|
|
||||||
Subject: [PATCH] Build: manpages: using help2man check exit-code of tools
|
|
||||||
|
|
||||||
---
|
|
||||||
mk/common.mk | 6 ++++++
|
|
||||||
1 file changed, 6 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/mk/common.mk b/mk/common.mk
|
|
||||||
index aa59feb..c3d1993 100644
|
|
||||||
--- a/mk/common.mk
|
|
||||||
+++ b/mk/common.mk
|
|
||||||
@@ -68,6 +68,12 @@ HELP2MAN_ARGS = -N --section 8 --name "Part of the Pacemaker cluster resource ma
|
|
||||||
# and all wrappers to C code.
|
|
||||||
%.8: % $(MAN8DEPS)
|
|
||||||
$(AM_V_at)chmod a+x $(abs_builddir)/$<
|
|
||||||
+ PATH=$(abs_builddir):$$PATH $(abs_builddir)/$< --version >/dev/null
|
|
||||||
+ if [ -f $(abs_srcdir)/$@.inc ]; then \
|
|
||||||
+ PATH=$(abs_builddir):$$PATH $(abs_builddir)/$< --help-all >/dev/null; \
|
|
||||||
+ else \
|
|
||||||
+ PATH=$(abs_builddir):$$PATH $(abs_builddir)/$< --help >/dev/null; \
|
|
||||||
+ fi
|
|
||||||
$(AM_V_MAN)if [ -f $(abs_srcdir)/$@.inc ]; then \
|
|
||||||
PATH=$(abs_builddir):$$PATH $(HELP2MAN) $(HELP2MAN_ARGS) \
|
|
||||||
-h --help-all \
|
|
||||||
--
|
|
||||||
1.8.3.1
|
|
||||||
|
|
@ -32,10 +32,10 @@
|
|||||||
## can be incremented to build packages reliably considered "newer"
|
## can be incremented to build packages reliably considered "newer"
|
||||||
## than previously built packages with the same pcmkversion)
|
## than previously built packages with the same pcmkversion)
|
||||||
%global pcmkversion 2.1.1
|
%global pcmkversion 2.1.1
|
||||||
%global specversion 0.5.rc3
|
%global specversion 6
|
||||||
|
|
||||||
## Upstream commit (full commit ID, abbreviated commit ID, or tag) to build
|
## Upstream commit (full commit ID, abbreviated commit ID, or tag) to build
|
||||||
%global commit c6a4f6e6cdcedf08e0bfd81248b86812c2a571b2
|
%global commit 77db57872790c73e44ee7f49005d3ee1dded652e
|
||||||
|
|
||||||
## Since git v2.11, the extent of abbreviation is autoscaled by default
|
## Since git v2.11, the extent of abbreviation is autoscaled by default
|
||||||
## (used to be constant of 7), so we need to convey it for non-tags, too.
|
## (used to be constant of 7), so we need to convey it for non-tags, too.
|
||||||
@ -219,9 +219,7 @@ Patch0: 0001-feature-watchdog-fencing-allow-restriction-to-certai.patch
|
|||||||
Patch1: 0002-Fix-watchdog-fencing-Silence-warning-without-node-re.patch
|
Patch1: 0002-Fix-watchdog-fencing-Silence-warning-without-node-re.patch
|
||||||
Patch2: 0003-Fix-fence_watchdog-fix-version-output-needed-for-hel.patch
|
Patch2: 0003-Fix-fence_watchdog-fix-version-output-needed-for-hel.patch
|
||||||
Patch3: 0004-Build-rpm-package-fence_watchdog-in-base-package.patch
|
Patch3: 0004-Build-rpm-package-fence_watchdog-in-base-package.patch
|
||||||
Patch4: 0005-Fix-tools-make-exit-code-stdout-stderr-consistent-wi.patch
|
Patch6: 0005-Fix-fence_watchdog-fix-malformed-xml-in-metadata.patch
|
||||||
Patch5: 0006-Build-manpages-using-help2man-check-exit-code-of-too.patch
|
|
||||||
Patch6: 0007-Fix-fence_watchdog-fix-malformed-xml-in-metadata.patch
|
|
||||||
|
|
||||||
# upstream commits
|
# upstream commits
|
||||||
|
|
||||||
@ -830,6 +828,12 @@ exit 0
|
|||||||
%license %{nagios_name}-%{nagios_hash}/COPYING
|
%license %{nagios_name}-%{nagios_hash}/COPYING
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Sep 13 2021 Klaus Wenninger <kwenning@redhat.com> - 2.1.1-6
|
||||||
|
- Update for new upstream release tarball: Pacemaker-2.1.1
|
||||||
|
for full details, see included ChangeLog file or
|
||||||
|
https://github.com/ClusterLabs/pacemaker/releases/tag/Pacemaker-2.1.1
|
||||||
|
- Add fencing regression-test to gating
|
||||||
|
|
||||||
* Thu Aug 19 2021 Klaus Wenninger <kwenning@redhat.com> - 2.1.1-0.5.rc3
|
* Thu Aug 19 2021 Klaus Wenninger <kwenning@redhat.com> - 2.1.1-0.5.rc3
|
||||||
- Fix malformed xml in fence_watchdog metadata
|
- Fix malformed xml in fence_watchdog metadata
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (nagios-agents-metadata-105ab8a7b2c16b9a29cf1c1596b80136eeef332b.tar.gz) = 11ddeb48a4929e7642b6dfa9c7962aa1d7a1af1c569830f55ed6cd6773abac13377317327bc1db8411c8077884f83f81cc54d746c834b63a99fa6dc219b5caad
|
SHA512 (nagios-agents-metadata-105ab8a7b2c16b9a29cf1c1596b80136eeef332b.tar.gz) = 11ddeb48a4929e7642b6dfa9c7962aa1d7a1af1c569830f55ed6cd6773abac13377317327bc1db8411c8077884f83f81cc54d746c834b63a99fa6dc219b5caad
|
||||||
SHA512 (pacemaker-c6a4f6e6c.tar.gz) = 28a313c016add4f95ec2b546c468826c8234bafdc1a7a7d26b785733ee10ec209dc0dbf3f107df57604990b5f89b2d05831684b5d3adfd45479706d9c6d5654f
|
SHA512 (pacemaker-77db57872.tar.gz) = 37fc0eafd8d3a0342e42b5a3a8eb2b32c24324a859adeed86c997884f667bf8e8bb2d231891c5be3268e78c0d950e9127e7a209fbec6a212c54420fab0c247a2
|
||||||
|
@ -8,7 +8,7 @@
|
|||||||
tests:
|
tests:
|
||||||
- cts-regression:
|
- cts-regression:
|
||||||
dir: .
|
dir: .
|
||||||
run: /usr/share/pacemaker/tests/cts-regression cli scheduler
|
run: /usr/share/pacemaker/tests/cts-regression cli scheduler fencing
|
||||||
required_packages:
|
required_packages:
|
||||||
- pacemaker
|
- pacemaker
|
||||||
- pacemaker-cts
|
- pacemaker-cts
|
||||||
|
Loading…
Reference in New Issue
Block a user