2.0.3-1 (rev. 2) - Fix unability to build with Inkscape 1.0 beta

...(and possibly beyond)

Signed-off-by: Jan Pokorný <jpokorny@redhat.com>
This commit is contained in:
Jan Pokorný 2019-11-26 21:09:08 +01:00
parent bf2e068dcf
commit 59e60f137d
No known key found for this signature in database
GPG Key ID: 61BBB23A9E8F8DE2

View File

@ -1,4 +1,4 @@
From a85d411e04eaffb2eb9f0a1bdba025b2fb168a54 Mon Sep 17 00:00:00 2001
From 8975b48cc498bfc0fa48cb7f51d78fd01309bcfa Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Jan=20Pokorn=C3=BD?= <jpokorny@redhat.com>
Date: Tue, 26 Nov 2019 20:07:36 +0100
Subject: [PATCH] Build: fix unability to build with Inkscape 1.0 beta
@ -9,27 +9,33 @@ Subject: [PATCH] Build: fix unability to build with Inkscape 1.0 beta
References:
https://gitlab.com/inkscape/inbox/issues/1244
---
doc/Makefile.am | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
doc/Makefile.am | 11 ++++++++---
1 file changed, 8 insertions(+), 3 deletions(-)
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 257f5cdf5..90670a605 100644
index 257f5cdf5..a51c5d6f4 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -85,13 +85,13 @@ PNGS = $(PNGS_ORIGINAL) $(PNGS_GENERATED)
@@ -84,14 +84,19 @@ PNGS = $(PNGS_ORIGINAL) $(PNGS_GENERATED)
graphics: $(PNGS)
+
+# two-phased attempts for Inkscape pre-1.0 and 1.0+ (upcoming) discrepancy
%.png: %.svg
- $(AM_V_GEN)$(INKSCAPE) --file=$< --export-dpi=90 -C --export-png=$@ $(PCMK_quiet)
+ $(AM_V_GEN)$(INKSCAPE) --export-dpi=90 -C --export-png=$@ $< $(PCMK_quiet)
+ $(AM_V_GEN) { $(INKSCAPE) --export-dpi=90 -C --export-png=$@ $< \
+ || $(INKSCAPE) --export-dpi=90 -C --export-file=$@ $<; } $(PCMK_quiet)
%-small.png: %.svg
- $(AM_V_GEN)$(INKSCAPE) --file=$< --export-dpi=45 -C --export-png=$@ $(PCMK_quiet)
+ $(AM_V_GEN)$(INKSCAPE) --export-dpi=45 -C --export-png=$@ $< $(PCMK_quiet)
+ $(AM_V_GEN) { $(INKSCAPE) --export-dpi=45 -C --export-png=$@ $< \
+ || $(INKSCAPE) --export-dpi=45 -C --export-file=$@ $<; } $(PCMK_quiet)
%-large.png: %.svg
- $(AM_V_GEN)$(INKSCAPE) --file=$< --export-dpi=180 -C --export-png=$@ $(PCMK_quiet)
+ $(AM_V_GEN)$(INKSCAPE) --export-dpi=180 -C --export-png=$@ $< $(PCMK_quiet)
+ $(AM_V_GEN) { $(INKSCAPE) --export-dpi=180 -C --export-png=$@ $< \
+ || $(INKSCAPE) --export-dpi=180 -C --export-png=$@ $<; } $(PCMK_quiet)
if IS_ASCIIDOC
ASCIIDOC_HTML_ARGS = --unsafe --backend=xhtml11