1.1.14-2.5a6cdd1.git - Update for currently stabilized snapshot
...beyond Pacemaker-1.1.14 (commit 5a6cdd1), but restore old-style notifications to the state at Pacemaker-1.1.14 point release (disabled) - Definitely get rid of Corsync v1 (Flatiron) hypothetical support - Remove some of the spec file cruft, not required for years (BuildRoot, AutoReqProv, "clean" scriptlet, etc.) and adapt the file per https://github.com/ClusterLabs/pacemaker/pull/965
This commit is contained in:
parent
16ac49a8ec
commit
395f5684d7
46
Revert-Low-crmd-re-enable-built-in-notifications.patch
Normal file
46
Revert-Low-crmd-re-enable-built-in-notifications.patch
Normal file
@ -0,0 +1,46 @@
|
||||
From 25ce4e9492b1ffea528b6d25b1b1bf82362c241e Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Jan=20Pokorn=C3=BD?= <jpokorny@redhat.com>
|
||||
Date: Thu, 31 Mar 2016 23:26:22 +0200
|
||||
Subject: [PATCH] Revert "Low: crmd: re-enable built-in notifications"
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
This reverts commit ea4f3a711486b38f51b7a52d3b39f6d7b621b8da.
|
||||
|
||||
That was a result of the initial iteration and more sophisticated
|
||||
mechanism is down road[1], with an expectation that an attempt to use
|
||||
the old will be strongly discouraged (to say the least).
|
||||
|
||||
Make this apparent for new-comers to Pacemaker and/or users thinking
|
||||
about the use of notifications that the old API is a dead end to
|
||||
avoid frustration later on.
|
||||
|
||||
[1] https://github.com/ClusterLabs/pacemaker/pull/950
|
||||
|
||||
Signed-off-by: Jan Pokorný <jpokorny@redhat.com>
|
||||
---
|
||||
crmd/control.c | 7 -------
|
||||
1 file changed, 7 deletions(-)
|
||||
|
||||
diff --git a/crmd/control.c b/crmd/control.c
|
||||
index 53d850e..f3d4732 100644
|
||||
--- a/crmd/control.c
|
||||
+++ b/crmd/control.c
|
||||
@@ -41,13 +41,6 @@
|
||||
#include <sys/types.h>
|
||||
#include <sys/stat.h>
|
||||
|
||||
-/* Enable support for built-in notifications
|
||||
- *
|
||||
- * The interface is expected to change significantly, and this will be defined
|
||||
- * in the upstream master branch only until a new design is finalized.
|
||||
- */
|
||||
-#define RHEL7_COMPAT
|
||||
-
|
||||
qb_ipcs_service_t *ipcs = NULL;
|
||||
|
||||
extern gboolean crm_connect_corosync(crm_cluster_t * cluster);
|
||||
--
|
||||
2.4.3
|
||||
|
@ -1,23 +0,0 @@
|
||||
--- a/configure.ac 2016-01-18 17:40:43.096090475 +0100
|
||||
+++ b/configure.ac 2016-01-18 17:54:09.426193896 +0100
|
||||
@@ -941,12 +941,18 @@
|
||||
|
||||
dnl Check for printw() prototype compatibility
|
||||
if test X"$CURSESLIBS" != X"" && cc_supports_flag -Wcast-qual && cc_supports_flag -Werror; then
|
||||
- AC_MSG_CHECKING(whether printw() requires argument of "const char *")
|
||||
ac_save_LIBS=$LIBS
|
||||
- LIBS="$CURSESLIBS $LIBS"
|
||||
+ LIBS="$CURSESLIBS"
|
||||
ac_save_CFLAGS=$CFLAGS
|
||||
CFLAGS="-Wcast-qual -Werror"
|
||||
+ # avoid broken test because of hardened build environment in Fedora 23+
|
||||
+ # - https://fedoraproject.org/wiki/Changes/Harden_All_Packages
|
||||
+ # - https://bugzilla.redhat.com/1297985
|
||||
+ if cc_supports_flag -fPIC; then
|
||||
+ CFLAGS="$CFLAGS -fPIC"
|
||||
+ fi
|
||||
|
||||
+ AC_MSG_CHECKING(whether printw() requires argument of "const char *")
|
||||
AC_LINK_IFELSE(
|
||||
[AC_LANG_PROGRAM(
|
||||
[
|
@ -2,9 +2,13 @@
|
||||
%global uname hacluster
|
||||
%global pcmk_docdir %{_docdir}/%{name}
|
||||
|
||||
%global specversion 1
|
||||
%global commit Pacemaker-1.1.14
|
||||
%global shortcommit %(c=%{commit}; echo ${c:0:7})
|
||||
%global specversion 2
|
||||
%global pcmkversion 1.1.14
|
||||
# set following to the actual commit or, for final release, concatenate
|
||||
# "pcmkversion" macro to "Pacemaker-" (will yield a tag per the convention)
|
||||
%global commit 5a6cdd11b4f93b4d55e1b2654078018c339931d4
|
||||
%global shortcommit %(c=%{commit}; [ ${c} = Pacemaker-%{pcmkversion} ] && echo %{pcmkversion} || echo ${c:0:7})
|
||||
%global post_release %([ %{commit} = Pacemaker-%{pcmkversion} ]; echo $?)
|
||||
%global github_owner ClusterLabs
|
||||
|
||||
%global nagios_name nagios-agents-metadata
|
||||
@ -52,29 +56,27 @@
|
||||
%global debug_package %{nil}
|
||||
%endif
|
||||
|
||||
%if %{with pre_release}
|
||||
%global pcmk_release 0.%{specversion}.%{shortcommit}.git
|
||||
%if 0%{post_release}
|
||||
%global pcmk_release %{specversion}.%{shortcommit}.git
|
||||
%else
|
||||
%global pcmk_release %{specversion}
|
||||
%endif
|
||||
|
||||
Name: pacemaker
|
||||
Summary: Scalable High-Availability cluster resource manager
|
||||
Version: 1.1.14
|
||||
Release: %{pcmk_release}%{?dist}.1
|
||||
Version: %{pcmkversion}
|
||||
Release: %{pcmk_release}%{?dist}
|
||||
License: GPLv2+ and LGPLv2+
|
||||
Url: http://www.clusterlabs.org
|
||||
Group: System Environment/Daemons
|
||||
|
||||
Source0: https://github.com/%{github_owner}/%{name}/archive/%{commit}/%{name}-%{commit}.tar.gz
|
||||
Source0: https://github.com/%{github_owner}/%{name}/archive/%{commit}/%{name}-%{shortcommit}.tar.gz
|
||||
Source1: https://github.com/%{github_owner}/%{nagios_name}/archive/%{nagios_hash}/%{nagios_name}-%{nagios_hash}.tar.gz
|
||||
# ---
|
||||
Patch1: bz1297985-fix-configure-curses-test.patch
|
||||
Patch0: Revert-Low-crmd-re-enable-built-in-notifications.patch
|
||||
# keep following commented out for now
|
||||
#Patch100: bz1179335-system-wide-crypto-policies.patch
|
||||
|
||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
AutoReqProv: on
|
||||
# for docker-wrapper RA (and perhaps more)
|
||||
Requires: python >= 2.4
|
||||
Requires: resource-agents
|
||||
@ -135,7 +137,7 @@ when related resources fail and can be configured to periodically check
|
||||
resource health.
|
||||
|
||||
Available rpmbuild rebuild options:
|
||||
--with(out) : doc coverage profiling pre_release upstart_job
|
||||
--with(out) : doc coverage profiling upstart_job
|
||||
|
||||
%package cli
|
||||
License: GPLv2+ and LGPLv2+
|
||||
@ -288,7 +290,6 @@ make %{_smp_mflags} V=1 docdir=%{pcmk_docdir} all
|
||||
./BasicSanity.sh -V pengine cli 2>&1 | sed s/[fF]ail/faiil/g
|
||||
|
||||
%install
|
||||
rm -rf %{buildroot}
|
||||
make DESTDIR=%{buildroot} docdir=%{pcmk_docdir} V=1 install
|
||||
|
||||
mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig
|
||||
@ -343,9 +344,6 @@ find . -name '*.gcno' -type f | while read F ; do
|
||||
done
|
||||
%endif
|
||||
|
||||
%clean
|
||||
rm -rf %{buildroot}
|
||||
|
||||
%if %{defined _unitdir}
|
||||
|
||||
%post
|
||||
@ -469,11 +467,6 @@ exit 0
|
||||
/usr/lib/ocf/resource.d/.isolation
|
||||
/usr/lib/ocf/resource.d/pacemaker
|
||||
|
||||
# No need to special-case for corosync 1.99 any longer (not officially shipped)
|
||||
%if 0%{?cs_version} < 2
|
||||
%{_libexecdir}/lcrso/pacemaker.lcrso
|
||||
%endif
|
||||
|
||||
%if %{with upstart_job}
|
||||
%config(noreplace) %{_sysconfdir}/init/pacemaker.conf
|
||||
%config(noreplace) %{_sysconfdir}/init/pacemaker.combined.conf
|
||||
@ -591,6 +584,15 @@ exit 0
|
||||
%attr(0644,root,root) %{_datadir}/pacemaker/nagios/plugins-metadata/*
|
||||
|
||||
%changelog
|
||||
* Thu Mar 31 2016 Jan Pokorný <jpokorny+rpm-pacemaker@redhat.com> - 1.1.14-2.5a6cdd1.git
|
||||
- Update for currently stabilized snapshot beyond Pacemaker-1.1.14
|
||||
(commit 5a6cdd1), but restore old-style notifications to the state at
|
||||
Pacemaker-1.1.14 point release (disabled)
|
||||
- Definitely get rid of Corsync v1 (Flatiron) hypothetical support
|
||||
- Remove some of the spec file cruft, not required for years
|
||||
(BuildRoot, AutoReqProv, "clean" scriptlet, etc.) and adapt the file
|
||||
per https://github.com/ClusterLabs/pacemaker/pull/965
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.14-1.1
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user