Update spec file

Related: RHEL-10571

Signed-off-by: Zoltan Fridrich <zfridric@redhat.com>
This commit is contained in:
Zoltan Fridrich 2023-11-29 11:32:02 +01:00
parent d7f82142e0
commit db7554a29d
6 changed files with 55 additions and 10 deletions

1
.gitignore vendored
View File

@ -2,3 +2,4 @@ SOURCES/gpgkey-462225C3B46F34879FC8496CD605848ED7E69871.gpg
SOURCES/p11-kit-0.23.22.tar.xz SOURCES/p11-kit-0.23.22.tar.xz
/gpgkey-462225C3B46F34879FC8496CD605848ED7E69871.gpg /gpgkey-462225C3B46F34879FC8496CD605848ED7E69871.gpg
/p11-kit-0.23.22.tar.xz /p11-kit-0.23.22.tar.xz
/p11-kit-0.23.22.tar.xz.sig

42
002-doc-dep.patch Normal file
View File

@ -0,0 +1,42 @@
From 9f01a8a45ba913a9b65894cef9369b6010005096 Mon Sep 17 00:00:00 2001
From: Eli Schwartz <eschwartz@archlinux.org>
Date: Tue, 11 Jan 2022 23:25:05 -0500
Subject: [PATCH] gtkdoc: remove dependencies on custom target files
Sadly, the `dependencies` kwarg does not actually do what it seems to be
trying to be used for, here. It is for listing dependency or library
objects whose compiler flags should be added to gtkdoc-scangobj.
It will not actually add ninja target dependencies. The similar kwarg in
other meson functions (e.g. genmarshal and compile_schemas) that *do*
allow adding target dependencies, is `depend_files`.
Older versions of meson simply did nothing in an if/elif/elif block
where these custom_targets never matched anything, and were thus
silently ignored.
Meson 0.61 type-validates the arguments and rejects CustomTarget as
invalid:
```
doc/manual/meson.build:72:8: ERROR: gnome.gtkdoc keyword argument 'dependencies' was of type array[CustomTarget | PkgConfigDependency] but should have been array[Dependency | SharedLibrary | StaticLibrary]
```
Fixes #406
---
doc/manual/meson.build | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/doc/manual/meson.build b/doc/manual/meson.build
index cf8758dbf..560df8dbc 100644
--- a/doc/manual/meson.build
+++ b/doc/manual/meson.build
@@ -73,7 +73,7 @@ if get_option('gtk_doc')
main_xml: 'p11-kit-docs.xml',
namespace: 'p11_kit',
src_dir: 'p11-kit',
- dependencies: libffi_deps + dlopen_deps + xml_deps,
+ dependencies: libffi_deps + dlopen_deps,
scan_args: [
'--ignore-headers=' + ' '.join(ignore_headers),
'--rebuild-types',

Binary file not shown.

View File

@ -1,10 +1,10 @@
# This spec file has been automatically updated # This spec file has been automatically updated
Version: 0.23.22 Version: 0.23.22
Release: 1%{?dist} Release: 1%{?dist}
Name: p11-kit Name: p11-kit
Summary: Library for loading and sharing PKCS#11 modules Summary: Library for loading and sharing PKCS#11 modules
License: BSD License: BSD-3-Clause
URL: http://p11-glue.freedesktop.org/p11-kit.html URL: http://p11-glue.freedesktop.org/p11-kit.html
Source0: https://github.com/p11-glue/p11-kit/releases/download/%{version}/p11-kit-%{version}.tar.xz Source0: https://github.com/p11-glue/p11-kit/releases/download/%{version}/p11-kit-%{version}.tar.xz
Source1: https://github.com/p11-glue/p11-kit/releases/download/%{version}/p11-kit-%{version}.tar.xz.sig Source1: https://github.com/p11-glue/p11-kit/releases/download/%{version}/p11-kit-%{version}.tar.xz.sig
@ -12,7 +12,8 @@ Source2: gpgkey-462225C3B46F34879FC8496CD605848ED7E69871.gpg
Source3: trust-extract-compat Source3: trust-extract-compat
Source4: p11-kit-client.service Source4: p11-kit-client.service
Patch1: p11-kit-dt-needed.patch Patch0: 001-dt-needed.patch
Patch1: 002-doc-dep.patch
BuildRequires: gcc BuildRequires: gcc
BuildRequires: libtasn1-devel >= 2.3 BuildRequires: libtasn1-devel >= 2.3
@ -26,6 +27,7 @@ BuildRequires: bash-completion
# Work around for https://bugzilla.redhat.com/show_bug.cgi?id=1497147 # Work around for https://bugzilla.redhat.com/show_bug.cgi?id=1497147
# Remove this once it is fixed # Remove this once it is fixed
BuildRequires: pkgconfig(glib-2.0) BuildRequires: pkgconfig(glib-2.0)
BuildRequires: pkgconfig(systemd)
BuildRequires: gnupg2 BuildRequires: gnupg2
BuildRequires: /usr/bin/xsltproc BuildRequires: /usr/bin/xsltproc
@ -47,13 +49,13 @@ developing applications that use %{name}.
%package trust %package trust
Summary: System trust module from %{name} Summary: System trust module from %{name}
Requires: %{name}%{?_isa} = %{version}-%{release} Requires: %{name}%{?_isa} = %{version}-%{release}
Requires(post): %{_sbindir}/update-alternatives Requires(post): %{_sbindir}/alternatives
Requires(postun): %{_sbindir}/update-alternatives Requires(postun): %{_sbindir}/alternatives
Conflicts: nss < 3.14.3-9 Conflicts: nss < 3.14.3-9
%description trust %description trust
The %{name}-trust package contains a system trust PKCS#11 module which The %{name}-trust package contains a system trust PKCS#11 module which
contains certificate anchors and black lists. contains certificate anchors and blocklists.
%package server %package server
@ -102,13 +104,12 @@ install -p -m 644 %{SOURCE4} $RPM_BUILD_ROOT%{_userunitdir}
%post trust %post trust
%{_sbindir}/update-alternatives --install %{_libdir}/libnssckbi.so \ %{_sbindir}/alternatives --install %{_libdir}/libnssckbi.so %{alt_ckbi} %{_libdir}/pkcs11/p11-kit-trust.so 30
%{alt_ckbi} %{_libdir}/pkcs11/p11-kit-trust.so 30
%postun trust %postun trust
if [ $1 -eq 0 ] ; then if [ $1 -eq 0 ] ; then
# package removal # package removal
%{_sbindir}/update-alternatives --remove %{alt_ckbi} %{_libdir}/pkcs11/p11-kit-trust.so %{_sbindir}/alternatives --remove %{alt_ckbi} %{_libdir}/pkcs11/p11-kit-trust.so
fi fi

View File

@ -1,2 +1,3 @@
SHA512 (gpgkey-462225C3B46F34879FC8496CD605848ED7E69871.gpg) = 177e5856fa0f0d542e8014f1beffafcd0b655c842f6a69236f26d628ed7b4bbebb5767c889e5e59ba285f65625eb024a4d754da1bcdd714274820f7206408c86 SHA512 (gpgkey-462225C3B46F34879FC8496CD605848ED7E69871.gpg) = 177e5856fa0f0d542e8014f1beffafcd0b655c842f6a69236f26d628ed7b4bbebb5767c889e5e59ba285f65625eb024a4d754da1bcdd714274820f7206408c86
SHA512 (p11-kit-0.23.22.tar.xz) = 098819e6ca4ad9cc2a0bc2e478aea67354d051a4f03e6c7d75d13d2469b6dc7654f26b15530052f6ed51acb35531c2539e0f971b31e29e6673e857c903afb080 SHA512 (p11-kit-0.23.22.tar.xz) = 098819e6ca4ad9cc2a0bc2e478aea67354d051a4f03e6c7d75d13d2469b6dc7654f26b15530052f6ed51acb35531c2539e0f971b31e29e6673e857c903afb080
SHA512 (p11-kit-0.23.22.tar.xz.sig) = ecceb637852527c81a032160c5a831e92cf140335aa756c5de1531046843a9041613c7750086e3c2dd1c55c6224422dc07226b4bebff56926f1e9cedc6d73d83