0.24.1 upstream release
Resolves: #2041511 Signed-off-by: Daiki Ueno <dueno@redhat.com>
This commit is contained in:
parent
d2e6355294
commit
510b74ed33
3
.gitignore
vendored
3
.gitignore
vendored
@ -35,3 +35,6 @@
|
||||
/p11-kit-0.23.21.tar.xz
|
||||
/p11-kit-0.23.22.tar.xz
|
||||
/p11-kit-0.24.0.tar.xz
|
||||
/gpgkey-462225C3B46F34879FC8496CD605848ED7E69871.gpg
|
||||
/p11-kit-0.24.1.tar.xz
|
||||
/p11-kit-0.24.1.tar.xz.sig
|
||||
|
21
.packit.yaml
21
.packit.yaml
@ -1,21 +0,0 @@
|
||||
specfile_path: p11-kit.spec
|
||||
upstream_package_name: p11-kit
|
||||
downstream_package_name: p11-kit
|
||||
|
||||
# Use only populated spec files and upstream sources.
|
||||
actions:
|
||||
post-upstream-clone:
|
||||
- wget https://src.fedoraproject.org/rpms/p11-kit/raw/rawhide/f/p11-kit.spec
|
||||
- wget https://src.fedoraproject.org/rpms/p11-kit/raw/rawhide/f/p11-kit-client.service
|
||||
- wget https://src.fedoraproject.org/rpms/p11-kit/raw/rawhide/f/trust-extract-compat
|
||||
get-current-version:
|
||||
- "git describe --abbrev=0"
|
||||
create-archive:
|
||||
- "wget https://github.com/p11-glue/p11-kit/releases/download/$PACKIT_PROJECT_VERSION/p11-kit-$PACKIT_PROJECT_VERSION.tar.xz"
|
||||
- "wget https://github.com/p11-glue/p11-kit/releases/download/$PACKIT_PROJECT_VERSION/p11-kit-$PACKIT_PROJECT_VERSION.tar.xz.sig"
|
||||
|
||||
jobs:
|
||||
- job: propose_downstream
|
||||
trigger: release
|
||||
metadata:
|
||||
dist_git_branches: fedora-all
|
@ -1,3 +0,0 @@
|
||||
This repository is maintained by packit.
|
||||
https://packit.dev/
|
||||
The file was generated using packit 0.31.0.
|
Binary file not shown.
Binary file not shown.
Binary file not shown.
@ -1,87 +0,0 @@
|
||||
From 40fbf74b02b8ad6625e3aa49d2cdef2b52e47a04 Mon Sep 17 00:00:00 2001
|
||||
From: Daiki Ueno <ueno@gnu.org>
|
||||
Date: Mon, 25 Jan 2021 18:24:01 +0100
|
||||
Subject: [PATCH] compat: Pacify ASan complaints on intentionally leaked buffer
|
||||
|
||||
Reported by Viktor Ashirov in:
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=1905581
|
||||
---
|
||||
common/compat.c | 25 +++++++++++++++++++------
|
||||
common/library.c | 9 +++++++++
|
||||
2 files changed, 28 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/common/compat.c b/common/compat.c
|
||||
index 4390cef..d6c5af6 100644
|
||||
--- a/common/compat.c
|
||||
+++ b/common/compat.c
|
||||
@@ -100,6 +100,19 @@ extern char *program_invocation_short_name;
|
||||
extern char *__progname;
|
||||
#endif
|
||||
|
||||
+#ifdef __linux__
|
||||
+/* This symbol is also defined in library.c so as to be freed by the library
|
||||
+ * destructor. If weak symbols are not supported nor library.c is not linked we
|
||||
+ * simply leak the memory allocated with realpath(). */
|
||||
+#ifdef __GNUC__
|
||||
+extern char *p11_program_realpath;
|
||||
+
|
||||
+char *p11_program_realpath __attribute__((weak));
|
||||
+#else
|
||||
+static char *p11_program_realpath;
|
||||
+#endif
|
||||
+#endif
|
||||
+
|
||||
const char *
|
||||
getprogname (void)
|
||||
{
|
||||
@@ -124,14 +137,14 @@ getprogname (void)
|
||||
* Logic borrowed from:
|
||||
* <https://github.com/mesa3d/mesa/commit/759b94038987bb983398cd4b1d2cb1c8f79817a9>.
|
||||
*/
|
||||
- static char *buf;
|
||||
-
|
||||
- if (!buf)
|
||||
- buf = realpath ("/proc/self/exe", NULL);
|
||||
+ if (!p11_program_realpath)
|
||||
+ p11_program_realpath = realpath ("/proc/self/exe", NULL);
|
||||
|
||||
- if (buf && strncmp (buf, name, strlen (buf)) == 0)
|
||||
+ if (p11_program_realpath &&
|
||||
+ strncmp (p11_program_realpath, name,
|
||||
+ strlen (p11_program_realpath)) == 0)
|
||||
/* Use the executable path if the prefix matches. */
|
||||
- name = strrchr (buf, '/') + 1;
|
||||
+ name = strrchr (p11_program_realpath, '/') + 1;
|
||||
else
|
||||
/* Otherwise fall back to
|
||||
* program_invocation_short_name. */
|
||||
diff --git a/common/library.c b/common/library.c
|
||||
index 891344a..1581702 100644
|
||||
--- a/common/library.c
|
||||
+++ b/common/library.c
|
||||
@@ -82,6 +82,11 @@ unsigned int p11_forkid = 1;
|
||||
extern locale_t p11_message_locale;
|
||||
#endif
|
||||
|
||||
+#ifdef __linux__
|
||||
+/* used only under __linux__ in the getprogname() emulation in compat.c. */
|
||||
+char *p11_program_realpath;
|
||||
+#endif
|
||||
+
|
||||
static char *
|
||||
thread_local_message (void)
|
||||
{
|
||||
@@ -190,6 +195,10 @@ p11_library_uninit (void)
|
||||
#endif
|
||||
p11_mutex_uninit (&p11_virtual_mutex);
|
||||
p11_mutex_uninit (&p11_library_mutex);
|
||||
+
|
||||
+#ifdef __linux__
|
||||
+ free (p11_program_realpath);
|
||||
+#endif
|
||||
}
|
||||
|
||||
#endif /* OS_UNIX */
|
||||
--
|
||||
2.29.2
|
||||
|
Binary file not shown.
Binary file not shown.
24
p11-kit.spec
24
p11-kit.spec
@ -1,6 +1,6 @@
|
||||
# This spec file has been automatically updated
|
||||
Version: 0.24.0
|
||||
Release: 4%{?dist}
|
||||
Version: 0.24.1
|
||||
Release: 1%{?dist}
|
||||
Name: p11-kit
|
||||
Summary: Library for loading and sharing PKCS#11 modules
|
||||
|
||||
@ -152,6 +152,26 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Jan 17 2022 Packit Service <user-cont-team+packit-service@redhat.com> - 0.24.1-1
|
||||
- Release 0.24.1 (Daiki Ueno)
|
||||
- common: Support copying attribute array recursively (Daiki Ueno)
|
||||
- common: Add assert_ptr_cmp (Daiki Ueno)
|
||||
- gtkdoc: remove dependencies on custom target files (Eli Schwartz)
|
||||
- doc: Replace occurrence of black list with blocklist (Daiki Ueno)
|
||||
- build: Suppress cppcheck false-positive on array bounds (Daiki Ueno)
|
||||
- ci: Use Docker image from the same repository (Daiki Ueno)
|
||||
- ci: Integrate Docker image building to GitHub workflow (Daiki Ueno)
|
||||
- rpc: Fallback to version 0 if server does not support negotiation (Daiki Ueno)
|
||||
- build: Port e850e03be65ed573d0b69ee0408e776c08fad8a3 to meson (Daiki Ueno)
|
||||
- Link libp11-kit so that it cannot unload (Emmanuel Dreyfus)
|
||||
- trust: Use dngettext for plurals (Daiki Ueno)
|
||||
- rpc: Support protocol version negotiation (Daiki Ueno)
|
||||
- rpc: Separate authentication step from transaction (Daiki Ueno)
|
||||
- Meson: p11_system_config_modules instead of p11_package_config_modules (Issam E. Maghni)
|
||||
- shell: test -a|o is not POSIX (Issam E. Maghni)
|
||||
- Meson: Add libtasn1 to trust programs (Issam E. Maghni)
|
||||
- meson: optionalise glib's development files for gtk_doc (Đoàn Trần Công Danh)
|
||||
|
||||
* Wed Aug 18 2021 DJ Delorie <dj@redhat.com> - 0.24.0-4
|
||||
- Rebuilt for libffi 3.4.2 SONAME transition.
|
||||
Related: rhbz#1891914
|
||||
|
4
sources
4
sources
@ -1 +1,3 @@
|
||||
SHA512 (p11-kit-0.24.0.tar.xz) = 48369d6fdae79b8c5a255c821fbdb982f0c649cce07c0d92f0ff0c16322fea8919faa94067cae2efede2da3646c0e69a71a3e399b769dc2327f247bcb113eb3c
|
||||
SHA512 (gpgkey-462225C3B46F34879FC8496CD605848ED7E69871.gpg) = 177e5856fa0f0d542e8014f1beffafcd0b655c842f6a69236f26d628ed7b4bbebb5767c889e5e59ba285f65625eb024a4d754da1bcdd714274820f7206408c86
|
||||
SHA512 (p11-kit-0.24.1.tar.xz) = 8cf170c714bb9e0cf3df93e8ec55b8e3c55cabf2c6a27f177ac6de8b8028985df2ca0216d3215d6828dc2ae3095c4e1a4febe8cb26b88ec321defc66bb011e81
|
||||
SHA512 (p11-kit-0.24.1.tar.xz.sig) = 9dfe3d86d7c1f396da529291cf0af4e38f56f05023f957604c86c8199cbd20ab48da6f2541b4bcb34bfa01dc7912056e06fc88783d321b07fced19c687bd0ac1
|
||||
|
Loading…
Reference in New Issue
Block a user