Import rpm: 7fbb89dac4c4701add68b8449dcbecacfb42ace2
This commit is contained in:
commit
5ee2f93298
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
SOURCES/v1.2.2.tar.gz
|
32
0_bundle-packaging.patch
Normal file
32
0_bundle-packaging.patch
Normal file
@ -0,0 +1,32 @@
|
|||||||
|
diff --git a/core/pom.xml b/core/pom.xml
|
||||||
|
index cd0293e..6d4276e 100644
|
||||||
|
--- a/core/pom.xml
|
||||||
|
+++ b/core/pom.xml
|
||||||
|
@@ -46,7 +46,7 @@
|
||||||
|
</parent>
|
||||||
|
|
||||||
|
<artifactId>encoder</artifactId>
|
||||||
|
- <packaging>jar</packaging>
|
||||||
|
+ <packaging>bundle</packaging>
|
||||||
|
|
||||||
|
<name>Java Encoder</name>
|
||||||
|
<description>
|
||||||
|
@@ -67,6 +67,18 @@
|
||||||
|
</excludes>
|
||||||
|
</configuration>
|
||||||
|
</plugin>
|
||||||
|
+ <plugin>
|
||||||
|
+ <groupId>org.apache.felix</groupId>
|
||||||
|
+ <artifactId>maven-bundle-plugin</artifactId>
|
||||||
|
+ <version>4.2.1</version>
|
||||||
|
+ <extensions>true</extensions>
|
||||||
|
+ <configuration>
|
||||||
|
+ <instructions>
|
||||||
|
+ <Export-Package>org.owasp.encoder</Export-Package>
|
||||||
|
+ <Bundle-SymbolicName>org.owasp.encoder</Bundle-SymbolicName>
|
||||||
|
+ </instructions>
|
||||||
|
+ </configuration>
|
||||||
|
+ </plugin>
|
||||||
|
</plugins>
|
||||||
|
</build>
|
||||||
|
<profiles>
|
12
0_manifest.patch
Normal file
12
0_manifest.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -Nur owasp-java-encoder-1.2.1-orig/META-INF/MANIFEST.MF owasp-java-encoder-1.2.1/META-INF/MANIFEST.MF
|
||||||
|
--- owasp-java-encoder-1.2.1-orig/META-INF/MANIFEST.MF 1969-12-31 19:00:00.000000000 -0500
|
||||||
|
+++ owasp-java-encoder-1.2.1/META-INF/MANIFEST.MF 2018-08-07 11:59:15.923471361 -0400
|
||||||
|
@@ -0,0 +1,8 @@
|
||||||
|
+Manifest-Version: 1.0
|
||||||
|
+Bnd-LastModified: 1533328833261
|
||||||
|
+Bundle-ManifestVersion: 2
|
||||||
|
+Bundle-Name: org.owasp.encoder
|
||||||
|
+Bundle-SymbolicName: org.owasp.encoder
|
||||||
|
+Created-By: 1.8.0_181 (Oracle Corporation)
|
||||||
|
+Export-Package: org.owasp.encoder
|
||||||
|
+Tool: Bnd-1.50.0
|
15
1_update-compiler-plugin-version.patch
Normal file
15
1_update-compiler-plugin-version.patch
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
diff --git a/pom.xml b/pom.xml
|
||||||
|
index d81ad2c..fe27928 100755
|
||||||
|
--- a/pom.xml
|
||||||
|
+++ b/pom.xml
|
||||||
|
@@ -261,8 +261,8 @@
|
||||||
|
<groupId>org.apache.maven.plugins</groupId>
|
||||||
|
<artifactId>maven-compiler-plugin</artifactId>
|
||||||
|
<configuration>
|
||||||
|
- <source>1.5</source>
|
||||||
|
- <target>1.5</target>
|
||||||
|
+ <source>1.8</source>
|
||||||
|
+ <target>1.8</target>
|
||||||
|
</configuration>
|
||||||
|
</plugin>
|
||||||
|
<plugin>
|
3
README.md
Normal file
3
README.md
Normal file
@ -0,0 +1,3 @@
|
|||||||
|
# owasp-java-encoder
|
||||||
|
|
||||||
|
The owasp-java-encoder package
|
77
owasp-java-encoder.spec
Normal file
77
owasp-java-encoder.spec
Normal file
@ -0,0 +1,77 @@
|
|||||||
|
Name: owasp-java-encoder
|
||||||
|
Version: 1.2.2
|
||||||
|
Release: 3%{?dist}
|
||||||
|
Summary: Collection of high-performance low-overhead contextual encoders
|
||||||
|
|
||||||
|
License: BSD
|
||||||
|
URL: https://github.com/OWASP/owasp-java-encoder/
|
||||||
|
|
||||||
|
Source0: https://github.com/OWASP/owasp-java-encoder/archive/v%{version}.tar.gz
|
||||||
|
|
||||||
|
# add OSGi metadata
|
||||||
|
Patch0: 0_manifest.patch
|
||||||
|
|
||||||
|
BuildArch: noarch
|
||||||
|
ExclusiveArch: x86_64
|
||||||
|
|
||||||
|
BuildRequires: maven-local
|
||||||
|
BuildRequires: mvn(org.apache.maven.plugins:maven-source-plugin)
|
||||||
|
BuildRequires: mvn(org.sonatype.oss:oss-parent:pom:)
|
||||||
|
|
||||||
|
%description
|
||||||
|
The OWASP Encoders package is a collection of high-performance low-overhead
|
||||||
|
contextual encoders, that when utilized correctly, is an effective tool in
|
||||||
|
preventing Web Application security vulnerabilities such as
|
||||||
|
Cross-Site Scripting.
|
||||||
|
|
||||||
|
%package javadoc
|
||||||
|
Summary: Javadoc for %{name}
|
||||||
|
|
||||||
|
%description javadoc
|
||||||
|
%{summary}.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
|
# add version number in OSGi metadata
|
||||||
|
sed -i '/^Bundle-SymbolicName: org.owasp.encoder$/a Bundle-Version: %{version}' %{_builddir}/%{name}-%{version}/META-INF/MANIFEST.MF
|
||||||
|
|
||||||
|
%pom_disable_module jsp
|
||||||
|
%pom_disable_module esapi
|
||||||
|
|
||||||
|
%pom_remove_plugin org.apache.maven.plugins:maven-javadoc-plugin
|
||||||
|
|
||||||
|
# analysis tool for testing coverage is not required
|
||||||
|
%pom_remove_plugin :cobertura-maven-plugin
|
||||||
|
|
||||||
|
%build
|
||||||
|
%mvn_build
|
||||||
|
|
||||||
|
# inject OSGi manifest
|
||||||
|
jar ufm %{_builddir}/%{name}-%{version}/core/target/encoder-%{version}.jar %{_builddir}/%{name}-%{version}/META-INF/MANIFEST.MF
|
||||||
|
|
||||||
|
%install
|
||||||
|
%mvn_install
|
||||||
|
|
||||||
|
%files -f .mfiles
|
||||||
|
%doc README.md
|
||||||
|
%license LICENSE
|
||||||
|
|
||||||
|
%files javadoc -f .mfiles-javadoc
|
||||||
|
%doc README.md
|
||||||
|
%license LICENSE
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Thu Mar 04 2021 Alex Macdonald <almacdon@redhat.com> - 1.2.2-3
|
||||||
|
- Add ExclusiveArch: x86_64
|
||||||
|
|
||||||
|
* Tue May 28 2019 Jie Kang <jkang@redhat.com> -1.2.2-2
|
||||||
|
- Remove unnecessary javadoc plugin for Fedora builds
|
||||||
|
|
||||||
|
* Fri Nov 16 2018 Salman Siddiqui <sasiddiq@redhat.com> - 1.2.2-1
|
||||||
|
- Version update
|
||||||
|
|
||||||
|
* Wed Aug 08 2018 Salman Siddiqui <sasiddiq@redhat.com> - 1.2.1-1
|
||||||
|
- Initial packaging
|
Loading…
Reference in New Issue
Block a user