Merged update from upstream sources

This is an automated DistroBaker update from upstream sources.
If you do not know what this is about or would like to opt out,
contact the OSCI team.

Source: https://src.fedoraproject.org/rpms/owasp-java-encoder.git#2bac160d78a01d09a1e5b8a2cbb455ae9d08dc24
This commit is contained in:
DistroBaker 2021-01-08 16:35:08 +00:00
parent 81300470bb
commit 38c498588e
7 changed files with 132 additions and 1 deletions

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
/v1.2.2.tar.gz

32
0_bundle-packaging.patch Normal file
View File

@ -0,0 +1,32 @@
diff --git a/core/pom.xml b/core/pom.xml
index cd0293e..6d4276e 100644
--- a/core/pom.xml
+++ b/core/pom.xml
@@ -46,7 +46,7 @@
</parent>
<artifactId>encoder</artifactId>
- <packaging>jar</packaging>
+ <packaging>bundle</packaging>
<name>Java Encoder</name>
<description>
@@ -67,6 +67,18 @@
</excludes>
</configuration>
</plugin>
+ <plugin>
+ <groupId>org.apache.felix</groupId>
+ <artifactId>maven-bundle-plugin</artifactId>
+ <version>4.2.1</version>
+ <extensions>true</extensions>
+ <configuration>
+ <instructions>
+ <Export-Package>org.owasp.encoder</Export-Package>
+ <Bundle-SymbolicName>org.owasp.encoder</Bundle-SymbolicName>
+ </instructions>
+ </configuration>
+ </plugin>
</plugins>
</build>
<profiles>

View File

@ -0,0 +1,15 @@
diff --git a/pom.xml b/pom.xml
index d81ad2c..fe27928 100755
--- a/pom.xml
+++ b/pom.xml
@@ -261,8 +261,8 @@
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-compiler-plugin</artifactId>
<configuration>
- <source>1.5</source>
- <target>1.5</target>
+ <source>1.8</source>
+ <target>1.8</target>
</configuration>
</plugin>
<plugin>

3
README.md Normal file
View File

@ -0,0 +1,3 @@
# owasp-java-encoder
The owasp-java-encoder package

View File

@ -1 +0,0 @@
retiring ursine package, replaced by jmc module build

80
owasp-java-encoder.spec Normal file
View File

@ -0,0 +1,80 @@
Name: owasp-java-encoder
Version: 1.2.2
Release: 4%{?dist}
Summary: Collection of high-performance low-overhead contextual encoders
License: BSD
URL: https://github.com/OWASP/owasp-java-encoder/
Source0: https://github.com/OWASP/owasp-java-encoder/archive/v%{version}.tar.gz
# package as a bundle instead of a jar
Patch0: 0_bundle-packaging.patch
# source/target option of 1.5 not compatible with maven-compiler-plugin 3.8.1 >= in f33
Patch1: 1_update-compiler-plugin-version.patch
BuildArch: noarch
BuildRequires: maven-local
BuildRequires: mvn(org.apache.maven.plugins:maven-source-plugin)
BuildRequires: mvn(org.apache.felix:maven-bundle-plugin)
%description
The OWASP Encoders package is a collection of high-performance low-overhead
contextual encoders, that when utilized correctly, is an effective tool in
preventing Web Application security vulnerabilities such as
Cross-Site Scripting.
%package javadoc
Summary: Javadoc for %{name}
%description javadoc
%{summary}.
%prep
%setup -q
%patch0 -p1
%patch1 -p1
%pom_disable_module jsp
%pom_disable_module esapi
%pom_remove_plugin org.apache.maven.plugins:maven-javadoc-plugin
# analysis tool for testing coverage is not required
%pom_remove_plugin :cobertura-maven-plugin
%pom_remove_parent
%build
%mvn_build
%install
%mvn_install
%files -f .mfiles
%doc README.md
%license LICENSE
%files javadoc -f .mfiles-javadoc
%doc README.md
%license LICENSE
%changelog
* Mon Sep 21 2020 Jie Kang <jkang@redhat.com> - 1.2.2-4
- Remove deprecated dependency: sonatype-oss-parent
* Tue Aug 18 2020 Alex Macdonald <almacdon@redhat.com> - 1.2.2-3
- Remove osgi metadata patch0 that previously added a manifest
- Include patch (courtesy of jkang) to package as a bundle instead of a jar
- Update maven-compiler-plugin source/target version for builds in f33
* Tue May 28 2019 Jie Kang <jkang@redhat.com> -1.2.2-2
- Remove unnecessary javadoc plugin for Fedora builds
* Fri Nov 16 2018 Salman Siddiqui <sasiddiq@redhat.com> - 1.2.2-1
- Version update
* Wed Aug 08 2018 Salman Siddiqui <sasiddiq@redhat.com> - 1.2.1-1
- Initial packaging

1
sources Normal file
View File

@ -0,0 +1 @@
SHA512 (v1.2.2.tar.gz) = 97e298ec802360718d3d70451d6e227d0bb5a27dc560445e64e1521b9e5fa790820f8b9f190a572757e3c58878f4e7baf0a8e0f4cf27d2bbba26f07f949e00af