ostree/0001-build-sys-Add-disable-http2.patch
Jonathan Lebon 263e4d5e7a Backport patch to build without HTTP2
It's causing problems for people. For more information, see:
https://src.fedoraproject.org/rpms/ostree/pull-request/6
2017-12-18 17:27:31 +00:00

67 lines
2.1 KiB
Diff

From 20984db8bd2dbe6edca9a9c2a042aed32142dab7 Mon Sep 17 00:00:00 2001
From: Colin Walters <walters@verbum.org>
Date: Tue, 12 Dec 2017 16:04:11 -0500
Subject: [PATCH] build-sys: Add --disable-http2
I may punt and use this in Fedora at least for now until we have time to debug
the issues.
Closes: #1373
Approved by: jlebon
---
configure.ac | 10 ++++++++++
src/libostree/ostree-fetcher-curl.c | 2 ++
2 files changed, 12 insertions(+)
diff --git a/configure.ac b/configure.ac
index 629c923b..050da747 100644
--- a/configure.ac
+++ b/configure.ac
@@ -135,6 +135,15 @@ AS_IF([test x$with_curl != xno ], [
], [with_soup_default=check])
AM_CONDITIONAL(USE_CURL, test x$with_curl != xno)
if test x$with_curl = xyes; then OSTREE_FEATURES="$OSTREE_FEATURES libcurl"; fi
+AC_ARG_ENABLE(http2,
+AS_HELP_STRING([--disable-http2],
+ [Disable use of http2 (default: no)]),,
+ [enable_http2=yes])
+AS_IF([test x$enable_http2 != xno ], [
+ AC_DEFINE([BUILDOPT_HTTP2], 1, [Define if we enable http2])
+], [
+ OSTREE_FEATURES="$OSTREE_FEATURES no-http2"
+])
dnl When bumping the libsoup-2.4 dependency, remember to bump
dnl SOUP_VERSION_MIN_REQUIRED and SOUP_VERSION_MAX_ALLOWED in
@@ -556,6 +565,7 @@ AC_OUTPUT
echo "
libostree $VERSION ($release_build_type)
+ features: $OSTREE_FEATURES
===============
diff --git a/src/libostree/ostree-fetcher-curl.c b/src/libostree/ostree-fetcher-curl.c
index 58835529..291df3db 100644
--- a/src/libostree/ostree-fetcher-curl.c
+++ b/src/libostree/ostree-fetcher-curl.c
@@ -771,6 +771,7 @@ initiate_next_curl_request (FetcherRequest *req,
* there are numerous HTTP/2 fixes since the original version in
* libcurl 7.43.0.
*/
+#ifdef BUILDOPT_HTTP2
#if CURL_AT_LEAST_VERSION(7, 51, 0)
curl_easy_setopt (req->easy, CURLOPT_HTTP_VERSION, CURL_HTTP_VERSION_2_0);
#endif
@@ -778,6 +779,7 @@ initiate_next_curl_request (FetcherRequest *req,
#if (CURLPIPE_MULTIPLEX > 0)
/* wait for pipe connection to confirm */
curl_easy_setopt (req->easy, CURLOPT_PIPEWAIT, 1L);
+#endif
#endif
curl_easy_setopt (req->easy, CURLOPT_WRITEFUNCTION, write_cb);
if (g_getenv ("OSTREE_DEBUG_HTTP"))
--
2.14.3