Rebase to v2023.5 and Backport 7f70614
This commit is contained in:
parent
a798e9f3c9
commit
f4c3fe1ce9
1
.gitignore
vendored
1
.gitignore
vendored
@ -96,3 +96,4 @@
|
||||
/libostree-2023.2.tar.xz
|
||||
/libostree-2023.3.tar.xz
|
||||
/libostree-2023.4.tar.xz
|
||||
/libostree-2023.5.tar.xz
|
||||
|
27
0001-Backport-7f70614a1ac1950ebde3df0e26cc9ab1d72b2f1f.patch
Normal file
27
0001-Backport-7f70614a1ac1950ebde3df0e26cc9ab1d72b2f1f.patch
Normal file
@ -0,0 +1,27 @@
|
||||
From 3443baa6e63b36d169f57027d7e80df614592c8e Mon Sep 17 00:00:00 2001
|
||||
From: Joseph Marrero <jmarrero@redhat.com>
|
||||
Date: Fri, 4 Aug 2023 16:09:20 -0400
|
||||
Subject: [PATCH] Backport: 7f70614a1ac1950ebde3df0e26cc9ab1d72b2f1f
|
||||
|
||||
---
|
||||
src/libostree/ostree-sysroot-deploy.c | 3 +--
|
||||
1 file changed, 1 insertion(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/libostree/ostree-sysroot-deploy.c b/src/libostree/ostree-sysroot-deploy.c
|
||||
index 2454a587..4d6d796e 100644
|
||||
--- a/src/libostree/ostree-sysroot-deploy.c
|
||||
+++ b/src/libostree/ostree-sysroot-deploy.c
|
||||
@@ -1613,9 +1613,8 @@ static void *
|
||||
sync_in_thread (void *ptr)
|
||||
{
|
||||
SyncData *syncdata = ptr;
|
||||
- // Ensure that the caller is blocked waiting
|
||||
- g_mutex_lock (&syncdata->mutex);
|
||||
sync ();
|
||||
+ g_mutex_lock (&syncdata->mutex);
|
||||
// Signal success
|
||||
syncdata->success = true;
|
||||
g_cond_broadcast (&syncdata->cond);
|
||||
--
|
||||
2.41.0
|
||||
|
@ -1,38 +0,0 @@
|
||||
From 15bb7c8d531c24a144c1b7e3f85322ebf4f25be6 Mon Sep 17 00:00:00 2001
|
||||
From: Colin Walters <walters@verbum.org>
|
||||
Date: Mon, 26 Jun 2023 05:17:45 -0400
|
||||
Subject: [PATCH] Revert "fetcher: Always open tmpfiles in repo location"
|
||||
|
||||
This reverts commit f7f6f87c513c9f35bc24f35e909779c19cb49d3a.
|
||||
|
||||
This seems to have broken flatpak, so we'll revert and then
|
||||
investigate.
|
||||
|
||||
Closes: https://github.com/ostreedev/ostree/issues/2900
|
||||
---
|
||||
src/libostree/ostree-fetcher-util.h | 8 +++++++-
|
||||
1 file changed, 7 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/libostree/ostree-fetcher-util.h b/src/libostree/ostree-fetcher-util.h
|
||||
index 35f3e854..c3243801 100644
|
||||
--- a/src/libostree/ostree-fetcher-util.h
|
||||
+++ b/src/libostree/ostree-fetcher-util.h
|
||||
@@ -35,8 +35,14 @@ static inline gboolean
|
||||
_ostree_fetcher_tmpf_from_flags (OstreeFetcherRequestFlags flags, int dfd, GLnxTmpfile *tmpf,
|
||||
GError **error)
|
||||
{
|
||||
- if (!glnx_open_tmpfile_linkable_at (dfd, ".", O_RDWR | O_CLOEXEC, tmpf, error))
|
||||
+ if ((flags & OSTREE_FETCHER_REQUEST_LINKABLE) > 0)
|
||||
+ {
|
||||
+ if (!glnx_open_tmpfile_linkable_at (dfd, ".", O_RDWR | O_CLOEXEC, tmpf, error))
|
||||
+ return FALSE;
|
||||
+ }
|
||||
+ else if (!glnx_open_anonymous_tmpfile (O_RDWR | O_CLOEXEC, tmpf, error))
|
||||
return FALSE;
|
||||
+
|
||||
if (!glnx_fchmod (tmpf->fd, 0644, error))
|
||||
return FALSE;
|
||||
return TRUE;
|
||||
--
|
||||
2.41.0
|
||||
|
11
ostree.spec
11
ostree.spec
@ -7,13 +7,13 @@
|
||||
|
||||
Summary: Tool for managing bootable, immutable filesystem trees
|
||||
Name: ostree
|
||||
Version: 2023.4
|
||||
Release: 2%{?dist}
|
||||
Version: 2023.5
|
||||
Release: 1%{?dist}
|
||||
Source0: https://github.com/ostreedev/%{name}/releases/download/v%{version}/libostree-%{version}.tar.xz
|
||||
Source1: ostree-readonly-sysroot-migration
|
||||
Source2: ostree-readonly-sysroot-migration.service
|
||||
|
||||
Patch0: 0001-Revert-fetcher-Always-open-tmpfiles-in-repo-location.patch
|
||||
Patch0: 0001-Backport-7f70614a1ac1950ebde3df0e26cc9ab1d72b2f1f.patch
|
||||
|
||||
License: LGPLv2+
|
||||
URL: https://ostree.readthedocs.io/en/latest/
|
||||
@ -180,6 +180,11 @@ find %{buildroot} -name '*.la' -delete
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Aug 4 2023 Joseph Marrero <jmarrero@fedoraproject.org> - 2023.5-1
|
||||
- https://github.com/ostreedev/ostree/releases/tag/v2023.5
|
||||
backport: https://github.com/ostreedev/ostree/commit/7f70614a1ac1950ebde3df0e26cc9ab1d72b2f1f
|
||||
Resolves: rhbz#2221997
|
||||
|
||||
* Wed Jun 28 2023 Joseph Marrero <jmarrero@fedoraproject.org> - 2023.4-2
|
||||
- Add patch https://github.com/ostreedev/ostree/pull/2901
|
||||
Resolves: rhbz#2216810
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (libostree-2023.4.tar.xz) = 7587732c6852843abd6e4ab0778399a3da868318eb536c1c8e7031bcc7d18ad033c3162e146da3dbdee1c468c4287721cf7421c6208dbd6a9383982e160a5e80
|
||||
SHA512 (libostree-2023.5.tar.xz) = 0bb19f199344d8db7299cf710f2ba0b2657cdcb5b1fc6d85446cef9538b069e470b47fc0c2c1029e12b8b9adb978f32a6f44f48949ff5c97a01051a425a9f2d5
|
||||
|
Loading…
Reference in New Issue
Block a user