New upstream version
This commit is contained in:
parent
8cc78ff4ea
commit
ee36854053
1
.gitignore
vendored
1
.gitignore
vendored
@ -41,3 +41,4 @@
|
|||||||
/ostree-2016.8.tar.xz
|
/ostree-2016.8.tar.xz
|
||||||
/ostree-2016.9.tar.xz
|
/ostree-2016.9.tar.xz
|
||||||
/ostree-2016.10.tar.xz
|
/ostree-2016.10.tar.xz
|
||||||
|
/ostree-2016.11.tar.xz
|
||||||
|
@ -1,31 +0,0 @@
|
|||||||
From 450361d89bb937e157994abb15923a881da57ba3 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Colin Walters <walters@verbum.org>
|
|
||||||
Date: Wed, 14 Sep 2016 12:56:07 -0400
|
|
||||||
Subject: [PATCH] boot: Ensure we remount /var writable before systemd does
|
|
||||||
journal flush
|
|
||||||
|
|
||||||
Otherwise, we may not get a persistent journal for the first boot.
|
|
||||||
https://bugzilla.redhat.com/show_bug.cgi?id=1265295
|
|
||||||
|
|
||||||
Closes: #511
|
|
||||||
Approved by: jlebon
|
|
||||||
---
|
|
||||||
src/boot/ostree-remount.service | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/boot/ostree-remount.service b/src/boot/ostree-remount.service
|
|
||||||
index 61dd5fa..8439b49 100644
|
|
||||||
--- a/src/boot/ostree-remount.service
|
|
||||||
+++ b/src/boot/ostree-remount.service
|
|
||||||
@@ -25,7 +25,7 @@ After=-.mount
|
|
||||||
After=systemd-remount-fs.service
|
|
||||||
Before=local-fs.target umount.target
|
|
||||||
# Other early boot units that need to write to /var
|
|
||||||
-Before=systemd-random-seed.service plymouth-read-write.service
|
|
||||||
+Before=systemd-random-seed.service plymouth-read-write.service systemd-journal-flush.service
|
|
||||||
# tmpfiles.d usually needs write access to a few places
|
|
||||||
Before=systemd-tmpfiles-setup.service
|
|
||||||
|
|
||||||
--
|
|
||||||
2.7.4
|
|
||||||
|
|
@ -1,41 +0,0 @@
|
|||||||
From 318430dc700973fbc54c5469343c45aaab4701a7 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Jonathan Lebon <jlebon@redhat.com>
|
|
||||||
Date: Tue, 20 Sep 2016 11:45:57 -0400
|
|
||||||
Subject: [PATCH] ostree_sysroot_init_osname: also create /var/log
|
|
||||||
|
|
||||||
/var/log is another one of those core directories that should be made
|
|
||||||
available and properly labeled during early boot before tmpfiles.d
|
|
||||||
starts up.
|
|
||||||
|
|
||||||
Related: https://bugzilla.redhat.com/show_bug.cgi?id=1265295
|
|
||||||
|
|
||||||
Closes: #513
|
|
||||||
Approved by: cgwalters
|
|
||||||
---
|
|
||||||
src/libostree/ostree-sysroot.c | 10 ++++++++++
|
|
||||||
1 file changed, 10 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/src/libostree/ostree-sysroot.c b/src/libostree/ostree-sysroot.c
|
|
||||||
index de92691..ee87128 100644
|
|
||||||
--- a/src/libostree/ostree-sysroot.c
|
|
||||||
+++ b/src/libostree/ostree-sysroot.c
|
|
||||||
@@ -1487,6 +1487,16 @@ ostree_sysroot_init_osname (OstreeSysroot *self,
|
|
||||||
goto out;
|
|
||||||
}
|
|
||||||
|
|
||||||
+ /* This needs to be available and properly labeled early during the boot
|
|
||||||
+ * process (before tmpfiles.d kicks in), so that journald can flush logs from
|
|
||||||
+ * the first boot there. https://bugzilla.redhat.com/show_bug.cgi?id=1265295
|
|
||||||
+ * */
|
|
||||||
+ if (mkdirat (dfd, "var/log", 0755) < 0)
|
|
||||||
+ {
|
|
||||||
+ glnx_set_prefix_error_from_errno (error, "Creating %s", "var/log");
|
|
||||||
+ goto out;
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
if (symlinkat ("../run", dfd, "var/run") < 0)
|
|
||||||
{
|
|
||||||
glnx_set_prefix_error_from_errno (error, "Symlinking %s", "var/run");
|
|
||||||
--
|
|
||||||
2.7.4
|
|
||||||
|
|
@ -1,54 +0,0 @@
|
|||||||
From 5893b68ef76b10fc4267faa09d27588f2594b2f6 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Colin Walters <walters@verbum.org>
|
|
||||||
Date: Sun, 11 Sep 2016 20:33:42 -0400
|
|
||||||
Subject: [PATCH] pull: Do allow executing deltas when mirroring into
|
|
||||||
bare{,-user}
|
|
||||||
|
|
||||||
In https://github.com/ostreedev/ostree/pull/408 we fixed a
|
|
||||||
bug where we would crash when trying to execute deltas into
|
|
||||||
an archive repo (which isn't presently supported).
|
|
||||||
|
|
||||||
But that was overly aggressive - we obviously *can* execute deltas
|
|
||||||
when mirroring into a bare repo. This should fix a regression with
|
|
||||||
the way flatpak uses mirroring to pull from a user repo into the
|
|
||||||
system.
|
|
||||||
|
|
||||||
Closes: #506
|
|
||||||
Approved by: alexlarsson
|
|
||||||
---
|
|
||||||
src/libostree/ostree-repo-pull.c | 5 ++++-
|
|
||||||
1 file changed, 4 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/libostree/ostree-repo-pull.c b/src/libostree/ostree-repo-pull.c
|
|
||||||
index 76c2927..01561df 100644
|
|
||||||
--- a/src/libostree/ostree-repo-pull.c
|
|
||||||
+++ b/src/libostree/ostree-repo-pull.c
|
|
||||||
@@ -2272,6 +2272,7 @@ ostree_repo_pull_with_options (OstreeRepo *self,
|
|
||||||
const char *url_override = NULL;
|
|
||||||
g_autofree char *base_meta_url = NULL;
|
|
||||||
g_autofree char *base_content_url = NULL;
|
|
||||||
+ gboolean mirroring_into_archive;
|
|
||||||
|
|
||||||
if (options)
|
|
||||||
{
|
|
||||||
@@ -2312,6 +2313,8 @@ ostree_repo_pull_with_options (OstreeRepo *self,
|
|
||||||
pull_data->is_untrusted = (flags & OSTREE_REPO_PULL_FLAGS_UNTRUSTED) > 0;
|
|
||||||
pull_data->cancellable = cancellable ? g_object_ref (cancellable) : NULL;
|
|
||||||
|
|
||||||
+ mirroring_into_archive = pull_data->is_mirror && self->mode == OSTREE_REPO_MODE_ARCHIVE_Z2;
|
|
||||||
+
|
|
||||||
if (error)
|
|
||||||
pull_data->async_error = &pull_data->cached_async_error;
|
|
||||||
else
|
|
||||||
@@ -2845,7 +2848,7 @@ ostree_repo_pull_with_options (OstreeRepo *self,
|
|
||||||
&from_revision, error))
|
|
||||||
goto out;
|
|
||||||
|
|
||||||
- if (!disable_static_deltas && !pull_data->is_mirror &&
|
|
||||||
+ if (!disable_static_deltas && !mirroring_into_archive &&
|
|
||||||
(from_revision == NULL || g_strcmp0 (from_revision, to_revision) != 0))
|
|
||||||
{
|
|
||||||
if (!request_static_delta_superblock_sync (pull_data, from_revision, to_revision,
|
|
||||||
--
|
|
||||||
2.7.4
|
|
||||||
|
|
11
ostree.spec
11
ostree.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: Tool for managing bootable, immutable filesystem trees
|
Summary: Tool for managing bootable, immutable filesystem trees
|
||||||
Name: ostree
|
Name: ostree
|
||||||
Version: 2016.10
|
Version: 2016.11
|
||||||
Release: 8%{?dist}
|
Release: 1%{?dist}
|
||||||
#VCS: git:git://git.gnome.org/ostree
|
#VCS: git:git://git.gnome.org/ostree
|
||||||
Source0: https://github.com/ostreedev/%{name}/releases/download/v%{version}/%{name}-%{version}.tar.xz
|
Source0: https://github.com/ostreedev/%{name}/releases/download/v%{version}/%{name}-%{version}.tar.xz
|
||||||
Source1: 91-ostree.preset
|
Source1: 91-ostree.preset
|
||||||
@ -9,11 +9,7 @@ License: LGPLv2+
|
|||||||
URL: http://live.gnome.org/OSTree
|
URL: http://live.gnome.org/OSTree
|
||||||
|
|
||||||
# Backported from upstream
|
# Backported from upstream
|
||||||
Patch0: 0001-pull-Do-allow-executing-deltas-when-mirroring-into-b.patch
|
|
||||||
|
|
||||||
Patch2: 0001-ostree-remount-Explicitly-set-tmp-to-01777.patch
|
Patch2: 0001-ostree-remount-Explicitly-set-tmp-to-01777.patch
|
||||||
Patch3: 0001-boot-Ensure-we-remount-var-writable-before-systemd-d.patch
|
|
||||||
Patch4: 0001-ostree_sysroot_init_osname-also-create-var-log.patch
|
|
||||||
|
|
||||||
BuildRequires: git
|
BuildRequires: git
|
||||||
# We always run autogen.sh
|
# We always run autogen.sh
|
||||||
@ -130,6 +126,9 @@ install -D -m 0644 %{SOURCE1} $RPM_BUILD_ROOT/%{_prefix}/lib/systemd/system-pres
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Oct 07 2016 walters@redhat.com - 2016.11-1
|
||||||
|
- New upstream version
|
||||||
|
|
||||||
* Tue Sep 20 2016 walters@redhat.com - 2016.10-8
|
* Tue Sep 20 2016 walters@redhat.com - 2016.10-8
|
||||||
- Backport another patch for systemd journal
|
- Backport another patch for systemd journal
|
||||||
Resolves: #1265295
|
Resolves: #1265295
|
||||||
|
Loading…
Reference in New Issue
Block a user