This commit is contained in:
parent
fa1bf93c89
commit
c99d7c2cbb
1
.gitignore
vendored
1
.gitignore
vendored
@ -73,3 +73,4 @@
|
||||
/libostree-2019.2.tar.xz
|
||||
/libostree-2019.3.tar.xz
|
||||
/libostree-2019.4.tar.xz
|
||||
/libostree-2019.5.tar.xz
|
||||
|
@ -1,38 +0,0 @@
|
||||
From a6476156735990ddf6e4d8cb9a12be4c0295eeca Mon Sep 17 00:00:00 2001
|
||||
From: Jonathan Lebon <jonathan@jlebon.com>
|
||||
Date: Mon, 7 Oct 2019 10:34:21 -0400
|
||||
Subject: [PATCH] Revert "grub2: Exit gracefully if the configuration has BLS
|
||||
enabled"
|
||||
|
||||
This reverts commit 985a14100295c99d0c6d712bfbee0ec52a3a1601.
|
||||
|
||||
Reverting for now due to some users experiencing no boot entries after
|
||||
upgrading. See for background:
|
||||
|
||||
https://github.com/ostreedev/ostree/pull/1929
|
||||
https://discussion.fedoraproject.org/t/boot-entries-gone-after-upgrade/8026
|
||||
---
|
||||
src/boot/grub2/grub2-15_ostree | 7 -------
|
||||
1 file changed, 7 deletions(-)
|
||||
|
||||
diff --git a/src/boot/grub2/grub2-15_ostree b/src/boot/grub2/grub2-15_ostree
|
||||
index 160ac2ca..0b9bf930 100644
|
||||
--- a/src/boot/grub2/grub2-15_ostree
|
||||
+++ b/src/boot/grub2/grub2-15_ostree
|
||||
@@ -26,13 +26,6 @@ if ! test -d /ostree/repo; then
|
||||
exit 0
|
||||
fi
|
||||
|
||||
-# Gracefully exit if the grub2 configuration has BLS enabled,
|
||||
-# since there is no need to create menu entries in that case.
|
||||
-. /etc/default/grub
|
||||
-if test ${GRUB_ENABLE_BLSCFG} = "true"; then
|
||||
- exit 0
|
||||
-fi
|
||||
-
|
||||
# Make sure we're in the right environment
|
||||
if ! test -n "${GRUB_DEVICE}"; then
|
||||
echo "This script must be run as a child of grub2-mkconfig" 1>&2
|
||||
--
|
||||
2.21.0
|
||||
|
@ -1,56 +0,0 @@
|
||||
From 985a14100295c99d0c6d712bfbee0ec52a3a1601 Mon Sep 17 00:00:00 2001
|
||||
From: Javier Martinez Canillas <javierm@redhat.com>
|
||||
Date: Thu, 26 Sep 2019 17:33:57 +0200
|
||||
Subject: [PATCH] grub2: Exit gracefully if the configuration has BLS enabled
|
||||
|
||||
Since Fedora 30 grub2 has support to populate its menu entries from the
|
||||
BootLoaderSpec fragments in /boot/loader/entries, so there's no need to
|
||||
generate menu entries anymore using the /etc/grub.d/15_ostree script.
|
||||
|
||||
But since ostree doesn't update the bootloader, it may be that the grub2
|
||||
installed is an old one that doesn't have BLS support.
|
||||
|
||||
For new installs, GRUB_ENABLE_BLSCFG=true is set in /etc/default/grub to
|
||||
tell the /etc/grub.d/10_linux script if a blscfg command has to be added
|
||||
to the generated grub2 config file.
|
||||
|
||||
So check if BLS is enabled in /etc/default/grub and only add the entries
|
||||
if that's not the case. Otherwise the menu entries will be duplicated.
|
||||
|
||||
The approach has the drawback that if a user sets GRUB_ENABLE_BLSCFG=true
|
||||
in /etc/default/grub without updating grub2, they will get an empty menu.
|
||||
Since there won't be any entries created by the 30_ostree script and the
|
||||
blscfg command won't work on the older grub2.
|
||||
|
||||
Unfortunately there is no way to know if the installed grub2 already has
|
||||
BLS support or not.
|
||||
|
||||
Related: https://bugzilla.redhat.com/show_bug.cgi?id=1751272#c27
|
||||
|
||||
Closes: #1929
|
||||
Approved by: jlebon
|
||||
---
|
||||
src/boot/grub2/grub2-15_ostree | 7 +++++++
|
||||
1 file changed, 7 insertions(+)
|
||||
|
||||
diff --git a/src/boot/grub2/grub2-15_ostree b/src/boot/grub2/grub2-15_ostree
|
||||
index 0b9bf930..160ac2ca 100644
|
||||
--- a/src/boot/grub2/grub2-15_ostree
|
||||
+++ b/src/boot/grub2/grub2-15_ostree
|
||||
@@ -26,6 +26,13 @@ if ! test -d /ostree/repo; then
|
||||
exit 0
|
||||
fi
|
||||
|
||||
+# Gracefully exit if the grub2 configuration has BLS enabled,
|
||||
+# since there is no need to create menu entries in that case.
|
||||
+. /etc/default/grub
|
||||
+if test ${GRUB_ENABLE_BLSCFG} = "true"; then
|
||||
+ exit 0
|
||||
+fi
|
||||
+
|
||||
# Make sure we're in the right environment
|
||||
if ! test -n "${GRUB_DEVICE}"; then
|
||||
echo "This script must be run as a child of grub2-mkconfig" 1>&2
|
||||
--
|
||||
2.21.0
|
||||
|
10
ostree.spec
10
ostree.spec
@ -7,15 +7,12 @@
|
||||
|
||||
Summary: Tool for managing bootable, immutable filesystem trees
|
||||
Name: ostree
|
||||
Version: 2019.4
|
||||
Release: 3%{?dist}
|
||||
Version: 2019.5
|
||||
Release: 2%{?dist}
|
||||
Source0: https://github.com/ostreedev/%{name}/releases/download/v%{version}/libostree-%{version}.tar.xz
|
||||
License: LGPLv2+
|
||||
URL: https://ostree.readthedocs.io/en/latest/
|
||||
|
||||
Patch0: 0001-grub2-Exit-gracefully-if-the-configuration-has-BLS-e.patch
|
||||
Patch1: 0001-Revert-grub2-Exit-gracefully-if-the-configuration-ha.patch
|
||||
|
||||
BuildRequires: git
|
||||
# We always run autogen.sh
|
||||
BuildRequires: autoconf automake libtool
|
||||
@ -165,6 +162,9 @@ find %{buildroot} -name '*.la' -delete
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Oct 30 2019 Colin Walters <walters@verbum.org> - 2019.5-2
|
||||
- https://github.com/ostreedev/ostree/releases/tag/v2019.5
|
||||
|
||||
* Thu Sep 26 2019 Jonathan Lebon <jonathan@jlebon.com> - 2019.4-2
|
||||
- Revert ostree-grub2 patch to fix duplicate entries
|
||||
https://github.com/ostreedev/ostree/pull/1929#issuecomment-539022174
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (libostree-2019.4.tar.xz) = 68184206ff6715526f772a607514aaee90236f53b6aee5034000f2728f852cfda1331287e26fc536122e30097999f57bfd3ddb7451564f18570f94259f5066ed
|
||||
SHA512 (libostree-2019.5.tar.xz) = 27150802ed9af16e698ed163f6ad235f0f99a1410df52b4b1e266585fe665880c0b9490bf245b5593cb277007b7229d808be7403dd964c58aded6e567349c912
|
||||
|
Loading…
Reference in New Issue
Block a user