Close sysroot fd in finalize to fix Anaconda
https://bugzilla.redhat.com/show_bug.cgi?id=1217578
This commit is contained in:
parent
2204ef1383
commit
b482182fce
27
0001-sysroot-Close-sysroot-fd-in-finalize.patch
Normal file
27
0001-sysroot-Close-sysroot-fd-in-finalize.patch
Normal file
@ -0,0 +1,27 @@
|
||||
From f08cb802ea1b02c874fd71a0672c28b49e890d49 Mon Sep 17 00:00:00 2001
|
||||
From: Colin Walters <walters@verbum.org>
|
||||
Date: Sun, 19 Apr 2015 15:25:05 -0400
|
||||
Subject: [PATCH] sysroot: Close sysroot fd in finalize
|
||||
|
||||
Just noticed this while I was going to add another one there.
|
||||
---
|
||||
src/libostree/ostree-sysroot.c | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/src/libostree/ostree-sysroot.c b/src/libostree/ostree-sysroot.c
|
||||
index b18c6b7..6255803 100644
|
||||
--- a/src/libostree/ostree-sysroot.c
|
||||
+++ b/src/libostree/ostree-sysroot.c
|
||||
@@ -66,6 +66,9 @@ ostree_sysroot_finalize (GObject *object)
|
||||
g_clear_object (&self->sepolicy);
|
||||
g_clear_object (&self->repo);
|
||||
|
||||
+ if (self->sysroot_fd != -1)
|
||||
+ (void) close (self->sysroot_fd);
|
||||
+
|
||||
G_OBJECT_CLASS (ostree_sysroot_parent_class)->finalize (object);
|
||||
}
|
||||
|
||||
--
|
||||
1.8.3.1
|
||||
|
10
ostree.spec
10
ostree.spec
@ -1,13 +1,15 @@
|
||||
Summary: Tool for managing bootable, immutable filesystem trees
|
||||
Name: ostree
|
||||
Version: 2015.6
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
#VCS: git:git://git.gnome.org/ostree
|
||||
Source0: http://ftp.gnome.org/pub/GNOME/sources/ostree/%{version}/ostree-%{version}.tar.xz
|
||||
Source1: 91-ostree.preset
|
||||
Patch0: 0001-sysroot-Close-sysroot-fd-in-finalize.patch
|
||||
License: LGPLv2+
|
||||
URL: http://live.gnome.org/OSTree
|
||||
|
||||
BuildRequires: git
|
||||
# We always run autogen.sh
|
||||
BuildRequires: autoconf automake libtool
|
||||
# For docs
|
||||
@ -60,7 +62,7 @@ GRUB2 integration for OSTree
|
||||
%endif
|
||||
|
||||
%prep
|
||||
%setup -q -n ostree-%{version}
|
||||
%autosetup -Sgit -n ostree-%{version}
|
||||
|
||||
%build
|
||||
env NOCONFIGURE=1 ./autogen.sh
|
||||
@ -117,6 +119,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Apr 30 2015 Colin Walters <walters@redhat.com> - 2015.6-3
|
||||
- Close sysroot fd in finalize to fix Anaconda
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=1217578
|
||||
|
||||
* Fri Apr 17 2015 Colin Walters <walters@redhat.com> - 2015.6-2
|
||||
- New upstream release
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user