Release 2019.2
This commit is contained in:
parent
70f390c04a
commit
aa46a7f5c0
1
.gitignore
vendored
1
.gitignore
vendored
@ -70,3 +70,4 @@
|
||||
/libostree-2018.8.tar.xz
|
||||
/libostree-2018.9.tar.xz
|
||||
/libostree-2019.1.tar.xz
|
||||
/libostree-2019.2.tar.xz
|
||||
|
@ -1,38 +0,0 @@
|
||||
From c79d792fd583e92750bdaabcbc9275866bda9976 Mon Sep 17 00:00:00 2001
|
||||
From: Colin Walters <walters@verbum.org>
|
||||
Date: Wed, 16 Jan 2019 08:30:53 -0500
|
||||
Subject: [PATCH 1/2] =?UTF-8?q?lib/commit:=20Fix=20bare=20=E2=86=92=20bare?=
|
||||
=?UTF-8?q?=20imports?=
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Regression from https://github.com/ostreedev/ostree/pull/1771
|
||||
|
||||
This broke rpmostreepayload in Anaconda where we import a bare repo:
|
||||
https://openqa.fedoraproject.org/tests/345339#step/_do_install_and_reboot/4
|
||||
|
||||
Reported-by: Adam Williamson <adamwill@fedoraproject.org>
|
||||
|
||||
Closes: #1803
|
||||
Approved by: jlebon
|
||||
---
|
||||
src/libostree/ostree-repo-commit.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/libostree/ostree-repo-commit.c b/src/libostree/ostree-repo-commit.c
|
||||
index 533cf03a..c95e0b61 100644
|
||||
--- a/src/libostree/ostree-repo-commit.c
|
||||
+++ b/src/libostree/ostree-repo-commit.c
|
||||
@@ -4269,7 +4269,7 @@ import_one_object_direct (OstreeRepo *dest_repo,
|
||||
G_IN_SET (src_repo->mode, OSTREE_REPO_MODE_BARE, OSTREE_REPO_MODE_BARE_USER);
|
||||
if (src_is_bare_or_bare_user && !OSTREE_OBJECT_TYPE_IS_META(objtype))
|
||||
{
|
||||
- if (src_repo == OSTREE_REPO_MODE_BARE)
|
||||
+ if (src_repo->mode == OSTREE_REPO_MODE_BARE)
|
||||
{
|
||||
g_autoptr(GVariant) xattrs = NULL;
|
||||
if (!glnx_fd_get_all_xattrs (src_fd, &xattrs,
|
||||
--
|
||||
2.20.1
|
||||
|
@ -1,41 +0,0 @@
|
||||
From 2ccf36ae3ded1da48dd659d46a4ccabdee0e0775 Mon Sep 17 00:00:00 2001
|
||||
From: Colin Walters <walters@verbum.org>
|
||||
Date: Fri, 4 Jan 2019 15:44:56 +0000
|
||||
Subject: [PATCH] sysroot: Remove immutable bit from /etc/sysconfig/nfs
|
||||
|
||||
Work around for https://src.fedoraproject.org/rpms/nfs-utils/pull-request/7
|
||||
Currently Fedora-only.
|
||||
---
|
||||
src/libostree/ostree-sysroot-cleanup.c | 16 ++++++++++++++++
|
||||
1 file changed, 16 insertions(+)
|
||||
|
||||
diff --git a/src/libostree/ostree-sysroot-cleanup.c b/src/libostree/ostree-sysroot-cleanup.c
|
||||
index 7a352e6b..b8ec9970 100644
|
||||
--- a/src/libostree/ostree-sysroot-cleanup.c
|
||||
+++ b/src/libostree/ostree-sysroot-cleanup.c
|
||||
@@ -271,6 +271,22 @@ _ostree_sysroot_rmrf_deployment (OstreeSysroot *self,
|
||||
return FALSE;
|
||||
if (!glnx_shutil_rm_rf_at (self->sysroot_fd, origin_relpath, cancellable, error))
|
||||
return FALSE;
|
||||
+
|
||||
+ /* Special hack for Fedora's NFS package which is abusing the immutable bit
|
||||
+ * https://src.fedoraproject.org/rpms/nfs-utils/pull-request/7
|
||||
+ */
|
||||
+ {
|
||||
+ glnx_autofd int nfs_sysconfig_fd = -1;
|
||||
+ if (!ot_openat_ignore_enoent (deployment_fd, "etc/sysconfig/nfs", &nfs_sysconfig_fd, error))
|
||||
+ return FALSE;
|
||||
+ if (nfs_sysconfig_fd != -1)
|
||||
+ {
|
||||
+ if (!_ostree_linuxfs_fd_alter_immutable_flag (nfs_sysconfig_fd, FALSE,
|
||||
+ cancellable, error))
|
||||
+ return FALSE;
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
if (!glnx_shutil_rm_rf_at (self->sysroot_fd, deployment_path, cancellable, error))
|
||||
return FALSE;
|
||||
|
||||
--
|
||||
2.19.2
|
||||
|
@ -1,33 +0,0 @@
|
||||
From c63ee3cef4fc77f995999035bcc57833653a94b0 Mon Sep 17 00:00:00 2001
|
||||
From: Colin Walters <walters@verbum.org>
|
||||
Date: Wed, 16 Jan 2019 08:36:55 -0500
|
||||
Subject: [PATCH 2/2] =?UTF-8?q?lib/commit:=20Set=20xattr=20on=20correct=20?=
|
||||
=?UTF-8?q?fd=20for=20bare-user=20=E2=86=92=20bare-user=20imports?=
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Another fix to https://github.com/ostreedev/ostree/pull/1771
|
||||
|
||||
Closes: #1803
|
||||
Approved by: jlebon
|
||||
---
|
||||
src/libostree/ostree-repo-commit.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/libostree/ostree-repo-commit.c b/src/libostree/ostree-repo-commit.c
|
||||
index c95e0b61..dfdd4853 100644
|
||||
--- a/src/libostree/ostree-repo-commit.c
|
||||
+++ b/src/libostree/ostree-repo-commit.c
|
||||
@@ -4287,7 +4287,7 @@ import_one_object_direct (OstreeRepo *dest_repo,
|
||||
if (bytes == NULL)
|
||||
return FALSE;
|
||||
|
||||
- if (TEMP_FAILURE_RETRY (fsetxattr (src_fd, "user.ostreemeta",
|
||||
+ if (TEMP_FAILURE_RETRY (fsetxattr (tmp_dest.fd, "user.ostreemeta",
|
||||
(char*)g_bytes_get_data (bytes, NULL),
|
||||
g_bytes_get_size (bytes), 0)) != 0)
|
||||
return glnx_throw_errno_prefix (error, "fsetxattr");
|
||||
--
|
||||
2.20.1
|
||||
|
12
ostree.spec
12
ostree.spec
@ -7,17 +7,12 @@
|
||||
|
||||
Summary: Tool for managing bootable, immutable filesystem trees
|
||||
Name: ostree
|
||||
Version: 2019.1
|
||||
Release: 5%{?dist}
|
||||
Version: 2019.2
|
||||
Release: 1%{?dist}
|
||||
Source0: https://github.com/ostreedev/%{name}/releases/download/v%{version}/libostree-%{version}.tar.xz
|
||||
License: LGPLv2+
|
||||
URL: https://ostree.readthedocs.io/en/latest/
|
||||
|
||||
# Work around https://src.fedoraproject.org/rpms/nfs-utils/pull-request/7
|
||||
Patch0: 0001-sysroot-Remove-immutable-bit-from-etc-sysconfig-nfs.patch
|
||||
Patch1: 0001-lib-commit-Fix-bare-bare-imports.patch
|
||||
Patch2: 0002-lib-commit-Set-xattr-on-correct-fd-for-bare-user-bar.patch
|
||||
|
||||
BuildRequires: git
|
||||
# We always run autogen.sh
|
||||
BuildRequires: autoconf automake libtool
|
||||
@ -167,6 +162,9 @@ find %{buildroot} -name '*.la' -delete
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Apr 24 2019 Jonathan Lebon <jonathan@jlebon.com> - 2019.2-1
|
||||
- https://github.com/ostreedev/ostree/releases/tag/v2019.2
|
||||
|
||||
* Sat Feb 09 2019 Dusty Mabe <dusty@dustymabe.com> - 2019.1-5
|
||||
- Re-enable http2 in ostree build
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (libostree-2019.1.tar.xz) = 71edc8175f05cc65baeb2973a951b3ac11d2557c2fd1a3faf2671057519e079b2ad49caca5d940935ad67674f192969325c898b60bd4d77035268c067d3f3c78
|
||||
SHA512 (libostree-2019.2.tar.xz) = ef009a510cc1b5e89b2be6347858151fa15d3ee7e2005d2c34fdfa3c1d6c48e5f9d171b94b1d2e40812c270c1d5710faae9aca893580b98fff8843deace486dc
|
||||
|
Loading…
Reference in New Issue
Block a user