Auto sync2gitlab import of osbuild-73-1.el8.src.rpm
This commit is contained in:
parent
5088304b42
commit
f7be9662a9
28
0001-test-fscache-drop-PathLike-annotation.patch
Normal file
28
0001-test-fscache-drop-PathLike-annotation.patch
Normal file
@ -0,0 +1,28 @@
|
|||||||
|
From 8511add1695c49cc7f3df2220044a4eed17ba1a5 Mon Sep 17 00:00:00 2001
|
||||||
|
From: David Rheinsberg <david.rheinsberg@gmail.com>
|
||||||
|
Date: Wed, 7 Dec 2022 13:44:57 +0100
|
||||||
|
Subject: [PATCH] test/fscache: drop PathLike annotation
|
||||||
|
|
||||||
|
Drop the PathLike annotation, since it is not compatible to py-3.6.
|
||||||
|
|
||||||
|
Signed-off-by: David Rheinsberg <david.rheinsberg@gmail.com>
|
||||||
|
---
|
||||||
|
test/mod/test_util_fscache.py | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/test/mod/test_util_fscache.py b/test/mod/test_util_fscache.py
|
||||||
|
index 4a3141b..1125abd 100644
|
||||||
|
--- a/test/mod/test_util_fscache.py
|
||||||
|
+++ b/test/mod/test_util_fscache.py
|
||||||
|
@@ -39,7 +39,7 @@ def test_calculate_size(tmpdir):
|
||||||
|
assert fscache.FsCache._calculate_size(os.path.join(tmpdir, "dir")) == 6
|
||||||
|
|
||||||
|
|
||||||
|
-def test_pathlike(tmpdir: os.PathLike[str]):
|
||||||
|
+def test_pathlike(tmpdir):
|
||||||
|
#
|
||||||
|
# Verify behavior of `__fspath__()`.
|
||||||
|
#
|
||||||
|
--
|
||||||
|
2.38.1
|
||||||
|
|
10
osbuild.spec
10
osbuild.spec
@ -1,7 +1,7 @@
|
|||||||
%global forgeurl https://github.com/osbuild/osbuild
|
%global forgeurl https://github.com/osbuild/osbuild
|
||||||
%global selinuxtype targeted
|
%global selinuxtype targeted
|
||||||
|
|
||||||
Version: 72
|
Version: 73
|
||||||
|
|
||||||
%forgemeta
|
%forgemeta
|
||||||
|
|
||||||
@ -18,6 +18,9 @@ Source0: %{forgesource}
|
|||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
Summary: A build system for OS images
|
Summary: A build system for OS images
|
||||||
|
|
||||||
|
# https://github.com/osbuild/osbuild/pull/1196
|
||||||
|
Patch0: 0001-test-fscache-drop-PathLike-annotation.patch
|
||||||
|
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
BuildRequires: python3-devel
|
BuildRequires: python3-devel
|
||||||
BuildRequires: python3-docutils
|
BuildRequires: python3-docutils
|
||||||
@ -120,7 +123,7 @@ Contains additional tools and utilities for development of
|
|||||||
manifests and osbuild.
|
manifests and osbuild.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%forgesetup
|
%forgeautosetup -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%py3_build
|
%py3_build
|
||||||
@ -251,6 +254,9 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Dec 07 2022 imagebuilder-bot <imagebuilder-bots+imagebuilder-bot@redhat.com> - 73-1
|
||||||
|
- New upstream release
|
||||||
|
|
||||||
* Wed Nov 23 2022 imagebuilder-bot <imagebuilder-bots+imagebuilder-bot@redhat.com> - 72-1
|
* Wed Nov 23 2022 imagebuilder-bot <imagebuilder-bots+imagebuilder-bot@redhat.com> - 72-1
|
||||||
- New upstream release
|
- New upstream release
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user