Update to 29
This commit also: - backports the devices and mounts patch from upstream 50971fbe - copies gating from RHEL 8 - RHEL 9 manifest is used instead of RHEL 8 Resolves: rhbz#1972429
This commit is contained in:
parent
0768e9282d
commit
9cfe887f2c
1
.gitignore
vendored
1
.gitignore
vendored
@ -25,3 +25,4 @@
|
|||||||
/osbuild-25.tar.gz
|
/osbuild-25.tar.gz
|
||||||
/osbuild-26.tar.gz
|
/osbuild-26.tar.gz
|
||||||
/osbuild-27.tar.gz
|
/osbuild-27.tar.gz
|
||||||
|
/osbuild-29.tar.gz
|
||||||
|
@ -1,23 +0,0 @@
|
|||||||
From 337e0f05ea55f7b2ee107fbc1e989d82d1815193 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Christian Kellner <christian@kellner.me>
|
|
||||||
Date: Wed, 17 Mar 2021 11:03:22 +0100
|
|
||||||
Subject: [PATCH] runners: add Fedora 35 runner
|
|
||||||
|
|
||||||
New `org.osbuild.fedora35` which is re-using the f30 runner.
|
|
||||||
Needed since Fedora 35 branched in early February.
|
|
||||||
---
|
|
||||||
runners/org.osbuild.fedora35 | 1 +
|
|
||||||
1 file changed, 1 insertion(+)
|
|
||||||
create mode 120000 runners/org.osbuild.fedora35
|
|
||||||
|
|
||||||
diff --git a/runners/org.osbuild.fedora35 b/runners/org.osbuild.fedora35
|
|
||||||
new file mode 120000
|
|
||||||
index 0000000..d46777b
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/runners/org.osbuild.fedora35
|
|
||||||
@@ -0,0 +1 @@
|
|
||||||
+org.osbuild.fedora30
|
|
||||||
\ No newline at end of file
|
|
||||||
--
|
|
||||||
2.29.2
|
|
||||||
|
|
@ -10,3 +10,10 @@ product_versions:
|
|||||||
decision_context: bodhi_update_push_stable
|
decision_context: bodhi_update_push_stable
|
||||||
rules:
|
rules:
|
||||||
- !PassingTestCaseRule {test_case_name: fedora-ci.koji-build.tier0.functional}
|
- !PassingTestCaseRule {test_case_name: fedora-ci.koji-build.tier0.functional}
|
||||||
|
--- !Policy
|
||||||
|
product_versions:
|
||||||
|
- rhel-8
|
||||||
|
- rhel-9
|
||||||
|
decision_context: osci_compose_gate
|
||||||
|
rules:
|
||||||
|
- !PassingTestCaseRule {test_case_name: osci.brew-build.tier0.functional}
|
||||||
|
33
osbuild.spec
33
osbuild.spec
@ -1,7 +1,7 @@
|
|||||||
%global forgeurl https://github.com/osbuild/osbuild
|
%global forgeurl https://github.com/osbuild/osbuild
|
||||||
%global selinuxtype targeted
|
%global selinuxtype targeted
|
||||||
|
|
||||||
Version: 27
|
Version: 29
|
||||||
|
|
||||||
%forgemeta
|
%forgemeta
|
||||||
|
|
||||||
@ -9,14 +9,12 @@ Version: 27
|
|||||||
%global pkgdir %{_prefix}/lib/%{pypi_name}
|
%global pkgdir %{_prefix}/lib/%{pypi_name}
|
||||||
|
|
||||||
Name: %{pypi_name}
|
Name: %{pypi_name}
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
License: ASL 2.0
|
License: ASL 2.0
|
||||||
|
|
||||||
URL: %{forgeurl}
|
URL: %{forgeurl}
|
||||||
|
|
||||||
Source0: %{forgesource}
|
Source0: %{forgesource}
|
||||||
# Fedora 35 runner, upstream commit 337e0f0
|
|
||||||
Patch0: Fedora-35-runner.patch
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
Summary: A build system for OS images
|
Summary: A build system for OS images
|
||||||
|
|
||||||
@ -94,7 +92,6 @@ containers it uses to build OS artifacts.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%forgesetup
|
%forgesetup
|
||||||
%patch0 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%py3_build
|
%py3_build
|
||||||
@ -122,9 +119,15 @@ install -p -m 0755 $(find runners -type f -or -type l) %{buildroot}%{pkgdir}/run
|
|||||||
mkdir -p %{buildroot}%{pkgdir}/sources
|
mkdir -p %{buildroot}%{pkgdir}/sources
|
||||||
install -p -m 0755 $(find sources -type f) %{buildroot}%{pkgdir}/sources
|
install -p -m 0755 $(find sources -type f) %{buildroot}%{pkgdir}/sources
|
||||||
|
|
||||||
|
mkdir -p %{buildroot}%{pkgdir}/devices
|
||||||
|
install -p -m 0755 $(find devices -type f) %{buildroot}%{pkgdir}/devices
|
||||||
|
|
||||||
mkdir -p %{buildroot}%{pkgdir}/inputs
|
mkdir -p %{buildroot}%{pkgdir}/inputs
|
||||||
install -p -m 0755 $(find inputs -type f) %{buildroot}%{pkgdir}/inputs
|
install -p -m 0755 $(find inputs -type f) %{buildroot}%{pkgdir}/inputs
|
||||||
|
|
||||||
|
mkdir -p %{buildroot}%{pkgdir}/mounts
|
||||||
|
install -p -m 0755 $(find mounts -type f) %{buildroot}%{pkgdir}/mounts
|
||||||
|
|
||||||
# mount point for bind mounting the osbuild library
|
# mount point for bind mounting the osbuild library
|
||||||
mkdir -p %{buildroot}%{pkgdir}/osbuild
|
mkdir -p %{buildroot}%{pkgdir}/osbuild
|
||||||
|
|
||||||
@ -156,9 +159,10 @@ exit 0
|
|||||||
%{_datadir}/osbuild/schemas
|
%{_datadir}/osbuild/schemas
|
||||||
%{pkgdir}
|
%{pkgdir}
|
||||||
# the following files are in the ostree sub-package
|
# the following files are in the ostree sub-package
|
||||||
%exclude %{pkgdir}/assemblers/org.osbuild.ostree.commit
|
%exclude %{pkgdir}/assemblers/org.osbuild.ostree*
|
||||||
%exclude %{pkgdir}/sources/org.osbuild.ostree
|
%exclude %{pkgdir}/inputs/org.osbuild.ostree*
|
||||||
%exclude %{pkgdir}/stages/org.osbuild.ostree
|
%exclude %{pkgdir}/sources/org.osbuild.ostree*
|
||||||
|
%exclude %{pkgdir}/stages/org.osbuild.ostree*
|
||||||
%exclude %{pkgdir}/stages/org.osbuild.rpm-ostree
|
%exclude %{pkgdir}/stages/org.osbuild.rpm-ostree
|
||||||
|
|
||||||
%files -n python3-%{pypi_name}
|
%files -n python3-%{pypi_name}
|
||||||
@ -168,9 +172,10 @@ exit 0
|
|||||||
%{python3_sitelib}/%{pypi_name}/
|
%{python3_sitelib}/%{pypi_name}/
|
||||||
|
|
||||||
%files ostree
|
%files ostree
|
||||||
%{pkgdir}/assemblers/org.osbuild.ostree.commit
|
%{pkgdir}/assemblers/org.osbuild.ostree*
|
||||||
%{pkgdir}/sources/org.osbuild.ostree
|
%{pkgdir}/inputs/org.osbuild.ostree*
|
||||||
%{pkgdir}/stages/org.osbuild.ostree
|
%{pkgdir}/sources/org.osbuild.ostree*
|
||||||
|
%{pkgdir}/stages/org.osbuild.ostree*
|
||||||
%{pkgdir}/stages/org.osbuild.rpm-ostree
|
%{pkgdir}/stages/org.osbuild.rpm-ostree
|
||||||
|
|
||||||
%files selinux
|
%files selinux
|
||||||
@ -189,7 +194,13 @@ fi
|
|||||||
%posttrans selinux
|
%posttrans selinux
|
||||||
%selinux_relabel_post -s %{selinuxtype}
|
%selinux_relabel_post -s %{selinuxtype}
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jun 29 2021 Ondřej Budai <ondrej@budai.cz> - 29-1
|
||||||
|
- Upstream release 29
|
||||||
|
- Adds host services
|
||||||
|
- Adds modprobe and logind stage
|
||||||
|
|
||||||
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 27-3
|
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 27-3
|
||||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (osbuild-27.tar.gz) = 43995f0747a62cce7ba87ab8d589ceba96f7c2048bf68c14388c97cf2bc0a39211a7e377fe821000bc94ac8f74a15217acd914bc3adea5f46a4b682c6d7d0039
|
SHA512 (osbuild-29.tar.gz) = a65fdc574386a28410344b7b5218f8190990170b5e9600f81304a09c3a8dc82a0be8c9f8f3516d906a776470db4c531efefc8cf280c8cd0ef8c673995fba5366
|
||||||
|
3555
tests/test-image.json
Normal file
3555
tests/test-image.json
Normal file
File diff suppressed because it is too large
Load Diff
@ -1,4 +1,3 @@
|
|||||||
---
|
|
||||||
- hosts: localhost
|
- hosts: localhost
|
||||||
roles:
|
roles:
|
||||||
- role: standard-test-source
|
- role: standard-test-source
|
||||||
@ -6,14 +5,16 @@
|
|||||||
- always
|
- always
|
||||||
- role: standard-test-basic
|
- role: standard-test-basic
|
||||||
tags:
|
tags:
|
||||||
- atomic
|
|
||||||
- classic
|
- classic
|
||||||
required_packages:
|
required_packages:
|
||||||
- osbuild
|
- git
|
||||||
|
- make
|
||||||
|
- python3-mako
|
||||||
|
- python3-pytest
|
||||||
tests:
|
tests:
|
||||||
- smoke:
|
- unit:
|
||||||
dir: smoke
|
dir: source
|
||||||
run: osbuild --help
|
run: python3 -m pytest test/mod
|
||||||
- image:
|
- image:
|
||||||
dir: .
|
dir: tests
|
||||||
run: osbuild source/test/data/manifests/fedora-boot.json --output-directory=/var/tmp/osbuild
|
run: osbuild test-image.json --output-directory=/var/tmp/osbuild
|
||||||
|
Loading…
Reference in New Issue
Block a user