Auto sync2gitlab import of osbuild-75-1.el8.src.rpm
This commit is contained in:
parent
f7be9662a9
commit
88a4fea64b
1
.gitignore
vendored
1
.gitignore
vendored
@ -12,3 +12,4 @@
|
||||
/osbuild-70.tar.gz
|
||||
/osbuild-71.tar.gz
|
||||
/osbuild-72.tar.gz
|
||||
/osbuild-75.tar.gz
|
||||
|
@ -1,28 +0,0 @@
|
||||
From 8511add1695c49cc7f3df2220044a4eed17ba1a5 Mon Sep 17 00:00:00 2001
|
||||
From: David Rheinsberg <david.rheinsberg@gmail.com>
|
||||
Date: Wed, 7 Dec 2022 13:44:57 +0100
|
||||
Subject: [PATCH] test/fscache: drop PathLike annotation
|
||||
|
||||
Drop the PathLike annotation, since it is not compatible to py-3.6.
|
||||
|
||||
Signed-off-by: David Rheinsberg <david.rheinsberg@gmail.com>
|
||||
---
|
||||
test/mod/test_util_fscache.py | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/test/mod/test_util_fscache.py b/test/mod/test_util_fscache.py
|
||||
index 4a3141b..1125abd 100644
|
||||
--- a/test/mod/test_util_fscache.py
|
||||
+++ b/test/mod/test_util_fscache.py
|
||||
@@ -39,7 +39,7 @@ def test_calculate_size(tmpdir):
|
||||
assert fscache.FsCache._calculate_size(os.path.join(tmpdir, "dir")) == 6
|
||||
|
||||
|
||||
-def test_pathlike(tmpdir: os.PathLike[str]):
|
||||
+def test_pathlike(tmpdir):
|
||||
#
|
||||
# Verify behavior of `__fspath__()`.
|
||||
#
|
||||
--
|
||||
2.38.1
|
||||
|
10
osbuild.spec
10
osbuild.spec
@ -1,7 +1,7 @@
|
||||
%global forgeurl https://github.com/osbuild/osbuild
|
||||
%global selinuxtype targeted
|
||||
|
||||
Version: 73
|
||||
Version: 75
|
||||
|
||||
%forgemeta
|
||||
|
||||
@ -18,9 +18,6 @@ Source0: %{forgesource}
|
||||
BuildArch: noarch
|
||||
Summary: A build system for OS images
|
||||
|
||||
# https://github.com/osbuild/osbuild/pull/1196
|
||||
Patch0: 0001-test-fscache-drop-PathLike-annotation.patch
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: python3-docutils
|
||||
@ -123,7 +120,7 @@ Contains additional tools and utilities for development of
|
||||
manifests and osbuild.
|
||||
|
||||
%prep
|
||||
%forgeautosetup -p1
|
||||
%forgesetup
|
||||
|
||||
%build
|
||||
%py3_build
|
||||
@ -254,6 +251,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Jan 04 2023 imagebuilder-bot <imagebuilder-bots+imagebuilder-bot@redhat.com> - 75-1
|
||||
- New upstream release
|
||||
|
||||
* Wed Dec 07 2022 imagebuilder-bot <imagebuilder-bots+imagebuilder-bot@redhat.com> - 73-1
|
||||
- New upstream release
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (osbuild-72.tar.gz) = 1742da2dac79e3629cc811e72fb7eb74ba92ac23414ef5afe5ee9f117c644d08598b7d60034bc54ebe83ee6c772eb2fa08bb39fd6f2836241188a19673ca1858
|
||||
SHA512 (osbuild-75.tar.gz) = 413665050eb1cb93fb1916c6feead94fe0b95bdbdce5f2b9281d951da935bd14c194f8c82f55bca88fda9130e6ca977b9c6a67fa3e625e88445ae31782c4badf
|
||||
|
Loading…
Reference in New Issue
Block a user