Update to 118
Resolves: RHEL-27178
This commit is contained in:
parent
d968937bee
commit
868bd84f6d
1
.gitignore
vendored
1
.gitignore
vendored
@ -96,3 +96,4 @@
|
||||
/osbuild-109.tar.gz
|
||||
/osbuild-110.tar.gz
|
||||
/osbuild-111.tar.gz
|
||||
/osbuild-118.tar.gz
|
||||
|
27
PR1539.patch
27
PR1539.patch
@ -1,27 +0,0 @@
|
||||
From 01446c54110e929d5b1a315003cdcce5032a7427 Mon Sep 17 00:00:00 2001
|
||||
From: Michael Vogt <michael.vogt@gmail.com>
|
||||
Date: Wed, 17 Jan 2024 08:45:19 +0100
|
||||
Subject: [PATCH] test: export schemas in testing_libdir_fixture
|
||||
|
||||
When constructing a minimal environment for osbuild the exported
|
||||
dirs lacked "schemas" so the test_exports.py test failed on RHEL8.
|
||||
|
||||
This commit adds it (and also "assemblers" for good measure). With
|
||||
that the test will pass.
|
||||
---
|
||||
test/run/test_exports.py | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/test/run/test_exports.py b/test/run/test_exports.py
|
||||
index 12b4cfe73..d89096494 100644
|
||||
--- a/test/run/test_exports.py
|
||||
+++ b/test/run/test_exports.py
|
||||
@@ -58,7 +58,7 @@ def testing_libdir_fixture(tmpdir_factory):
|
||||
# in buildroot.py
|
||||
(fake_libdir_path / "osbuild").mkdir()
|
||||
# construct minimal viable libdir from current checkout
|
||||
- for d in ["stages", "runners", ]:
|
||||
+ for d in ["stages", "runners", "schemas", "assemblers"]:
|
||||
subprocess.run(
|
||||
["cp", "-a", os.fspath(project_path / d), f"{fake_libdir_path}"],
|
||||
check=True)
|
24
PR1540.patch
24
PR1540.patch
@ -1,24 +0,0 @@
|
||||
From 49d9cc5897ec2b47ee5ef3254e5d93c7aecb3a52 Mon Sep 17 00:00:00 2001
|
||||
From: Michael Vogt <michael.vogt@gmail.com>
|
||||
Date: Wed, 17 Jan 2024 09:05:13 +0100
|
||||
Subject: [PATCH] test: check that `mkfs.fat` has the `-g` option in `test_fat`
|
||||
|
||||
Older versions of RHEL/Centos do not have `mkfs.fat -g` yet so
|
||||
this test will fail. Detect this and skip the test if mkfs.fat
|
||||
is too old (see 7af2f1a for the original commit).
|
||||
---
|
||||
test/run/test_stages.py | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/test/run/test_stages.py b/test/run/test_stages.py
|
||||
index bc6d8b31c..f6156369d 100644
|
||||
--- a/test/run/test_stages.py
|
||||
+++ b/test/run/test_stages.py
|
||||
@@ -573,6 +573,7 @@ def test_btrfs(self):
|
||||
assert "path home" in subvols[1]
|
||||
|
||||
@unittest.skipUnless(test.TestBase.has_filesystem_support("fat"), "FAT needed")
|
||||
+ @unittest.skipUnless("-g GEOM" in subprocess.getoutput("mkfs.fat"), "mkfs.fat -g GEOM missing")
|
||||
def test_fat(self):
|
||||
def _get_file_fields(image: str) -> List[str]:
|
||||
r = subprocess.run(
|
43
PR1541.patch
43
PR1541.patch
@ -1,43 +0,0 @@
|
||||
From 78fc821803ce62d7f2846cb7c581d68c2be74c73 Mon Sep 17 00:00:00 2001
|
||||
From: Michael Vogt <michael.vogt@gmail.com>
|
||||
Date: Wed, 17 Jan 2024 09:29:26 +0100
|
||||
Subject: [PATCH] test: fix `test_libc_futimes_works`
|
||||
|
||||
The test_libc_futimes_works() is failing under RHEL/Centos right
|
||||
now. To make it more robust a tiny sleep and rounding of the
|
||||
timestamps is introduced to ensure that we are not run into
|
||||
floating point comaparison funnines.
|
||||
|
||||
The second part of the fix is to open the stamp_file in read-only
|
||||
mode to ensure that the mtime is not modified by the open itself
|
||||
which is what lead to the actual test failure.
|
||||
---
|
||||
test/mod/test_util_linux.py | 6 ++++--
|
||||
1 file changed, 4 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/test/mod/test_util_linux.py b/test/mod/test_util_linux.py
|
||||
index be31723d3..518a4bfa2 100644
|
||||
--- a/test/mod/test_util_linux.py
|
||||
+++ b/test/mod/test_util_linux.py
|
||||
@@ -6,6 +6,7 @@
|
||||
import os
|
||||
import subprocess
|
||||
import tempfile
|
||||
+import time
|
||||
|
||||
import pytest
|
||||
|
||||
@@ -255,10 +256,11 @@ def test_libc_futimes_works(tmpdir):
|
||||
with open(stamp_file, "wb") as fp:
|
||||
fp.write(b"meep")
|
||||
mtime1 = os.stat(stamp_file).st_mtime
|
||||
- with open(stamp_file, "wb") as fp:
|
||||
+ time.sleep(0.1)
|
||||
+ with open(stamp_file, "rb") as fp:
|
||||
libc.futimens(fp.fileno(), ctypes.byref(linux.c_timespec_times2(
|
||||
atime=linux.c_timespec(tv_sec=3, tv_nsec=300 * 1000 * 1000),
|
||||
mtime=linux.c_timespec(tv_sec=0, tv_nsec=libc.UTIME_OMIT),
|
||||
)))
|
||||
assert os.stat(stamp_file).st_atime == 3.3
|
||||
- assert os.stat(stamp_file).st_mtime == mtime1
|
||||
+ assert round(os.stat(stamp_file).st_mtime, 3) == round(mtime1, 3)
|
15
osbuild.spec
15
osbuild.spec
@ -1,7 +1,7 @@
|
||||
%global forgeurl https://github.com/osbuild/osbuild
|
||||
%global selinuxtype targeted
|
||||
|
||||
Version: 111
|
||||
Version: 118
|
||||
|
||||
%forgemeta
|
||||
|
||||
@ -137,12 +137,7 @@ manifests and osbuild.
|
||||
Summary: Dependency solving support for DNF
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
# Fedora 40 and later use libdnf5, RHEL and Fedora < 40 use libdnf
|
||||
%if 0%{?fedora} >= 40
|
||||
Requires: python3-libdnf5 >= 5.1.1
|
||||
%else
|
||||
Requires: python3-libdnf
|
||||
%endif
|
||||
|
||||
%description depsolve-dnf
|
||||
Contains depsolving capabilities for package managers.
|
||||
@ -213,12 +208,7 @@ install -p -m 0755 data/10-osbuild-inhibitor.rules %{buildroot}%{_udevrulesdir}
|
||||
|
||||
# Install `osbuild-depsolve-dnf` into libexec
|
||||
mkdir -p %{buildroot}%{_libexecdir}
|
||||
# Fedora 40 and later use dnf5-json, RHEL and Fedora < 40 use dnf-json
|
||||
%if 0%{?fedora} >= 40
|
||||
install -p -m 0755 tools/osbuild-depsolve-dnf5 %{buildroot}%{_libexecdir}/osbuild-depsolve-dnf
|
||||
%else
|
||||
install -p -m 0755 tools/osbuild-depsolve-dnf %{buildroot}%{_libexecdir}/osbuild-depsolve-dnf
|
||||
%endif
|
||||
|
||||
%check
|
||||
exit 0
|
||||
@ -296,6 +286,9 @@ fi
|
||||
%{_libexecdir}/osbuild-depsolve-dnf
|
||||
|
||||
%changelog
|
||||
* Fri May 10 2024 imagebuilder-bot <imagebuilder-bots+imagebuilder-bot@redhat.com> - 118-1
|
||||
- New upstream release
|
||||
|
||||
* Wed Feb 28 2024 imagebuilder-bot <imagebuilder-bots+imagebuilder-bot@redhat.com> - 111-1
|
||||
- New upstream release
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (osbuild-111.tar.gz) = 946ac8140b88dec35f7e73f3703cea5357b50b535a770cabff4fc56efc81922559bca5b4467cfa45218ff36070db9a8a5fd1c28365413d750c333dc898f62bea
|
||||
SHA512 (osbuild-118.tar.gz) = 8004fead5783fe7e9ed468fe4a7eaebd7df4368f83d44374eba5dbaf71d711dddfb52ba43c49f98414b679c5513a2585e0b3c5bcd686c3a856867e6a8322a20f
|
||||
|
Loading…
Reference in New Issue
Block a user