15 upstream release
Drop sources-fix-break-when-secrets-is-None.patch patch included upstream.
This commit is contained in:
parent
3c8e2caef4
commit
7d9cc21846
1
.gitignore
vendored
1
.gitignore
vendored
@ -13,3 +13,4 @@
|
|||||||
/osbuild-13.tar.gz
|
/osbuild-13.tar.gz
|
||||||
/osbuild-14.tar.gz
|
/osbuild-14.tar.gz
|
||||||
/osbuild-15.tar.gz
|
/osbuild-15.tar.gz
|
||||||
|
/osbuild-16.tar.gz
|
||||||
|
12
osbuild.spec
12
osbuild.spec
@ -1,6 +1,6 @@
|
|||||||
%global forgeurl https://github.com/osbuild/osbuild
|
%global forgeurl https://github.com/osbuild/osbuild
|
||||||
|
|
||||||
Version: 15
|
Version: 16
|
||||||
|
|
||||||
%forgemeta
|
%forgemeta
|
||||||
|
|
||||||
@ -8,14 +8,12 @@ Version: 15
|
|||||||
%global pkgdir %{_prefix}/lib/%{pypi_name}
|
%global pkgdir %{_prefix}/lib/%{pypi_name}
|
||||||
|
|
||||||
Name: %{pypi_name}
|
Name: %{pypi_name}
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
License: ASL 2.0
|
License: ASL 2.0
|
||||||
|
|
||||||
URL: %{forgeurl}
|
URL: %{forgeurl}
|
||||||
|
|
||||||
Source0: %{forgesource}
|
Source0: %{forgesource}
|
||||||
# PR416 (merged): https://github.com/osbuild/osbuild/pull/416
|
|
||||||
Patch0: sources-fix-break-when-secrets-is-None.patch
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
Summary: A build system for OS images
|
Summary: A build system for OS images
|
||||||
|
|
||||||
@ -67,7 +65,6 @@ to build OSTree based images.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%forgesetup
|
%forgesetup
|
||||||
%patch0 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%py3_build
|
%py3_build
|
||||||
@ -133,6 +130,11 @@ exit 0
|
|||||||
%{pkgdir}/stages/org.osbuild.rpm-ostree
|
%{pkgdir}/stages/org.osbuild.rpm-ostree
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jun 4 2020 Christian Kellner <ckellner@redhat.com> - 16-1
|
||||||
|
- new upstream release 15
|
||||||
|
- Drop sources-fix-break-when-secrets-is-None.patch included in
|
||||||
|
the new upstream reelase.
|
||||||
|
|
||||||
* Wed May 27 2020 Miro Hrončok <mhroncok@redhat.com> - 15-4
|
* Wed May 27 2020 Miro Hrončok <mhroncok@redhat.com> - 15-4
|
||||||
- Rebuilt for Python 3.9
|
- Rebuilt for Python 3.9
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (osbuild-15.tar.gz) = 408c1327ea4a8281c6e90c96ffef045235e739352575d28ac63dfbbb1adccfb11f8a4a9ba9ae4aa326be89a0c3aab2607610361623e45ec71dfe44d07e0af317
|
SHA512 (osbuild-16.tar.gz) = 21041af1b617ef30ae7e6e27a986d094a13bcbc3a4d52d69272f24a88c49a0d4b5f57e4d54a7dd322053d607a2c859ff7586f0392d0e1efae163a9bfe6b5c065
|
||||||
|
@ -1,28 +0,0 @@
|
|||||||
From 9cbedc049671bf2a2eb50caa2759d91acbf7c7f5 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Jacob Kozol <jacobdkozol@gmail.com>
|
|
||||||
Date: Fri, 22 May 2020 19:11:46 +0200
|
|
||||||
Subject: [PATCH] sources: fix break when secrets is None
|
|
||||||
|
|
||||||
When the urls' secrets field is not set, an error is thrown when trying
|
|
||||||
to get the name of the secrets. The secrets now have a default value of
|
|
||||||
{} when they are checked for the name.
|
|
||||||
---
|
|
||||||
sources/org.osbuild.files | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/sources/org.osbuild.files b/sources/org.osbuild.files
|
|
||||||
index 0444d59..34d5334 100755
|
|
||||||
--- a/sources/org.osbuild.files
|
|
||||||
+++ b/sources/org.osbuild.files
|
|
||||||
@@ -110,7 +110,7 @@ def main(options, checksums, cache, output):
|
|
||||||
try:
|
|
||||||
if isinstance(urls[checksum], dict):
|
|
||||||
# check if url needs rhsm secrets
|
|
||||||
- if urls[checksum].get("secrets").get("name") == "org.osbuild.rhsm":
|
|
||||||
+ if urls[checksum].get("secrets", {}).get("name") == "org.osbuild.rhsm":
|
|
||||||
# rhsm secrets only need to be retrieved once and can then be reused
|
|
||||||
if rhsm_secrets is None:
|
|
||||||
try:
|
|
||||||
--
|
|
||||||
2.26.2
|
|
||||||
|
|
Loading…
Reference in New Issue
Block a user