Update to 123
Resolves: RHEL-32133
This commit is contained in:
parent
400a008511
commit
734f364e56
1
.gitignore
vendored
1
.gitignore
vendored
@ -108,3 +108,4 @@
|
||||
/osbuild-118.tar.gz
|
||||
/osbuild-119.tar.gz
|
||||
/osbuild-122.tar.gz
|
||||
/osbuild-123.tar.gz
|
||||
|
44
PR1824.patch
Normal file
44
PR1824.patch
Normal file
@ -0,0 +1,44 @@
|
||||
From 2a69d10da676d067bf42b936114d3785fd1c37da Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Tom=C3=A1=C5=A1=20Hozza?= <thozza@redhat.com>
|
||||
Date: Thu, 25 Jul 2024 10:27:44 +0200
|
||||
Subject: [PATCH] Test: fix dnf4.mark stage test with DNF5
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
DNF5 contains a breaking change in the repoquery --qf output,
|
||||
specifically it does not include the trailing newline. This breaks the
|
||||
test case e.g. on the latest Fedora Rawhide [1].
|
||||
|
||||
As a fix, explicitly use 'dnf4' for now, until the inconsistency is
|
||||
fixed in the upstream [2].
|
||||
|
||||
[1] https://artifacts.dev.testing-farm.io/3a3a2898-0a6a-42eb-8792-660f03c35c3c/
|
||||
[2] https://github.com/rpm-software-management/dnf5/issues/709
|
||||
|
||||
Signed-off-by: Tomáš Hozza <thozza@redhat.com>
|
||||
---
|
||||
test/run/test_stages.py | 5 ++++-
|
||||
1 file changed, 4 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/test/run/test_stages.py b/test/run/test_stages.py
|
||||
index a4d78b7e..ca224f07 100644
|
||||
--- a/test/run/test_stages.py
|
||||
+++ b/test/run/test_stages.py
|
||||
@@ -537,9 +537,12 @@ class TestStages(test.TestBase):
|
||||
assert os.path.isdir(tree)
|
||||
|
||||
# we're going to verify that packages in the tree are marked according to
|
||||
+ # Explicitly use 'dnf4' for now, because 'dnf5' contains a breaking change
|
||||
+ # in the repoquery --qf output, specifically it does not add a trailing newline.
|
||||
+ # We can use plan 'dnf' again once https://github.com/rpm-software-management/dnf5/issues/709 is fixed.
|
||||
r = subprocess.run(
|
||||
[
|
||||
- "dnf",
|
||||
+ "dnf4",
|
||||
"--installroot", tree,
|
||||
"repoquery", "--installed",
|
||||
"--qf", "%{name},%{reason}"
|
||||
--
|
||||
2.45.2
|
||||
|
10
osbuild.spec
10
osbuild.spec
@ -1,7 +1,7 @@
|
||||
%global forgeurl https://github.com/osbuild/osbuild
|
||||
%global selinuxtype targeted
|
||||
|
||||
Version: 122
|
||||
Version: 123
|
||||
|
||||
%forgemeta
|
||||
|
||||
@ -9,7 +9,7 @@ Version: 122
|
||||
%global pkgdir %{_prefix}/lib/%{pypi_name}
|
||||
|
||||
Name: %{pypi_name}
|
||||
Release: 2%{?dist}
|
||||
Release: 1%{?dist}
|
||||
License: Apache-2.0
|
||||
|
||||
URL: %{forgeurl}
|
||||
@ -18,6 +18,9 @@ Source0: %{forgesource}
|
||||
BuildArch: noarch
|
||||
Summary: A build system for OS images
|
||||
|
||||
# https://github.com/osbuild/osbuild/pull/1824
|
||||
Patch0: PR1824.patch
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: python3-docutils
|
||||
@ -286,6 +289,9 @@ fi
|
||||
%{_libexecdir}/osbuild-depsolve-dnf
|
||||
|
||||
%changelog
|
||||
* Thu Jul 25 2024 imagebuilder-bot <imagebuilder-bots+imagebuilder-bot@redhat.com> - 123-1
|
||||
- New upstream release
|
||||
|
||||
* Tue Jul 23 2024 Tomáš Hozza <thozza@redhat.com> - 122-2
|
||||
- Rebuild for test fixes
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (osbuild-122.tar.gz) = f045489855cf9401876f57011ce9ac143ec47c4313b07e387b083ff655a76c8904bd85fe6286b6b973501f453d92b11024720b42eef324a74af6329e5403f0cc
|
||||
SHA512 (osbuild-123.tar.gz) = e76d93aa11370cf9ef768c1895c09c358ed2f57384b3194c9781d03c6d0053646e13138c1e3349f4ec87f0b5f419d071c008de93f552793ee7dd41248b9e7949
|
||||
|
Loading…
Reference in New Issue
Block a user