Initial import (#678442)
This commit is contained in:
parent
9c5388cc69
commit
5182318c4f
1
.gitignore
vendored
1
.gitignore
vendored
@ -0,0 +1 @@
|
||||
/os-prober_1.46.tar.gz
|
10
os-prober-newnsdirfix.patch
Normal file
10
os-prober-newnsdirfix.patch
Normal file
@ -0,0 +1,10 @@
|
||||
diff -up os-prober-1.46/common.sh.newnsmove os-prober-1.46/common.sh
|
||||
--- os-prober-1.46/common.sh.newnsmove 2011-04-10 05:30:57.000000000 +0430
|
||||
+++ os-prober-1.46/common.sh 2011-05-04 04:08:09.603020037 +0430
|
||||
@@ -1,5 +1,5 @@
|
||||
newns () {
|
||||
- [ "$OS_PROBER_NEWNS" ] || exec /usr/lib/os-prober/newns "$0" "$@"
|
||||
+ [ "$OS_PROBER_NEWNS" ] || exec /usr/lib/newns "$0" "$@"
|
||||
}
|
||||
|
||||
cleanup_tmpdir=false
|
84
os-prober.spec
Normal file
84
os-prober.spec
Normal file
@ -0,0 +1,84 @@
|
||||
Name: os-prober
|
||||
Version: 1.46
|
||||
Release: 2%{?dist}
|
||||
Summary: Probes disks on the system for installed operating systems
|
||||
|
||||
Group: System Environment/Base
|
||||
License: GPL+
|
||||
URL: http://kitenet.net/~joey/code/os-prober/
|
||||
Source0: http://ftp.de.debian.org/debian/pool/main/o/os-prober/%{name}_%{version}.tar.gz
|
||||
# move newns binary outside of os-prober subdirectory, so that debuginfo
|
||||
# can be automatically generated for it
|
||||
Patch0: os-prober-newnsdirfix.patch
|
||||
|
||||
Requires: dmraid lvm2 udev coreutils util-linux
|
||||
Requires: /bin/grep /bin/sed /sbin/modprobe
|
||||
|
||||
%description
|
||||
This package detects other OSes available on a system and outputs the results
|
||||
in a generic machine-readable format. Support for new OSes and Linux
|
||||
distributions can be added easily.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .newnsdirfix
|
||||
find -type f -exec sed -i -e 's|usr/lib|usr/libexec|g' {} \;
|
||||
|
||||
%build
|
||||
make %{?_smp_mflags} CFLAGS="%{optflags}"
|
||||
|
||||
%install
|
||||
install -m 0755 -d %{buildroot}%{_bindir}
|
||||
install -m 0755 -d %{buildroot}%{_var}/lib/%{name}
|
||||
|
||||
install -m 0755 -p os-prober linux-boot-prober %{buildroot}%{_bindir}
|
||||
install -m 0755 -Dp newns %{buildroot}%{_libexecdir}/newns
|
||||
install -m 0644 -Dp common.sh %{buildroot}%{_datadir}/%{name}/common.sh
|
||||
|
||||
%ifarch m68k
|
||||
ARCH=m68k
|
||||
%endif
|
||||
%ifarch ppc ppc64
|
||||
ARCH=powerpc
|
||||
%endif
|
||||
%ifarch sparc sparc64
|
||||
ARCH=sparc
|
||||
%endif
|
||||
%ifarch %{ix86} x86_64
|
||||
ARCH=x86
|
||||
%endif
|
||||
|
||||
for probes in os-probes os-probes/mounted os-probes/init \
|
||||
linux-boot-probes linux-boot-probes/mounted; do
|
||||
install -m 755 -d %{buildroot}%{_libexecdir}/$probes
|
||||
cp -a $probes/common/* %{buildroot}%{_libexecdir}/$probes
|
||||
if [ -e "$probes/$ARCH" ]; then
|
||||
cp -a $probes/$ARCH/* %{buildroot}%{_libexecdir}/$probes
|
||||
fi
|
||||
done
|
||||
if [ "$ARCH" = x86 ]; then
|
||||
install -m 755 -p os-probes/mounted/powerpc/20macosx \
|
||||
%{buildroot}%{_libexecdir}/os-probes/mounted
|
||||
fi
|
||||
|
||||
%files
|
||||
%doc README TODO debian/copyright debian/changelog
|
||||
%{_bindir}/*
|
||||
%{_libexecdir}/*
|
||||
%{_datadir}/%{name}
|
||||
%{_var}/lib/%{name}
|
||||
|
||||
%changelog
|
||||
* Wed May 04 2011 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.46-2
|
||||
- Removed obsolete parts (build tag, defattr, etc)
|
||||
- Added a patch to move newns outside of os-prober subdirectory
|
||||
- Added required utilities as package requires
|
||||
|
||||
* Sat Apr 30 2011 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.46-1
|
||||
- Updated to 1.46 release
|
||||
|
||||
* Tue Feb 22 2011 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.42-2
|
||||
- Remove executable permission from common.sh
|
||||
|
||||
* Thu Feb 17 2011 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.42-1
|
||||
- Initial version
|
Loading…
Reference in New Issue
Block a user