Add upstream patch for selinux issue with tmp files
This commit is contained in:
parent
97ac4fc6fb
commit
d045a55808
47
orc-selinux-tmplocation.patch
Normal file
47
orc-selinux-tmplocation.patch
Normal file
@ -0,0 +1,47 @@
|
|||||||
|
From 0e31d7fc6a03faf1076dfd51b49401539c3ebed9 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Fabian Deutsch <fabiand@fedoraproject.org>
|
||||||
|
Date: Tue, 2 Sep 2014 10:38:17 +0200
|
||||||
|
Subject: TMPDIR becomes the last option
|
||||||
|
|
||||||
|
Previously $TMPDIR and /tmp were the first options to try to use for
|
||||||
|
intermediate files. To prevent name collisions, now user specific dirs ($HOME
|
||||||
|
and $XDG_RUNTIME_DIR) are prefered over the user unspecific dirs ($TMP and
|
||||||
|
/tmp).
|
||||||
|
|
||||||
|
https://bugzilla.gnome.org/show_bug.cgi?id=735871
|
||||||
|
|
||||||
|
diff --git a/orc/orccodemem.c b/orc/orccodemem.c
|
||||||
|
index 7bb78d2..8bc2a48 100644
|
||||||
|
--- a/orc/orccodemem.c
|
||||||
|
+++ b/orc/orccodemem.c
|
||||||
|
@@ -266,21 +266,21 @@ orc_code_region_allocate_codemem (OrcCodeRegion *region)
|
||||||
|
{
|
||||||
|
const char *tmpdir;
|
||||||
|
|
||||||
|
- tmpdir = getenv ("TMPDIR");
|
||||||
|
+ tmpdir = getenv ("XDG_RUNTIME_DIR");
|
||||||
|
if (tmpdir && orc_code_region_allocate_codemem_dual_map (region,
|
||||||
|
tmpdir, FALSE)) return;
|
||||||
|
|
||||||
|
- if (orc_code_region_allocate_codemem_dual_map (region,
|
||||||
|
- "/tmp", FALSE)) return;
|
||||||
|
-
|
||||||
|
- tmpdir = getenv ("XDG_RUNTIME_DIR");
|
||||||
|
+ tmpdir = getenv ("HOME");
|
||||||
|
if (tmpdir && orc_code_region_allocate_codemem_dual_map (region,
|
||||||
|
tmpdir, FALSE)) return;
|
||||||
|
|
||||||
|
- tmpdir = getenv ("HOME");
|
||||||
|
+ tmpdir = getenv ("TMPDIR");
|
||||||
|
if (tmpdir && orc_code_region_allocate_codemem_dual_map (region,
|
||||||
|
tmpdir, FALSE)) return;
|
||||||
|
|
||||||
|
+ if (orc_code_region_allocate_codemem_dual_map (region,
|
||||||
|
+ "/tmp", FALSE)) return;
|
||||||
|
+
|
||||||
|
if (orc_code_region_allocate_codemem_anon_map (region)) return;
|
||||||
|
|
||||||
|
ORC_ERROR("Failed to create write and exec mmap regions. This "
|
||||||
|
--
|
||||||
|
cgit v0.10.2
|
||||||
|
|
7
orc.spec
7
orc.spec
@ -1,6 +1,6 @@
|
|||||||
Name: orc
|
Name: orc
|
||||||
Version: 0.4.22
|
Version: 0.4.22
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: The Oil Run-time Compiler
|
Summary: The Oil Run-time Compiler
|
||||||
|
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
@ -12,6 +12,7 @@ URL: http://cgit.freedesktop.org/gstreamer/orc/
|
|||||||
# git clone git://anongit.freedesktop.org/gstreamer/orc
|
# git clone git://anongit.freedesktop.org/gstreamer/orc
|
||||||
# git archive --format=tar --prefix=%{name}-%{version}/ %{name}-%{version} | bzip2 > %{name}-%{version}.tar.bz2
|
# git archive --format=tar --prefix=%{name}-%{version}/ %{name}-%{version} | bzip2 > %{name}-%{version}.tar.bz2
|
||||||
Source0: %{name}-%{version}.tar.bz2
|
Source0: %{name}-%{version}.tar.bz2
|
||||||
|
Patch0: orc-selinux-tmplocation.patch
|
||||||
|
|
||||||
BuildRequires: gtk-doc, libtool
|
BuildRequires: gtk-doc, libtool
|
||||||
|
|
||||||
@ -54,6 +55,7 @@ The Orc compiler, to produce optimized code.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1 -b .selinux
|
||||||
NOCONFIGURE=1 autoreconf -vif
|
NOCONFIGURE=1 autoreconf -vif
|
||||||
|
|
||||||
|
|
||||||
@ -105,6 +107,9 @@ make check
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Sep 4 2014 Peter Robinson <pbrobinson@fedoraproject.org> 0.4.22-2
|
||||||
|
- Add upstream patch for selinux issue with tmp files
|
||||||
|
|
||||||
* Fri Aug 29 2014 Peter Robinson <pbrobinson@fedoraproject.org> 0.4.22-1
|
* Fri Aug 29 2014 Peter Robinson <pbrobinson@fedoraproject.org> 0.4.22-1
|
||||||
- Update to 0.4.22
|
- Update to 0.4.22
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user