- revert commits changing ppc64/ppc64le support
This commit is contained in:
parent
354ff96131
commit
8ec37a8471
73
orc-0.4.29-ppc64-revert.patch
Normal file
73
orc-0.4.29-ppc64-revert.patch
Normal file
@ -0,0 +1,73 @@
|
|||||||
|
From b02d7e797a9d66fe22c131526b46524171675319 Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
||||||
|
Date: Fri, 10 May 2019 12:55:06 +0200
|
||||||
|
Subject: [PATCH 1/2] Revert "PowerPC: Support ELFv2 ABI"
|
||||||
|
|
||||||
|
This reverts commit 4e080ed8d64e73465ffe9f79d95b56ff184cf01a.
|
||||||
|
---
|
||||||
|
orc/orcpowerpc.c | 2 +-
|
||||||
|
orc/orcprogram-altivec.c | 2 --
|
||||||
|
2 files changed, 1 insertion(+), 3 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/orc/orcpowerpc.c b/orc/orcpowerpc.c
|
||||||
|
index 8eeb4e5..a6835ba 100644
|
||||||
|
--- a/orc/orcpowerpc.c
|
||||||
|
+++ b/orc/orcpowerpc.c
|
||||||
|
@@ -418,7 +418,7 @@ orc_powerpc_flush_cache (OrcCode *code)
|
||||||
|
int size = code->code_size;
|
||||||
|
|
||||||
|
ptr = code->code;
|
||||||
|
-#if defined(__powerpc64__) && (!defined(_CALL_ELF) || _CALL_ELF == 1)
|
||||||
|
+#ifdef __powerpc64__
|
||||||
|
*(unsigned char **) ptr = (unsigned char *) code->exec + 24;
|
||||||
|
#endif
|
||||||
|
for (i=0;i<size;i+=cache_line_size) {
|
||||||
|
diff --git a/orc/orcprogram-altivec.c b/orc/orcprogram-altivec.c
|
||||||
|
index bc40633..2ad11e8 100644
|
||||||
|
--- a/orc/orcprogram-altivec.c
|
||||||
|
+++ b/orc/orcprogram-altivec.c
|
||||||
|
@@ -27,14 +27,12 @@ powerpc_emit_prologue (OrcCompiler *compiler)
|
||||||
|
ORC_ASM_CODE (compiler, "%s:\n", compiler->program->name);
|
||||||
|
|
||||||
|
if (compiler->is_64bit) {
|
||||||
|
-#if !defined(_CALL_ELF) || _CALL_ELF == 1
|
||||||
|
ORC_ASM_CODE (compiler, " .quad .%s,.TOC.@tocbase,0\n",
|
||||||
|
compiler->program->name);
|
||||||
|
ORC_ASM_CODE (compiler, ".%s:\n", compiler->program->name);
|
||||||
|
powerpc_emit (compiler, 0); powerpc_emit (compiler, 0);
|
||||||
|
powerpc_emit (compiler, 0); powerpc_emit (compiler, 0);
|
||||||
|
powerpc_emit (compiler, 0); powerpc_emit (compiler, 0);
|
||||||
|
-#endif
|
||||||
|
powerpc_emit_stdu (compiler, POWERPC_R1, POWERPC_R1, -16);
|
||||||
|
} else {
|
||||||
|
powerpc_emit_stwu (compiler, POWERPC_R1, POWERPC_R1, -16);
|
||||||
|
--
|
||||||
|
2.21.0
|
||||||
|
|
||||||
|
|
||||||
|
From e51942caa119b27693ca9aad8b5c2780d10ccb32 Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
||||||
|
Date: Fri, 10 May 2019 12:57:52 +0200
|
||||||
|
Subject: [PATCH 2/2] Revert "Add support for ppc64le"
|
||||||
|
|
||||||
|
This reverts commit 7e504fa1367b15c12807da1053a51db528f37c79.
|
||||||
|
---
|
||||||
|
m4/as-host-defines.m4 | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/m4/as-host-defines.m4 b/m4/as-host-defines.m4
|
||||||
|
index 4a6ae45..7223c51 100644
|
||||||
|
--- a/m4/as-host-defines.m4
|
||||||
|
+++ b/m4/as-host-defines.m4
|
||||||
|
@@ -19,7 +19,7 @@ AC_DEFUN([AS_HOST_DEFINES],
|
||||||
|
HAVE_AMD64=yes
|
||||||
|
AC_DEFINE(HAVE_AMD64, 1, [Defined if host is amd64])
|
||||||
|
;;
|
||||||
|
- xpowerpc|xppc|xpowerpc64*|xppc64*)
|
||||||
|
+ xpowerpc|xppc|xpowerpc64|xppc64)
|
||||||
|
HAVE_POWERPC=yes
|
||||||
|
AC_DEFINE(HAVE_POWERPC, 1, [Defined if host is powerpc])
|
||||||
|
;;
|
||||||
|
--
|
||||||
|
2.21.0
|
||||||
|
|
9
orc.spec
9
orc.spec
@ -1,11 +1,14 @@
|
|||||||
Name: orc
|
Name: orc
|
||||||
Version: 0.4.29
|
Version: 0.4.29
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: The Oil Run-time Compiler
|
Summary: The Oil Run-time Compiler
|
||||||
|
|
||||||
License: BSD
|
License: BSD
|
||||||
URL: http://cgit.freedesktop.org/gstreamer/orc/
|
URL: http://cgit.freedesktop.org/gstreamer/orc/
|
||||||
Source0: http://gstreamer.freedesktop.org/src/orc/%{name}-%{version}.tar.xz
|
Source0: http://gstreamer.freedesktop.org/src/orc/%{name}-%{version}.tar.xz
|
||||||
|
# https://gitlab.freedesktop.org/gstreamer/orc/issues/19
|
||||||
|
# revert commits changing ppc64/ppc64le support
|
||||||
|
Patch0: orc-0.4.29-ppc64-revert.patch
|
||||||
|
|
||||||
BuildRequires: gtk-doc, libtool
|
BuildRequires: gtk-doc, libtool
|
||||||
|
|
||||||
@ -45,6 +48,7 @@ The Orc compiler, to produce optimized code.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
gtkdocize --copy
|
gtkdocize --copy
|
||||||
NOCONFIGURE=1 autoreconf -vif
|
NOCONFIGURE=1 autoreconf -vif
|
||||||
|
|
||||||
@ -95,6 +99,9 @@ make check
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri May 10 2019 Dan Horák <dan[at]danny.cz> 0.4.29-2
|
||||||
|
- revert commits changing ppc64/ppc64le support
|
||||||
|
|
||||||
* Tue Apr 23 2019 Wim Taymans <wtaymans@redhat.com> 0.4.29-1
|
* Tue Apr 23 2019 Wim Taymans <wtaymans@redhat.com> 0.4.29-1
|
||||||
- Update to 0.4.29
|
- Update to 0.4.29
|
||||||
- Add orc-test pkgconfig file
|
- Add orc-test pkgconfig file
|
||||||
|
Loading…
Reference in New Issue
Block a user