Update to 0.4.33
This commit is contained in:
parent
67594788d8
commit
5a7c525195
1
.gitignore
vendored
1
.gitignore
vendored
@ -7,3 +7,4 @@
|
||||
/orc-0.4.29.tar.xz
|
||||
/orc-0.4.30.tar.xz
|
||||
/orc-0.4.31.tar.xz
|
||||
/orc-0.4.33.tar.xz
|
||||
|
@ -1,41 +0,0 @@
|
||||
From 59eb41b7bc5f701a040c546fe68d81fcfb9f01ef Mon Sep 17 00:00:00 2001
|
||||
From: Doug Nazar <nazard@nazar.ca>
|
||||
Date: Tue, 17 Aug 2021 19:49:08 -0400
|
||||
Subject: [PATCH] executor: Fix orc_executor_set_program() to save OrcCode
|
||||
|
||||
orc_executor_set_program() was missed when it was added to
|
||||
orc_executor_new().
|
||||
---
|
||||
orc/orcexecutor.c | 9 ++-------
|
||||
1 file changed, 2 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/orc/orcexecutor.c b/orc/orcexecutor.c
|
||||
index d1565cb..e36953f 100644
|
||||
--- a/orc/orcexecutor.c
|
||||
+++ b/orc/orcexecutor.c
|
||||
@@ -24,8 +24,7 @@ orc_executor_new (OrcProgram *program)
|
||||
ex = malloc(sizeof(OrcExecutor));
|
||||
memset(ex,0,sizeof(OrcExecutor));
|
||||
|
||||
- ex->program = program;
|
||||
- ex->arrays[ORC_VAR_A2] = program->orccode;
|
||||
+ orc_executor_set_program (ex, program);
|
||||
|
||||
return ex;
|
||||
}
|
||||
@@ -78,11 +77,7 @@ void
|
||||
orc_executor_set_program (OrcExecutor *ex, OrcProgram *program)
|
||||
{
|
||||
ex->program = program;
|
||||
- if (program->code_exec) {
|
||||
- ex->arrays[ORC_VAR_A1] = (void *)program->code_exec;
|
||||
- } else {
|
||||
- ex->arrays[ORC_VAR_A1] = (void *)orc_executor_emulate;
|
||||
- }
|
||||
+ ex->arrays[ORC_VAR_A2] = program->orccode;
|
||||
}
|
||||
|
||||
void
|
||||
--
|
||||
GitLab
|
||||
|
12
orc.spec
12
orc.spec
@ -1,14 +1,11 @@
|
||||
Name: orc
|
||||
Version: 0.4.31
|
||||
Release: 8%{?dist}
|
||||
Version: 0.4.33
|
||||
Release: 1%{?dist}
|
||||
Summary: The Oil Run-time Compiler
|
||||
|
||||
License: BSD
|
||||
URL: http://cgit.freedesktop.org/gstreamer/orc/
|
||||
Source0: http://gstreamer.freedesktop.org/src/orc/%{name}-%{version}.tar.xz
|
||||
# Fix ppc64le segfault when used via libvips.
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1917540
|
||||
Patch0: orc-0.4.32-executor-Fix-orc_executor_set_program-to-save-OrcCode.patch
|
||||
|
||||
BuildRequires: meson >= 0.47.0
|
||||
BuildRequires: gcc
|
||||
@ -51,8 +48,6 @@ The Orc compiler, to produce optimized code.
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
%meson -D default_library=shared
|
||||
%meson_build
|
||||
@ -93,6 +88,9 @@ rm -rf %{buildroot}/%{_libdir}/orc
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Nov 04 2022 Wim Taymans <wtaymans@redhat.com> 0.4.33-1
|
||||
- Update to 0.4.33
|
||||
|
||||
* Fri Jul 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.31-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (orc-0.4.31.tar.xz) = 4e97597e70982dbfc239d1ef9a8913b0155e5aaac15d91162d7f73a1095bd944e27fbe6d6194b9f74af07b985a44b1d9dddbe917425e1ad9e8da17ce86495696
|
||||
SHA512 (orc-0.4.33.tar.xz) = ae8adce5dd62f4054879e6f2db76ce8a7959fd32fef0fb99f73f450ff58c5237e15bca764f6780309a163e40afcf400345f12b0aed5b88dc698064e44f8eede0
|
||||
|
Loading…
Reference in New Issue
Block a user