Fixed couple of things in the spec file
This commit is contained in:
parent
6206abc073
commit
c8234dd49c
14
openwsman-authors.patch
Normal file
14
openwsman-authors.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
diff -up openwsman-2.2.3/AUTHORS.diff openwsman-2.2.3/AUTHORS
|
||||||
|
--- openwsman-2.2.3/AUTHORS.diff 2010-04-20 10:42:40.156797595 -0500
|
||||||
|
+++ openwsman-2.2.3/AUTHORS 2010-04-20 10:43:10.440803220 -0500
|
||||||
|
@@ -13,5 +13,10 @@ Contributions and Patches by:
|
||||||
|
Viktor Mihajlovski, IBM
|
||||||
|
Klaus Kaempf, Novell
|
||||||
|
|
||||||
|
+AUTHORS from Spec file:
|
||||||
|
+ Anas Nashif <anas.nashif@intel.com>
|
||||||
|
+ Vadim Revyakin <vadim.revyakin@intel.com>
|
||||||
|
+ Denis Sadykov <denis.sadykov@intel.com>
|
||||||
|
+
|
||||||
|
|
||||||
|
If you think you name should be here and I forgot it, please let me know.
|
@ -1,12 +1,14 @@
|
|||||||
diff -up openwsman-2.2.3/etc/init/openwsmand.sh.in.orig openwsman-2.2.3/etc/init/openwsmand.sh.in
|
diff -up openwsman-2.2.3/etc/init/openwsmand.sh.in.orig openwsman-2.2.3/etc/init/openwsmand.sh.in
|
||||||
--- openwsman-2.2.3/etc/init/openwsmand.sh.in.orig 2010-01-21 11:12:34.000000000 +0100
|
--- openwsman-2.2.3/etc/init/openwsmand.sh.in.orig 2010-04-22 09:36:29.186800378 -0500
|
||||||
+++ openwsman-2.2.3/etc/init/openwsmand.sh.in 2010-03-02 14:29:31.618984202 +0100
|
+++ openwsman-2.2.3/etc/init/openwsmand.sh.in 2010-04-22 09:38:15.507820659 -0500
|
||||||
@@ -4,15 +4,13 @@
|
@@ -4,15 +4,15 @@
|
||||||
# Provides: openwsmand
|
# Provides: openwsmand
|
||||||
# Required-Start: $remote_fs
|
# Required-Start: $remote_fs
|
||||||
# Required-Stop: $network
|
# Required-Stop: $network
|
||||||
-# Default-Start: 2 3 4 5
|
-# Default-Start: 2 3 4 5
|
||||||
-# Default-Stop: 0 1 6
|
-# Default-Stop: 0 1 6
|
||||||
|
+# Default-Start:
|
||||||
|
+# Default-Stop:
|
||||||
# Short-Description: Openwsman Daemon
|
# Short-Description: Openwsman Daemon
|
||||||
# Description: openwsmand
|
# Description: openwsmand
|
||||||
# Start/Stop the Openwsman Daemon
|
# Start/Stop the Openwsman Daemon
|
||||||
@ -18,7 +20,7 @@ diff -up openwsman-2.2.3/etc/init/openwsmand.sh.in.orig openwsman-2.2.3/etc/init
|
|||||||
# description: Openwsman Daemon
|
# description: Openwsman Daemon
|
||||||
# processname: openwsmand
|
# processname: openwsmand
|
||||||
|
|
||||||
@@ -61,7 +59,7 @@ start()
|
@@ -61,7 +61,7 @@ start()
|
||||||
if [ "x${FQDN}" = "x" ]; then
|
if [ "x${FQDN}" = "x" ]; then
|
||||||
FQDN=localhost.localdomain
|
FQDN=localhost.localdomain
|
||||||
fi
|
fi
|
||||||
@ -27,3 +29,18 @@ diff -up openwsman-2.2.3/etc/init/openwsmand.sh.in.orig openwsman-2.2.3/etc/init
|
|||||||
--
|
--
|
||||||
SomeState
|
SomeState
|
||||||
SomeCity
|
SomeCity
|
||||||
|
@@ -145,8 +145,13 @@ case "$1" in
|
||||||
|
fi
|
||||||
|
;;
|
||||||
|
|
||||||
|
+
|
||||||
|
+ condrestart)
|
||||||
|
+ [ -e $lockfile ] && restart
|
||||||
|
+
|
||||||
|
+
|
||||||
|
*)
|
||||||
|
- echo "Usage: $0 {restart|start|stop|reload|force-reload|status}"
|
||||||
|
+ echo "Usage: $0 {restart|start|stop|reload|force-reload|status|condrestart}"
|
||||||
|
esac
|
||||||
|
|
||||||
|
if [ $lsb -ne 0 ]; then
|
||||||
|
119
openwsman.spec
119
openwsman.spec
@ -1,18 +1,5 @@
|
|||||||
#
|
#
|
||||||
# spec file for package openwsman (Version 2.2.0)
|
# spec file for package openwsman (Version 2.2.3)
|
||||||
#
|
|
||||||
# Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany.
|
|
||||||
#
|
|
||||||
# All modifications and additions to the file contributed by third parties
|
|
||||||
# remain the property of their copyright owners, unless otherwise agreed
|
|
||||||
# upon. The license for this file, and modifications and additions to the
|
|
||||||
# file, is the same license as for the pristine package itself (unless the
|
|
||||||
# license for the pristine package is not an Open Source License, in which
|
|
||||||
# case the license is the MIT License). An "Open Source License" is a
|
|
||||||
# license that conforms to the Open Source Definition (Version 1.9)
|
|
||||||
# published by the Open Source Initiative.
|
|
||||||
|
|
||||||
# Please submit bugfixes or comments via http://bugs.opensuse.org/
|
|
||||||
#
|
#
|
||||||
|
|
||||||
# norootforbuild
|
# norootforbuild
|
||||||
@ -30,14 +17,15 @@ BuildRequires: perl-devel pkgconfig openssl-devel
|
|||||||
BuildRequires: libtool
|
BuildRequires: libtool
|
||||||
Requires: net-tools
|
Requires: net-tools
|
||||||
Version: 2.2.3
|
Version: 2.2.3
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
Url: http://www.openwsman.org/
|
Url: http://www.openwsman.org/
|
||||||
License: BSD
|
License: BSD
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
Summary: Opensource Implementation of WS-Management
|
Summary: Opensource Implementation of WS-Management
|
||||||
Source: %{name}-%{version}.tar.bz2
|
Source: http://downloads.sourceforge.net/project/openwsman/%{name}/%{version}/%{name}-%{version}.tar.bz2
|
||||||
Patch0: %{name}-initscript.patch
|
Patch0: %{name}-initscript.patch
|
||||||
Patch1: %{name}-randfile.patch
|
Patch1: %{name}-randfile.patch
|
||||||
|
Patch2: %{name}-authors.patch
|
||||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXXX)
|
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXXX)
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -51,11 +39,6 @@ all system management aspects.
|
|||||||
|
|
||||||
|
|
||||||
|
|
||||||
Authors:
|
|
||||||
--------
|
|
||||||
Anas Nashif <anas.nashif@intel.com>
|
|
||||||
Vadim Revyakin <vadim.revyakin@intel.com>
|
|
||||||
Denis Sadykov <denis.sadykov@intel.com>
|
|
||||||
|
|
||||||
%package -n libwsman1
|
%package -n libwsman1
|
||||||
License: BSD
|
License: BSD
|
||||||
@ -63,18 +46,12 @@ Group: System Environment/Libraries
|
|||||||
Summary: Opensource Implementation of WS-Management
|
Summary: Opensource Implementation of WS-Management
|
||||||
Provides: %{name} = %{version}
|
Provides: %{name} = %{version}
|
||||||
Obsoletes: %{name} < %{version}
|
Obsoletes: %{name} < %{version}
|
||||||
Requires: %{name}-client
|
|
||||||
|
|
||||||
%description -n libwsman1
|
%description -n libwsman1
|
||||||
Openwsman library for packages dependent on openwsman
|
Openwsman library for packages dependent on openwsman
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
Authors:
|
|
||||||
--------
|
|
||||||
Anas Nashif <anas.nashif@intel.com>
|
|
||||||
Vadim Revyakin <vadim.revyakin@intel.com>
|
|
||||||
Denis Sadykov <denis.sadykov@intel.com>
|
|
||||||
|
|
||||||
%package -n libwsman-devel
|
%package -n libwsman-devel
|
||||||
License: BSD
|
License: BSD
|
||||||
@ -92,11 +69,6 @@ Requires: libcurl-devel
|
|||||||
Development files for openwsman
|
Development files for openwsman
|
||||||
|
|
||||||
|
|
||||||
Authors:
|
|
||||||
--------
|
|
||||||
Anas Nashif <anas.nashif@intel.com>
|
|
||||||
Vadim Revyakin <vadim.revyakin@intel.com>
|
|
||||||
Denis Sadykov <denis.sadykov@intel.com>
|
|
||||||
|
|
||||||
%package client
|
%package client
|
||||||
License: BSD
|
License: BSD
|
||||||
@ -108,17 +80,11 @@ Openwsman Client libraries
|
|||||||
|
|
||||||
|
|
||||||
|
|
||||||
Authors:
|
|
||||||
--------
|
|
||||||
Anas Nashif <anas.nashif@intel.com>
|
|
||||||
Vadim Revyakin <vadim.revyakin@intel.com>
|
|
||||||
Denis Sadykov <denis.sadykov@intel.com>
|
|
||||||
|
|
||||||
%package server
|
%package server
|
||||||
License: BSD
|
License: BSD
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
Requires: net-tools
|
Requires: net-tools
|
||||||
Requires: openwsman-client
|
|
||||||
Requires(post): chkconfig
|
Requires(post): chkconfig
|
||||||
Requires(preun): chkconfig
|
Requires(preun): chkconfig
|
||||||
Requires(postun): initscripts
|
Requires(postun): initscripts
|
||||||
@ -129,11 +95,6 @@ Openwsman Server and service libraries
|
|||||||
|
|
||||||
|
|
||||||
|
|
||||||
Authors:
|
|
||||||
--------
|
|
||||||
Anas Nashif <anas.nashif@intel.com>
|
|
||||||
Vadim Revyakin <vadim.revyakin@intel.com>
|
|
||||||
Denis Sadykov <denis.sadykov@intel.com>
|
|
||||||
|
|
||||||
%package python
|
%package python
|
||||||
License: BSD
|
License: BSD
|
||||||
@ -147,11 +108,6 @@ API.
|
|||||||
|
|
||||||
|
|
||||||
|
|
||||||
Authors:
|
|
||||||
--------
|
|
||||||
Anas Nashif <anas.nashif@intel.com>
|
|
||||||
Vadim Revyakin <vadim.revyakin@intel.com>
|
|
||||||
Denis Sadykov <denis.sadykov@intel.com>
|
|
||||||
|
|
||||||
%package ruby
|
%package ruby
|
||||||
License: BSD
|
License: BSD
|
||||||
@ -165,11 +121,6 @@ This package provides Ruby bindings to access the openwsman client API.
|
|||||||
|
|
||||||
|
|
||||||
|
|
||||||
Authors:
|
|
||||||
--------
|
|
||||||
Anas Nashif <anas.nashif@intel.com>
|
|
||||||
Vadim Revyakin <vadim.revyakin@intel.com>
|
|
||||||
Denis Sadykov <denis.sadykov@intel.com>
|
|
||||||
|
|
||||||
%package perl
|
%package perl
|
||||||
License: BSD
|
License: BSD
|
||||||
@ -182,16 +133,12 @@ This package provides Perl bindings to access the openwsman client API.
|
|||||||
|
|
||||||
|
|
||||||
|
|
||||||
Authors:
|
|
||||||
--------
|
|
||||||
Anas Nashif <anas.nashif@intel.com>
|
|
||||||
Vadim Revyakin <vadim.revyakin@intel.com>
|
|
||||||
Denis Sadykov <denis.sadykov@intel.com>
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
sh autoconfiscate.sh
|
sh autoconfiscate.sh
|
||||||
@ -213,18 +160,18 @@ make CFLAGS="$RPM_OPT_FLAGS" %{?_smp_flags}
|
|||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf %{buildroot}
|
rm -rf %{buildroot}
|
||||||
make DESTDIR=$RPM_BUILD_ROOT install
|
make DESTDIR=%{buildroot} install
|
||||||
rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
|
rm -f %{buildroot}/%{_libdir}/*.la
|
||||||
rm -f $RPM_BUILD_ROOT%{_libdir}/openwsman/plugins/*.la
|
rm -f %{buildroot}/%{_libdir}/openwsman/plugins/*.la
|
||||||
rm -f $RPM_BUILD_ROOT%{_libdir}/openwsman/authenticators/*.la
|
rm -f %{buildroot}/%{_libdir}/openwsman/authenticators/*.la
|
||||||
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/init.d
|
mkdir -p %{buildroot}/%{_sysconfdir}/init.d
|
||||||
install -m 644 etc/openwsman.conf $RPM_BUILD_ROOT%{_sysconfdir}/openwsman
|
install -m 644 etc/openwsman.conf %{buildroot}/%{_sysconfdir}/openwsman
|
||||||
install -m 644 etc/ssleay.cnf $RPM_BUILD_ROOT%{_sysconfdir}/openwsman
|
install -m 644 etc/ssleay.cnf %{buildroot}/%{_sysconfdir}/openwsman
|
||||||
install -m 755 etc/init/openwsmand.sh $RPM_BUILD_ROOT%{_sysconfdir}/init.d/openwsmand
|
install -m 755 etc/init/openwsmand.sh %{buildroot}/%{_sysconfdir}/init.d/openwsmand
|
||||||
ln -sf %{_sysconfdir}/init.d/openwsmand $RPM_BUILD_ROOT%{_sbindir}/rcopenwsmand
|
ln -sf %{_sysconfdir}/init.d/openwsmand %{buildroot}/%{_sbindir}/rcopenwsmand
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf %{buildroot}
|
||||||
|
|
||||||
%post -n libwsman1 -p /sbin/ldconfig
|
%post -n libwsman1 -p /sbin/ldconfig
|
||||||
|
|
||||||
@ -235,10 +182,17 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
chkconfig --add openwsmand
|
chkconfig --add openwsmand
|
||||||
|
|
||||||
%preun server
|
%preun server
|
||||||
chkconfig --del openwsmand
|
if [ $1 = 0 ] ; then
|
||||||
|
/sbin/service %{name}d stop >/dev/null 2>&1
|
||||||
|
/sbin/chkconfig --del openwsmand
|
||||||
|
fi
|
||||||
|
|
||||||
%postun server
|
%postun server
|
||||||
rm -f /var/log/wsmand.log
|
rm -f /var/log/wsmand.log
|
||||||
|
|
||||||
|
if [ "$1" -ge "1" ] ; then
|
||||||
|
/sbin/service %{name}d condrestart >/dev/null 2>&1 || :
|
||||||
|
fi
|
||||||
/sbin/ldconfig
|
/sbin/ldconfig
|
||||||
|
|
||||||
%post client -p /sbin/ldconfig
|
%post client -p /sbin/ldconfig
|
||||||
@ -246,21 +200,21 @@ rm -f /var/log/wsmand.log
|
|||||||
%postun client -p /sbin/ldconfig
|
%postun client -p /sbin/ldconfig
|
||||||
|
|
||||||
%files -n libwsman1
|
%files -n libwsman1
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root,-)
|
||||||
%doc AUTHORS COPYING ChangeLog README TODO
|
%doc AUTHORS COPYING ChangeLog README TODO
|
||||||
%{_libdir}/libwsman.so.*
|
%{_libdir}/libwsman.so.*
|
||||||
%{_libdir}/libwsman_client.so.*
|
%{_libdir}/libwsman_client.so.*
|
||||||
%{_libdir}/libwsman_curl_client_transport.so.*
|
%{_libdir}/libwsman_curl_client_transport.so.*
|
||||||
|
|
||||||
%files -n libwsman-devel
|
%files -n libwsman-devel
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root,-)
|
||||||
%{_includedir}/*
|
%{_includedir}/*
|
||||||
%{_libdir}/pkgconfig/*
|
%{_libdir}/pkgconfig/*
|
||||||
%{_libdir}/*.so
|
%{_libdir}/*.so
|
||||||
%doc AUTHORS COPYING ChangeLog README
|
%doc AUTHORS COPYING ChangeLog README
|
||||||
|
|
||||||
%files python
|
%files python
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root,-)
|
||||||
%{python_sitearch}/*.so
|
%{python_sitearch}/*.so
|
||||||
%{python_sitelib}/*.py
|
%{python_sitelib}/*.py
|
||||||
%{python_sitelib}/*.pyc
|
%{python_sitelib}/*.pyc
|
||||||
@ -268,7 +222,7 @@ rm -f /var/log/wsmand.log
|
|||||||
%doc AUTHORS COPYING ChangeLog README
|
%doc AUTHORS COPYING ChangeLog README
|
||||||
|
|
||||||
%files ruby
|
%files ruby
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root,-)
|
||||||
%{ruby_sitearch}/openwsman.so
|
%{ruby_sitearch}/openwsman.so
|
||||||
%dir %{ruby_sitelib}/openwsman
|
%dir %{ruby_sitelib}/openwsman
|
||||||
%{ruby_sitelib}/openwsman/openwsman.rb
|
%{ruby_sitelib}/openwsman/openwsman.rb
|
||||||
@ -276,7 +230,7 @@ rm -f /var/log/wsmand.log
|
|||||||
%doc AUTHORS COPYING ChangeLog README
|
%doc AUTHORS COPYING ChangeLog README
|
||||||
|
|
||||||
%files perl
|
%files perl
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root,-)
|
||||||
%{perl_vendorarch}/openwsman.so
|
%{perl_vendorarch}/openwsman.so
|
||||||
%{perl_vendorlib}/openwsman.pm
|
%{perl_vendorlib}/openwsman.pm
|
||||||
%doc AUTHORS COPYING ChangeLog README
|
%doc AUTHORS COPYING ChangeLog README
|
||||||
@ -284,7 +238,7 @@ rm -f /var/log/wsmand.log
|
|||||||
%files server
|
%files server
|
||||||
# Don't remove *.so files from the server package.
|
# Don't remove *.so files from the server package.
|
||||||
# the server fails to start without these files.
|
# the server fails to start without these files.
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root,-)
|
||||||
%dir %{_sysconfdir}/openwsman
|
%dir %{_sysconfdir}/openwsman
|
||||||
%config(noreplace) %{_sysconfdir}/openwsman/openwsman.conf
|
%config(noreplace) %{_sysconfdir}/openwsman/openwsman.conf
|
||||||
%config(noreplace) %{_sysconfdir}/openwsman/ssleay.cnf
|
%config(noreplace) %{_sysconfdir}/openwsman/ssleay.cnf
|
||||||
@ -304,12 +258,24 @@ rm -f /var/log/wsmand.log
|
|||||||
%doc AUTHORS COPYING ChangeLog README
|
%doc AUTHORS COPYING ChangeLog README
|
||||||
|
|
||||||
%files client
|
%files client
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root,-)
|
||||||
%{_libdir}/libwsman_clientpp.so.*
|
%{_libdir}/libwsman_clientpp.so.*
|
||||||
%doc AUTHORS COPYING ChangeLog README
|
%doc AUTHORS COPYING ChangeLog README
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Apr 22 2010 Praveen K Paladugu <praveen_paladugu@dell.com> - 2.2.3-3
|
||||||
|
- authors.patch: Moved all the AUTHORS info to AUTHORS file.
|
||||||
|
- Corrected the Source tag.
|
||||||
|
- Corrected the package dependencies to break cyclic dependencies.
|
||||||
|
- Fixed the default attributes.
|
||||||
|
- Fixed the preun & postun scripts, to make sure the openwsmand service
|
||||||
|
- is stopped before the package is removed.
|
||||||
|
- Added 'condrestart' function to the init script.
|
||||||
|
- Had to let the *.so files be part of the openwsman-server becuase
|
||||||
|
- some of the source files explicitly call out for *.so files.
|
||||||
|
|
||||||
|
|
||||||
* Thu Apr 15 2010 Praveen K Paladugu <praveen_paladugu@dell.com> - 2.2.3-2
|
* Thu Apr 15 2010 Praveen K Paladugu <praveen_paladugu@dell.com> - 2.2.3-2
|
||||||
- Updated the spec file to adhere to the upstream standard of breaking
|
- Updated the spec file to adhere to the upstream standard of breaking
|
||||||
- the package in server, client, lib modules
|
- the package in server, client, lib modules
|
||||||
@ -324,6 +290,7 @@ rm -f /var/log/wsmand.log
|
|||||||
* Wed Mar 3 2010 Vitezslav Crhonek <vcrhonek@redhat.com> - 2.2.3-1
|
* Wed Mar 3 2010 Vitezslav Crhonek <vcrhonek@redhat.com> - 2.2.3-1
|
||||||
- Update to openwsman-2.2.3
|
- Update to openwsman-2.2.3
|
||||||
|
|
||||||
|
|
||||||
* Wed Sep 23 2009 Praveen K Paladugu <praveen_paladugu@dell.com> - 2.2.0-1
|
* Wed Sep 23 2009 Praveen K Paladugu <praveen_paladugu@dell.com> - 2.2.0-1
|
||||||
- Added the new 2.2.0 sources.
|
- Added the new 2.2.0 sources.
|
||||||
- Changed the release and version numbers.
|
- Changed the release and version numbers.
|
||||||
|
Loading…
Reference in New Issue
Block a user