Update to openwsman-2.3.0
This commit is contained in:
parent
047514163b
commit
b833a80033
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@ openwsman-2.2.3.tar.bz2
|
|||||||
/openwsman-2.2.4.tar.bz2
|
/openwsman-2.2.4.tar.bz2
|
||||||
/openwsman-2.2.5.tar.bz2
|
/openwsman-2.2.5.tar.bz2
|
||||||
/openwsman-2.2.7.tar.bz2
|
/openwsman-2.2.7.tar.bz2
|
||||||
|
/openwsman-2.3.0.tar.bz2
|
||||||
|
@ -1,12 +1,12 @@
|
|||||||
diff -up openwsman-2.2.7/CMakeLists.txt.ruby openwsman-2.2.7/CMakeLists.txt
|
diff -up openwsman-2.3.0/CMakeLists.txt.orig openwsman-2.3.0/CMakeLists.txt
|
||||||
--- openwsman-2.2.7/CMakeLists.txt.ruby 2012-02-09 09:13:51.222066933 +0100
|
--- openwsman-2.3.0/CMakeLists.txt.orig 2012-03-27 11:51:51.262460385 +0200
|
||||||
+++ openwsman-2.2.7/CMakeLists.txt 2012-02-09 09:14:01.059119669 +0100
|
+++ openwsman-2.3.0/CMakeLists.txt 2012-03-27 11:52:13.732573549 +0200
|
||||||
@@ -103,7 +103,7 @@ SET( BUILD_JAVA_EXPLICIT ${BUILD_JAVA})
|
@@ -105,7 +105,7 @@ SET( BUILD_JAVA_EXPLICIT ${BUILD_JAVA})
|
||||||
OPTION( BUILD_LIBCIM "Build CIM plugin" YES )
|
OPTION( BUILD_LIBCIM "Build CIM plugin" YES )
|
||||||
OPTION( BUILD_EXAMPLES "Build examples" YES )
|
OPTION( BUILD_EXAMPLES "Build examples" YES )
|
||||||
OPTION( BUILD_PYTHON "Build Python bindings" YES )
|
OPTION( BUILD_PYTHON "Build Python bindings" YES )
|
||||||
-OPTION( BUILD_RUBY "Build Ruby bindings" YES )
|
-OPTION( BUILD_RUBY "Build Ruby bindings" YES )
|
||||||
+OPTION( BUILD_RUBY "Build Ruby bindings" NO )
|
+OPTION( BUILD_RUBY "Build Ruby bindings" NO )
|
||||||
OPTION( BUILD_PERL "Build Perl bindings" YES )
|
IF( BUILD_RUBY )
|
||||||
OPTION( BUILD_JAVA "Build Java bindings" YES )
|
OPTION( BUILD_RUBY_GEM "Build Ruby GEM" YES )
|
||||||
OPTION( BUILD_CSHARP "Build C# bindings" YES)
|
ENDIF( BUILD_RUBY )
|
||||||
|
@ -9,12 +9,12 @@
|
|||||||
Name: openwsman
|
Name: openwsman
|
||||||
BuildRequires: swig
|
BuildRequires: swig
|
||||||
BuildRequires: libcurl-devel libxml2-devel pam-devel sblim-sfcc-devel
|
BuildRequires: libcurl-devel libxml2-devel pam-devel sblim-sfcc-devel
|
||||||
#BuildRequires: python python-devel ruby ruby-devel ruby-rdoc perl
|
#BuildRequires: python python-devel ruby ruby-devel rubygem(rdoc) perl
|
||||||
BuildRequires: python python-devel perl
|
BuildRequires: python python-devel perl
|
||||||
BuildRequires: perl-devel pkgconfig openssl-devel
|
BuildRequires: perl-devel pkgconfig openssl-devel
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
Version: 2.2.7
|
Version: 2.3.0
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Url: http://www.openwsman.org/
|
Url: http://www.openwsman.org/
|
||||||
License: BSD
|
License: BSD
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
@ -222,7 +222,7 @@ fi
|
|||||||
|
|
||||||
%files -n libwsman1
|
%files -n libwsman1
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%doc AUTHORS COPYING ChangeLog README TODO
|
%doc AUTHORS COPYING ChangeLog README.md TODO
|
||||||
%{_libdir}/libwsman.so.*
|
%{_libdir}/libwsman.so.*
|
||||||
%{_libdir}/libwsman_client.so.*
|
%{_libdir}/libwsman_client.so.*
|
||||||
%{_libdir}/libwsman_curl_client_transport.so.*
|
%{_libdir}/libwsman_curl_client_transport.so.*
|
||||||
@ -232,7 +232,7 @@ fi
|
|||||||
%{_includedir}/*
|
%{_includedir}/*
|
||||||
%{_libdir}/pkgconfig/*
|
%{_libdir}/pkgconfig/*
|
||||||
%{_libdir}/*.so
|
%{_libdir}/*.so
|
||||||
%doc AUTHORS COPYING ChangeLog README
|
%doc AUTHORS COPYING ChangeLog README.md
|
||||||
|
|
||||||
%files python
|
%files python
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
@ -240,7 +240,7 @@ fi
|
|||||||
%{python_sitearch}/*.py
|
%{python_sitearch}/*.py
|
||||||
%{python_sitearch}/*.pyc
|
%{python_sitearch}/*.pyc
|
||||||
%{python_sitearch}/*.pyo
|
%{python_sitearch}/*.pyo
|
||||||
%doc AUTHORS COPYING ChangeLog README
|
%doc AUTHORS COPYING ChangeLog README.md
|
||||||
|
|
||||||
#%files ruby
|
#%files ruby
|
||||||
#%defattr(-,root,root,-)
|
#%defattr(-,root,root,-)
|
||||||
@ -248,13 +248,13 @@ fi
|
|||||||
#%{ruby_sitearch}/_openwsman.so
|
#%{ruby_sitearch}/_openwsman.so
|
||||||
#%dir %{ruby_sitelib}/openwsman
|
#%dir %{ruby_sitelib}/openwsman
|
||||||
#%{ruby_sitelib}/openwsman/*.rb
|
#%{ruby_sitelib}/openwsman/*.rb
|
||||||
#%doc AUTHORS COPYING ChangeLog README
|
#%doc AUTHORS COPYING ChangeLog README.md
|
||||||
|
|
||||||
%files perl
|
%files perl
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%{perl_vendorarch}/openwsman.so
|
%{perl_vendorarch}/openwsman.so
|
||||||
%{perl_vendorlib}/openwsman.pm
|
%{perl_vendorlib}/openwsman.pm
|
||||||
%doc AUTHORS COPYING ChangeLog README
|
%doc AUTHORS COPYING ChangeLog README.md
|
||||||
|
|
||||||
%files server
|
%files server
|
||||||
# Don't remove *.so files from the server package.
|
# Don't remove *.so files from the server package.
|
||||||
@ -277,16 +277,19 @@ fi
|
|||||||
%{_sbindir}/rcopenwsmand
|
%{_sbindir}/rcopenwsmand
|
||||||
%{_libdir}/libwsman_server.so.*
|
%{_libdir}/libwsman_server.so.*
|
||||||
%{_mandir}/man8/*
|
%{_mandir}/man8/*
|
||||||
%doc AUTHORS COPYING ChangeLog README
|
%doc AUTHORS COPYING ChangeLog README.md
|
||||||
|
|
||||||
%files client
|
%files client
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%{_libdir}/libwsman_clientpp.so.*
|
%{_libdir}/libwsman_clientpp.so.*
|
||||||
%config(noreplace) %{_sysconfdir}/openwsman/openwsman_client.conf
|
%config(noreplace) %{_sysconfdir}/openwsman/openwsman_client.conf
|
||||||
%doc AUTHORS COPYING ChangeLog README
|
%doc AUTHORS COPYING ChangeLog README.md
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Mar 27 2012 Vitezslav Crhonek <vcrhonek@redhat.com> - 2.3.0-1
|
||||||
|
- Update to openwsman-2.3.0
|
||||||
|
|
||||||
* Thu Feb 09 2012 Vitezslav Crhonek <vcrhonek@redhat.com> - 2.2.7-4
|
* Thu Feb 09 2012 Vitezslav Crhonek <vcrhonek@redhat.com> - 2.2.7-4
|
||||||
- Fix libssl loading
|
- Fix libssl loading
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user