This commit is contained in:
parent
b2e9c6a775
commit
8a0b9f25c0
1
.gitignore
vendored
1
.gitignore
vendored
@ -5,3 +5,4 @@ openwsman-2.2.3.tar.bz2
|
||||
/openwsman-2.3.0.tar.bz2
|
||||
/openwsman-2.3.5.tar.bz2
|
||||
/openwsman-2.3.6.tar.bz2
|
||||
/openwsmand.8.gz
|
||||
|
@ -1,81 +0,0 @@
|
||||
diff -up openwsman-2.2.7/etc/init/openwsmand.sh.cmake.orig openwsman-2.2.7/etc/init/openwsmand.sh.cmake
|
||||
--- openwsman-2.2.7/etc/init/openwsmand.sh.cmake.orig 2012-01-11 13:38:58.789392556 +0100
|
||||
+++ openwsman-2.2.7/etc/init/openwsmand.sh.cmake 2012-01-11 13:44:32.383593944 +0100
|
||||
@@ -4,28 +4,28 @@
|
||||
# Provides: openwsmand
|
||||
# Required-Start: $remote_fs
|
||||
# Required-Stop: $network
|
||||
-# Default-Start: 2 3 5
|
||||
-# Default-Stop: 0 1 6
|
||||
+# Default-Start:
|
||||
+# Default-Stop:
|
||||
# Short-Description: Openwsman Daemon
|
||||
# Description: openwsmand
|
||||
# Start/Stop the Openwsman Daemon
|
||||
### END INIT INFO
|
||||
#
|
||||
#
|
||||
-# chkconfig: 2345 36 64
|
||||
+# chkconfig: - 36 64
|
||||
# description: Openwsman Daemon
|
||||
# processname: openwsmand
|
||||
|
||||
NAME=openwsmand
|
||||
DAEMON=/usr/sbin/$NAME
|
||||
OPTIONS=-S # with SSL
|
||||
-PIDFILE=/var/run/$NAME.pid
|
||||
+PIDFILE=/var/run/wsmand.pid
|
||||
|
||||
lsb=0
|
||||
|
||||
if [ $EUID != 0 ]; then
|
||||
echo "This script must be run as root."
|
||||
- exit 1;
|
||||
+ exit 4;
|
||||
fi
|
||||
|
||||
if [ "$DESCRIPTIVE" = "" ]; then
|
||||
@@ -65,6 +65,7 @@ start()
|
||||
|
||||
echo "NOTE: The script uses /dev/random device for generating some random bits while generating the server key."
|
||||
echo " If this takes too long, you can replace the value of \"RANDFILE\" in @SYSCONFDIR@/ssleay.cnf with /dev/urandom. Please understand the implications of replacing the RNADFILE."
|
||||
+ exit 6 # Six means "program is not configured", seems to be suitable value
|
||||
|
||||
fi
|
||||
fi
|
||||
@@ -103,6 +104,9 @@ case "$1" in
|
||||
stop)
|
||||
stop
|
||||
rm -f $lockfile
|
||||
+ # pid file should be removed by server itself, but it's marked as
|
||||
+ # TODO in wsmand.c source file;)
|
||||
+ rm -f $PIDFILE
|
||||
;;
|
||||
|
||||
restart)
|
||||
@@ -137,6 +141,16 @@ case "$1" in
|
||||
echo " running"
|
||||
else
|
||||
echo " stopped"
|
||||
+ if [ -e $PIDFILE ]; then
|
||||
+ echo " stopped, but pid file exists"
|
||||
+ exit 1
|
||||
+ elif [ -e $lockfile ]; then
|
||||
+ echo " stopped, but lock file exists"
|
||||
+ exit 2
|
||||
+ else
|
||||
+ echo " stopped"
|
||||
+ exit 3
|
||||
+ fi
|
||||
fi
|
||||
fi
|
||||
;;
|
||||
@@ -147,6 +161,8 @@ case "$1" in
|
||||
|
||||
*)
|
||||
echo "Usage: $0 {restart|start|stop|reload|force-reload|status|condrestart}"
|
||||
+ [ "$1" = "usage" ] && exit 0
|
||||
+ exit 2
|
||||
esac
|
||||
|
||||
if [ $lsb -ne 0 ]; then
|
@ -1,12 +0,0 @@
|
||||
diff -up openwsman-2.3.0/CMakeLists.txt.orig openwsman-2.3.0/CMakeLists.txt
|
||||
--- openwsman-2.3.0/CMakeLists.txt.orig 2012-03-27 11:51:51.262460385 +0200
|
||||
+++ openwsman-2.3.0/CMakeLists.txt 2012-03-27 11:52:13.732573549 +0200
|
||||
@@ -105,7 +105,7 @@ SET( BUILD_JAVA_EXPLICIT ${BUILD_JAVA})
|
||||
OPTION( BUILD_LIBCIM "Build CIM plugin" YES )
|
||||
OPTION( BUILD_EXAMPLES "Build examples" YES )
|
||||
OPTION( BUILD_PYTHON "Build Python bindings" YES )
|
||||
-OPTION( BUILD_RUBY "Build Ruby bindings" YES )
|
||||
+OPTION( BUILD_RUBY "Build Ruby bindings" NO )
|
||||
IF( BUILD_RUBY )
|
||||
OPTION( BUILD_RUBY_GEM "Build Ruby GEM" YES )
|
||||
ENDIF( BUILD_RUBY )
|
@ -1,29 +0,0 @@
|
||||
diff -up ./bindings/ruby/Makefile.am.diff ./bindings/ruby/Makefile.am
|
||||
--- ./bindings/ruby/Makefile.am.diff 2010-08-02 16:57:20.407937479 -0500
|
||||
+++ ./bindings/ruby/Makefile.am 2010-08-02 16:57:54.718188163 -0500
|
||||
@@ -4,8 +4,10 @@
|
||||
|
||||
SUBDIRS = openwsman tests
|
||||
|
||||
-rubyarchdir = $(shell ruby -r rbconfig -e "vad = Config::CONFIG['vendorarchdir']; print(vad ? vad : Config::CONFIG['sitearchdir'])")
|
||||
-rubydir = $(shell ruby -r rbconfig -e "vd = Config::CONFIG['vendorlibdir']; print(vd ? vd : Config::CONFIG['sitelibdir'])")
|
||||
+#rubyarchdir = $(shell ruby -r rbconfig -e "vad = Config::CONFIG['vendorarchdir']; print(vad ? vad : Config::CONFIG['sitearchdir'])")
|
||||
+rubyarchdir = $(shell ruby -r rbconfig -e " print( Config::CONFIG['sitearchdir'])")
|
||||
+#rubydir = $(shell ruby -r rbconfig -e "vd = Config::CONFIG['vendorlibdir']; print(vd ? vd : Config::CONFIG['sitelibdir'])")
|
||||
+rubydir = $(shell ruby -r rbconfig -e " print(Config::CONFIG['sitelibdir'])")
|
||||
rubyincdir = $(shell ruby -r rbconfig -e "print(Config::CONFIG['archdir'])")
|
||||
|
||||
INCLUDES = \
|
||||
diff -up ./bindings/ruby/openwsman/Makefile.am.diff ./bindings/ruby/openwsman/Makefile.am
|
||||
--- ./bindings/ruby/openwsman/Makefile.am.diff 2010-08-02 16:58:05.201189127 -0500
|
||||
+++ ./bindings/ruby/openwsman/Makefile.am 2010-08-02 16:58:20.999937941 -0500
|
||||
@@ -2,7 +2,8 @@
|
||||
# Makefile.am for openwsman/bindings/ruby/openwsman
|
||||
#
|
||||
|
||||
-rubylibdir = $(shell ruby -r rbconfig -e "vld = Config::CONFIG['vendorlibdir']; print(vld ? vld : Config::CONFIG['sitelibdir'])")
|
||||
+#rubylibdir = $(shell ruby -r rbconfig -e "vld = Config::CONFIG['vendorlibdir']; print(vld ? vld : Config::CONFIG['sitelibdir'])")
|
||||
+rubylibdir = $(shell ruby -r rbconfig -e "print( Config::CONFIG['sitelibdir'])")
|
||||
|
||||
install-data-local:
|
||||
$(mkinstalldirs) $(DESTDIR)$(rubylibdir)/openwsman
|
@ -3,8 +3,6 @@
|
||||
%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
|
||||
%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
|
||||
%endif
|
||||
%{!?ruby_sitelib: %global ruby_sitelib %(ruby -r rbconfig -e 'vd = RbConfig::CONFIG["vendorlibdir"]; print(vd ? vd : RbConfig::CONFIG["sitelibdir"])')}
|
||||
%{!?ruby_sitearch: %global ruby_sitearch %(ruby -r rbconfig -e 'vad = RbConfig::CONFIG["vendorarchdir"]; print(vad ? vad : RbConfig::CONFIG["sitearchdir"])')}
|
||||
|
||||
Name: openwsman
|
||||
BuildRequires: swig
|
||||
@ -28,7 +26,6 @@ Source1: openwsmand.8.gz
|
||||
Source2: openwsmand.service
|
||||
# script for testing presence of the certificates in ExecStartPre
|
||||
Source3: owsmantestcert.sh
|
||||
Patch0: %{name}-sitelibdir.patch
|
||||
Patch1: openwsman-2.2.7-libssl.patch
|
||||
|
||||
%description
|
||||
@ -147,8 +144,6 @@ This package provides Perl bindings to access the openwsman client API.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
# don't make backup of file patched by patch0, it'll be installed...
|
||||
%patch0 -p1
|
||||
%patch1 -p1 -b .libssl
|
||||
|
||||
%build
|
||||
@ -182,9 +177,8 @@ cd ..
|
||||
rm -f %{buildroot}/%{_libdir}/*.la
|
||||
rm -f %{buildroot}/%{_libdir}/openwsman/plugins/*.la
|
||||
rm -f %{buildroot}/%{_libdir}/openwsman/authenticators/*.la
|
||||
[ -d %{buildroot}/%{ruby_sitelib} ] && rm -f %{buildroot}/%{ruby_sitelib}/openwsmanplugin.rb
|
||||
[ -d %{buildroot}/%{ruby_sitelib} ] && rm -f %{buildroot}/%{ruby_sitelib}/openwsman.rb
|
||||
[ -d %{buildroot/}%{ruby_vendorlib} ] && rm -f %{buildroot}/%{ruby_vendorlib}/openwsmanplugin.rb
|
||||
[ -d %{buildroot}/%{ruby_vendorlibdir} ] && rm -f %{buildroot}/%{ruby_vendorlibdir}/openwsmanplugin.rb
|
||||
[ -d %{buildroot}/%{ruby_vendorlibdir} ] && rm -f %{buildroot}/%{ruby_vendorlibdir}/openwsman.rb
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/init.d
|
||||
install -m 644 etc/openwsman.conf %{buildroot}/%{_sysconfdir}/openwsman
|
||||
install -m 644 etc/openwsman_client.conf %{buildroot}/%{_sysconfdir}/openwsman
|
||||
@ -240,9 +234,9 @@ rm -f /var/log/wsmand.log
|
||||
%doc AUTHORS COPYING ChangeLog README.md
|
||||
|
||||
%files ruby
|
||||
%{ruby_sitearch}/_openwsman.so
|
||||
%dir %{ruby_sitelib}/openwsman
|
||||
%{ruby_sitelib}/openwsman/*.rb
|
||||
%{ruby_vendorarchdir}/_openwsman.so
|
||||
%dir %{ruby_vendorlibdir}/openwsman
|
||||
%{ruby_vendorlibdir}/openwsman/*.rb
|
||||
%doc AUTHORS COPYING ChangeLog README.md
|
||||
|
||||
#%files java
|
||||
|
BIN
openwsmand.8.gz
BIN
openwsmand.8.gz
Binary file not shown.
Loading…
Reference in New Issue
Block a user