Initail Import to devel
This commit is contained in:
parent
4dbbd1cbfa
commit
702dc6c82f
@ -0,0 +1 @@
|
|||||||
|
openwsman-2.1.0.tar.bz2
|
1
import.log
Normal file
1
import.log
Normal file
@ -0,0 +1 @@
|
|||||||
|
openwsman-2_1_0-1_fc9:HEAD:openwsman-2.1.0-1.fc9.src.rpm:1225537021
|
28
openwsman-initscript.patch
Normal file
28
openwsman-initscript.patch
Normal file
@ -0,0 +1,28 @@
|
|||||||
|
--- openwsman-2.0.0/etc/init/openwsmand.sh.in.orig 2008-09-07 00:01:29.000000000 -0500
|
||||||
|
+++ openwsman-2.0.0/etc/init/openwsmand.sh.in 2008-09-07 00:34:57.000000000 -0500
|
||||||
|
@@ -4,15 +4,13 @@
|
||||||
|
# Provides: openwsmand
|
||||||
|
# Required-Start: $remote_fs
|
||||||
|
# Required-Stop: $network
|
||||||
|
-# Default-Start: 2 3 4 5
|
||||||
|
-# Default-Stop: 0 1 6
|
||||||
|
# Short-Description: Openwsman Daemon
|
||||||
|
# Description: openwsmand
|
||||||
|
# Start/Stop the Openwsman Daemon
|
||||||
|
### END INIT INFO
|
||||||
|
#
|
||||||
|
#
|
||||||
|
-# chkconfig: 2345 36 64
|
||||||
|
+# chkconfig: - 36 64
|
||||||
|
# description: Openwsman Daemon
|
||||||
|
# processname: openwsmand
|
||||||
|
|
||||||
|
@@ -57,7 +55,7 @@ case "$1" in
|
||||||
|
if [ "x${FQDN}" = "x" ]; then
|
||||||
|
FQDN=localhost.localdomain
|
||||||
|
fi
|
||||||
|
-cat << EOF | sh @SYSCONFDIR@/owsmangencert.sh > /dev/null 2>&1
|
||||||
|
+cat << EOF | sh @libexecdir@/openwsman/owsmangencert.sh > /dev/null 2>&1
|
||||||
|
--
|
||||||
|
SomeState
|
||||||
|
SomeCity
|
142
openwsman.spec
Normal file
142
openwsman.spec
Normal file
@ -0,0 +1,142 @@
|
|||||||
|
%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
|
||||||
|
%{!?ruby_sitearch: %define ruby_sitearch %(ruby -rrbconfig -e 'puts Config::CONFIG["sitearchdir"] ')}
|
||||||
|
|
||||||
|
Name: openwsman
|
||||||
|
Version: 2.1.0
|
||||||
|
Release: 1%{?dist}
|
||||||
|
License: BSD
|
||||||
|
Url: http://www.openwsman.org/
|
||||||
|
Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
|
||||||
|
Patch0: %{name}-initscript.patch
|
||||||
|
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXXX)
|
||||||
|
Group: System Environment/Daemons
|
||||||
|
Summary: Web Services Management libraries
|
||||||
|
BuildRequires: sblim-sfcc-devel curl-devel libxml2-devel pkgconfig pam-devel openssl-devel swig python python-devel ruby ruby-devel
|
||||||
|
Requires(post): chkconfig
|
||||||
|
Requires(preun): chkconfig
|
||||||
|
Requires(postun): initscripts
|
||||||
|
|
||||||
|
%description
|
||||||
|
Openwsman is a project intended to provide an open-source
|
||||||
|
implementation of the Web Services Management specification
|
||||||
|
(WS-Management) and to expose system management information on the
|
||||||
|
Linux operating system using the WS-Management protocol. WS-Management
|
||||||
|
is based on a suite of web services specifications and usage
|
||||||
|
requirements that exposes a set of operations focused on and covers
|
||||||
|
all system management aspects.
|
||||||
|
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Openwsman Development files
|
||||||
|
Group: Development/Libraries
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Requires: pkgconfig
|
||||||
|
%description devel
|
||||||
|
Openwsman Development files
|
||||||
|
|
||||||
|
%package python
|
||||||
|
Summary: Openwsman Python bindings
|
||||||
|
Group: Development/Libraries
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
%description python
|
||||||
|
Openwsman python bindings
|
||||||
|
|
||||||
|
%package -n ruby-%{name}
|
||||||
|
Summary: Openwsman Ruby bindings
|
||||||
|
Group: Development/Libraries
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Requires: ruby(abi) = 1.8
|
||||||
|
Provides: ruby(%{name}) = %{version}
|
||||||
|
%description -n ruby-%{name}
|
||||||
|
Openwsman ruby bindings
|
||||||
|
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
chmod a-x src/lib/*.[ch]
|
||||||
|
chmod a-x src/cpp/*.[ch]
|
||||||
|
chmod a-x include/*.[ch]
|
||||||
|
|
||||||
|
# disable eventing, as Fedora libcurl isn't linked against openssl
|
||||||
|
# disable tests in 2.1.0, http://www.openwsman.org/bug/263
|
||||||
|
%configure --with-examples=yes --with-tests=no --enable-python=yes --enable-ruby=yes --enable-eventing=no --disable-more-warnings
|
||||||
|
make %{?_smp_flags}
|
||||||
|
|
||||||
|
%install
|
||||||
|
rm -rf %{buildroot}
|
||||||
|
make DESTDIR=%{buildroot} install
|
||||||
|
install -m 0644 etc/openwsman.conf %{buildroot}/etc/openwsman
|
||||||
|
install -m 0644 etc/ssleay.cnf %{buildroot}/etc/openwsman
|
||||||
|
install -D -m 0755 etc/init/%{name}d.sh %{buildroot}/%{_initrddir}/%{name}d
|
||||||
|
# move this helper script out of /etc
|
||||||
|
mkdir -p %{buildroot}/%{_libexecdir}/%{name}/
|
||||||
|
chmod 0755 %{buildroot}/etc/%{name}/owsmangencert.sh
|
||||||
|
mv %{buildroot}/etc/%{name}/owsmangencert.sh %{buildroot}/%{_libexecdir}/%{name}/
|
||||||
|
find %{buildroot} -type f -name \*.la -exec rm \{\} \;
|
||||||
|
find %{buildroot} -type f -name \*.a -exec rm \{\} \;
|
||||||
|
|
||||||
|
%clean
|
||||||
|
rm -rf %{buildroot}
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_sbindir}/%{name}d
|
||||||
|
%{_initrddir}/%{name}d
|
||||||
|
%{_libexecdir}/%{name}
|
||||||
|
%dir %{_libdir}/%{name}
|
||||||
|
%dir %{_libdir}/%{name}/plugins
|
||||||
|
%dir %{_libdir}/%{name}/authenticators
|
||||||
|
%{_libdir}/libwsman*.so.*
|
||||||
|
%{_libdir}/%{name}/plugins/*so.*
|
||||||
|
%{_libdir}/%{name}/authenticators/*so.*
|
||||||
|
%dir /etc/openwsman
|
||||||
|
%config(noreplace) /etc/openwsman/openwsman.conf
|
||||||
|
%config(noreplace) /etc/openwsman/ssleay.cnf
|
||||||
|
%doc COPYING README
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_includedir}/*
|
||||||
|
%{_libdir}/*.so
|
||||||
|
%{_libdir}/%{name}/plugins/*so
|
||||||
|
%{_libdir}/%{name}/authenticators/*so
|
||||||
|
%{_libdir}/pkgconfig/%{name}*.pc
|
||||||
|
%doc COPYING examples/serialize.c doc/plugin*
|
||||||
|
|
||||||
|
%files python
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{python_sitelib}/pywsman.py
|
||||||
|
%{python_sitelib}/*.so
|
||||||
|
%doc COPYING
|
||||||
|
|
||||||
|
%files -n ruby-%{name}
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{ruby_sitearch}/*.so
|
||||||
|
%doc COPYING
|
||||||
|
|
||||||
|
%post
|
||||||
|
/sbin/ldconfig
|
||||||
|
/sbin/chkconfig --add %{name}d
|
||||||
|
|
||||||
|
%preun
|
||||||
|
if [ $1 = 0 ] ; then
|
||||||
|
/sbin/service %{name}d stop >/dev/null 2>&1
|
||||||
|
/sbin/chkconfig --del %{name}d
|
||||||
|
fi
|
||||||
|
|
||||||
|
%postun
|
||||||
|
/sbin/ldconfig
|
||||||
|
if [ "$1" -ge "1" ] ; then
|
||||||
|
/sbin/service %{name}d condrestart >/dev/null 2>&1 || :
|
||||||
|
fi
|
||||||
|
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Sep 22 2008 Matt Domsch <Matt_Domsch@dell.com> - 2.1.0-1
|
||||||
|
- update to 2.1.0, resolves security issues
|
||||||
|
|
||||||
|
* Tue Aug 19 2008 <srinivas_ramanatha@dell.com> - 2.0.0-1%{?dist}
|
||||||
|
- Modified the spec file to adhere to fedora packaging guidelines.
|
Loading…
Reference in New Issue
Block a user