Temporarily disable ruby subpackage
This commit is contained in:
parent
9692028410
commit
4e5ae91a5a
12
openwsman-2.2.7-disable-ruby.patch
Normal file
12
openwsman-2.2.7-disable-ruby.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up openwsman-2.2.7/CMakeLists.txt.ruby openwsman-2.2.7/CMakeLists.txt
|
||||||
|
--- openwsman-2.2.7/CMakeLists.txt.ruby 2012-02-09 09:13:51.222066933 +0100
|
||||||
|
+++ openwsman-2.2.7/CMakeLists.txt 2012-02-09 09:14:01.059119669 +0100
|
||||||
|
@@ -103,7 +103,7 @@ SET( BUILD_JAVA_EXPLICIT ${BUILD_JAVA})
|
||||||
|
OPTION( BUILD_LIBCIM "Build CIM plugin" YES )
|
||||||
|
OPTION( BUILD_EXAMPLES "Build examples" YES )
|
||||||
|
OPTION( BUILD_PYTHON "Build Python bindings" YES )
|
||||||
|
-OPTION( BUILD_RUBY "Build Ruby bindings" YES )
|
||||||
|
+OPTION( BUILD_RUBY "Build Ruby bindings" NO )
|
||||||
|
OPTION( BUILD_PERL "Build Perl bindings" YES )
|
||||||
|
OPTION( BUILD_JAVA "Build Java bindings" YES )
|
||||||
|
OPTION( BUILD_CSHARP "Build C# bindings" YES)
|
@ -9,11 +9,12 @@
|
|||||||
Name: openwsman
|
Name: openwsman
|
||||||
BuildRequires: swig
|
BuildRequires: swig
|
||||||
BuildRequires: libcurl-devel libxml2-devel pam-devel sblim-sfcc-devel
|
BuildRequires: libcurl-devel libxml2-devel pam-devel sblim-sfcc-devel
|
||||||
BuildRequires: python python-devel ruby ruby-devel ruby-rdoc perl
|
#BuildRequires: python python-devel ruby ruby-devel ruby-rdoc perl
|
||||||
|
BuildRequires: python python-devel perl
|
||||||
BuildRequires: perl-devel pkgconfig openssl-devel
|
BuildRequires: perl-devel pkgconfig openssl-devel
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
Version: 2.2.7
|
Version: 2.2.7
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
Url: http://www.openwsman.org/
|
Url: http://www.openwsman.org/
|
||||||
License: BSD
|
License: BSD
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
@ -23,6 +24,7 @@ Source: http://downloads.sourceforge.net/project/openwsman/%{name}/%{ver
|
|||||||
Source1: openwsmand.8.gz
|
Source1: openwsmand.8.gz
|
||||||
Patch0: %{name}-sitelibdir.patch
|
Patch0: %{name}-sitelibdir.patch
|
||||||
Patch1: openwsman-2.2.3-initscript.patch
|
Patch1: openwsman-2.2.3-initscript.patch
|
||||||
|
Patch2: openwsman-2.2.7-disable-ruby.patch
|
||||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXXX)
|
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXXX)
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -106,15 +108,15 @@ API.
|
|||||||
|
|
||||||
|
|
||||||
|
|
||||||
%package ruby
|
#%package ruby
|
||||||
License: BSD
|
#License: BSD
|
||||||
Group: Development/Libraries
|
#Group: Development/Libraries
|
||||||
Requires: ruby
|
#Requires: ruby
|
||||||
Requires: ruby(abi) = 1.8
|
#Requires: ruby(abi) = 1.9.1
|
||||||
Summary: Ruby bindings for openwsman client API
|
#Summary: Ruby bindings for openwsman client API
|
||||||
|
#
|
||||||
%description ruby
|
#%description ruby
|
||||||
This package provides Ruby bindings to access the openwsman client API.
|
#This package provides Ruby bindings to access the openwsman client API.
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
@ -136,6 +138,7 @@ This package provides Perl bindings to access the openwsman client API.
|
|||||||
# don't make backup of file patched by patch0, it'll be installed...
|
# don't make backup of file patched by patch0, it'll be installed...
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
%patch1 -p1 -b .initscript
|
%patch1 -p1 -b .initscript
|
||||||
|
%patch2 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# Removing executable permissions on .c and .h files to fix rpmlint warnings.
|
# Removing executable permissions on .c and .h files to fix rpmlint warnings.
|
||||||
@ -237,13 +240,13 @@ fi
|
|||||||
%{python_sitearch}/*.pyo
|
%{python_sitearch}/*.pyo
|
||||||
%doc AUTHORS COPYING ChangeLog README
|
%doc AUTHORS COPYING ChangeLog README
|
||||||
|
|
||||||
%files ruby
|
#%files ruby
|
||||||
%defattr(-,root,root,-)
|
#%defattr(-,root,root,-)
|
||||||
#%{ruby_sitearch}/openwsman.so
|
#%{ruby_sitearch}/openwsman.so
|
||||||
%{ruby_sitearch}/_openwsman.so
|
#%{ruby_sitearch}/_openwsman.so
|
||||||
%dir %{ruby_sitelib}/openwsman
|
#%dir %{ruby_sitelib}/openwsman
|
||||||
%{ruby_sitelib}/openwsman/*.rb
|
#%{ruby_sitelib}/openwsman/*.rb
|
||||||
%doc AUTHORS COPYING ChangeLog README
|
#%doc AUTHORS COPYING ChangeLog README
|
||||||
|
|
||||||
%files perl
|
%files perl
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
@ -282,6 +285,9 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Feb 09 2012 Vitezslav Crhonek <vcrhonek@redhat.com> - 2.2.7-3
|
||||||
|
- Temporarily disable ruby subpackage
|
||||||
|
|
||||||
* Thu Jan 26 2012 Vitezslav Crhonek <vcrhonek@redhat.com> - 2.2.7-2
|
* Thu Jan 26 2012 Vitezslav Crhonek <vcrhonek@redhat.com> - 2.2.7-2
|
||||||
- Remove unnecessary net-tools requirement
|
- Remove unnecessary net-tools requirement
|
||||||
Resolves: #784787
|
Resolves: #784787
|
||||||
|
Loading…
Reference in New Issue
Block a user