diff --git a/opentest4j.spec b/opentest4j.spec
index 22b0c26..609739c 100644
--- a/opentest4j.spec
+++ b/opentest4j.spec
@@ -2,7 +2,7 @@
Name: opentest4j
Version: 1.2.0
-Release: 12%{?dist}
+Release: 13%{?dist}
Summary: Open Test Alliance for the JVM
License: ASL 2.0
URL: https://github.com/ota4j-team/opentest4j
@@ -40,6 +40,8 @@ API documentation for %{name}.
find -name \*.jar -delete
cp -p %{SOURCE100} pom.xml
+mv src/module/java/* src/main/java
+
%pom_add_dep junit:junit::test
%pom_xpath_inject pom:project "
@@ -51,7 +53,6 @@ cp -p %{SOURCE100} pom.xml
- org.opentest4j
opentest4j
opentest4j.org
%{version}
@@ -67,6 +68,36 @@ cp -p %{SOURCE100} pom.xml
+
+ org.apache.maven.plugins
+ maven-compiler-plugin
+
+
+ default-compile
+
+ compile
+
+
+ 8
+
+ **/module-info.java
+
+
+
+
+ module-info
+
+ compile
+
+
+ 9
+
+ **/module-info.java
+
+
+
+
+
"
@@ -76,7 +107,7 @@ cp -p %{SOURCE100} pom.xml
sed -i -e '/org\.apache\.commons\.codec/d' src/test/java/org/opentest4j/AssertionFailedErrorTests.java
%build
-%mvn_build -- -Dmaven.compiler.source=1.7 -Dmaven.compiler.target=1.7
+%mvn_build
%install
%mvn_install
@@ -89,6 +120,9 @@ sed -i -e '/org\.apache\.commons\.codec/d' src/test/java/org/opentest4j/Assertio
%license LICENSE
%changelog
+* Wed Feb 15 2023 Marian Koncek - 1.2.0-13
+- Build with module-info
+
* Thu Jan 19 2023 Fedora Release Engineering - 1.2.0-12
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild