update to upstream version 1.1.0c

This commit is contained in:
Tomas Mraz 2016-11-11 14:47:36 +01:00
parent a416cba2f4
commit be56ae067b
7 changed files with 320 additions and 360 deletions

1
.gitignore vendored
View File

@ -32,3 +32,4 @@ openssl-1.0.0a-usa.tar.bz2
/openssl-1.0.2i-hobbled.tar.xz /openssl-1.0.2i-hobbled.tar.xz
/openssl-1.0.2j-hobbled.tar.xz /openssl-1.0.2j-hobbled.tar.xz
/openssl-1.1.0b-hobbled.tar.xz /openssl-1.1.0b-hobbled.tar.xz
/openssl-1.1.0c-hobbled.tar.xz

View File

@ -1,32 +0,0 @@
From 9161bcb63b58114eda5f3223d96953f93ea072aa Mon Sep 17 00:00:00 2001
From: Tomas Mraz <tmraz@fedoraproject.org>
Date: Wed, 12 Oct 2016 14:32:05 +0200
Subject: [PATCH] Engine afalg: properly set operation type also on big endian.
Copy the whole ALG_OP_TYPE to CMSG_DATA.
---
engines/afalg/e_afalg.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/engines/afalg/e_afalg.c b/engines/afalg/e_afalg.c
index 2c13ba8..658de42 100644
--- a/engines/afalg/e_afalg.c
+++ b/engines/afalg/e_afalg.c
@@ -322,12 +322,12 @@ int afalg_fin_cipher_aio(afalg_aio *aio, int sfd, unsigned char *buf,
}
static ossl_inline void afalg_set_op_sk(struct cmsghdr *cmsg,
- const unsigned int op)
+ const ALG_OP_TYPE op)
{
cmsg->cmsg_level = SOL_ALG;
cmsg->cmsg_type = ALG_SET_OP;
cmsg->cmsg_len = CMSG_LEN(ALG_OP_LEN);
- *CMSG_DATA(cmsg) = (char)op;
+ memcpy(CMSG_DATA(cmsg), &op, ALG_OP_LEN);
}
static void afalg_set_iv_sk(struct cmsghdr *cmsg, const unsigned char *iv,
--
2.5.5

View File

@ -1,7 +1,7 @@
diff -up openssl-1.1.0b/Configurations/unix-Makefile.tmpl.build openssl-1.1.0b/Configurations/unix-Makefile.tmpl diff -up openssl-1.1.0c/Configurations/unix-Makefile.tmpl.build openssl-1.1.0c/Configurations/unix-Makefile.tmpl
--- openssl-1.1.0b/Configurations/unix-Makefile.tmpl.build 2016-09-26 11:46:04.000000000 +0200 --- openssl-1.1.0c/Configurations/unix-Makefile.tmpl.build 2016-11-10 15:03:43.000000000 +0100
+++ openssl-1.1.0b/Configurations/unix-Makefile.tmpl 2016-09-26 15:16:26.935660147 +0200 +++ openssl-1.1.0c/Configurations/unix-Makefile.tmpl 2016-11-11 13:26:36.094400833 +0100
@@ -640,7 +640,7 @@ install_man_docs: @@ -630,7 +630,7 @@ install_man_docs:
@\ @\
OUTSUFFIX='.$${SEC}$(MANSUFFIX)'; \ OUTSUFFIX='.$${SEC}$(MANSUFFIX)'; \
OUTTOP="$(DESTDIR)$(MANDIR)"; \ OUTTOP="$(DESTDIR)$(MANDIR)"; \
@ -10,18 +10,18 @@ diff -up openssl-1.1.0b/Configurations/unix-Makefile.tmpl.build openssl-1.1.0b/C
$(PROCESS_PODS) $(PROCESS_PODS)
uninstall_man_docs: uninstall_man_docs:
diff -up openssl-1.1.0b/Configurations/10-main.conf.build openssl-1.1.0b/Configurations/10-main.conf diff -up openssl-1.1.0c/Configurations/10-main.conf.build openssl-1.1.0c/Configurations/10-main.conf
--- openssl-1.1.0b/Configurations/10-main.conf.build 2016-09-26 11:46:04.000000000 +0200 --- openssl-1.1.0c/Configurations/10-main.conf.build 2016-11-10 15:03:43.000000000 +0100
+++ openssl-1.1.0b/Configurations/10-main.conf 2016-09-26 15:16:26.935660147 +0200 +++ openssl-1.1.0c/Configurations/10-main.conf 2016-11-11 13:29:26.502289226 +0100
@@ -655,6 +655,7 @@ sub vms_info { @@ -656,6 +656,7 @@ sub vms_info {
cflags => add("-m64 -DL_ENDIAN"), cflags => add("-m64 -DL_ENDIAN"),
perlasm_scheme => "linux64le", perlasm_scheme => "linux64le",
shared_ldflag => "-m64", shared_ldflag => add("-m64"),
+ multilib => "64", + multilib => "64",
}, },
"linux-armv4" => { "linux-armv4" => {
@@ -681,6 +682,7 @@ sub vms_info { @@ -696,6 +697,7 @@ sub vms_info {
"linux-aarch64" => { "linux-aarch64" => {
inherit_from => [ "linux-generic64", asm("aarch64_asm") ], inherit_from => [ "linux-generic64", asm("aarch64_asm") ],
perlasm_scheme => "linux64", perlasm_scheme => "linux64",
@ -29,9 +29,9 @@ diff -up openssl-1.1.0b/Configurations/10-main.conf.build openssl-1.1.0b/Configu
}, },
"linux-arm64ilp32" => { # https://wiki.linaro.org/Platform/arm64-ilp32 "linux-arm64ilp32" => { # https://wiki.linaro.org/Platform/arm64-ilp32
inherit_from => [ "linux-generic32", asm("aarch64_asm") ], inherit_from => [ "linux-generic32", asm("aarch64_asm") ],
diff -up openssl-1.1.0b/crypto/ec/ec_lib.c.build openssl-1.1.0b/crypto/ec/ec_lib.c diff -up openssl-1.1.0c/crypto/ec/ec_lib.c.build openssl-1.1.0c/crypto/ec/ec_lib.c
--- openssl-1.1.0b/crypto/ec/ec_lib.c.build 2016-09-26 15:16:26.936660171 +0200 --- openssl-1.1.0c/crypto/ec/ec_lib.c.build 2016-11-10 15:03:44.000000000 +0100
+++ openssl-1.1.0b/crypto/ec/ec_lib.c 2016-09-26 15:18:38.351742195 +0200 +++ openssl-1.1.0c/crypto/ec/ec_lib.c 2016-11-11 13:26:36.097400901 +0100
@@ -74,9 +74,6 @@ void EC_pre_comp_free(EC_GROUP *group) @@ -74,9 +74,6 @@ void EC_pre_comp_free(EC_GROUP *group)
break; break;
#endif #endif
@ -52,9 +52,9 @@ diff -up openssl-1.1.0b/crypto/ec/ec_lib.c.build openssl-1.1.0b/crypto/ec/ec_lib
case PCT_nistp256: case PCT_nistp256:
dest->pre_comp.nistp256 = EC_nistp256_pre_comp_dup(src->pre_comp.nistp256); dest->pre_comp.nistp256 = EC_nistp256_pre_comp_dup(src->pre_comp.nistp256);
break; break;
diff -up openssl-1.1.0b/test/ecdhtest_cavs.h.build openssl-1.1.0b/test/ecdhtest_cavs.h diff -up openssl-1.1.0c/test/ecdhtest_cavs.h.build openssl-1.1.0c/test/ecdhtest_cavs.h
--- openssl-1.1.0b/test/ecdhtest_cavs.h.build 2016-09-26 15:16:26.918659749 +0200 --- openssl-1.1.0c/test/ecdhtest_cavs.h.build 2016-11-11 13:26:36.079400491 +0100
+++ openssl-1.1.0b/test/ecdhtest_cavs.h 2016-09-26 15:16:26.936660171 +0200 +++ openssl-1.1.0c/test/ecdhtest_cavs.h 2016-11-11 13:26:36.097400901 +0100
@@ -29,6 +29,7 @@ typedef struct { @@ -29,6 +29,7 @@ typedef struct {
static const ecdh_cavs_kat_t ecdh_cavs_kats[] = { static const ecdh_cavs_kat_t ecdh_cavs_kats[] = {
@ -71,9 +71,9 @@ diff -up openssl-1.1.0b/test/ecdhtest_cavs.h.build openssl-1.1.0b/test/ecdhtest_
{ NID_X9_62_prime256v1, { NID_X9_62_prime256v1,
"700c48f77f56584c5cc632ca65640db91b6bacce3a4df6b42ce7cc838833d287", "700c48f77f56584c5cc632ca65640db91b6bacce3a4df6b42ce7cc838833d287",
"db71e509e3fd9b060ddb20ba5c51dcc5948d46fbf640dfe0441782cab85fa4ac", "db71e509e3fd9b060ddb20ba5c51dcc5948d46fbf640dfe0441782cab85fa4ac",
diff -up openssl-1.1.0b/test/ecdhtest.c.build openssl-1.1.0b/test/ecdhtest.c diff -up openssl-1.1.0c/test/ecdhtest.c.build openssl-1.1.0c/test/ecdhtest.c
--- openssl-1.1.0b/test/ecdhtest.c.build 2016-09-26 11:46:08.000000000 +0200 --- openssl-1.1.0c/test/ecdhtest.c.build 2016-11-10 15:03:47.000000000 +0100
+++ openssl-1.1.0b/test/ecdhtest.c 2016-09-26 15:16:26.936660171 +0200 +++ openssl-1.1.0c/test/ecdhtest.c 2016-11-11 13:26:36.097400901 +0100
@@ -252,6 +252,7 @@ typedef struct { @@ -252,6 +252,7 @@ typedef struct {
static const ecdh_kat_t ecdh_kats[] = { static const ecdh_kat_t ecdh_kats[] = {
@ -106,9 +106,9 @@ diff -up openssl-1.1.0b/test/ecdhtest.c.build openssl-1.1.0b/test/ecdhtest.c
}; };
/* Given private value and NID, create EC_KEY structure */ /* Given private value and NID, create EC_KEY structure */
diff -up openssl-1.1.0b/test/ecdsatest.c.build openssl-1.1.0b/test/ecdsatest.c diff -up openssl-1.1.0c/test/ecdsatest.c.build openssl-1.1.0c/test/ecdsatest.c
--- openssl-1.1.0b/test/ecdsatest.c.build 2016-09-26 11:46:08.000000000 +0200 --- openssl-1.1.0c/test/ecdsatest.c.build 2016-11-10 15:03:47.000000000 +0100
+++ openssl-1.1.0b/test/ecdsatest.c 2016-09-26 15:16:26.936660171 +0200 +++ openssl-1.1.0c/test/ecdsatest.c 2016-11-11 13:26:36.097400901 +0100
@@ -216,6 +216,7 @@ int x9_62_tests(BIO *out) @@ -216,6 +216,7 @@ int x9_62_tests(BIO *out)
if (!change_rand()) if (!change_rand())
goto x962_err; goto x962_err;

File diff suppressed because it is too large Load Diff

View File

@ -1,12 +0,0 @@
diff -up openssl-1.1.0-pre5/Makefile.shared.no-rpath openssl-1.1.0-pre5/Makefile.shared
--- openssl-1.1.0-pre5/Makefile.shared.no-rpath 2016-07-18 14:41:53.081002002 +0200
+++ openssl-1.1.0-pre5/Makefile.shared 2016-07-18 14:43:08.790467584 +0200
@@ -175,7 +175,7 @@ DO_GNU_SO=\
ALLSYMSFLAGS='-Wl,--whole-archive'; \
NOALLSYMSFLAGS='-Wl,--no-whole-archive'; \
$(DO_GNU_SO_COMMON)
-DO_GNU_APP=LDFLAGS="$(CFLAGS) $(LDFLAGS) -Wl,-rpath,$(LIBRPATH)"
+DO_GNU_APP=LDFLAGS="$(CFLAGS) $(LDFLAGS)"
#This is rather special. It's a special target with which one can link
#applications without bothering with any features that have anything to

View File

@ -21,8 +21,8 @@
Summary: Utilities from the general purpose cryptography library with TLS implementation Summary: Utilities from the general purpose cryptography library with TLS implementation
Name: openssl Name: openssl
Version: 1.1.0b Version: 1.1.0c
Release: 4%{?dist} Release: 1%{?dist}
Epoch: 1 Epoch: 1
# We have to remove certain patented algorithms from the openssl source # We have to remove certain patented algorithms from the openssl source
# tarball with the hobble-openssl script which is included below. # tarball with the hobble-openssl script which is included below.
@ -41,7 +41,6 @@ Source13: ectest.c
Patch1: openssl-1.1.0-build.patch Patch1: openssl-1.1.0-build.patch
Patch2: openssl-1.1.0-defaults.patch Patch2: openssl-1.1.0-defaults.patch
Patch3: openssl-1.1.0-no-html.patch Patch3: openssl-1.1.0-no-html.patch
Patch5: openssl-1.1.0-no-rpath.patch
# Bug fixes # Bug fixes
Patch21: openssl-1.1.0-issuer-hash.patch Patch21: openssl-1.1.0-issuer-hash.patch
Patch22: openssl-1.1.0-algo-doc.patch Patch22: openssl-1.1.0-algo-doc.patch
@ -60,7 +59,6 @@ Patch40: openssl-1.1.0-disable-ssl3.patch
Patch41: openssl-1.1.0-system-cipherlist.patch Patch41: openssl-1.1.0-system-cipherlist.patch
Patch42: openssl-1.1.0-fips.patch Patch42: openssl-1.1.0-fips.patch
Patch43: openssl-1.1.0-afalg-eventfd2.patch Patch43: openssl-1.1.0-afalg-eventfd2.patch
Patch44: openssl-1.1.0-afalg-endian.patch
# Backported fixes including security fixes # Backported fixes including security fixes
License: OpenSSL License: OpenSSL
@ -142,7 +140,6 @@ cp %{SOURCE13} test/
%patch1 -p1 -b .build %{?_rawbuild} %patch1 -p1 -b .build %{?_rawbuild}
%patch2 -p1 -b .defaults %patch2 -p1 -b .defaults
%patch3 -p1 -b .no-html %{?_rawbuild} %patch3 -p1 -b .no-html %{?_rawbuild}
%patch5 -p1 -b .no-rpath
%patch21 -p1 -b .issuer-hash %patch21 -p1 -b .issuer-hash
%patch22 -p1 -b .algo-doc %patch22 -p1 -b .algo-doc
@ -161,7 +158,6 @@ cp %{SOURCE13} test/
%patch41 -p1 -b .system-cipherlist %patch41 -p1 -b .system-cipherlist
%patch42 -p1 -b .fips %patch42 -p1 -b .fips
%patch43 -p1 -b .eventfd2 %patch43 -p1 -b .eventfd2
%patch44 -p1 -b .endian
%build %build
# Figure out which flags we want to use. # Figure out which flags we want to use.
@ -261,6 +257,10 @@ patch -p1 -R < %{PATCH31}
LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}} LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
export LD_LIBRARY_PATH export LD_LIBRARY_PATH
crypto/fips/fips_standalone_hmac libcrypto.so.%{soversion} >.libcrypto.so.%{soversion}.hmac
ln -s .libcrypto.so.%{soversion}.hmac .libcrypto.so.hmac
crypto/fips/fips_standalone_hmac libssl.so.%{soversion} >.libssl.so.%{soversion}.hmac
ln -s .libssl.so.%{soversion}.hmac .libssl.so.hmac
OPENSSL_ENABLE_MD5_VERIFY= OPENSSL_ENABLE_MD5_VERIFY=
export OPENSSL_ENABLE_MD5_VERIFY export OPENSSL_ENABLE_MD5_VERIFY
make test make test
@ -425,6 +425,9 @@ export LD_LIBRARY_PATH
%postun libs -p /sbin/ldconfig %postun libs -p /sbin/ldconfig
%changelog %changelog
* Fri Nov 11 2016 Tomáš Mráz <tmraz@redhat.com> 1.1.0c-1
- update to upstream version 1.1.0c
* Fri Nov 4 2016 Tomáš Mráz <tmraz@redhat.com> 1.1.0b-4 * Fri Nov 4 2016 Tomáš Mráz <tmraz@redhat.com> 1.1.0b-4
- use a random seed if the supplied one did not generate valid - use a random seed if the supplied one did not generate valid
parameters in dsa_builtin_paramgen2() parameters in dsa_builtin_paramgen2()

View File

@ -1 +1 @@
ec4eac4d86e5f9b5dd723bc0702f7954 openssl-1.1.0b-hobbled.tar.xz 1292a3e2bafa419cd61212cfd5e34d02 openssl-1.1.0c-hobbled.tar.xz