Fix openssl curl error with LANG=tr_TR.utf8
Resolves: rhbz#2071631
This commit is contained in:
parent
c0744a0cbf
commit
a711ac2e4f
23
0055-nonlegacy-fetch-null-deref.patch
Normal file
23
0055-nonlegacy-fetch-null-deref.patch
Normal file
@ -0,0 +1,23 @@
|
|||||||
|
diff --git a/crypto/core_namemap.c b/crypto/core_namemap.c
|
||||||
|
index e1da724bd2f4..2bee5ef19447 100644
|
||||||
|
--- a/crypto/core_namemap.c
|
||||||
|
+++ b/crypto/core_namemap.c
|
||||||
|
@@ -409,14 +409,16 @@ static void get_legacy_cipher_names(const OBJ_NAME *on, void *arg)
|
||||||
|
{
|
||||||
|
const EVP_CIPHER *cipher = (void *)OBJ_NAME_get(on->name, on->type);
|
||||||
|
|
||||||
|
- get_legacy_evp_names(NID_undef, EVP_CIPHER_get_type(cipher), NULL, arg);
|
||||||
|
+ if (cipher != NULL)
|
||||||
|
+ get_legacy_evp_names(NID_undef, EVP_CIPHER_get_type(cipher), NULL, arg);
|
||||||
|
}
|
||||||
|
|
||||||
|
static void get_legacy_md_names(const OBJ_NAME *on, void *arg)
|
||||||
|
{
|
||||||
|
const EVP_MD *md = (void *)OBJ_NAME_get(on->name, on->type);
|
||||||
|
|
||||||
|
- get_legacy_evp_names(0, EVP_MD_get_type(md), NULL, arg);
|
||||||
|
+ if (md != NULL)
|
||||||
|
+ get_legacy_evp_names(0, EVP_MD_get_type(md), NULL, arg);
|
||||||
|
}
|
||||||
|
|
||||||
|
static void get_legacy_pkey_meth_names(const EVP_PKEY_ASN1_METHOD *ameth,
|
2279
0056-strcasecmp.patch
Normal file
2279
0056-strcasecmp.patch
Normal file
File diff suppressed because it is too large
Load Diff
10
openssl.spec
10
openssl.spec
@ -15,7 +15,7 @@
|
|||||||
Summary: Utilities from the general purpose cryptography library with TLS implementation
|
Summary: Utilities from the general purpose cryptography library with TLS implementation
|
||||||
Name: openssl
|
Name: openssl
|
||||||
Version: 3.0.1
|
Version: 3.0.1
|
||||||
Release: 22%{?dist}
|
Release: 23%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
# We have to remove certain patented algorithms from the openssl source
|
# We have to remove certain patented algorithms from the openssl source
|
||||||
# tarball with the hobble-openssl script which is included below.
|
# tarball with the hobble-openssl script which is included below.
|
||||||
@ -88,6 +88,10 @@ Patch52: 0052-Allow-SHA1-in-seclevel-2-if-rh-allow-sha1-signatures.patch
|
|||||||
Patch53: 0053-CVE-2022-0778.patch
|
Patch53: 0053-CVE-2022-0778.patch
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=2004915, backport of 2c0f7d46b8449423446cfe1e52fc1e1ecd506b62
|
# https://bugzilla.redhat.com/show_bug.cgi?id=2004915, backport of 2c0f7d46b8449423446cfe1e52fc1e1ecd506b62
|
||||||
Patch54: 0054-Replace-size-check-with-more-meaningful-pubkey-check.patch
|
Patch54: 0054-Replace-size-check-with-more-meaningful-pubkey-check.patch
|
||||||
|
# https://github.com/openssl/openssl/pull/17324
|
||||||
|
Patch55: 0055-nonlegacy-fetch-null-deref.patch
|
||||||
|
# https://github.com/openssl/openssl/pull/18103
|
||||||
|
Patch56: 0056-strcasecmp.patch
|
||||||
|
|
||||||
License: ASL 2.0
|
License: ASL 2.0
|
||||||
URL: http://www.openssl.org/
|
URL: http://www.openssl.org/
|
||||||
@ -418,6 +422,10 @@ install -m644 %{SOURCE9} \
|
|||||||
%ldconfig_scriptlets libs
|
%ldconfig_scriptlets libs
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Apr 20 2022 Dmitry Belyavskiy <dbelyavs@redhat.com> - 1:3.0.1-23
|
||||||
|
- Fix openssl curl error with LANG=tr_TR.utf8
|
||||||
|
- Resolves: rhbz#2071631
|
||||||
|
|
||||||
* Mon Mar 28 2022 Dmitry Belyavskiy <dbelyavs@redhat.com> - 1:3.0.1-22
|
* Mon Mar 28 2022 Dmitry Belyavskiy <dbelyavs@redhat.com> - 1:3.0.1-22
|
||||||
- FIPS provider should block RSA encryption for key transport
|
- FIPS provider should block RSA encryption for key transport
|
||||||
- Resolves: rhbz#2053289
|
- Resolves: rhbz#2053289
|
||||||
|
Loading…
Reference in New Issue
Block a user