- fix stale open handles in libica (#177155)
- fix build if 'rand' or 'passwd' in buildroot path (#178782) - initialize VIA Padlock engine (#186857)
This commit is contained in:
parent
8c34b0921c
commit
6f11ea3f44
22
openssl-0.9.8a-padlock.patch
Normal file
22
openssl-0.9.8a-padlock.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
--- openssl-0.9.8a/crypto/engine/eng_all.c.padlock 2005-11-22 16:36:22.000000000 +0100
|
||||||
|
+++ openssl-0.9.8a/crypto/engine/eng_all.c 2006-04-04 18:03:13.000000000 +0200
|
||||||
|
@@ -72,6 +72,9 @@
|
||||||
|
#if !defined(OPENSSL_NO_HW) && !defined(OPENSSL_NO_HW_IBMCA)
|
||||||
|
ENGINE_load_ibmca();
|
||||||
|
#endif
|
||||||
|
+#if !defined(OPENSSL_NO_HW) && !defined(OPENSSL_NO_HW_PADLOCK)
|
||||||
|
+ ENGINE_load_padlock();
|
||||||
|
+#endif
|
||||||
|
#ifndef OPENSSL_NO_STATIC_ENGINE
|
||||||
|
#ifndef OPENSSL_NO_HW
|
||||||
|
#ifndef OPENSSL_NO_HW_4758_CCA
|
||||||
|
@@ -98,9 +101,6 @@
|
||||||
|
#ifndef OPENSSL_NO_HW_UBSEC
|
||||||
|
ENGINE_load_ubsec();
|
||||||
|
#endif
|
||||||
|
-#ifndef OPENSSL_NO_HW_PADLOCK
|
||||||
|
- ENGINE_load_padlock();
|
||||||
|
-#endif
|
||||||
|
#endif
|
||||||
|
#if defined(__OpenBSD__) || defined(__FreeBSD__)
|
||||||
|
ENGINE_load_cryptodev();
|
17
openssl.spec
17
openssl.spec
@ -23,7 +23,7 @@
|
|||||||
Summary: The OpenSSL toolkit.
|
Summary: The OpenSSL toolkit.
|
||||||
Name: openssl
|
Name: openssl
|
||||||
Version: 0.9.8a
|
Version: 0.9.8a
|
||||||
Release: 5.2
|
Release: 6
|
||||||
Source: openssl-%{version}-usa.tar.bz2
|
Source: openssl-%{version}-usa.tar.bz2
|
||||||
Source1: hobble-openssl
|
Source1: hobble-openssl
|
||||||
Source2: Makefile.certificate
|
Source2: Makefile.certificate
|
||||||
@ -48,6 +48,8 @@ Patch6: openssl-0.9.7a-libica-autoconf.patch
|
|||||||
Patch20: libica-1.3.4-urandom.patch
|
Patch20: libica-1.3.4-urandom.patch
|
||||||
Patch21: libica-1.3.6-linkcrypto.patch
|
Patch21: libica-1.3.6-linkcrypto.patch
|
||||||
Patch22: openssl-0.9.8a-ICA_engine-sep142005.patch
|
Patch22: openssl-0.9.8a-ICA_engine-sep142005.patch
|
||||||
|
Patch23: libica-1.3.6-stale-handles.patch
|
||||||
|
Patch24: openssl-0.9.8a-padlock.patch
|
||||||
# Functionality changes
|
# Functionality changes
|
||||||
Patch32: openssl-0.9.7-beta6-ia64.patch
|
Patch32: openssl-0.9.7-beta6-ia64.patch
|
||||||
Patch33: openssl-0.9.7f-ca-dir.patch
|
Patch33: openssl-0.9.7f-ca-dir.patch
|
||||||
@ -111,8 +113,10 @@ pushd libica-%{libicaversion}
|
|||||||
# generator.
|
# generator.
|
||||||
%patch20 -p2 -b .urandom
|
%patch20 -p2 -b .urandom
|
||||||
%patch21 -p1 -b .linkcrypto
|
%patch21 -p1 -b .linkcrypto
|
||||||
|
%patch23 -p1 -b .stale-handles
|
||||||
popd
|
popd
|
||||||
%patch22 -p1 -b .ibmca
|
%patch22 -p1 -b .ibmca
|
||||||
|
%patch24 -p1 -b .padlock
|
||||||
|
|
||||||
%patch32 -p1 -b .ia64
|
%patch32 -p1 -b .ia64
|
||||||
#patch33 is applied after make test
|
#patch33 is applied after make test
|
||||||
@ -232,7 +236,8 @@ for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
|
|||||||
done
|
done
|
||||||
|
|
||||||
# Rename man pages so that they don't conflict with other system man pages.
|
# Rename man pages so that they don't conflict with other system man pages.
|
||||||
for manpage in $RPM_BUILD_ROOT%{_mandir}/man*/* ; do
|
pushd $RPM_BUILD_ROOT%{_mandir}
|
||||||
|
for manpage in man*/* ; do
|
||||||
if [ -L ${manpage} ]; then
|
if [ -L ${manpage} ]; then
|
||||||
TARGET=`ls -l ${manpage} | awk '{ print $NF }'`
|
TARGET=`ls -l ${manpage} | awk '{ print $NF }'`
|
||||||
ln -snf ${TARGET}ssl ${manpage}ssl
|
ln -snf ${TARGET}ssl ${manpage}ssl
|
||||||
@ -242,8 +247,9 @@ for manpage in $RPM_BUILD_ROOT%{_mandir}/man*/* ; do
|
|||||||
fi
|
fi
|
||||||
done
|
done
|
||||||
for conflict in passwd rand ; do
|
for conflict in passwd rand ; do
|
||||||
rename ${conflict} ssl${conflict} $RPM_BUILD_ROOT%{_mandir}/man*/${conflict}*
|
rename ${conflict} ssl${conflict} man*/${conflict}*
|
||||||
done
|
done
|
||||||
|
popd
|
||||||
|
|
||||||
# Pick a CA script.
|
# Pick a CA script.
|
||||||
pushd $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/misc
|
pushd $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/misc
|
||||||
@ -382,6 +388,11 @@ rm -f $RPM_BUILD_ROOT/%{_libdir}/libssl.so.%{soversion}
|
|||||||
%postun -p /sbin/ldconfig
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Apr 4 2006 Tomas Mraz <tmraz@redhat.com> - 0.9.8a-6
|
||||||
|
- fix stale open handles in libica (#177155)
|
||||||
|
- fix build if 'rand' or 'passwd' in buildroot path (#178782)
|
||||||
|
- initialize VIA Padlock engine (#186857)
|
||||||
|
|
||||||
* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.8a-5.2
|
* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.8a-5.2
|
||||||
- bump again for double-long bug on ppc(64)
|
- bump again for double-long bug on ppc(64)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user