move the libraries needed for static linking to Libs.private
This commit is contained in:
parent
6f65ffce68
commit
497f2d674c
33
openssl-1.0.0e-pkgconfig-private.patch
Normal file
33
openssl-1.0.0e-pkgconfig-private.patch
Normal file
@ -0,0 +1,33 @@
|
|||||||
|
diff -up openssl-1.0.0e/Makefile.org.private openssl-1.0.0e/Makefile.org
|
||||||
|
--- openssl-1.0.0e/Makefile.org.private 2011-11-03 10:01:53.000000000 +0100
|
||||||
|
+++ openssl-1.0.0e/Makefile.org 2011-11-22 11:50:27.000000000 +0100
|
||||||
|
@@ -326,7 +326,8 @@ libcrypto.pc: Makefile
|
||||||
|
echo 'Description: OpenSSL cryptography library'; \
|
||||||
|
echo 'Version: '$(VERSION); \
|
||||||
|
echo 'Requires: '; \
|
||||||
|
- echo 'Libs: -L$${libdir} -lcrypto $(EX_LIBS)'; \
|
||||||
|
+ echo 'Libs: -L$${libdir} -lcrypto'; \
|
||||||
|
+ echo 'Libs.private: $(EX_LIBS)'; \
|
||||||
|
echo 'Cflags: -I$${includedir} $(KRB5_INCLUDES)' ) > libcrypto.pc
|
||||||
|
|
||||||
|
libssl.pc: Makefile
|
||||||
|
@@ -339,7 +340,8 @@ libssl.pc: Makefile
|
||||||
|
echo 'Description: Secure Sockets Layer and cryptography libraries'; \
|
||||||
|
echo 'Version: '$(VERSION); \
|
||||||
|
echo 'Requires: '; \
|
||||||
|
- echo 'Libs: -L$${libdir} -lssl -lcrypto $(EX_LIBS)'; \
|
||||||
|
+ echo 'Libs: -L$${libdir} -lssl -lcrypto'; \
|
||||||
|
+ echo 'Libs.private: $(EX_LIBS)'; \
|
||||||
|
echo 'Cflags: -I$${includedir} $(KRB5_INCLUDES)' ) > libssl.pc
|
||||||
|
|
||||||
|
openssl.pc: Makefile
|
||||||
|
@@ -352,7 +354,8 @@ openssl.pc: Makefile
|
||||||
|
echo 'Description: Secure Sockets Layer and cryptography libraries and tools'; \
|
||||||
|
echo 'Version: '$(VERSION); \
|
||||||
|
echo 'Requires: '; \
|
||||||
|
- echo 'Libs: -L$${libdir} -lssl -lcrypto $(EX_LIBS)'; \
|
||||||
|
+ echo 'Libs: -L$${libdir} -lssl -lcrypto'; \
|
||||||
|
+ echo 'Libs.private: $(EX_LIBS)'; \
|
||||||
|
echo 'Cflags: -I$${includedir} $(KRB5_INCLUDES)' ) > openssl.pc
|
||||||
|
|
||||||
|
Makefile: Makefile.org Configure config
|
@ -21,7 +21,7 @@
|
|||||||
Summary: A general purpose cryptography library with TLS implementation
|
Summary: A general purpose cryptography library with TLS implementation
|
||||||
Name: openssl
|
Name: openssl
|
||||||
Version: 1.0.0e
|
Version: 1.0.0e
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
# We remove certain patented algorithms from the openssl source tarball
|
# We remove certain patented algorithms from the openssl source tarball
|
||||||
# with the hobble-openssl script which is included below.
|
# with the hobble-openssl script which is included below.
|
||||||
Source: openssl-%{version}-usa.tar.bz2
|
Source: openssl-%{version}-usa.tar.bz2
|
||||||
@ -77,6 +77,7 @@ Patch63: openssl-1.0.0d-xmpp-starttls.patch
|
|||||||
Patch64: openssl-1.0.0d-intelopts.patch
|
Patch64: openssl-1.0.0d-intelopts.patch
|
||||||
Patch65: openssl-1.0.0e-chil-fixes.patch
|
Patch65: openssl-1.0.0e-chil-fixes.patch
|
||||||
Patch66: openssl-1.0.0-sha2test.patch
|
Patch66: openssl-1.0.0-sha2test.patch
|
||||||
|
Patch67: openssl-1.0.0-pkgconfig-private.patch
|
||||||
# Backported fixes including security fixes
|
# Backported fixes including security fixes
|
||||||
Patch81: openssl-1.0.0d-padlock64.patch
|
Patch81: openssl-1.0.0d-padlock64.patch
|
||||||
|
|
||||||
@ -175,6 +176,7 @@ from other formats to the formats used by the OpenSSL toolkit.
|
|||||||
%patch64 -p1 -b .intelopts
|
%patch64 -p1 -b .intelopts
|
||||||
%patch65 -p1 -b .chil
|
%patch65 -p1 -b .chil
|
||||||
%patch66 -p1 -b .sha2test
|
%patch66 -p1 -b .sha2test
|
||||||
|
%patch67 -p1 -b .private
|
||||||
|
|
||||||
%patch81 -p1 -b .padlock64
|
%patch81 -p1 -b .padlock64
|
||||||
|
|
||||||
@ -426,6 +428,9 @@ rm -rf $RPM_BUILD_ROOT/%{_libdir}/fipscanister.*
|
|||||||
%postun -p /sbin/ldconfig
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Nov 22 2011 Tomas Mraz <tmraz@redhat.com> 1.0.0e-4
|
||||||
|
- move the libraries needed for static linking to Libs.private
|
||||||
|
|
||||||
* Thu Nov 3 2011 Tomas Mraz <tmraz@redhat.com> 1.0.0e-3
|
* Thu Nov 3 2011 Tomas Mraz <tmraz@redhat.com> 1.0.0e-3
|
||||||
- do not use AVX instructions when osxsave bit not set
|
- do not use AVX instructions when osxsave bit not set
|
||||||
- add direct known answer tests for SHA2 algorithms
|
- add direct known answer tests for SHA2 algorithms
|
||||||
|
Loading…
Reference in New Issue
Block a user