new upstream release
This commit is contained in:
parent
0aa7d61151
commit
0f0ab24176
1
.gitignore
vendored
1
.gitignore
vendored
@ -7,3 +7,4 @@ openssl-1.0.0a-usa.tar.bz2
|
||||
/openssl-1.0.0g-usa.tar.xz
|
||||
/openssl-1.0.1-beta2-usa.tar.xz
|
||||
/openssl-1.0.1-beta3-usa.tar.xz
|
||||
/openssl-1.0.1-usa.tar.xz
|
||||
|
@ -1,64 +0,0 @@
|
||||
diff -up openssl-1.0.1-beta3/crypto/cversion.c.version openssl-1.0.1-beta3/crypto/cversion.c
|
||||
--- openssl-1.0.1-beta3/crypto/cversion.c.version 2004-04-19 20:09:22.000000000 +0200
|
||||
+++ openssl-1.0.1-beta3/crypto/cversion.c 2012-02-29 11:53:50.650380234 +0100
|
||||
@@ -110,8 +110,15 @@ const char *SSLeay_version(int t)
|
||||
return("not available");
|
||||
}
|
||||
|
||||
-unsigned long SSLeay(void)
|
||||
+unsigned long _original_SSLeay(void)
|
||||
+ {
|
||||
+ return(0x10000003);
|
||||
+ }
|
||||
+
|
||||
+unsigned long _current_SSLeay(void)
|
||||
{
|
||||
return(SSLEAY_VERSION_NUMBER);
|
||||
}
|
||||
|
||||
+__asm__(".symver _original_SSLeay,SSLeay@");
|
||||
+__asm__(".symver _current_SSLeay,SSLeay@@OPENSSL_1.0.1");
|
||||
diff -up openssl-1.0.1-beta3/crypto/opensslv.h.version openssl-1.0.1-beta3/crypto/opensslv.h
|
||||
--- openssl-1.0.1-beta3/crypto/opensslv.h.version 2012-02-29 11:53:49.952374261 +0100
|
||||
+++ openssl-1.0.1-beta3/crypto/opensslv.h 2012-02-29 11:53:50.650380234 +0100
|
||||
@@ -25,7 +25,7 @@
|
||||
* (Prior to 0.9.5a beta1, a different scheme was used: MMNNFFRBB for
|
||||
* major minor fix final patch/beta)
|
||||
*/
|
||||
-#define OPENSSL_VERSION_NUMBER 0x10001003L
|
||||
+#define OPENSSL_VERSION_NUMBER 0x1000100fL
|
||||
#ifdef OPENSSL_FIPS
|
||||
#define OPENSSL_VERSION_TEXT "OpenSSL 1.0.1-fips-beta3 23 Feb 2012"
|
||||
#else
|
||||
@@ -83,7 +83,7 @@
|
||||
* should only keep the versions that are binary compatible with the current.
|
||||
*/
|
||||
#define SHLIB_VERSION_HISTORY ""
|
||||
-#define SHLIB_VERSION_NUMBER "1.0.0"
|
||||
+#define SHLIB_VERSION_NUMBER "1.0.1"
|
||||
|
||||
|
||||
#endif /* HEADER_OPENSSLV_H */
|
||||
diff -up openssl-1.0.1-beta3/Makefile.shared.version openssl-1.0.1-beta3/Makefile.shared
|
||||
--- openssl-1.0.1-beta3/Makefile.shared.version 2012-02-29 11:53:50.511379043 +0100
|
||||
+++ openssl-1.0.1-beta3/Makefile.shared 2012-02-29 11:54:47.794869236 +0100
|
||||
@@ -151,7 +151,7 @@ DO_GNU_SO=$(CALC_VERSIONS); \
|
||||
SHLIB_SUFFIX=; \
|
||||
ALLSYMSFLAGS='-Wl,--whole-archive'; \
|
||||
NOALLSYMSFLAGS='-Wl,--no-whole-archive'; \
|
||||
- SHAREDFLAGS="$(CFLAGS) $(SHARED_LDFLAGS) -shared -Wl,-Bsymbolic -Wl,-soname=$$SHLIB$$SHLIB_SOVER$$SHLIB_SUFFIX"
|
||||
+ SHAREDFLAGS="$(CFLAGS) $(SHARED_LDFLAGS) -shared -Wl,-Bsymbolic -Wl,--default-symver,--version-script=version.map -Wl,-soname=$$SHLIB$$SHLIB_SOVER$$SHLIB_SUFFIX"
|
||||
|
||||
DO_GNU_APP=LDFLAGS="$(CFLAGS)"
|
||||
|
||||
diff -up openssl-1.0.1-beta3/version.map.version openssl-1.0.1-beta3/version.map
|
||||
--- openssl-1.0.1-beta3/version.map.version 2012-02-29 11:53:50.651380242 +0100
|
||||
+++ openssl-1.0.1-beta3/version.map 2012-02-29 11:55:28.110214232 +0100
|
||||
@@ -0,0 +1,7 @@
|
||||
+OPENSSL_1.0.1 {
|
||||
+ global:
|
||||
+ SSLeay;
|
||||
+ local:
|
||||
+ _original*;
|
||||
+ _current*;
|
||||
+};
|
55
openssl-1.0.1-version.patch
Normal file
55
openssl-1.0.1-version.patch
Normal file
@ -0,0 +1,55 @@
|
||||
diff -up openssl-1.0.1/crypto/cversion.c.version openssl-1.0.1/crypto/cversion.c
|
||||
--- openssl-1.0.1/crypto/cversion.c.version 2004-04-19 20:09:22.000000000 +0200
|
||||
+++ openssl-1.0.1/crypto/cversion.c 2012-03-14 20:58:20.630352536 +0100
|
||||
@@ -110,8 +110,15 @@ const char *SSLeay_version(int t)
|
||||
return("not available");
|
||||
}
|
||||
|
||||
-unsigned long SSLeay(void)
|
||||
+unsigned long _original_SSLeay(void)
|
||||
+ {
|
||||
+ return(0x10000003);
|
||||
+ }
|
||||
+
|
||||
+unsigned long _current_SSLeay(void)
|
||||
{
|
||||
return(SSLEAY_VERSION_NUMBER);
|
||||
}
|
||||
|
||||
+__asm__(".symver _original_SSLeay,SSLeay@");
|
||||
+__asm__(".symver _current_SSLeay,SSLeay@@OPENSSL_1.0.1");
|
||||
diff -up openssl-1.0.1/crypto/opensslv.h.version openssl-1.0.1/crypto/opensslv.h
|
||||
--- openssl-1.0.1/crypto/opensslv.h.version 2012-03-14 20:58:19.914337879 +0100
|
||||
+++ openssl-1.0.1/crypto/opensslv.h 2012-03-14 20:58:20.630352536 +0100
|
||||
@@ -83,7 +83,7 @@
|
||||
* should only keep the versions that are binary compatible with the current.
|
||||
*/
|
||||
#define SHLIB_VERSION_HISTORY ""
|
||||
-#define SHLIB_VERSION_NUMBER "1.0.0"
|
||||
+#define SHLIB_VERSION_NUMBER "1.0.1"
|
||||
|
||||
|
||||
#endif /* HEADER_OPENSSLV_H */
|
||||
diff -up openssl-1.0.1/Makefile.shared.version openssl-1.0.1/Makefile.shared
|
||||
--- openssl-1.0.1/Makefile.shared.version 2012-03-14 20:58:20.553350959 +0100
|
||||
+++ openssl-1.0.1/Makefile.shared 2012-03-14 20:58:20.631352556 +0100
|
||||
@@ -151,7 +151,7 @@ DO_GNU_SO=$(CALC_VERSIONS); \
|
||||
SHLIB_SUFFIX=; \
|
||||
ALLSYMSFLAGS='-Wl,--whole-archive'; \
|
||||
NOALLSYMSFLAGS='-Wl,--no-whole-archive'; \
|
||||
- SHAREDFLAGS="$(CFLAGS) $(SHARED_LDFLAGS) -shared -Wl,-Bsymbolic -Wl,-soname=$$SHLIB$$SHLIB_SOVER$$SHLIB_SUFFIX"
|
||||
+ SHAREDFLAGS="$(CFLAGS) $(SHARED_LDFLAGS) -shared -Wl,-Bsymbolic -Wl,--default-symver,--version-script=version.map -Wl,-soname=$$SHLIB$$SHLIB_SOVER$$SHLIB_SUFFIX"
|
||||
|
||||
DO_GNU_APP=LDFLAGS="$(CFLAGS)"
|
||||
|
||||
diff -up openssl-1.0.1/version.map.version openssl-1.0.1/version.map
|
||||
--- openssl-1.0.1/version.map.version 2012-03-14 20:58:20.631352556 +0100
|
||||
+++ openssl-1.0.1/version.map 2012-03-14 20:58:20.631352556 +0100
|
||||
@@ -0,0 +1,7 @@
|
||||
+OPENSSL_1.0.1 {
|
||||
+ global:
|
||||
+ SSLeay;
|
||||
+ local:
|
||||
+ _original*;
|
||||
+ _current*;
|
||||
+};
|
11
openssl.spec
11
openssl.spec
@ -21,12 +21,12 @@
|
||||
Summary: Utilities from the general purpose cryptography library with TLS implementation
|
||||
Name: openssl
|
||||
Version: 1.0.1
|
||||
Release: 0.3.beta3%{?dist}
|
||||
Release: 1%{?dist}
|
||||
Epoch: 1
|
||||
# We have to remove certain patented algorithms from the openssl source
|
||||
# tarball with the hobble-openssl script which is included below.
|
||||
# The original openssl upstream tarball cannot be shipped in the .src.rpm.
|
||||
Source: openssl-%{version}-beta3-usa.tar.xz
|
||||
Source: openssl-%{version}-usa.tar.xz
|
||||
Source1: hobble-openssl
|
||||
Source2: Makefile.certificate
|
||||
Source6: make-dummy-cert
|
||||
@ -56,7 +56,7 @@ Patch45: openssl-0.9.8j-env-nozlib.patch
|
||||
Patch47: openssl-1.0.0-beta5-readme-warning.patch
|
||||
Patch49: openssl-1.0.0-beta4-algo-doc.patch
|
||||
Patch50: openssl-1.0.1-beta2-dtls1-abi.patch
|
||||
Patch51: openssl-1.0.1-beta3-version.patch
|
||||
Patch51: openssl-1.0.1-version.patch
|
||||
Patch56: openssl-1.0.0c-rsa-x931.patch
|
||||
Patch58: openssl-1.0.1-beta2-fips-md5-allow.patch
|
||||
Patch60: openssl-1.0.0d-apps-dgst.patch
|
||||
@ -127,7 +127,7 @@ package provides Perl scripts for converting certificates and keys
|
||||
from other formats to the formats used by the OpenSSL toolkit.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}-beta3
|
||||
%setup -q -n %{name}-%{version}
|
||||
|
||||
# The hobble_openssl is called here redundantly, just to be sure.
|
||||
# The tarball has already the sources removed.
|
||||
@ -415,6 +415,9 @@ rm -rf $RPM_BUILD_ROOT/%{_libdir}/fipscanister.*
|
||||
%postun libs -p /sbin/ldconfig
|
||||
|
||||
%changelog
|
||||
* Wed Mar 14 2012 Tomas Mraz <tmraz@redhat.com> 1.0.1-1
|
||||
- new upstream release
|
||||
|
||||
* Mon Mar 5 2012 Tomas Mraz <tmraz@redhat.com> 1.0.1-0.3.beta3
|
||||
- add obsoletes to assist multilib updates (#799636)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user