Unbreak SO version detectino with OpenSSL 3.1
this broke compose as the SO version went to 2 here https://pagure.io/releng/failed-composes/issue/5907
This commit is contained in:
parent
9d64f962eb
commit
a1b3b163c7
@ -247,3 +247,47 @@ index 556b170..fd6940f 100644
|
||||
}
|
||||
|
||||
|
||||
commit 580c12b78b63d88010a6178d7c4c58186938c479
|
||||
Author: Dominique Leuenberger <dimstar@opensuse.org>
|
||||
Date: Tue Jun 6 14:27:46 2023 +0200
|
||||
|
||||
Detect openSSL 3.1; compatible to openSSL 3.0
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index d6b0ee9..b96979d 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -33,7 +33,7 @@ AC_C_BIGENDIAN
|
||||
# issues with applications linking to new openssl, old libp11, and vice versa
|
||||
case "`$PKG_CONFIG --modversion --silence-errors libcrypto || \
|
||||
$PKG_CONFIG --modversion openssl`" in
|
||||
- 3.0.*) # Predicted engines directory prefix for OpenSSL 3.x
|
||||
+ 3.1.*|3.0.*) # Predicted engines directory prefix for OpenSSL 3.x
|
||||
LIBP11_LT_OLDEST="3"
|
||||
debian_ssl_prefix="openssl-3.0.0";;
|
||||
1.1.*) # Predicted engines directory prefix for OpenSSL 1.1.x
|
||||
|
||||
commit 74497e0fa5b69b15790d6697e1ebce13af842d4c
|
||||
Author: Mike Gilbert <floppym@gentoo.org>
|
||||
Date: Thu Jul 13 13:52:54 2023 -0400
|
||||
|
||||
configure: treat all openssl-3.x releases the same
|
||||
|
||||
OpenSSL's soversion will not change for any 3.x minor release.
|
||||
|
||||
https://www.openssl.org/policies/general/versioning-policy.html
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index b96979d..c344e84 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -33,7 +33,7 @@ AC_C_BIGENDIAN
|
||||
# issues with applications linking to new openssl, old libp11, and vice versa
|
||||
case "`$PKG_CONFIG --modversion --silence-errors libcrypto || \
|
||||
$PKG_CONFIG --modversion openssl`" in
|
||||
- 3.1.*|3.0.*) # Predicted engines directory prefix for OpenSSL 3.x
|
||||
+ 3.*) # Predicted engines directory prefix for OpenSSL 3.x
|
||||
LIBP11_LT_OLDEST="3"
|
||||
debian_ssl_prefix="openssl-3.0.0";;
|
||||
1.1.*) # Predicted engines directory prefix for OpenSSL 1.1.x
|
||||
|
||||
|
@ -17,6 +17,8 @@ Patch4: openssl-pkcs11-0.4.10-set-rsa-fips-method-flag.patch
|
||||
# unbreak operation when some other engine is present in openssl.cnf
|
||||
# https://github.com/OpenSC/libp11/pull/460
|
||||
# https://github.com/OpenSC/libp11/commit/feb22a66
|
||||
# 580c12b78b63d88010a6178d7c4c58186938c479
|
||||
# 74497e0fa5b69b15790d6697e1ebce13af842d4c
|
||||
Patch5: openssl-pkcs11-ossl3.patch
|
||||
Patch6: openssl-pkcs11-ec-copy.patch
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user